RE: [PATCH] mwifiex: add __GFP_REPEAT to skb allocation call

2016-04-04 Thread Amitkumar Karwar
Hi Eric, Thanks for the comments. > From: Eric Dumazet [mailto:eric.duma...@gmail.com] > Sent: Tuesday, March 29, 2016 6:29 PM > To: Wei-Ning Huang > Cc: Kalle Valo; Linux Wireless; LKML; Amitkumar Karwar; Nishant > Sarmukadam; Sameer Nanda; net...@vger.kernel.org; Sonny Rao; Douglas > Anderson

[PATCH 0/3] ath10k: add a support of set_tsf on vdev interface

2016-04-04 Thread Peter Oh
10.2.4 and 10.4 firmware has introduced new function to set TSF via vdev parameter. set_tsf function can be used to shift TBTT that will help avoid its clockdrift which happens when beacons are collided. Peter Oh (3): ath10k: add a support of set_tsf on vdev interface ath10k: update 10.4 WMI

[PATCH 1/3] ath10k: add a support of set_tsf on vdev interface

2016-04-04 Thread Peter Oh
10.2.4.70.24 firmware introduces new feature to set TSF via vdev parameter, hence implement relevant function. set_tsf function can be used to shift TBTT that will help avoid its clockdrift which happens when beacons are collided. Signed-off-by: Peter Oh ---

[PATCH 2/3] ath10k: update 10.4 WMI vdev parameters

2016-04-04 Thread Peter Oh
Update 10.4 WMI vdev param to sync to current 10.4 firmware as of 2/23/2016. Signed-off-by: Peter Oh --- drivers/net/wireless/ath/ath10k/wmi.h | 6 ++ 1 file changed, 6 insertions(+) diff --git a/drivers/net/wireless/ath/ath10k/wmi.h

[PATCH 3/3] ath10k: enable set_tsf vdev command to WMI 10.4

2016-04-04 Thread Peter Oh
10.4 firmware has addeded set_tsf vdev parameter, hence enable it. set_tsf function can be used to shift TBTT that will help avoid its clockdrift which happens when beacons are collided. Signed-off-by: Peter Oh --- drivers/net/wireless/ath/ath10k/wmi.c | 2 +- 1 file

[PATCH] mac80211: fix "warning: ‘target_metric’ may be used uninitialized"

2016-04-04 Thread Jeff Mahoney
This fixes: net/mac80211/mesh_hwmp.c:603:26: warning: ‘target_metric’ may be used uninitialized in this function target_metric is only consumed when reply = true so no bug exists here, but gcc doesn't notice that. Initializing to 0 clears the warning. Signed-off-by: Jeff Mahoney

Re: [PATCH 1/2] wil6210: allow empty WMI commands in debugfs wmi_send

2016-04-04 Thread Kalle Valo
Maya Erez writes: > From: Lior David > > There are many valid WMI commands with only header without any > additional payload. Such WMI commands could not be sent using > the debugfs wmi_send facility. Fix the code to allow sending > of

Re: [PATCH] ath5k: Change led pin configuration for compaq c700 laptop

2016-04-04 Thread Kalle Valo
Joseph Salisbury writes: > BugLink: http://bugs.launchpad.net/bugs/972604 > > Commit 09c9bae26b0d3c9472cb6ae45010460a2cee8b8d ("ath5k: add led pin > configuration for compaq c700 laptop") added a pin configuration for the > Compaq > c700 laptop. However, the

Re: [PATCH v2] ath10k: parse Rx MAC timestamp in mgmt frame for FW 10.4

2016-04-04 Thread Valo, Kalle
Peter Oh writes: > Check and parse Rx MAC timestamp when firmware sets its flag > to status variable. > 10.4 firmware adds it in Rx beacon frame only at this moment. > Drivers and mac80211 may utilize it to detect such clockdrift > or beacon collision and use the result

Re: [PATCH 0/9] ath10k: improve throughput performance

2016-04-04 Thread Valo, Kalle
Rajkumar Manoharan writes: > Hi All, > > In order to reuse HTT Rx descriptor (copy engine 5), HTT response > processing should be decoupled from txrx data processing. This change also > helps to reduce rx ring lock contention. As txrx tasklet's work load is > reduced,

Re: [PATCH v1 1/3] ath10k: Enable debugfs provision to enable Peer Stats feature

2016-04-04 Thread Valo, Kalle
Mohammed Shafi Shajakhan writes: > From: Mohammed Shafi Shajakhan > > Provide a debugfs entry to enable/ disable Peer Stats feature. > Peer Stats feature is for developers/users who are more interested > in studying in Rx/Tx stats with

Re: AP firmware for TI wl1251 wifi chip (wl1251-fw-ap.bin)

2016-04-04 Thread Pali Rohár
On Sunday 20 March 2016 00:40:25 Pali Rohár wrote: > Hi! > > In linux-firmware repository [1] is missing AP firmware for TI wl1251 > chip. There is only STA firmware wl1251-fw.bin which supports managed > and ad-hoc modes. > > For other TI wilink chips there are -ap.bin firmware files >

Re: [PATCH v2 10/15] wcn36xx: Copy all members in config_sta v1 conversion

2016-04-04 Thread Sergei Shtylyov
On 4/4/2016 1:16 AM, Bjorn Andersson wrote: From: Pontus Fuchs When converting to version 1 of the config_sta struct not all members where copied. This fixes the problem of multicast frames Were. not being delivered on an encrypted network. Signed-off-by:

Re: [PATCH v2 09/15] wcn36xx: Parse trigger_ba response properly

2016-04-04 Thread Sergei Shtylyov
Hello. On 4/4/2016 1:16 AM, Bjorn Andersson wrote: From: Pontus Fuchs This message does not follow the canonical format and needs it's own parser. Signed-off-by: Pontus Fuchs Signed-off-by: Bjorn Andersson ---

[PATCH 7/8] staging: wilc1000: rename u32WidsCount in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames u32WidsCount to index to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 58 +++ 1 file changed, 29 insertions(+), 29 deletions(-) diff --git

[PATCH 6/8] staging: wilc1000: rename strWIDList in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames strWIDList to wid_list to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 48 +++ 1 file changed, 24 insertions(+), 24 deletions(-) diff --git

[PATCH 4/8] staging: wilc1000: rename Handle_Scan

2016-04-04 Thread Chaehyun Lim
This patch renames Handle_Scan to handle_scan to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 1/8] staging: wilc1000: rename goto label in handle_cfg_param

2016-04-04 Thread Chaehyun Lim
This patch changes goto label from ERRORHANDLER to unlock. unlock is a more meaningful name than ERRORHANDLER. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 38 +++ 1 file changed, 19 insertions(+), 19

[PATCH 8/8] staging: wilc1000: rename pu8Buffer in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames pu8Buffer to buffer to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 3/8] staging: wilc1000: remove block scope braces and fix indentation

2016-04-04 Thread Chaehyun Lim
This patch removes unnecessary block scope braces and fix indentation of the codes. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 12 +--- 1 file changed, 5 insertions(+), 7 deletions(-) diff --git

[PATCH 5/8] staging: wilc1000: rename pstrHostIFscanAttr in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames pstrHostIFscanAttr to scan_info to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 55 +++ 1 file changed, 27 insertions(+), 28 deletions(-) diff --git

Re: mac80211 kasan splat, hacked 4.4.6+, ath10k with modified 10.4.3 fw

2016-04-04 Thread Michal Kazior
On 1 April 2016 at 17:56, Ben Greear wrote: > I saw this splat yesterday evening... Any ideas on what this could be? > > I'll add some bounds checking on the rate->idx in case that is the issue... > > > (gdb) l *(sta_set_rate_info_tx+0x1b3) > 0x38dcc is in