Hello.
After kernel upgrade from 4.6.4 to 4.7.0 WiFi LED stops working after
suspend/hibernate cycle. LED works properly right after (re)boot. LED worked
properly after suspend/hibernate cycle with 4.6.4, thus it's a regression.
My hardware is "Qualcomm Atheros AR9285 Wireless Network Adapter (
On Tue, Aug 02, 2016 at 07:49:19AM +0200, Daniel Wagner wrote:
> >The sysdata API's main goal rather is to provide a flexible API first,
> >compartamentalizing the usermode helper was secondary. But now it seems
> >I may just also add devm support too to help simplify code further.
>
> I missed th
Hi Luis,
I was ignorant on all the nasty details around the firmware loading.
If I parse Luis' patches correctly they introduce an API which calls
kernel_read_file_from_path() asynchronously:
sysdata_file_request_async(..., &cookie)
*coookie = async_schedule_domain(request_sysdata_file_work_f
On 2016年08月01日 19:03, Johannes Berg wrote:
But why is that behaviour *correct*? We still support 40 MHz bandwidth
things, we just don't use them if we disable HT40.
Or do you mean difference between "hardware capability" and "software
capability" ?
Do you think IEEE80211_HT_CAP_SUP_WIDTH_20_4
On Mon, Aug 01, 2016 at 10:19:51AM -0700, Bjorn Andersson wrote:
> On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote:
>
> > On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
> > > + Luis (again) ;-)
> > >
> > > On 29-07-16 08:13, Daniel Wagner wrote:
> > > > On 07/28/2016 09:0
On Mon, Aug 01, 2016 at 10:19:51AM -0700, Bjorn Andersson wrote:
> On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote:
>
> > On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
> > > + Luis (again) ;-)
> > >
> > > On 29-07-16 08:13, Daniel Wagner wrote:
> > > > On 07/28/2016 09:0
On Sun, Jul 31, 2016 at 12:23:09AM -0700, Dmitry Torokhov wrote:
> On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez"
> wrote:
> >On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
> >> + Luis (again) ;-)
> >>
> >> On 29-07-16 08:13, Daniel Wagner wrote:
> >> > On 07/28/2016 09:
On Mon, Aug 01, 2016 at 02:26:04PM +0200, Daniel Wagner wrote:
> On 07/31/2016 09:23 AM, Dmitry Torokhov wrote:
> >On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez"
> >wrote:
> >>On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
> >>>On 29-07-16 08:13, Daniel Wagner wrote:
> >>
* Update the comments that refer to semaphores
* Remove redundant includes to semphore.h
Signed-off-by: Joshua Houghton
---
drivers/staging/wilc1000/TODO | 1 -
drivers/staging/wilc1000/linux_wlan.c | 1 -
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +-
drivers/stag
On 08/01/2016 02:02 AM, Arnd Bergmann wrote:
> On Sunday, July 31, 2016 4:48:44 PM CEST Arvind Yadav wrote:
>> IS_ERR_VALUE() assumes that parameter is an unsigned long.
>> It can not be used to check if 'unsigned int' is passed insted.
>> Which tends to reflect an error.
>>
>> In 64bit architectur
IS_ERR_VALUE() assumes that parameter is an unsigned long.
It can not be used to check if 'unsigned int' is passed insted.
Which tends to reflect an error.
In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8.
IS_ERR_VALUE(x) is ((x) >= (unsigned long)-4095).
IS_ERR_VALUE() of 'unsigned
On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote:
> On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
> > + Luis (again) ;-)
> >
> > On 29-07-16 08:13, Daniel Wagner wrote:
> > > On 07/28/2016 09:01 PM, Bjorn Andersson wrote:
> > >> On Thu 28 Jul 11:33 PDT 2016, Dmitry Torokh
On 08/01/2016 02:29 AM, Johannes Berg wrote:
Sure.. First use case will be to help with the problem of legacy
client devices that roam across multiple APs. It is a classic
enterprise Wi-Fi AP problem, often managed by a "network controller"
unit that is connected to all the APs.
The problem
> Added ieee80211_iface_work_handle_frame_control.
That function name doesn't really make sense - handle_mgmt() perhaps?
johannes
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger
On 2016年08月01日 19:03, Johannes Berg wrote:
But why is that behaviour *correct*? We still support 40 MHz bandwidth
things, we just don't use them if we disable HT40.
I could not fully understand your concern...
Do you mean we have 2 bugs about disabling HT40 ?
1) bits in HT capabilities IE
2)
On 07/31/2016 09:23 AM, Dmitry Torokhov wrote:
On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez" wrote:
On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote:
On 29-07-16 08:13, Daniel Wagner wrote:
On 07/28/2016 09:01 PM, Bjorn Andersson wrote:
On Thu 28 Jul 11:33 PDT 2016, Dm
On Thu, 2016-07-21 at 11:39 -0400, Bob Copeland wrote:
> iw was showing 'width: unknown' for channels on OCB interfaces; teach
> it the values for 5/10 MHz so it will show the configured width.
>
Applied, thanks.
johannes
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless
> + if (ieee80211_iface_work_handle_pkt_type(skb, sdata) &&
> + ieee80211_iface_work_handle_frame_control(skb, sdata)) {
> + ieee80211_iface_work_handle_vif_type(skb, sdata);
> }
>
This ends up being pretty strange IMHO, using boolean
Please don't submit three patches with identical subject.
> Added ieee80211_iface_work_handle_pkt_type function. Moved part of
Should also use present tense here - "Add ... function, move [...]".
This also applies to the other patches.
The if/else if/... -> switch change should also be part of
On Fri, 2016-07-22 at 14:26 +0900, Masashi Honma wrote:
> On 2016年07月14日 05:07, Yaniv Machani wrote:
> > +
> > + /* if channel width is 20MHz - configure HT capab
> > accordingly*/
> > + if (sdata->vif.bss_conf.chandef.width ==
> > NL80211_CHAN_WIDTH_20) {
> > + cap &= ~IEEE80211_HT_C
> From: Heinrich Schuchardt [mailto:xypron.g...@gmx.de]
> Sent: Sunday, July 31, 2016 4:09 PM
> To: Amitkumar Karwar; Nishant Sarmukadam; Kalle Valo
> Cc: linux-wireless@vger.kernel.org; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; Heinrich Schuchardt
> Subject: [PATCH 1/1] mwifiex: rem
> From: Heinrich Schuchardt [mailto:xypron.g...@gmx.de]
> Sent: Sunday, July 31, 2016 5:41 PM
> To: Amitkumar Karwar; Nishant Sarmukadam; Kalle Valo
> Cc: linux-wireless@vger.kernel.org; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; Heinrich Schuchardt
> Subject: [PATCH 1/1] mwifiex: key
On Wed, 2016-07-13 at 10:11 +, Machani, Yaniv wrote:
> On Wed, Jun 29, 2016 at 10:14:19, Johannes Berg wrote:
> > Cc: Hahn, Maital
> > Subject: Re: [PATCH 1/4] mac80211: mesh: flush stations before
> > beacons
> > are stopped
> >
> > On Tue, 2016-06-28 at 14:13 +0300, Yaniv Machani wrote:
> >
On Fri, 2016-07-22 at 15:12 +0530, Purushottam Kushwaha wrote:
> Driver may allow support for different beacon interval on virtual
> interfaces.
> Allow if such support is advertised by driver. This adds new
> ext_feature as
> NL80211_EXT_FEATURE_DIFF_BEACON_INTERVAL.
>
My earlier comment regardin
On Mon, Aug 1, 2016 at 1:35 AM, Roman Yeryomin wrote:
> On 7 July 2016 at 19:30, Valo, Kalle wrote:
>> Michal Kazior writes:
>>
>>> Ideally wake_tx_queue should be used regardless as
>>> it is a requirement for reducing bufferbloat and
>>> implementing airtime fairness in the future.
>>>
>>> How
On Wed, 2016-07-13 at 14:44 +0300, Yaniv Machani wrote:
> From: Maital Hahn
>
> Some drivers (e.g. wl18xx) expect that the last stage in the
> de-initialization process will be stopping the beacons, similar to AP
> flow.
> Update ieee80211_stop_mesh() flow accordingly.
> As peers can be removed d
> >
> > > + /* bus private data */
> > > + char bus_priv[0];
> > You might want to - for future proofing - add some aligned()
> > attribute.
> > Otherwise, if struct mutex doesn't have a size that's a multiple of
> > the
> > pointer size, fields in here will not be aligned right.
>
> Right, than
> Sure.. First use case will be to help with the problem of legacy
> client devices that roam across multiple APs. It is a classic
> enterprise Wi-Fi AP problem, often managed by a "network controller"
> unit that is connected to all the APs.
> The problem is how to handle seamless handoff of cl
On Thu, 2016-07-28 at 16:02 +0800, Kai Hendry wrote:
> Hi there,
>
> Since laptops typically have a toggle button for killing and enabled
> wifi, how does one supposed to bind rfkill like a toggle?
>
> I.e. knowing which state you are in so you can call {block,unblock}
> accordingly?
>
> Parsing
Hi,
please don't reply to me privately. Let's keep the discussion on the
lists so that others can join and learn.
"russianneuroman...@ya.ru" writes:
>> That looks good to me, but please submit it officially as defined in
>> the wiki
>
> Just to be sure I understand you right - I have to just se
On Sunday, July 31, 2016 4:48:44 PM CEST Arvind Yadav wrote:
> IS_ERR_VALUE() assumes that parameter is an unsigned long.
> It can not be used to check if 'unsigned int' is passed insted.
> Which tends to reflect an error.
>
> In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8.
> IS_ER
31 matches
Mail list logo