Re: [PATCH] mac80211: fix rx-rate report when rate is invalid.

2016-12-07 Thread Johannes Berg
On Mon, 2016-12-05 at 14:12 -0800, gree...@candelatech.com wrote: > From: Ben Greear > > This fixes obtaining the rate info via sta_set_sinfo > when the rx rate is invalid (for instance, on IBSS > interface that has received no frames from one of its > peers). Please fix this completely while at

Re: [PATCH] mac80211: Remove invalid flag operations in mesh TSF synchronization

2016-12-07 Thread Johannes Berg
Hi, I'm not sure what to do with this now :) > > There are two functionalities. > > > > 1) 13.13.2.2 Neighbor offset synchronization method > > 2) 13.13.4.4 TBTT adjustment Yes, this much is obvious. > > The flag is updated by 2). Yes, the definition of the flag says: "The TBTT Adjusting sub

Re: [PATCH v2 2/2] cfg80211: Add support to sched scan to report better BSSs

2016-12-07 Thread Johannes Berg
> v2: address comments from Luca, Arend, and Johannes What about Arend's comment regarding this functionality overlapping with the BSS selection offload configuration? Do you think there's any ability to share attributes/functionality? johannes

RE: [PATCH v2 2/2] cfg80211: Add support to sched scan to report better BSSs

2016-12-07 Thread Vamsi, Krishna
> -Original Message- > From: Johannes Berg [mailto:johan...@sipsolutions.net] > What about Arend's comment regarding this functionality overlapping with the > BSS selection offload configuration? > > Do you think there's any ability to share attributes/functionality? Hi Johannes, I thin

Re: [PATCH v2 2/2] mac80211: Show pending txqlen in debugfs.

2016-12-07 Thread Johannes Berg
On Mon, 2016-12-05 at 10:58 -0800, gree...@candelatech.com wrote: > From: Ben Greear > > Could be useful for debugging memory consumption issues, > and perhaps power-save as well. Applied this one, but I tend to agree with Felix about the ethtool stuff, so I've dropped that. FWIW, we have cfg80

Re: [PATCH] mac80211: Ensure enough headroom when forwarding mesh pkt

2016-12-07 Thread Johannes Berg
> - fwd_skb = skb_copy(skb, GFP_ATOMIC); > + if (skb_headroom(skb) >= local->tx_headroom) > + fwd_skb = skb_copy(skb, GFP_ATOMIC); > + else > + fwd_skb = skb_copy_expand(skb, local->tx_headroom, > +   0, GFP_ATOMIC); Why both

Re: [PATCH][RFC] cfg80211: NL80211_ATTR_SOCKET_OWNER support for CMD_CONNECT

2016-12-07 Thread Andrew Zaborowski
On 7 December 2016 at 07:19, Johannes Berg wrote: >> Possibly Johanness refers to the fact that if you use >> CMD_AUTHENTICATE, or if you use CMD_CONNECT but the driver implements >> the SME -- doesn't use the cfg80211 software SME -- then >> cfg80211_disconnect won't do anything if we're not asso

[PATCH v2] mac80211: Ensure enough headroom when forwarding mesh pkt

2016-12-07 Thread Cedric Izoard
When a buffer is duplicated during MESH packet forwarding, this patch ensures that the new buffer has enough headroom. Signed-off-by: Cedric Izoard --- net/mac80211/rx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/mac80211/rx.c b/net/mac80211/rx.c index d2a00f2..bfa5f

RE: [PATCH] mac80211: Ensure enough headroom when forwarding mesh pkt

2016-12-07 Thread Cedric Izoard
> > - fwd_skb = skb_copy(skb, GFP_ATOMIC); > > + if (skb_headroom(skb) >= local->tx_headroom) > > + fwd_skb = skb_copy(skb, GFP_ATOMIC); > > + else > > + fwd_skb = skb_copy_expand(skb, local->tx_headroom, > > +   0, GFP_ATOMIC); > > Why b

RE: [1/2] mwifiex: code rearrangement in pcie.c and sdio.c

2016-12-07 Thread Amitkumar Karwar
Hi Kalle, > From: linux-wireless-ow...@vger.kernel.org [mailto:linux-wireless- > ow...@vger.kernel.org] On Behalf Of Kalle Valo > Sent: Monday, December 05, 2016 4:39 PM > To: Amitkumar Karwar > Cc: linux-wireless@vger.kernel.org; Cathy Luo; Nishant Sarmukadam; > raja...@google.com; briannor...@go

Re: [PATCH 1/4] cfg80211: Add support to enable or disable btcoex

2016-12-07 Thread Tamizh chelvam
Hi Johannes, Thanks for the comments. On 2016-12-05 20:16, Johannes Berg wrote: On Tue, 2016-11-08 at 18:45 +0530, c_tr...@qti.qualcomm.com wrote: From: Tamizh chelvam This patch adds support to enable or disable btcoex by adding NL80211_ATTR_WIPHY_BTCOEX_ENABLE attribute in NL80211_CMD_SET_

Re: [PATCH] iwlegacy: make il3945_mac_ops __ro_after_init

2016-12-07 Thread Stanislaw Gruszka
On Wed, Dec 07, 2016 at 07:36:46AM +0100, Johannes Berg wrote: > From: Johannes Berg > > There's no need for this to be only __read_mostly, since > it's only written in a single way depending on the module > parameter, so that can be moved into the module's __init > function, and the ops can be _

Re: [PATCH 1/1] net: wireless: intersil: fix improper return value

2016-12-07 Thread Kalle Valo
Pan Bian writes: > Function orinoco_ioctl_commit() returns 0 (indicates success) when the > call to orinoco_lock() fails. Thus, the return value is inconsistent with > the execution status. It may be better to return "-EBUSY" when the call > to orinoco_lock() fails. > > Bugzilla: https://bugzill

Re: [PATCH 10/14] rtlwifi: Add BTC_TRACE_STRING to new btcoex

2016-12-07 Thread Kalle Valo
Greg KH writes: > On Mon, Dec 05, 2016 at 04:34:08PM -0600, Larry Finger wrote: >> On 12/05/2016 03:34 PM, Dan Carpenter wrote: >> > On Thu, Dec 01, 2016 at 07:48:29PM -0600, Larry Finger wrote: >> > > --- >> > > wireless-drivers-next.orig/drivers/net/wireless/realtek/rtlwifi/btcoexist/halbtcout

Re: [PATCH] mac80211: Remove invalid flag operations in mesh TSF synchronization

2016-12-07 Thread Masashi Honma
On 2016年12月07日 18:24, Johannes Berg wrote: And the flag is refered by 1) as you said. The purpose of the flag is to prevent 1) while 2) is ongoing. In other words, 1) has only read access authority to the flag. However, previous code updated the flag in 1). In addition, there is no code for 2)

[patch] adm80211: return an error if adm8211_alloc_rings() fails

2016-12-07 Thread Dan Carpenter
We accidentally return success when adm8211_alloc_rings() fails but we should preserve the error code. Fixes: cc0b88cf5ecf ("[PATCH] Add adm8211 802.11b wireless driver") Signed-off-by: Dan Carpenter diff --git a/drivers/net/wireless/admtek/adm8211.c b/drivers/net/wireless/admtek/adm8211.c inde

Re: [PATCH 10/14] rtlwifi: Add BTC_TRACE_STRING to new btcoex

2016-12-07 Thread Dan Carpenter
On Wed, Dec 07, 2016 at 02:16:06PM +0200, Kalle Valo wrote: > We have disccused this before, but for wireless it's not really that > simple. AFAIK with dyndbg you can only control the messages per line > (painful to enable group of messages) or per file (enables too many > messages). In wireless we

Re: [PATCH] mac80211: Remove invalid flag operations in mesh TSF synchronization

2016-12-07 Thread Bob Copeland
On Wed, Dec 07, 2016 at 09:55:41PM +0900, Masashi Honma wrote: > >It's called mesh_sync_offset_adjust_tbtt() which matches more closely > >"TBTT adjustment" than "neighbor offset synchronization"? > > I think so. Because there is not any code creating "TBTT Adjustment Request > frame" even though

Re: [PATCH 23/39] Annotate hardware config module parameters in drivers/net/wireless/

2016-12-07 Thread David Howells
Kalle Valo wrote: > Via which tree are you planning to submit this, should I take it to > wireless-drivers or will someone else handle it? I didn't get the cover > letter so I have no idea. I'll see if I can get patch 1 (which defines the macros) in a window prior to the others - or maybe I can

Re: [v3,3/3] mt76: add driver code for MT76x2e

2016-12-07 Thread Felix Fietkau
On 2016-10-04 18:34, Kalle Valo wrote: > Felix Fietkau wrote: >> From: Felix Fietkau >> >> This is a 2x2 PCIe 802.11ac chipset by MediaTek >> >> Signed-off-by: Felix Fietkau > > A summary of what feature work would be nice to have. Also if there's > something > notable which is not working i

Re: [v3,3/3] mt76: add driver code for MT76x2e

2016-12-07 Thread Felix Fietkau
On 2016-10-04 18:45, Kalle Valo wrote: > Felix Fietkau wrote: >> From: Felix Fietkau >> >> This is a 2x2 PCIe 802.11ac chipset by MediaTek >> >> Signed-off-by: Felix Fietkau > > I already asked this in v2, but what about firmware images? Will they be > available from linux-firmware.git? Seems

Re: [PATCH 10/14] rtlwifi: Add BTC_TRACE_STRING to new btcoex

2016-12-07 Thread Larry Finger
On 12/07/2016 07:32 AM, Dan Carpenter wrote: On Wed, Dec 07, 2016 at 02:16:06PM +0200, Kalle Valo wrote: We have disccused this before, but for wireless it's not really that simple. AFAIK with dyndbg you can only control the messages per line (painful to enable group of messages) or per file (en

[PATCH 1/5] ath10k: fix IRAM banks number for QCA9377

2016-12-07 Thread Bartosz Markowski
QCA9377 firmware shall alloc 4 IRAM banks Signed-off-by: Bartosz Markowski --- drivers/net/wireless/ath/ath10k/pci.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ath/ath10k/pci.c b/drivers/net/wireless/ath/ath10k/pci.c index 0457e315d336..983f65bbb7fb

[PATCH 5/5] ath10k: add debug trace to rts/cts set function

2016-12-07 Thread Bartosz Markowski
Align it with the cts protection call. Signed-off-by: Bartosz Markowski --- drivers/net/wireless/ath/ath10k/mac.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/net/wireless/ath/ath10k/mac.c b/drivers/net/wireless/ath/ath10k/mac.c index 6f1825964177..508366f139f1 100644 --- a/dr

[PATCH 4/5] ath10k: set CTS protection VDEV param only if VDEV is up

2016-12-07 Thread Bartosz Markowski
The cts protection vdev parameter, in new QCA9377 TF2.0 firmware, requires bss peer to be created for the STATION vdev type. bss peer is being allocated by the firmware after vdev_start/_up commands. mac80211 may call the cts protection setup at any time, so the we needs to track the situation and

[PATCH 3/5] ath10k: decrease num of peers support

2016-12-07 Thread Bartosz Markowski
The correct number for QCA9377 chip is 33 VDEVs. This impacts also QCA6174 chip and it's max VDEV number. Signed-off-by: Bartosz Markowski --- drivers/net/wireless/ath/ath10k/hw.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ath/ath10k/hw.h b/drivers/

[PATCH 2/5] ath10k: override CE5 config for QCA9377

2016-12-07 Thread Bartosz Markowski
Similarly to QCA6174, QCA9377 requires the CE5 configuration to be available for other feature. Use the ath10k_pci_override_ce_config() for it as well. This is required for TF2.0 firmware. Previous FW revisions were working fine without this patch. Fixes: a70587b3389a ("ath10k: configure copy eng

Re: [PATCH 2/4] cfg80211: Add new NL80211_CMD_SET_BTCOEX_PRIORITY to support BTCOEX

2016-12-07 Thread Tamizh chelvam
Hi Johannes, Thanks for the comments. On 2016-12-05 20:19, Johannes Berg wrote: On Tue, 2016-11-08 at 18:45 +0530, c_tr...@qti.qualcomm.com wrote:   + * struct cfg80211_btcoex_priority - BTCOEX support frame type + * + * This structure defines the driver supporting frame types for BTCOEX + * +

Re: [PATCH] RFC: Universal scan proposal

2016-12-07 Thread Dmitry Shmidt
On Tue, Dec 6, 2016 at 10:44 PM, Johannes Berg wrote: > >> Indeed, results are results. I just want to take care of two things: >> 1) Memory consumption - we can clear stale scan results for >> connection, but not for location if we are using history scan. > > Well eventually we also have to clear

Re: [PATCH v2 2/2] cfg80211: Add support to sched scan to report better BSSs

2016-12-07 Thread Arend Van Spriel
On 7-12-2016 10:33, Vamsi, Krishna wrote: >> -Original Message- >> From: Johannes Berg [mailto:johan...@sipsolutions.net] > >> What about Arend's comment regarding this functionality overlapping with the >> BSS selection offload configuration? >> >> Do you think there's any ability to shar

Re: [PATCH v2 2/2] cfg80211: Add support to sched scan to report better BSSs

2016-12-07 Thread Arend Van Spriel
On 2-12-2016 22:59, Jouni Malinen wrote: > From: vamsi krishna > > Enhance sched scan to support option of finding a better BSS while in > connected state. Firmware scans the medium and reports when it finds a > known BSS which has better RSSI than the current connected BSS. New > attributes to s

Re: [PATCH] RFC: Universal scan proposal

2016-12-07 Thread Arend Van Spriel
On 7-12-2016 19:39, Dmitry Shmidt wrote: > On Tue, Dec 6, 2016 at 10:44 PM, Johannes Berg > wrote: >> >>> Indeed, results are results. I just want to take care of two things: >>> 1) Memory consumption - we can clear stale scan results for >>> connection, but not for location if we are using histor

[PATCH] ath10k: fix incorrect txpower set by P2P_DEVICE interface

2016-12-07 Thread ryanhsu
From: Ryan Hsu Ath10k reports the phy capability that upports P2P_DEVICE interface. When we use the P2P supported wpa_supplicant to start connection, it'll create the two interfaces, one is wlan0 (vdev_id=0) and one is P2P_DEVICE p2p-dev-wlan0 which is for p2p control channel (vdev_id=1).

[PATCH 1/1] orinoco: fix improper return value

2016-12-07 Thread Pan Bian
Function orinoco_ioctl_commit() returns 0 (indicates success) when the call to orinoco_lock() fails. Thus, the return value is inconsistent with the execution status. It may be better to return "-EBUSY" when the call to orinoco_lock() fails. Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=1

Ralink Rt3290

2016-12-07 Thread Abhiroop Dabral
Hi, I am working on porting of Ralinks rt3290 wireless adapter. Is there any resource like specification manual or programming guide which explains the register space of the chip? I will really appreciate if anyone can direct me to a resource like this. Kins regards, Abhiroop

[PATCH v2 2/2] mac80211: Use appropriate name for functions and messages

2016-12-07 Thread Masashi Honma
These functions drifts TSF timers, not TBTT. Signed-off-by: Masashi Honma --- net/mac80211/ieee80211_i.h | 4 ++-- net/mac80211/mesh.c| 2 +- net/mac80211/mesh.h| 2 +- net/mac80211/mesh_sync.c | 16 net/mac80211/tx.c | 2 +- 5 files changed, 13 in

[PATCH v2 1/2] mac80211: Remove invalid flag operations in mesh TSF synchronization

2016-12-07 Thread Masashi Honma
mesh_sync_offset_adjust_tbtt() implements Extensible synchronization framework ([1] 13.13.2 Extensible synchronization framework). It shall not operate the flag "TBTT Adjusting subfield" ([1] 8.4.2.100.8 Mesh Capability), since it is used only for MBCA ([1] 13.13.4 Mesh beacon collision avoidance,

Re: [PATCH] mac80211: Remove invalid flag operations in mesh TSF synchronization

2016-12-07 Thread Masashi Honma
On 2016年12月07日 22:33, Bob Copeland wrote: This mesh_sync_offset_adjust_tbtt is definitely doing offset synchronization, so probably "tbtt" should be renamed "tsf" here. Right. I will send a patch for this. Actually, looking at the code now it doesn't make a lot of sense to set this flag for o

[PATCH 1/3] rsi: Renamed the file rsi_91x_pkt.c to rsi_91x_hal.c

2016-12-07 Thread Prameela Rani Garnepudi
The file 'rsi_91x_hal.c' is going to contain device specific code like firmware loading etc. As the file 'rsi_91x_pkt.c' contains code for preparing device (frimware understandable) specific descriptors for the transmit frames, it is moved to 'rsi_91x_hal.c' Signed-off-by: Prameela Rani Garnepudi

[PATCH 2/3] rsi: Add new firmware loading method for RS9113 chip set

2016-12-07 Thread Prameela Rani Garnepudi
The older firmware loading method has been deprecated and not in use with the current RS9113 modules. The newer method uses soft boot loader (resides in device) to load the functional firmware. In this method complete RAM image and FLASH image are present in the flash. Before loading the functional

[PATCH 3/3] rsi: Remove old firmware loading method for RS9113 chip set

2016-12-07 Thread Prameela Rani Garnepudi
Older firmware loading method is not being used by any RSI module. Hence removing that part of code doesn't impact. New device ID is added which is widely used for current RSI chip sets. Changes done in usb and sdio inteface files to support new firmware loading method. Signed-off-by: Prameela Ran

[PATCH v2 1/2] net: rfkill: Cleanup error handling in rfkill_init()

2016-12-07 Thread Michał Kępień
Use a separate label per error condition in rfkill_init() to make it a bit cleaner and easier to extend. Signed-off-by: Michał Kępień --- No changes from v1. net/rfkill/core.c | 23 --- 1 file changed, 12 insertions(+), 11 deletions(-) diff --git a/net/rfkill/core.c b/net/r

[PATCH v2 2/2] net: rfkill: Add rfkill-any LED trigger

2016-12-07 Thread Michał Kępień
Add a new "global" (i.e. not per-rfkill device) LED trigger, rfkill-any, which may be useful on laptops with a single "radio LED" and multiple radio transmitters. The trigger is meant to turn a LED on whenever there is at least one radio transmitter active and turn it off otherwise. Signed-off-by