Re: [PATCH 2/3] ath10k: use dma_zalloc_coherent()

2017-01-23 Thread Joe Perches
On Tue, 2017-01-24 at 05:18 +, Valo, Kalle wrote: > Joe Perches writes: > > > On Mon, 2017-01-23 at 15:04 +, Srinivas Kandagatla wrote: > > > use dma_zalloc_coherent() instead of dma_alloc_coherent and memset(). > > > > [] > > > diff --git

Re: [PATCH 2/3] ath10k: use dma_zalloc_coherent()

2017-01-23 Thread Valo, Kalle
Joe Perches writes: > On Mon, 2017-01-23 at 15:04 +, Srinivas Kandagatla wrote: >> use dma_zalloc_coherent() instead of dma_alloc_coherent and memset(). > [] >> diff --git a/drivers/net/wireless/ath/ath10k/pci.c >> b/drivers/net/wireless/ath/ath10k/pci.c > [] >> @@ -896,7

Re: [PATCH 2/3] ath10k: use dma_zalloc_coherent()

2017-01-23 Thread Joe Perches
On Mon, 2017-01-23 at 15:04 +, Srinivas Kandagatla wrote: > use dma_zalloc_coherent() instead of dma_alloc_coherent and memset(). [] > diff --git a/drivers/net/wireless/ath/ath10k/pci.c > b/drivers/net/wireless/ath/ath10k/pci.c [] > @@ -896,7 +896,7 @@ static int

[PATCH 10/25] iwlwifi: enlarge number of ucode sections

2017-01-23 Thread Luca Coelho
From: Sara Sharon The maximum number of firmware sections is now 32 instead of 16 for a000 devices. Set the appropriate define. Avoid out of bounds access in case there are more sections than the maximum set by driver. Make the driver extensible to FW size changes by

[PATCH 11/25] iwlwifi: mvm: change iwl_mvm_tx_csum to return value

2017-01-23 Thread Luca Coelho
From: Sara Sharon Currently the function changes the TX cmd itself. Make it more generic by returning a value, as preperation to the new TX cmd. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho ---

[PATCH 17/25] iwlwifi: mvm: rs: Remove unused 'mcs' variable

2017-01-23 Thread Luca Coelho
From: Kirtika Ruchandani Commit 5fc0f76c4 introduced Rx stats from debugfs, the function iwl_mvm_reset_frame_stats from that commit defines and sets mcs but does not use it. Compiling iwlwifi with W=1 gives this warning - iwlwifi/mvm/rs.c: In function

[PATCH 14/25] iwlwifi: fix MODULE_FIRMWARE for 6030

2017-01-23 Thread Luca Coelho
From: Jürg Billeter IWL6000G2B_UCODE_API_MAX is not defined. ucode_api_max of IWL_DEVICE_6030 uses IWL6000G2_UCODE_API_MAX. Use this also for MODULE_FIRMWARE. Fixes: 9d9b21d1b616 ("iwlwifi: remove IWL_*_UCODE_API_OK") Signed-off-by: Jürg Billeter Signed-off-by:

[PATCH 22/25] iwlwifi: dvm: remove unused variable compiler warning in debugfs.c

2017-01-23 Thread Luca Coelho
From: Luca Coelho When compiling with W=1, we get the following warning in debugfs.c: /home/luca/iwlwifi/stack-dev/drivers/net/wireless/intel/iwlwifi/dvm/debugfs.c: In function ‘iwl_dbgfs_fw_restart_write’:

[PATCH 13/25] iwlwifi: mvm: support version 2 of stored beacon notification

2017-01-23 Thread Luca Coelho
From: Sara Sharon For 9000 devices withg upload, FW cannot send the entire phy flags, and will send only the band - which is what we really care about anyway. Change is backward compatible. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho

[PATCH 23/25] iwlwifi: mvm: mark ret as maybe_unused in iwl_dbgfs_fw_restart_write()

2017-01-23 Thread Luca Coelho
From: Luca Coelho The value returned from iwl_mvm_send_cmd_pdu() in this function is not used and always returns an error (which is the whole point of the call). Tag the ret variable with __maybe_unused to avoid this compile warning when W=1 is used:

[PATCH 16/25] iwlwifi: mvm: rs: Remove unused 'mvmvif'/'mvmsta' variables

2017-01-23 Thread Luca Coelho
From: Kirtika Ruchandani mvmvif is defined and set in rs_mimo_allow but not used. Compiling iwlwifi with W=1 gives the following warning, remove it. mvmsta is used only to obtain mvmvif so remove it as well. iwlwifi/mvm/rs.c: In function 'rs_mimo_allow':

[PATCH 24/25] iwlwifi: mvm: use mvm_disable_queue instead of sharing logic

2017-01-23 Thread Luca Coelho
From: Sara Sharon When removing inactive queue - use the central disable queue function. This is needed due to a000 changes to come, but is a proper cleanup anyway. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho

[PATCH 18/25] iwlwifi: pcie: trans: Remove unused 'shift_param'

2017-01-23 Thread Luca Coelho
From: Kirtika Ruchandani shift_param is defined and set in iwl_pcie_load_cpu_sections but not used. Fix this to avoid -Wunused-but-set-variable warning. The code using it turned into dead code with commit dcab8ecd5617 ("iwlwifi: mvm: support ucode load for

[PATCH 12/25] iwlwifi: mvm: separate rate calculation to a new function

2017-01-23 Thread Luca Coelho
From: Sara Sharon In preparation for the new TX cmd - move the rate calculation to a diffrent function, and make it independent of the TX command. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho ---

[PATCH 15/25] iwlwifi: mvm: remove unused variable in iwl_mvm_handle_statistics()

2017-01-23 Thread Luca Coelho
From: Luca Coelho The temperature variable is set but not used in iwl_mvm_handle_statistics(). Remove it to avoid the following compiler warning when W=1 is used: /home/luca/iwlwifi/stack-dev/drivers/net/wireless/intel/iwlwifi/mvm/rx.c: In function

[PATCH 21/25] iwlwifi: mvm: remove unused sta_id variable in iwl_mvm_change_queue_owner()

2017-01-23 Thread Luca Coelho
From: Luca Coelho Remove the sta_id variable, to avoid this compile warning when compiling with W=1: /home/luca/iwlwifi/stack-dev/drivers/net/wireless/intel/iwlwifi/mvm/sta.c: In function ‘iwl_mvm_change_queue_owner’:

[PATCH 20/25] iwlwifi: pcie: cleanup rfkill checks

2017-01-23 Thread Luca Coelho
From: Sara Sharon Move repeating code to a separate function. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/pcie/trans.c | 39 - 1 file changed, 18

[PATCH 07/25] iwlwifi: mvm: bump max API to 28

2017-01-23 Thread Luca Coelho
From: Luca Coelho We skipped one release, so bump twice, to 28. Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/iwl-7000.c | 4 ++-- drivers/net/wireless/intel/iwlwifi/iwl-8000.c | 4 ++--

[PATCH 08/25] iwlwifi: mvm: simplify paging allocation code

2017-01-23 Thread Luca Coelho
From: Sara Sharon Some of the code there is duplicate while the only change is the block size. Unifying it shortens the code and make the difference clearer. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho ---

[PATCH 09/25] iwlwifi: mvm: replace the number of blocks calculation

2017-01-23 Thread Luca Coelho
From: Sara Sharon The logic in the paging calculations is a bit hard to follow. Replace it with a kernel define. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw.c | 4

[PATCH 05/25] iwlwifi: allow memory debug TLV to specify the memory type

2017-01-23 Thread Luca Coelho
From: Johannes Berg Due to some new features and changes, the firmware file will now specify what type of memory to dump, in upper 8 bits of the type field of the TLV. Parse it (types we don't understand are errors) and teach the code to dump periphery memory.

[PATCH 02/25] iwlwifi: mvm: don't restart HW if suspend fails with unified image

2017-01-23 Thread Luca Coelho
From: Luca Coelho For unified images, we shouldn't restart the HW if suspend fails. The only reason for restarting the HW with non-unified images is to go back to the D0 image. Fixes: 23ae61282b88 ("iwlwifi: mvm: Do not switch to D3 image on suspend") Signed-off-by:

[PATCH 01/25] iwlwifi: mvm: expose device timestamp in radiotap

2017-01-23 Thread Luca Coelho
From: Johannes Berg Set the relevant fields to export the 32-bit device timestamp to radiotap using the new mac80211 infrastructure. This will be useful to allow synchronising monitor captures taken on different hardware simultaneously. Signed-off-by: Johannes Berg

[PATCH 00/25] iwlwifi: updates intended for v4.11 2017-01-23

2017-01-23 Thread Luca Coelho
From: Luca Coelho Hi, Here's my first series for v4.11. These are the changes: * A bunch of cleanups here and there; * A few simple bugfixes; * Some more work in preparation for A000 family support; * Add support for radiotap timestamps; * Some work on our firmware

[PATCH 06/25] iwlwifi: mvm: properly check for transport data in dump

2017-01-23 Thread Luca Coelho
From: Johannes Berg When copying from vmalloc'ed memory to the SG list, don't crash if the transport didn't provide any data. Fixes: 7e62a699aafb ("iwlwifi: mvm: use dev_coredumpsg()") Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho

[PATCH 03/25] iwlwifi: mvm: accept arbitrary memory dump TLVs

2017-01-23 Thread Luca Coelho
From: Johannes Berg There's no reason to be validating the memory dump types, or checking them for duplication, or anything, since we really just pass them through from the TLV to the dump. Thus, change the way we handle memory dump TLVs to let the driver just blindly

[PATCH 04/25] iwlwifi: mvm: make iwl_dump_prph() void

2017-01-23 Thread Luca Coelho
From: Johannes Berg The return value is never used, so make the function void. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-dbg.c | 16 ++-- 1 file

pull-request: iwlwifi 2017-01-23

2017-01-23 Thread Luca Coelho
Hi Kalle, After a long time (too long time, I admit), here comes a pull request with two fixes intended for v4.10. Nothing major, just two small fixes that were pending in our internal trees. I have some more, but I'm keeping this small for the -rc series. More details in the tag description.

Re: [RFC 0/1] ath9k: Frame corruption simulator

2017-01-23 Thread Ben Greear
On 01/20/2017 07:26 AM, Wojciech Dubowik wrote: On 20/01/17 15:45, Ben Greear wrote: On 01/20/2017 06:29 AM, Wojciech Dubowik wrote: I have been debugging customer reported timeout and loss of communication and I have relaized that I don't have such a lossy environment available in the

Urgent Delivery!!

2017-01-23 Thread Mr. Lewis Hawkins
Good day! I am contacting you regarding a special cargo that has been abandoned here at our warehouse for over a period of 2 years and when scanned, it revealed an undisclosed sum of money in it. From my findings, the cargo originated from Europe and the content was not declared as money by

Re: Strange Behaviors in 802.11 Association MLME

2017-01-23 Thread Johannes Berg
On Mon, 2017-01-16 at 16:16 -0500, Jinghao Shi wrote: > Hi, > > We're working on a formal validation framework for wireless protocol > implementations. We have performed experiments on the 802.11 > association state machine and have found peculiar association > behaviors.We'd like to share our

[PATCH 2/3] ath10k: use dma_zalloc_coherent()

2017-01-23 Thread Srinivas Kandagatla
use dma_zalloc_coherent() instead of dma_alloc_coherent and memset(). Signed-off-by: Srinivas Kandagatla --- drivers/net/wireless/ath/ath10k/ce.c | 9 + drivers/net/wireless/ath/ath10k/pci.c | 3 +-- 2 files changed, 2 insertions(+), 10 deletions(-)

[PATCH 3/3] ath10k: fix typo in addr calculation

2017-01-23 Thread Srinivas Kandagatla
CORE_CTRL_ADDRESS is offset in register address space, it does not make sense to OR it to derive the final address. It looks like its a typo, so fix it. Signed-off-by: Srinivas Kandagatla --- drivers/net/wireless/ath/ath10k/pci.c | 2 +- 1 file changed, 1

[PATCH 1/3] ath10k: remove multiple defines of DIAG_TRANSFER_LIMIT

2017-01-23 Thread Srinivas Kandagatla
DIAG_TRANSFER_LIMIT is redefined with same value and comments just below this entry, remove this duplicate entry. Signed-off-by: Srinivas Kandagatla --- drivers/net/wireless/ath/ath10k/pci.h | 5 - 1 file changed, 5 deletions(-) diff --git

Re: [PATCH v2 01/13] wil6210: add sysfs file for FTM calibration

2017-01-23 Thread Lior David
On 1/19/2017 3:14 PM, Arend Van Spriel wrote: > On 19-1-2017 13:36, Lior David wrote: >> On 1/19/2017 2:24 PM, Valo, Kalle wrote: >>> Maya Erez writes: >>> From: Lior David In fine timing measurements, the calculation is

From:Miss:Fatima Yusuf.

2017-01-23 Thread Miss Fatima Yusuf
From:Miss:Fatima Yusuf. For sure this mail would definitely come to you as a surprise, but do take your good time to go through it, My name is Miss.Fatima Yusuf,i am from Ivory Coast. I lost my parents a year and couple of months ago. My father was a serving director of the Agro-exporting

[PATCH 2/2] iwlwifi: mvm: avoid crash on restart w/o reserved queues

2017-01-23 Thread Luca Coelho
From: Johannes Berg When the firmware restarts in a situation in which any station has no queue reserved anymore because that queue was used, the code will crash trying to access the queue_info array at the offset 255, which is far too big. Fix this by checking that a

[PATCH 0/2] iwlwifi: updates intended for v4.10 2017-01-23

2017-01-23 Thread Luca Coelho
From: Luca Coelho Hi, These are a couple of fixes intended for v4.10. One avoids a crash in specific scenarios, the other prevents a firmware load failure due to wrong file name. -- Luca. Johannes Berg (1): iwlwifi: mvm: avoid crash on restart w/o reserved queues

[PATCH 1/2] iwlwifi: fix double hyphen in MODULE_FIRMWARE for 8000

2017-01-23 Thread Luca Coelho
From: Jürg Billeter Mistakenly, the driver is trying to load the 8000C firmware with an incorrect name (i.e. with two hyphens where there should be only one) and that fails. Fix that by removing the hyphen from the format macro. Fixes: e1ba684f762b ("iwlwifi: 8000: fix

Re: [RFC v3 0/8] ath10k sdio support

2017-01-23 Thread Valo, Kalle
Erik Stromdahl writes: > This is the third version of the sdio RFC patch series. > The actual sdio code (patch 6) has been subject to a massive overhaul, > mainly as a result of Kalle's review comments. > It no longer has any strong resemblance of the original ath6kl

Re: [PATCH 0/6] iwlwifi: updates intended for v4.10 2017-01-13

2017-01-23 Thread Coelho, Luciano
On Fri, 2017-01-13 at 14:39 +0200, Luca Coelho wrote: > From: Luca Coelho > > Hi, > > Here are a few fixes that I intend to send for v4.10: > > * fix suspend failure with unified firmware images > * fix a potential crash when dumping debug data > * fix a couple of

[PATCH] mac80211: don't try to sleep in rate_control_rate_init()

2017-01-23 Thread Johannes Berg
From: Johannes Berg In my previous patch, I missed that rate_control_rate_init() is called from some places that cannot sleep, so it cannot call ieee80211_recalc_min_chandef(). Remove that call for now to fix the context bug, we'll have to find a different way to fix the