From: Ryan Hsu
For QCA6174 hw3.0, since WLAN.RM.4.4-00022-QCARMSWPZ-2, it starts to
support the board ID information from otp, with some devices released on
the market that didn't calibrated with OTP, will have 0 for board ID
information, which cause the backward compatibility issue and was fixed
On Tue, 2017-04-11 at 13:42 -0400, David Miller wrote:
> > Then, the library needs to be extended to enable this handling to
> > modify the way it needs to handle errors, together with the
> > setsockopt().
So I'd tend to agree, but
* it was easy to solve this, with the flags I added
* the fla
On 4/11/17 1:05 PM, David Miller wrote:
> From: David Ahern
> Date: Tue, 11 Apr 2017 12:57:59 -0600
>
>> On 4/11/17 11:42 AM, David Miller wrote:
>>> David, if you have a specific case where it's absolutely impossible
>>> to resolve this when the library is converted to support extended
>>> ACKs,
From: David Ahern
Date: Tue, 11 Apr 2017 12:57:59 -0600
> On 4/11/17 11:42 AM, David Miller wrote:
>> David, if you have a specific case where it's absolutely impossible
>> to resolve this when the library is converted to support extended
>> ACKs, please mention it.
>
> I don't have a specific l
On 4/11/17 11:42 AM, David Miller wrote:
> David, if you have a specific case where it's absolutely impossible
> to resolve this when the library is converted to support extended
> ACKs, please mention it.
I don't have a specific library in mind. It is more the disjoint nature
of a socket option a
From: Pablo Neira Ayuso
Date: Tue, 11 Apr 2017 19:31:43 +0200
> On Tue, Apr 11, 2017 at 08:25:57AM -0600, David Ahern wrote:
>> On 4/11/17 1:02 AM, Johannes Berg wrote:
>> > On Tue, 2017-04-11 at 08:59 +0200, Pablo Neira Ayuso wrote:
>> >> CAP_ACK means: trim off the payload that the netlink erro
On Tue, Apr 11, 2017 at 10:11:43PM +0530, Aditya Shankar wrote:
> Change the config packet format used in handle_set_wfi_drv_handler()
> to align the host driver with the new format used in the wilc firmware.
So does this break devices with "old" firmware?
Where is the "new" firmware? What is en
On Tue, Apr 11, 2017 at 08:25:57AM -0600, David Ahern wrote:
> On 4/11/17 1:02 AM, Johannes Berg wrote:
> > On Tue, 2017-04-11 at 08:59 +0200, Pablo Neira Ayuso wrote:
> >> CAP_ACK means: trim off the payload that the netlink error message
> >> is embedding, just like ICMP error does.
> >>
> >> Wha
Change the config packet format used in handle_set_wfi_drv_handler()
to align the host driver with the new format used in the wilc firmware.
The change updates the format in which the host driver provides the
firmware with the drv_handler index and also uses two new
fields viz. "mode" and 'name" i
Hi Larry,
> The OBDA8723 ACPI HID is used on quite a few Bay Trail based tablets
> for bluetooth rfkill functionality.
>
> Tested-by: russianneuroman...@ya.ru
> Signed-off-by: Hans de Goede
> ---
> net/rfkill/rfkill-gpio.c | 1 +
> 1 file changed, 1 insertion(+)
>
On 4/11/17 1:02 AM, Johannes Berg wrote:
> On Tue, 2017-04-11 at 08:59 +0200, Pablo Neira Ayuso wrote:
>> CAP_ACK means: trim off the payload that the netlink error message
>> is embedding, just like ICMP error does.
>>
>> What is exactly your concern? If the user explicitly requests this
>> via so
On Tue, Apr 11, 2017 at 01:30:16PM +0200, Arend Van Spriel wrote:
> On 11-4-2017 11:19, Hans de Goede wrote:
> > The rtl8188eu driver defines a ton of global symbols which tend to
> > conflict with other realtek wifi drivers, force it to be built as
> > a module.
>
> Or get rid of those globals as
tree: https://git.kernel.org/pub/scm/linux/kernel/git/jberg/mac80211-next.git
bpf
head: fe544432ea248442bc748639d66dbd6ac6a7cc5e
commit: fe544432ea248442bc748639d66dbd6ac6a7cc5e [2/2] bpf: remove struct
bpf_map_type_list
config: m68k-sun3_defconfig (attached as .config)
compiler: m68k-linux-g
From: Sara Sharon
Currently multicast queue is associated with the broadcast
station.
This raises quite a few issues:
The multicast queue has a special treatment:
- It is sent in the MAC context command
- It is excluded from tfd_queue_mask
In DQA mode we end up enabling two queues - the probe
From: Johannes Berg
That's a bit nicer than open-coding it.
Signed-off-by: Johannes Berg
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-fh.h | 2 +-
drivers/net/wireless/intel/iwlwifi/iwl-io.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/driv
From: Sara Sharon
The command was changed to support PN offload and TKIP offload.
The FW will do TKIP calculations in D0 only for a000 devices,
but API is aligned anyway.
However, for all devices we can stop sending the wowlan tkip
command.
Firmware will fetch the keys from the station key comman
From: Sara Sharon
a000 devices are going to have a lot of flows simplified
and changed: init flow, RX, TX, and more.
This, combined with the fact that code is already very
complicated due to backward compatibility - introduce
a split that will enable to introduce simplified version
of functions.
From: Sara Sharon
This reverts commit 8aacf4b73fe8 ("iwlwifi: introduce trans API
to get byte count table").
The commit is not needed as a better approach will be taken.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-trans.h | 11 -
From: Luca Coelho
We don't need this parameter anymore, since we always pass 0 anyway.
Remove it from the structure and from all the relevant functions.
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-trans.c | 7 ++-
drivers/net/wireless/intel/iwlwifi/iwl-trans.h
From: Sara Sharon
In a000 devices FW will assign the queue number. Prepare for
that by getting rid of static defines and store them in variables.
Enlarge to u16 since we may have up to 512 queues.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm
From: Sara Sharon
Now that transport inits the paging in the context info -
remove the call in mvm.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm/fw.c | 8
drivers/net/wireless/intel/iwlwifi/mvm/mvm.h | 3 ++-
2 files changed, 2 ins
From: Sara Sharon
Context information structure is going to be used in a000
devices for firmware self init.
The self init includes firmware self loading from DRAM by
ROM.
This means the TFH relevant firmware loading can be cleaned up.
The firmware loading includes the paging memory as well, so
From: Liad Kaufman
Once we remove support for A-step, we'll be able to
clean the code back again.
Signed-off-by: Liad Kaufman
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-9000.c | 25 -
drivers/net/wireless/intel/iwlwifi/iwl-config.h | 7 +++
From: Sara Sharon
We already have queue_used in the transport - we can
use it instead.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/pcie/internal.h | 2 --
drivers/net/wireless/intel/iwlwifi/pcie/tx.c | 7 +++
2 files changed, 3 insert
From: Sara Sharon
This register is helpful for debugging D3 issues.
Driver turns all bits on, and then on exit reads the
updated value there.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-prph.h | 1 +
drivers/net/wireless/intel/iwlwifi/pc
From: Golan Ben-Ami
In case of a MFUART assert, get a notification from the fw
that consists of the assert id and debug data.
The notification may be divided to multiple chunks, depending
on the size of the debug data sent to the driver, which would
be up to 1KB.
Get the notification, and if th
From: Sara Sharon
As preparation for a000 different queue management, separate
mapping of queues from actual enablement.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm/utils.c | 34 --
1 file changed, 21 insertions(+),
From: Sara Sharon
Currently we release up to the last expired frame.
However, if there are consecutive frames after it - we can
optimize it further and release them as well - until the next
hole.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm/
From: Johannes Berg
Use iwl_get_dma_hi_addr() instead of open-coding it.
Signed-off-by: Johannes Berg
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/pcie/tx.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/tx.c
From: Emmanuel Grumbach
We don't need to print so much data in the kernel log.
Limit the data to be printed to the queue that actually
got stuck in case of a TFD queue hang, and stop dumping
all the CSR and FH registers. Over the course of time, the
CSR and FH values haven't proven themselves to
From: Sara Sharon
When a station is asleep, the fw will set it as "asleep".
All queues that are used only by one station will be stopped by
the fw.
In pre-DQA mode this was relevant for aggregation queues. However,
in DQA mode a queue is owned by one station only, so all queues
will be stopped.
From: Luca Coelho
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-7000.c | 4 ++--
drivers/net/wireless/intel/iwlwifi/iwl-8000.c | 4 ++--
drivers/net/wireless/intel/iwlwifi/iwl-9000.c | 2 +-
drivers/net/wireless/intel/iwlwifi/iwl-a000.c | 2 +-
4 files changed, 6 inserti
From: Sara Sharon
Final API has a reserved field - adjust accordingly.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm/fw-api-tx.h | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/fw-api-tx.h
b/dr
From: Johannes Berg
When receiving a frame, we currently pull in sizeof(*hdr) plus
some extra (crypto/snap), which is too much, most headers aren't
actually sizeof(*hdr) since that takes into account the 4-address
format but doesn't take into account QoS. As a result, a typical
frame will have 4
From: Luca Coelho
One of the RF modules we support has been deprecated and never
released publicly. Remove support for this module.
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/iwl-9000.c | 19 ---
drivers/net/wireless/intel/iwlwifi/iwl-config.h | 1 -
From: Emmanuel Grumbach
This will allow to print the name of the commands in the
logs when we sent it.
Signed-off-by: Emmanuel Grumbach
Signed-off-by: Luca Coelho
---
drivers/net/wireless/intel/iwlwifi/mvm/ops.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/net/wireless/intel/iw
From: Luca Coelho
Hi,
This is my first patch set intended for v4.12. These are the changes:
* Some small fixes here and there;
* The usual cleanups and small improvements;
* Work to support A000 devices continues;
* New FW API version;
* Some debugging improvements;
As usual, I'm pushing
From: Luca Coelho
If the supported firmware versions are not found, we currently only
print "no suitable firmware found". This is not very informative for
the user trying to find the correct version to use. Improve this by
printing the exact firmware name(s) the driver supports and pointing
to
From: Sara Sharon
For a000 devices the binding API needs to include relevant
lmac ID - support the new API.
The new API should be used regardless if the device had CDB or
not. If there is no actual CDB support the binding is bound
to first lmac regardless of the band.
There are some functionality
+ linux-bluetooth, Marcel
On 11-4-2017 12:15, c_tr...@qti.qualcomm.com wrote:
> From: Tamizh chelvam
>
> This patchset add support for BTCOEX feature to enable/disable and
> modifying btcoex priority value via nl80211
So you make a distinction between WMM ACs, but what about the different
types
On 11-4-2017 11:19, Hans de Goede wrote:
> The rtl8188eu driver defines a ton of global symbols which tend to
> conflict with other realtek wifi drivers, force it to be built as
> a module.
Or get rid of those globals as we did to get out of staging :-p
Regards,
Arend
> Signed-off-by: Hans de Go
From: Tamizh chelvam
This patch introduces NL80211_CMD_SET_BTCOEX command and
NL80211_ATTR_BTCOEX_OP attribute to enable or disable btcoex.
And this change enables user to set btcoex priority by using
NL80211_ATTR_BTCOEX_PRIORITY attribute for the driver which
has the btcoex priority capability.
From: Tamizh chelvam
This patch introduces a new driver call back drv_set_btcoex.
This API will pass user space value to driver to
enable or disabe btcoex and set or modify the btcoex priority value.
Signed-off-by: Tamizh chelvam
---
include/net/mac80211.h|5 +
net/mac80211/cfg.c
From: Tamizh chelvam
This patchset add support for BTCOEX feature to enable/disable and
modifying btcoex priority value via nl80211
Tamizh chelvam (2):
cfg80211: Add support to enable or disable btcoex and set
btcoex_priority
mac80211: Add support to enable or disable btcoex and set btco
The rtl8188eu driver defines a ton of global symbols which tend to
conflict with other realtek wifi drivers, force it to be built as
a module.
Signed-off-by: Hans de Goede
---
drivers/staging/rtl8188eu/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/rtl8188eu/Kconfig
Tue, Apr 11, 2017 at 10:29:52AM CEST, johan...@sipsolutions.net wrote:
>On Tue, 2017-04-11 at 10:13 +0200, Jiri Pirko wrote:
>> Tue, Apr 11, 2017 at 09:29:18AM CEST, johan...@sipsolutions.net
>> wrote:
>> > On Tue, 2017-04-11 at 09:19 +0200, Jiri Pirko wrote:
>> > >
>> > > > + NUM_NLMSGERR_AT
Hi,
On 10-04-17 23:50, Arend Van Spriel wrote:
On 8-4-2017 11:53, Hans de Goede wrote:
Hi,
On 07-04-17 23:43, Arend Van Spriel wrote:
On 6-4-2017 14:14, Hans de Goede wrote:
Hi,
I noticed your patch-series on the lwn.net kernel page,
and I took a peek :)
I don't think that this patch:
h
On Tue, 2017-04-11 at 10:13 +0200, Jiri Pirko wrote:
> Tue, Apr 11, 2017 at 09:29:18AM CEST, johan...@sipsolutions.net
> wrote:
> > On Tue, 2017-04-11 at 09:19 +0200, Jiri Pirko wrote:
> > >
> > > > + NUM_NLMSGERR_ATTRS,
> > >
> > > According to the rest of the uapi, this should be rather n
Tue, Apr 11, 2017 at 09:29:18AM CEST, johan...@sipsolutions.net wrote:
>On Tue, 2017-04-11 at 09:19 +0200, Jiri Pirko wrote:
>>
>> > + NUM_NLMSGERR_ATTRS,
>>
>> According to the rest of the uapi, this should be rather named:
>> __NLMSGERR_ATTR_MAX
>
>nl80211 uses NUM_ so I guess that's a ma
On Tue, 2017-04-11 at 09:19 +0200, Jiri Pirko wrote:
>
> > + NUM_NLMSGERR_ATTRS,
>
> According to the rest of the uapi, this should be rather named:
> __NLMSGERR_ATTR_MAX
nl80211 uses NUM_ so I guess that's a matter of convention, but I can
change that I guess.
> > if (err |
Tue, Apr 11, 2017 at 08:56:56AM CEST, johan...@sipsolutions.net wrote:
>From: Johannes Berg
>
>Add the base infrastructure and UAPI for netlink
>extended ACK reporting. All "manual" calls to
>netlink_ack() pass NULL for now and thus don't
>get extended ACK reporting.
>
>Big thanks goes to Pablo Ne
Tue, Apr 11, 2017 at 08:56:56AM CEST, johan...@sipsolutions.net wrote:
>From: Johannes Berg
>
>Add the base infrastructure and UAPI for netlink
>extended ACK reporting. All "manual" calls to
>netlink_ack() pass NULL for now and thus don't
>get extended ACK reporting.
Johannes, I asked already why
On Tue, 2017-04-11 at 08:59 +0200, Pablo Neira Ayuso wrote:
> CAP_ACK means: trim off the payload that the netlink error message
> is embedding, just like ICMP error does.
>
> What is exactly your concern? If the user explicitly requests this
> via socket option for this socket, then we're expecti
53 matches
Mail list logo