Re: [PATCH 01/11] staging: wilc1000: refactor scan() to free kmalloc memory on failure cases

2018-03-20 Thread Ajay Singh
Hi Dan, Thanks for your detailed review comments. On Tue, 20 Mar 2018 22:46:32 +0300 Dan Carpenter wrote: > On Tue, Mar 20, 2018 at 10:25:34PM +0530, Ajay Singh wrote: > > Added changes to free the allocated memory in scan() for error condition. > > Also added 'NULL'

[PATCH] mac80211: notify driver for change in multicast rates

2018-03-20 Thread Pradeep Kumar Chitrapu
It is required to pass the rate information to driver/firmware when rate control is offloaded to firmware. This helps in changing multicast traffic rates thereby improving the network performance. Signed-off-by: Pradeep Kumar Chitrapu --- include/net/mac80211.h | 1 +

Re: [PATCH 10/10] rsi: drop RX broadcast/multicast packets with invalid PN

2018-03-20 Thread Johannes Berg
On Mon, 2018-03-05 at 20:07 +0530, Amitkumar Karwar wrote: > From: Siva Rebbagondla > > This patch adds a check to drop received broadcast/multicast frames > if > PN is invalid (i.e. not greater than last PN). bc_mc_pn > variable added for each interface >

Re: [PATCH] mt76: enable MAC80211_LEDS by default

2018-03-20 Thread Johannes Berg
On Fri, 2018-03-16 at 15:45 +0100, Lorenzo Bianconi wrote: > --- a/drivers/net/wireless/mediatek/mt76/Kconfig > +++ b/drivers/net/wireless/mediatek/mt76/Kconfig > @@ -1,5 +1,8 @@ > config MT76_CORE > tristate > + select MAC80211_LEDS Should drivers really mess with mac80211's

Re: [PATCH 01/10] rsi: add support for hardware scan offload

2018-03-20 Thread Johannes Berg
On Thu, 2018-03-15 at 14:57 +0530, Amitkumar Karwar wrote: > > > What I don't like here is that you are duplicating functionality > > already > > existing in mac80211 and I hope there is a better way to solve the > > problem. Just as a a crazy idea what if the driver returns > > -EOPNOTSUPP > >

Re: [PATCH] ath9k: introduce endian_check module parameter

2018-03-20 Thread Martin Blumenstingl
Hi Rafal, On Tue, Mar 20, 2018 at 10:07 PM, Rafał Miłecki wrote: > On 19 March 2018 at 09:11, Martin Blumenstingl > wrote: >> - some ship with a broken EEPROM that enables the 5GHz band on a >> 2.4GHz-only card, which is why we need

Re: [PATCH] ath9k: introduce endian_check module parameter

2018-03-20 Thread Rafał Miłecki
On 19 March 2018 at 09:11, Martin Blumenstingl wrote: > - some ship with a broken EEPROM that enables the 5GHz band on a > 2.4GHz-only card, which is why we need "qca,disable-5ghz" No. You just need to use ieee80211-freq-limit. -- Rafał

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Luis R. Rodriguez
On Tue, Mar 20, 2018 at 02:54:44PM -0400, Konstantin Ryabitsev wrote: > On 03/20/18 14:24, Luis R. Rodriguez wrote: > > *Iff* this seems sensible, this would only mean kernel.org would have to > > start > > accepting git notes long term, for those who optionally want to push them or > > fetch

Re: [PATCH 01/11] staging: wilc1000: refactor scan() to free kmalloc memory on failure cases

2018-03-20 Thread Dan Carpenter
On Tue, Mar 20, 2018 at 10:25:34PM +0530, Ajay Singh wrote: > Added changes to free the allocated memory in scan() for error condition. > Also added 'NULL' check validation before accessing allocated memory. > > Signed-off-by: Ajay Singh > --- >

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Konstantin Ryabitsev
On 03/20/18 14:24, Luis R. Rodriguez wrote: > *Iff* this seems sensible, this would only mean kernel.org would have to start > accepting git notes long term, for those who optionally want to push them or > fetch them. We don't disallow them. You just need to make sure you're fetching and pushing

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Ben Greear
On 03/20/2018 11:24 AM, Michal Kubecek wrote: On Tue, Mar 20, 2018 at 08:39:33AM -0700, Ben Greear wrote: On 03/20/2018 03:37 AM, Michal Kubecek wrote: IMHO it would be more practical to set "0 means same as GSTATS" as a rule and make ethtool_get_stats() a wrapper for ethtool_get_stats2() to

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Michal Kubecek
On Tue, Mar 20, 2018 at 08:39:33AM -0700, Ben Greear wrote: > On 03/20/2018 03:37 AM, Michal Kubecek wrote: > > > > IMHO it would be more practical to set "0 means same as GSTATS" as a > > rule and make ethtool_get_stats() a wrapper for ethtool_get_stats2() to > > avoid code duplication (or

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Luis R. Rodriguez
On Tue, Mar 20, 2018 at 06:38:01PM +0100, Greg KH wrote: > On Tue, Mar 20, 2018 at 05:34:09PM +, Luis R. Rodriguez wrote: > > On Tue, Mar 20, 2018 at 09:30:55AM +0100, Greg KH wrote: > > > On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote: > > > >

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Greg KH
On Tue, Mar 20, 2018 at 05:34:09PM +, Luis R. Rodriguez wrote: > On Tue, Mar 20, 2018 at 09:30:55AM +0100, Greg KH wrote: > > On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote: > > > +EXPORT_SYMBOL_GPL(request_firmware_cache); > > > > I know you are just following the existing

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Luis R. Rodriguez
On Tue, Mar 20, 2018 at 09:30:55AM +0100, Greg KH wrote: > On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote: > > +EXPORT_SYMBOL_GPL(request_firmware_cache); > > I know you are just following the existing naming scheme, but please > let's not continue the problem here. Can you

Re: [PATCH 00/16] remove eight obsolete architectures

2018-03-20 Thread Palmer Dabbelt
On Thu, 15 Mar 2018 03:42:25 PDT (-0700), Arnd Bergmann wrote: On Thu, Mar 15, 2018 at 10:59 AM, Hannes Reinecke wrote: On 03/15/2018 10:42 AM, David Howells wrote: Do we have anything left that still implements NOMMU? RISC-V ? (evil grin :-) Is anyone producing a chip that

[PATCH 09/11] staging: wilc1000: remove line over 80 char in cfg_connect_result()

2018-03-20 Thread Ajay Singh
Fix 'line over 80 characters' issues reported by checkpatch.pl script in cfg_connect_result(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 34 +++ 1 file changed, 22 insertions(+), 12 deletions(-) diff --git

[PATCH 10/11] staging: wilc1000: remove unused 'struct add_key_params'

2018-03-20 Thread Ajay Singh
Cleanup patch to remove unused struct data structure. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c

[PATCH 11/11] staging: wilc1000: remove line over 80 char warning in few functions

2018-03-20 Thread Ajay Singh
Remove 'line over 80 characters' issues found by checkpatch.pl script for following functions. disconnect() del_pmksa() wilc_create_wiphy() del_pmksa() Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 12 1 file changed,

[PATCH 06/11] staging: wilc1000: refactor mgmt_tx to fix line over 80 chars

2018-03-20 Thread Ajay Singh
Refactor mgmt_tx() to fix line over 80 characters issue. Split the function to avoid the checkpatch.pl warning. Returning the same error code in case of memory allocation failure. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 187

[PATCH 08/11] staging: wilc1000: fix line over 80 char issue in clear_shadow_scan()

2018-03-20 Thread Ajay Singh
Remove 'line over 80 char' issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 21 +++-- 1 file changed, 11 insertions(+), 10 deletions(-) diff --git

[PATCH 05/11] staging: wilc1000: rename WILC_WFI_p2p_rx & s32Freq to avoid camelCase

2018-03-20 Thread Ajay Singh
Fix 'Avoid camelCase' issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 18 +- drivers/staging/wilc1000/wilc_wlan.h

[PATCH 07/11] staging: wilc1000: rename hAgingTimer to avoid camelCase issue

2018-03-20 Thread Ajay Singh
Fix 'Avoid camelCase' issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c

[PATCH 00/11] staging: wilc1000: fix for checkpatch and handled malloc memory properly

2018-03-20 Thread Ajay Singh
This patch series contains fixes to avoid checkpatch issues and removed unused code. Few patch contains changes related to NULL check and freeing of dynamically allocated memory. Ajay Singh (11): staging: wilc1000: refactor scan() to free kmalloc memory on failure cases staging:

[PATCH 03/11] staging: wilc1000: remove line over 80 char warnings in set_wiphy_params()

2018-03-20 Thread Ajay Singh
Fix 'line over 80 character' issue reported by checkpatch.pl script in set_wiphy_params(). Directly used the 'wiphy' pointer received as function argument instead of using 'priv->dev->ieee80211_ptr->wiphy'. Signed-off-by: Ajay Singh ---

[PATCH 04/11] staging: wilc1000: refactor WILC_WFI_p2p_rx() to avoid line over 80 char

2018-03-20 Thread Ajay Singh
Fix 'line over 80 characters' issue found by checkpatch.pl script. Refactor and split the function to avoid the checkpatch reported issues. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 145 -- 1 file changed, 82

[PATCH 01/11] staging: wilc1000: refactor scan() to free kmalloc memory on failure cases

2018-03-20 Thread Ajay Singh
Added changes to free the allocated memory in scan() for error condition. Also added 'NULL' check validation before accessing allocated memory. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 62 +-- 1 file

[PATCH 02/11] staging: wilc1000: removed unused global variables for gtk and ptk information

2018-03-20 Thread Ajay Singh
Removed the unnecessary global variables used to store gtk and ptk information. Key data stored in the params was never access using these global variables. Global variables given below are removed g_add_gtk_key_params; g_key_gtk_params; g_add_ptk_key_params; g_key_ptk_params; g_key_wep_params;

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Ben Greear
On 03/20/2018 09:11 AM, Steve deRosier wrote: On Tue, Mar 20, 2018 at 8:39 AM, Ben Greear wrote: On 03/20/2018 03:37 AM, Michal Kubecek wrote: On Wed, Mar 07, 2018 at 11:51:29AM -0800, gree...@candelatech.com wrote: From: Ben Greear This

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Steve deRosier
On Tue, Mar 20, 2018 at 8:39 AM, Ben Greear wrote: > On 03/20/2018 03:37 AM, Michal Kubecek wrote: >> >> On Wed, Mar 07, 2018 at 11:51:29AM -0800, gree...@candelatech.com wrote: >>> >>> From: Ben Greear >>> >>> This is similar to ETHTOOL_GSTATS,

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Ben Greear
On 03/20/2018 03:37 AM, Michal Kubecek wrote: On Wed, Mar 07, 2018 at 11:51:29AM -0800, gree...@candelatech.com wrote: From: Ben Greear This is similar to ETHTOOL_GSTATS, but it allows you to specify a 'level'. This level can be used by the driver to decrease the

[PATCH 2/2] rsi: fix kernel panic observed on 64bit machine

2018-03-20 Thread Amitkumar Karwar
From: Amitkumar Karwar Following kernel panic is observed on 64bit machine while loading the driver. It is fixed if we pass dynamically allocated memory to SDIO for DMA. BUG: unable to handle kernel paging request at eb04000172e0 IP: sg_miter_stop+0x56/0x70

[PATCH 1/2] rsi: fix error path handling in SDIO probe

2018-03-20 Thread Amitkumar Karwar
From: Amitkumar Karwar We miss to release IRQ in certain error path in SDIO probe which causes following kernel panic. This patch corrects error path handling BUG: unable to handle kernel NULL pointer dereference at(null) IP: (null) PGD 0 P4D 0

[PATCHv3] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread hariprasath . elango
From: HariPrasath Elango In this case,there is only a single switch case statement.So replacing by a simple if condition Signed-off-by: HariPrasath Elango --- changes since v3: *rebase on latest code *missed revision

Re: [PATCHv2] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread
On Tue, Mar 20, 2018 at 12:47:21PM +0100, Greg KH wrote: > On Tue, Mar 20, 2018 at 05:13:31PM +0530, hariprasath.ela...@gmail.com wrote: > > From: HariPrasath Elango > > > > In this case,there is only a single switch case statement.So replacing > > by a simple if

Re: [PATCHv2] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread Greg KH
On Tue, Mar 20, 2018 at 05:13:31PM +0530, hariprasath.ela...@gmail.com wrote: > From: HariPrasath Elango > > In this case,there is only a single switch case statement.So replacing > by a simple if condition > > Signed-off-by: HariPrasath Elango

[PATCHv2] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread hariprasath . elango
From: HariPrasath Elango In this case,there is only a single switch case statement.So replacing by a simple if condition Signed-off-by: HariPrasath Elango --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 8 +--- 1 file

Re: [PATCH 5/7] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread
On Tue, Mar 20, 2018 at 02:29:51PM +0300, Dan Carpenter wrote: > On Tue, Mar 20, 2018 at 11:42:27AM +0530, wrote: > > On Mon, Mar 19, 2018 at 07:45:46PM +0100, Greg KH wrote: > > > On Wed, Mar 14, 2018 at 06:15:03PM +0530, hariprasath.ela...@gmail.com > > > wrote: > > > > From: HariPrasath

Re: [PATCH 5/7] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread Dan Carpenter
On Tue, Mar 20, 2018 at 11:42:27AM +0530, wrote: > On Mon, Mar 19, 2018 at 07:45:46PM +0100, Greg KH wrote: > > On Wed, Mar 14, 2018 at 06:15:03PM +0530, hariprasath.ela...@gmail.com > > wrote: > > > From: HariPrasath Elango > > > > > > In this case,there is only

Re: [RFC] ethtool: Support ETHTOOL_GSTATS2 command.

2018-03-20 Thread Michal Kubecek
On Wed, Mar 07, 2018 at 11:51:29AM -0800, gree...@candelatech.com wrote: > From: Ben Greear > > This is similar to ETHTOOL_GSTATS, but it allows you to specify > a 'level'. This level can be used by the driver to decrease the > amount of stats refreshed. In particular,

Re: brcmfmac: Fix check for ISO3166 code

2018-03-20 Thread Kalle Valo
Stefan Wahren wrote: > The commit "regulatory: add NUL to request alpha2" increases the length of > alpha2 to 3. This causes a regression on brcmfmac, because > brcmf_cfg80211_reg_notifier() expect valid ISO3166 codes in the complete > array. So fix this accordingly. > >

Re: pull-request: iwlwifi 2018-03-19

2018-03-20 Thread Kalle Valo
Luca Coelho writes: > Here is my fourth set of fixes for 4.16. More details in the tag > description. > > I have sent this out before and kbuildbot didn't find any issues. > Please let me know if there are any issues. > > Cheers, > Luca. > > > The following changes since commit

Re: [PATCH net-next v2 2/2] dt: bindings: add new dt entries for brcmfmac

2018-03-20 Thread Kalle Valo
Arend van Spriel writes: >>> If I get it right, you mean something like this: >>> >>> mmc3: mmc@1c12000 { >>> ... >>> broken-sg-support; >>> sd-head-align = 4; >>> sd-sgentry-align = 512; >>> >>> brcmf: wifi@1 { >>>

Re: [PATCH net-next v2 2/2] dt: bindings: add new dt entries for brcmfmac

2018-03-20 Thread Alexey Roslyakov
Arend, Agreed. Let's dismiss these patches. Now I'm curious if I can get the information about DMA SG limitations from MMC layer, I'll try to figure out something. BTW, my specific setup (with default alignments) triggers kernel panic (I see brcm_* in backtrace). It's better if I create separate

Re: [PATCH net-next v2 2/2] dt: bindings: add new dt entries for brcmfmac

2018-03-20 Thread Arend van Spriel
On 3/20/2018 8:58 AM, Alexey Roslyakov wrote: Arend, Also I am not sure if the broken-sg-support is still needed. We added that for omap_hsmmc, but that has since changed to scatter-gather emulation so it might not be needed anymore. I can confirm it doesn't impact wifi performance in case

Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot

2018-03-20 Thread Greg KH
On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote: > Some devices have an optimization in place to enable the firmware to > be retaineed during a system reboot, so after reboot the device can skip > requesting and loading the firmware. This can save up to 1s in load > time. The

Re: [PATCH net-next v2 2/2] dt: bindings: add new dt entries for brcmfmac

2018-03-20 Thread Alexey Roslyakov
Arend, >Also I am not sure if the broken-sg-support is still needed. We added that for >omap_hsmmc, but that has since changed to scatter-gather emulation so it might >not be needed anymore. I can confirm it doesn't impact wifi performance in case of rk3288+ap6335. But I still have to set

Re: [PATCH 5/7] staging: wilc1000: replace switch statement by simple if condition

2018-03-20 Thread
On Mon, Mar 19, 2018 at 07:45:46PM +0100, Greg KH wrote: > On Wed, Mar 14, 2018 at 06:15:03PM +0530, hariprasath.ela...@gmail.com wrote: > > From: HariPrasath Elango > > > > In this case,there is only a single switch case statement.So replacing > > by a simple if