On Wed, 2007-12-05 at 22:39 -0800, Greg KH wrote:
> > that is it can be either unsigned int, unsigned long or unsigned
> long
> > long... and we have no way to reliably printk that.
>
> We do this already just fine. Take a look in the kernel, I think we
> just always cast it to long long to be
On Thu, Dec 06, 2007 at 02:22:27PM +1100, Benjamin Herrenschmidt wrote:
>
> On Wed, 2007-12-05 at 17:40 +1100, Benjamin Herrenschmidt wrote:
> > The current pci_assign_unassigned_resources() code doesn't work properly
> > on 32 bits platforms with 64 bits resources. The main reason is the use
> >
Arnd Bergmann <[EMAIL PROTECTED]> wrote:
> On Tuesday 04 December 2007, Ishizaki Kou wrote:
> > This patch adds supporting for native CBE on Celleb. Many codes in
> > platforms/cell/ are used when native CBE environment.
> >
> > Signed-off-by: Kou Ishizaki <[EMAIL PROTECTED]>
>
> Ah, excellent to
Arnd Bergmann <[EMAIL PROTECTED]> wrote:
> On Tuesday 04 December 2007, Ishizaki Kou wrote:
> >
> > +#ifdef CONFIG_MMIO_NVRAM
> > mmio_nvram_init();
> > +#endif
> > }
>
> The patch is technically correct, but the preferred way of doing this is
> to define a conditional inline function in the
Currently we hardwire the number of SLBs but PAPR says we export an
ibm,slb-size property to specify the number of SLB entries. This
patch uses this property instead of assuming 64. If no property is
found, we assume 64 entries as before.
This soft patches the SLB handler, so it won't change per
On 12/6/07, Grant Likely <[EMAIL PROTECTED]> wrote:
> On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > On 12/6/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > > On 12/5/07, Grant Likely <[EMAIL PROTECTED]> wrote:
> > > > On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > > > > Why does the fec52
On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> On 12/6/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > On 12/5/07, Grant Likely <[EMAIL PROTECTED]> wrote:
> > > On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > > > Why does the fec5200 driver sometimes not print 'PHY' correctly?
> > > >
> > > >
After the last couple of patches converting various old-style semantic
checks to the new framework, the only thing that the old-style
check_properties() function still checks is that the size of "reg"
properties is a multiple of the cell size.
This patch removes check_properties() and all related
This patch converts to the new tree checking framework those checks
which verify that certain properties (device_type, model) have a
string value, when present.
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
Index: dtc/checks.c
===
This patch converts to the new tree checking framework those checks
which verify that certain properties (#address-cells and #size-cells)
are exactly one cell in size, when present.
We also drop the old-style check for "linux,phandle" being one cell,
since that is already implied in the the existi
This patch modifies the dtc-checkfails.sh testcase wrapper so that
instead of testing just that dtc fails with a particular error code on
the sample input, it scans dtc's stderr output looking for a message
that dtc failed a specific check or checks. This has several advantages:
- It means
On 12/6/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> On 12/5/07, Grant Likely <[EMAIL PROTECTED]> wrote:
> > On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > > Why does the fec5200 driver sometimes not print 'PHY' correctly?
> > >
> > > phyCORE-MPC5200B-tiny login: TؤV� f0003000:10 - Link is Down
On 12/5/07, Grant Likely <[EMAIL PROTECTED]> wrote:
> On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> > Why does the fec5200 driver sometimes not print 'PHY' correctly?
> >
> > phyCORE-MPC5200B-tiny login: TؤV� f0003000:10 - Link is Down
> > T�Y: f0003000:10 - Link is Up - 100/Full
> > T�Y: f000
On 12/5/07, Jon Smirl <[EMAIL PROTECTED]> wrote:
> Why does the fec5200 driver sometimes not print 'PHY' correctly?
>
> phyCORE-MPC5200B-tiny login: TؤV� f0003000:10 - Link is Down
> T�Y: f0003000:10 - Link is Up - 100/Full
> T�Y: f0003000:10 - Link is Down
> PHY: f0003000:10 - Link is Up - 100/Ful
On Wed, 2007-12-05 at 13:41 -0800, Greg KH wrote:
> On Wed, Dec 05, 2007 at 10:10:31PM +1100, Michael Ellerman wrote:
> > On Wed, 2007-12-05 at 01:30 -0800, Greg KH wrote:
> > > In doing a massive kobject cleanup of the kernel tree, I ran across the
> > > iseries_veth.c driver.
> > >
> > > It look
Michael Neuling writes:
> Currently we hardwire the number of SLBs but the PAPR says we export an
> ibm,slb-size property to specify the number of SLB entries. This patch
> uses this property instead of assuming 64 always. If no property is
> found, we assume 64 entries as before.
On 32-bit pla
On Wed, 2007-12-05 at 17:40 +1100, Benjamin Herrenschmidt wrote:
> The current pci_assign_unassigned_resources() code doesn't work properly
> on 32 bits platforms with 64 bits resources. The main reason is the use
> of unsigned long in various places instead of resource_size_t.
>
> This fixes it,
Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/pseries/iommu.c | 24 +++-
1 files changed, 7 insertions(+), 17 deletions(-)
--
Cheers,
Stephen Rothwell[EMAIL PROTECTED]
diff --git a/arch/powerpc/platforms/pseries/iommu.c
It only needs the iommu_table address. It also makes use of the node
name to print error messages. So just pass it the things it needs.
This reduces the places that know about the pci_dn by one.
Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
---
arch/powerpc/kernel/iommu.c|
Author: Geoff Levand <[EMAIL PROTECTED]>
Apparently some versions of flex don't correctly parse the -o
parameter, if there's a space between the -o and its argument. So,
this patch removes it.
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
Index: dtc/Makefile
==
Why does the fec5200 driver sometimes not print 'PHY' correctly?
phyCORE-MPC5200B-tiny login: TؤV� f0003000:10 - Link is Down
T�Y: f0003000:10 - Link is Up - 100/Full
T�Y: f0003000:10 - Link is Down
PHY: f0003000:10 - Link is Up - 100/Full
--
Jon Smirl
[EMAIL PROTECTED]
_
Hi,
We need only SMP mode, asper ur idea let me disable the Low
memory offset mode. We face some issues when ioremap in the kernel, we guess
the problem is related to Low memory offset mode so only we go for that.
Consider now the Low memory offset is disable the bootargs (root=/dev/ram
From: Étienne Bersac <[EMAIL PROTECTED]>
Implement a new driver named windfarm_pm121 which drive fans on PowerMac
12,1 machine : iMac G5 iSight (rev C) 17" and 20". It's based on
windfarm_pm81 driver from Benjamin Herrenschmidt.
Signed-off-by: Étienne Bersac <[EMAIL PROTECTED]>
---
Implement fan
BTW... it is not true that core1 is idle when low memory offset mode is
disabled. Taking core1 out of reset will enable core1 to start booting.
These two are two different things.
- Siva
-Original Message-
From: Siva Prasad
Sent: Wednesday, December 05, 2007 5:06 PM
To: 'linuxppc-dev@o
Hi,
If you want to use SMP, do not enable low memory offset mode. That is
only and only for AMP, not for SMP. All the exception vectors go into a
different address range for core1, once you enable that, resulting in a
need for entirely different copy of OS (be it Linux, or any other OS).
You are
Hai,
The kernel was compiled in SMP mode. The low memory offset mode
is only for AMP mode means, then how we test both the core 0 and 1 in the
linux kernel ?. Asper my understanding if we enable the Low Memory Offset
mode, then only the core1 translation is enabled. If we disalbed the
Sorry for my noobness, i though i wasn't allowed to sign my own
patches /o\
So …
Signed-off-by: Étienne Bersac <[EMAIL PROTECTED]>
If you want a re-submission, please tell me so.
Regards,
Étienne.
--
E Ultreïa !
___
Linuxppc-dev mailing list
Linuxp
On Thursday 06 December 2007, Timur Tabi wrote:
> > In that case, I think it
> > would really be better to just put the blob into the tree and only
> > have the fw loading code in the kernel instead of duplicating it in the boot
> > loader.
>
> That would require the firmware to present in RAM for
Arnd Bergmann wrote:
> What does the firmware node contain then? The way I read it, you only put
> metadata about the uploaded firmware in there, but not the blob itself, right?
That's correct. The meta-data is only the information that a device driver
would need to identify and interact with t
Hi,
I am trying to bring up 8641 based on 2.6.19 kernel.
My system hangs after printing the message "VFS: Mounted root (ext2
filesystem)." I tried to follow down the path to identify where it is
hanging, and ended up at the following...
init/do_mounts_initrd.c: handle_initrd() function
.
.
.
On Thursday 06 December 2007, Timur Tabi wrote:
> Arnd Bergmann wrote:
>
> > Of course, that approach does not help you if the blob is not GPL compatible
> > and you are relying on the dts file to be linked into the kernel,
>
> Well, the blobs will never be GPL compatible, which is why I created
Hi everyone,
Finally, i had time, skills and help from Benjamin Herrenschmidt to
implement the Windfarm plateform module for PowerMac12,1 named
windfarm-pm121. This plateform is used in iMac G5 iSight models (17" and
20").
I review the patch a couple of time, especially the hex values which are
c
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Since commit c80d9133e99de1af607314107910a2a1645efb17 (Make direct DMA use
> node local allocations) went in this comment makes no sense.
>
> Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
Acked-by: Arnd Bergmann <[EMAIL PROTECTED]>
__
On Wednesday 05 December 2007, Michael Ellerman wrote:
> We no longer need the global dma_direct_offset, update the comment to
> reflect the new reality.
>
> Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
Acked-by: Arnd Bergmann <[EMAIL PROTECTED]>
___
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Rather than using the global variable, have celleb use its own variable to
> store the direct DMA offset.
>
> Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
Arnd Bergmann <[EMAIL PROTECTED]>
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Rather than using the global variable, have cell use its own variable to
> store the direct DMA offset.
>
> Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
Acked-by: Arnd Bergmann <[EMAIL PROTECTED]>
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Now that all platforms using dma_direct_offset setup the archdata.dma_data
> correctly, we can change the dma_direct_ops to retrieve the offset from
> the dma_data, rather than directly from the global.
>
> Signed-off-by: Michael Ellerman <[
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Celleb always uses dma_direct_ops, and sets dma_direct_offset, so it too
> should set dma_data to dma_direct_offset.
>
> Currently there's no pci_dma_dev_setup() routine for Celleb so add one.
>
> Signed-off-by: Michael Ellerman <[EMAIL PRO
On Wednesday 05 December 2007, Michael Ellerman wrote:
> Store a pointer to the direct_dma_offset in each device's dma_data
> in the case where we're using the direct DMA ops.
>
> Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
Acked-by: Arnd Bergmann <[EMAIL PROTECTED]>
_
Arnd Bergmann wrote:
> Of course, that approach does not help you if the blob is not GPL compatible
> and you are relying on the dts file to be linked into the kernel,
Well, the blobs will never be GPL compatible, which is why I created the
firmware binary format. Previously, the firmware was
On Wednesday 05 December 2007, Timur Tabi wrote:
> Define the layout of a binary blob that contains a QE firmware and
> instructions
> on how to upload it. Add function qe_upload_firmware() to parse the blob
> and perform the actual upload. Fully define 'struct rsp' in immap_qe.h to
> include th
On Wed, 5 Dec 2007 16:34:09 -0600
Josh Boyer <[EMAIL PROTECTED]> wrote:
> On Thu, 22 Nov 2007 17:10:07 +1100
> David Gibson <[EMAIL PROTECTED]> wrote:
>
> > The recent change to the lexer to only recognize property and node
> > names in the appropriate context removed a number of lexical warts in
Define the layout of a binary blob that contains a QE firmware and instructions
on how to upload it. Add function qe_upload_firmware() to parse the blob
and perform the actual upload. Fully define 'struct rsp' in immap_qe.h to
include the actual RISC Special Registers.
Signed-off-by: Timur Tabi
On Thu, 22 Nov 2007 17:10:07 +1100
David Gibson <[EMAIL PROTECTED]> wrote:
> The recent change to the lexer to only recognize property and node
> names in the appropriate context removed a number of lexical warts in
> our language that would have gotten ugly as we add expression support
> and so f
On Wed, Dec 05, 2007 at 03:28:16PM -0700, Mark A. Greer wrote:
> On Wed, Dec 05, 2007 at 11:32:50AM -0600, Jon Loeliger wrote:
>
> > diff --git a/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> > b/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> > index abb26dc..b039f21 100644
> > --- a/arch/powerpc/boot/dts/m
On Wed, Dec 05, 2007 at 11:32:50AM -0600, Jon Loeliger wrote:
> diff --git a/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> b/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> index abb26dc..b039f21 100644
> --- a/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> +++ b/arch/powerpc/boot/dts/mpc8641_hpcn.dts
> @@ -16,6 +
On Wed, Dec 05, 2007 at 10:10:31PM +1100, Michael Ellerman wrote:
> On Wed, 2007-12-05 at 01:30 -0800, Greg KH wrote:
> > In doing a massive kobject cleanup of the kernel tree, I ran across the
> > iseries_veth.c driver.
> >
> > It looks like the driver is creating a number of subdirectories under
On Wed, Dec 05, 2007 at 09:48:41AM +0900, Paul Mundt wrote:
> On Tue, Dec 04, 2007 at 02:01:21PM -0600, Olof Johansson wrote:
> > On Tue, Dec 04, 2007 at 10:49:21PM +0300, Anton Vorontsov wrote:
> > > tristate "Generic platform device PATA support"
> > > - depends on EMBEDDED || ARCH_RPC
> > > +
On Wed, 05 Dec 2007 12:05:07 -0600
Jon Loeliger <[EMAIL PROTECTED]> wrote:
> On Wed, 2007-12-05 at 11:38, Grant Likely wrote:
>
> > >
> > > + aliases {
> > > + ethernet0 = &enet0;
> > > + ethernet1 = &enet1;
> > > + ethernet2 = &enet2;
> > > +
On 12/5/07, Jon Loeliger <[EMAIL PROTECTED]> wrote:
> On Wed, 2007-12-05 at 11:38, Grant Likely wrote:
> > I had thought aliases were supposed to be full paths to nodes instead
> > of phandles. Was I wrong?
>
> Indeed, that is correct. And they are!
>
> Grant, you need to keep up, man. Just this
On Wed, 5 Dec 2007 10:38:38 -0700
Grant Likely wrote:
> >
> > + aliases {
> > + ethernet0 = &enet0;
> > + ethernet1 = &enet1;
> > + ethernet2 = &enet2;
> > + ethernet3 = &enet3;
> > + serial0 = &serial0;
> > +
On Wed, 2007-12-05 at 11:38, Grant Likely wrote:
> >
> > + aliases {
> > + ethernet0 = &enet0;
> > + ethernet1 = &enet1;
> > + ethernet2 = &enet2;
> > + ethernet3 = &enet3;
> > + serial0 = &serial0;
> > + ser
> -Original Message-
> From: Medve Emilian
> Sent: Tuesday, November 13, 2007 10:24 AM
> To: [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
[EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PROTECTED];
linuxppc-dev@ozlabs.org; [EMAIL PROTECTED]
> Cc: Medve Emilian
> Subject: [PATCH v2
On 12/5/07, Jon Loeliger <[EMAIL PROTECTED]> wrote:
>
> The addition of the aliases node is needed for U-Boot
> and, eventually, cuImage, to help locate the proper
> nodes reliably when using the libfdt approach.
>
> Signed-off-by: Jon Loeliger <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/dts/mpc
The addition of the aliases node is needed for U-Boot
and, eventually, cuImage, to help locate the proper
nodes reliably when using the libfdt approach.
Signed-off-by: Jon Loeliger <[EMAIL PROTECTED]>
---
arch/powerpc/boot/dts/mpc8641_hpcn.dts | 28
1 files changed
On Tue, 2007-12-04 at 23:51 -0800, sivaji wrote:
> We have designed a MPC8641D based AMC card. We are using the
> kernel (2.6.23-rc4) and uboot (1.2.0). When we disable the core1 Low Memory
> offset mode the kernel was up and when we enable this core1 Low Memory
> offset mode kernel w
Arnd Bergmann wrote:
> In that case, I think the right solution would be to have different properties
> in the device tree, depending on whether or not you have a soft-uart and
> whether
> you need to download the microcode.
> Having only a compile time option is very bad because it prevents you
On Tue, Dec 04, 2007 at 08:06:25PM +0300, Anton Vorontsov wrote:
> Split pata_platform_{probe,remove} into two pieces:
> 1. pata_platform_{probe,remove} -- platform_device-dependant bits;
> 2. __ptata_platform_{probe,remove} -- device type neutral bits.
>
> This is done to not duplicate code for t
So, like, the other day David Gibson mumbled:
> This patch extends dtc syntax to allow references (&label, or
> &{/full/path}) directly within property definitions, rather than
> inside a cell list. Such references are expanded to the full path of
> the referenced node, as a string, instead of to
So, like, the other day Kumar Gala mumbled:
> "Add an option to pad the blob that is generated" broke the padding
> support. We were updating the fdt header after writing it.
>
> Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
Applied.
jdl
___
Linuxppc-
So, like, the other day David Gibson mumbled:
> On several occasions, I've accidentally put properties after subnodes
> in a dts file. I've then spent ages thinking that the resulting
> syntax error was because of something else.
>
> This patch arranges for this specific syntax error to generate
So, like, the other day David Gibson mumbled:
> This patch applies a couple of tiny cleanups to the lexer. The
> not-very-useful 'WS' named pattern is removed, and the debugging
> printf() for single character tokens is moved to the top of the
> action, which results in less confusing output when
So, like, the other day David Gibson mumbled:
> This patch removes the old-style checking code for the "name" property
> - i.e. verifying that the "name" property, if present, matches the
> node name. It replaces it with a pair of more-or-less equivalent
> checks in the new checking framework.
>
So, like, the other day David Gibson mumbled:
> The way the checking subsystem FAIL() macro is currently implemented
> it must take at least one paramater after the format string. This
> patch corrects the problem.
>
> Signed-off-by: David Gibson <[EMAIL PROTECTED]>
Applied.
jdl
___
So, like, the other day Kumar Gala mumbled:
> Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
> ---
> ftdump.c |2 ++
> 1 files changed, 2 insertions(+), 0 deletions(-)
Applied.
jdl
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlab
> "Stephen" == Stephen Neuendorffer <[EMAIL PROTECTED]> writes:
Hi,
Stephen> Supports static platform_device and static device tree configuration.
Stephen> This is a standalone driver that does not depend on EDK generated
Stephen> files. However, it is also somewhat different in functiona
On Tue, 04 Dec 2007 16:51:44 +1100, Tony Breeds wrote:
> The commit fa13a5a1f25f671d084d8884be96fc48d9b68275 (sched: restore
> deterministic CPU accounting on powerpc), unconditionally calls
> update_process_tick() in system context. In the deterministic
> accounting case this is the correct thin
On Wed, 2007-12-05 at 01:30 -0800, Greg KH wrote:
> In doing a massive kobject cleanup of the kernel tree, I ran across the
> iseries_veth.c driver.
>
> It looks like the driver is creating a number of subdirectories under
> the driver sysfs directory. This is odd and probably wrong. You want
>
Signed-off-by: Li Yang <[EMAIL PROTECTED]>
---
Update SATA nodes; remove serdes nodes; add aliases and labels.
arch/powerpc/boot/dts/mpc8377_mds.dts | 270 +++
arch/powerpc/boot/dts/mpc8378_mds.dts | 256 +
arch/powerpc/boot/dts/mpc8379_md
In doing a massive kobject cleanup of the kernel tree, I ran across the
iseries_veth.c driver.
It looks like the driver is creating a number of subdirectories under
the driver sysfs directory. This is odd and probably wrong. You want
these virtual connections to show up in the main sysfs device
70 matches
Mail list logo