Re: [PATCH v21 001/100] eclone (1/11): Factor out code to allocate pidmap page

2010-05-01 Thread Josh Boyer
On Sat, May 01, 2010 at 03:10:22PM -0700, David Miller wrote: > >NO WAY, there is no way in the world you should post 100 patches >at a time to any mailing list, especially those at vger.kernel.org >that have thousands upon thousands of subscribers. > >Post only small, well contained, sets of patch

Re: [PATCH v21 001/100] eclone (1/11): Factor out code to allocate pidmap page

2010-05-01 Thread David Miller
NO WAY, there is no way in the world you should post 100 patches at a time to any mailing list, especially those at vger.kernel.org that have thousands upon thousands of subscribers. Post only small, well contained, sets of patches at a time. At most 10 or so in one go. Do you realize how much

Re: [PATCH 3/3] ptp: Added a clock that uses the eTSEC found on the MPC85xx.

2010-05-01 Thread Kumar Gala
On Apr 29, 2010, at 4:20 AM, Richard Cochran wrote: > The eTSEC includes a PTP clock with quite a few features. This patch adds > support for the basic clock adjustment functions. > > Signed-off-by: Richard Cochran > --- > arch/powerpc/boot/dts/mpc8313erdb.dts | 14 ++ > arch/powerpc/boot/dts/

Re: [PATCH 3/5] powerpc/mpc5121: shared DIU framebuffer support

2010-05-01 Thread Anatolij Gustschin
On Fri, 30 Apr 2010 15:40:12 -0500 Scott Wood wrote: > Timur Tabi wrote: > > On Fri, Apr 30, 2010 at 11:22 AM, Scott Wood > > wrote: > > > >>> That's what I meant. Actually, I think it's ULL. Regardless, I think > >>> the compiler will see the "10 ... * 1000" and just combine > >>>

[PATCH v21 087/100] powerpc: wire up checkpoint and restart syscalls

2010-05-01 Thread Oren Laadan
From: Nathan Lynch Changelog [v21]: - Fix build break with CONFIG_CHECKPOINT=n Changelog [v19]: - Checkpoint/powerpc: fix up checkpoint syscall, tidy restart Cc: linuxppc-...@ozlabs.org Signed-off-by: Nathan Lynch Acked-by: Serge E. Hallyn --- arch/powerpc/include/asm/systbl.h |2 ++ ar

[PATCH v21 088/100] powerpc: enable checkpoint support in Kconfig

2010-05-01 Thread Oren Laadan
From: Nathan Lynch Cc: linuxppc-...@ozlabs.org Signed-off-by: Nathan Lynch Acked-by: Serge E. Hallyn --- arch/powerpc/Kconfig |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig index 2e19500..16416b0 100644 --- a/arch/powerpc/

[PATCH v21 085/100] powerpc: provide APIs for validating and updating DABR

2010-05-01 Thread Oren Laadan
From: Nathan Lynch A checkpointed task image may specify a value for the DABR (Data Access Breakpoint Register). The restart code needs to validate this value before making any changes to the current task. ptrace_set_debugreg encapsulates the bounds checking and platform dependencies of program

[PATCH v21 086/100] powerpc: checkpoint/restart implementation

2010-05-01 Thread Oren Laadan
From: Nathan Lynch Support for checkpointing and restarting GPRs, FPU state, DABR, and Altivec state. The portion of the checkpoint image manipulated by this code begins with a bitmask of features indicating the various contexts saved. Fields in image that can vary depending on kernel configurat

[PATCH v21 084/100] powerpc: reserve checkpoint arch identifiers

2010-05-01 Thread Oren Laadan
From: Nathan Lynch Changelog [v19-rc1]: - [Matt Helsley] Add cpp definitions for enums Cc: linuxppc-...@ozlabs.org Signed-off-by: Nathan Lynch Acked-by: Serge E. Hallyn Tested-by: Serge E. Hallyn --- include/linux/checkpoint_hdr.h |4 1 files changed, 4 insertions(+), 0 deletions(

[PATCH v21 021/100] c/r: create syscalls: sys_checkpoint, sys_restart

2010-05-01 Thread Oren Laadan
Create trivial sys_checkpoint and sys_restore system calls. They will enable to checkpoint and restart an entire container, to and from a checkpoint image file descriptor. The syscalls take a pid, a file descriptor (for the image file) and flags as arguments. The pid identifies the top-most (root)

[PATCH v21 001/100] eclone (1/11): Factor out code to allocate pidmap page

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu To simplify alloc_pidmap(), move code to allocate a pid map page to a separate function. Changelog[v4]: - [Oren Laadan] Adapt to kernel 2.6.33-rc5 Changelog[v3]: - Earlier version of patchset called alloc_pidmap_page() from two places. But now

[PATCH v21 003/100] eclone (3/11): Define set_pidmap() function

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu Define a set_pidmap() interface which is like alloc_pidmap() only that caller specifies the pid number to be assigned. Changelog[v13]: - Don't let do_alloc_pidmap return 0 if it failed to find a pid. Changelog[v9]: - Completely rewrote this patch based o

[PATCH v21 007/100] eclone (7/11): Define do_fork_with_pids()

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu do_fork_with_pids() is same as do_fork(), except that it takes an additional, 'pid_set', parameter. This parameter, currently unused, specifies the set of target pids of the process in each of its pid namespaces. Changelog[v7]: - Drop 'struct pid_set' object and

[PATCH v21 006/100] eclone (6/11): Check invalid clone flags

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu As pointed out by Oren Laadan, we want to ensure that unused bits in the clone-flags remain unused and available for future. To ensure this, define a mask of clone-flags and check the flags in the clone() system calls. Changelog[v9]: - Include the unused clone-f

[PATCH v21 005/100] eclone (5/11): Add target_pids parameter to copy_process()

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu Add a 'target_pids' parameter to copy_process(). The new parameter will be used in a follow-on patch when eclone() is implemented. Cc: linux-...@vger.kernel.org Cc: x...@kernel.org Cc: linux-s...@vger.kernel.org Cc: linuxppc-...@ozlabs.org Cc: Oleg Nesterov Signed-off

[PATCH v21 011/100] eclone (11/11): Document sys_eclone

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu This gives a brief overview of the eclone() system call. We should eventually describe more details in existing clone(2) man page or in a new man page. Changelog[v13]: - [Nathan Lynch, Serge Hallyn] Rename ->child_stack_base to ->child_stack and ensur

[PATCH v21 012/100] c/r: extend arch_setup_additional_pages()

2010-05-01 Thread Oren Laadan
From: Alexey Dobriyan Add "start" argument, to request to map vDSO to a specific place, and fail the operation if not. This is useful for restart(2) to ensure that memory layout is restore exactly as needed. Changelog[v19]: - [serge hallyn] Fix potential use-before-set ret Changelog[v2]: -

[PATCH v21 004/100] eclone (4/11): Add target_pids parameter to alloc_pid()

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu This parameter is currently NULL, but will be used in a follow-on patch. Cc: linux-...@vger.kernel.org Cc: x...@kernel.org Cc: linux-s...@vger.kernel.org Cc: linuxppc-...@ozlabs.org Signed-off-by: Sukadev Bhattiprolu Acked-by: Serge E. Hallyn Tested-by: Serge E. Hally

[PATCH v21 010/100] eclone (10/11): Implement sys_eclone for powerpc

2010-05-01 Thread Oren Laadan
From: Nathan Lynch Wired up for both ppc32 and ppc64, but tested only with the latter. Changelog: - Jan 20: (ntl) fix 32-bit build - Nov 17: (serge) remove redundant flags_high check, and don't fold it into flags. Cc: linux-...@vger.kernel.org Cc: x...@kernel.org Cc: linux-s...@

[PATCH v21 009/100] eclone (9/11): Implement sys_eclone for s390

2010-05-01 Thread Oren Laadan
From: Serge E. Hallyn Implement the s390 hook for sys_eclone(). Changelog: Nov 24: Removed user-space code from commit log. See user-cr git tree. Nov 17: remove redundant flags_high check Nov 13: As suggested by Heiko, convert eclone to take its parameters

[PATCH v21 008/100] eclone (8/11): Implement sys_eclone for x86 (32, 64)

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu Container restart requires that a task have the same pid it had when it was checkpointed. When containers are nested the tasks within the containers exist in multiple pid namespaces and hence have multiple pids to specify during restart. eclone(), intended for use durin

[PATCH v21 002/100] eclone (2/11): Have alloc_pidmap() return actual error code

2010-05-01 Thread Oren Laadan
From: Sukadev Bhattiprolu alloc_pidmap() can fail either because all pid numbers are in use or because memory allocation failed. With support for setting a specific pid number, alloc_pidmap() would also fail if either the given pid number is invalid or in use. Rather than have callers assume -E

Re: -next Apr 30: OOPS during eHEA driver initialization

2010-05-01 Thread Sachin Sant
Grant Likely wrote: On Fri, Apr 30, 2010 at 11:35 AM, Grant Likely wrote: On Fri, Apr 30, 2010 at 11:27 AM, Sachin Sant wrote: Sachin Sant wrote: With today's next eHEA drivers fails to initialize. If i revert the following patch eHEA network interface is initialized