Re: [PATCH V5 1/9] Add Synopsys DesignWare HS USB OTG Control and Status Register (CSR).

2010-10-21 Thread Felipe Balbi
Hi, On Wed, Oct 20, 2010 at 07:42:44PM -0500, Fushen Chen wrote: Control and Status Register (CSR) are classified as follows: - Core Global Registers - Device Mode Registers - Device Global Registers - Device Endpoint Specific Registers - Host Mode Registers - Host Global Registers - Host Port

Re: [PATCH V5 2/9] Add Synopsys DesignWare HS USB OTG driver framework.

2010-10-21 Thread Felipe Balbi
On Wed, Oct 20, 2010 at 07:42:45PM -0500, Fushen Chen wrote: Platform probing is in dwc_otg_apmppc.c. Driver parameter and parameter checking are in dwc_otg_param.c. Signed-off-by: Fushen Chen fc...@apm.com Signed-off-by: Mark Miesfeld mmiesf...@apm.com --- drivers/usb/dwc_otg/dwc_otg_apmppc.c

Re: [2.6.36-rc7, Power6] LTP Ftrace Stress tests causes KERNEL PANIC and brings the system to xmon

2010-10-21 Thread Subrata Modak
Stefen, Can you please know your thoughts on this issue ? Regards-- Subrata On Thu, 2010-10-14 at 01:04 +0530, Subrata Modak wrote: Hi, Executing LTP Ftrace Stress tests on 2.6.36-rc7, Power6 creates kernel Panic and xmon is invoked: Ways to reproduce the problem: Download latest LTP

Re: [PATCH V5 2/9] Add Synopsys DesignWare HS USB OTG driver framework.

2010-10-21 Thread Alan Cox
+ int retval = IRQ_NONE; + + retval = dwc_otg_handle_common_intr(dwc_dev-core_if); + return IRQ_RETVAL(retval); Why assign retval first ? +} + +/** + * This function is the interrupt handler for the OverCurrent condition + * from the external charge pump (if enabled) + */

Re: [PATCH V5 1/9] Add Synopsys DesignWare HS USB OTG Control and Status Register (CSR).

2010-10-21 Thread Alan Cox
+#if defined(CONFIG_DWC_OTG_REG_LE) Is it really necessary to have everything in the header twice rather than using endian switches in the I/O ? Also with the code in that form how do you build a single copy of the driver that runs on platforms which may have one or the other endian Finally -

Re: [2.6.36-rc7, Power6] LTP Ftrace Stress tests causes KERNEL PANIC and brings the system to xmon

2010-10-21 Thread Li Zefan
(I guess you didn't notice I've also forwarded the bug report to LKML? http://marc.info/?l=linux-kernelm=128737193919500w=2) Subrata Modak wrote: Stefen, Can you please know your thoughts on this issue ? Stefen? Steven? :) Regards-- Subrata On Thu, 2010-10-14 at 01:04 +0530, Subrata

RE: [QUESTION] MPC8343 'internal only' DMA support

2010-10-21 Thread KRONSTORFER Horst
-Original Message- From: timur.t...@gmail.com [mailto:timur.t...@gmail.com] On Behalf Of Timur Tabi Sent: Mittwoch, 20. Oktober 2010 21:45 To: KRONSTORFER Horst Cc: linuxppc-dev@lists.ozlabs.org Subject: Re: [QUESTION] MPC8343 'internal only' DMA support On Tue, Oct 19, 2010 at

[PATCH] powerpc: Fix hcall tracepoint recursion

2010-10-21 Thread Anton Blanchard
Hi, This is a dead loop: trace_hcall_entry() - trace_clock_global() - trace_hcall_entry() .. And this is a PPC specific bug. Hope some ppc guys will fix it? Or we kill trace_clock_global() if no one actually uses it.. Nasty! How does the patch below look? I had to disable irqs otherwise

[PATCH v2 02/22] bitops: rename generic little-endian bitops functions

2010-10-21 Thread Akinobu Mita
As a preparation for providing little-endian bitops for all architectures, This removes generic_ prefix from little-endian bitops function names in asm-generic/bitops/le.h. s/generic_find_next_le_bit/find_next_le_bit/ s/generic_find_next_zero_le_bit/find_next_zero_le_bit/

Re: [PATCH v2 02/22] bitops: rename generic little-endian bitops functions

2010-10-21 Thread Arnd Bergmann
On Thursday 21 October 2010, Akinobu Mita wrote: As a preparation for providing little-endian bitops for all architectures, This removes generic_ prefix from little-endian bitops function names in asm-generic/bitops/le.h. s/generic_find_next_le_bit/find_next_le_bit/

Re: [PATCH V5 0/9] Add Synopsys DesignWare HS USB OTG driver

2010-10-21 Thread fushen chen
On Wed, 2010-10-20 at 21:03 -0700, Greg KH wrote: On Wed, Oct 20, 2010 at 06:06:34PM -0700, Fushen Chen wrote: This patch series add Synopsys DesignWare HS USB OTG driver support. Unfortunatly this is right at the start of the merge window for me, which means it is past the window for

Re: [PATCH 0/9] v3 De-couple sysfs memory directories from memory sections

2010-10-21 Thread Nikanth Karthikesan
On Friday 01 October 2010 23:52:56 Nathan Fontenot wrote: This set of patches decouples the concept that a single memory section corresponds to a single directory in /sys/devices/system/memory/. On systems with large amounts of memory (1+ TB) there are performance issues related to creating

USB bring-up with MPC8313

2010-10-21 Thread Péter
Hi, We are trying to bring-up USB support on a custom HW using MPC8313 (version 2 hw). Our Linux kernel version is a standard 2.6.23. We are trying to use the ULPI interface of 8313, which is connected to an USB3300 chip. The relevant part of the device tree is the following: /* phy type (ULPI,

Re: [PATCH V5 9/9] Add Synopsys DesignWare HS USB OTG driver kernel configuration and Makefile.

2010-10-21 Thread David Daney
On 10/20/2010 05:42 PM, Fushen Chen wrote: Signed-off-by: Fushen Chenfc...@apm.com Signed-off-by: Mark Miesfeldmmiesf...@apm.com --- drivers/Makefile |1 + drivers/usb/Kconfig |2 + drivers/usb/dwc_otg/Kconfig | 99 ++

[PATCH -mm 0/2] RapidIO: Changes to handling of RIO switches

2010-10-21 Thread Alexandre Bounine
The following two patches are produced as result of the discussion referenced below: http://lists.ozlabs.org/pipermail/linuxppc-dev/2010-September/085829.html http://lists.ozlabs.org/pipermail/linuxppc-dev/2010-October/086226.html Switches in RapidIO subsystem are presented the same way as

[PATCH -mm 2/2] RapidIO: Integrate rio_switch into rio_dev

2010-10-21 Thread Alexandre Bounine
Convert RIO switches device structures (rio_dev + rio_switch) into a single allocation unit. This change is based on the fact that RIO switches are using common RIO device objects anyway. Allocating RIO switch objects as RIO devices with added space for switch information simplifies handling of

[PATCH -mm 1/2] RapidIO: Use common destid storage for endpoints and switches

2010-10-21 Thread Alexandre Bounine
Changes code to use one storage location common for switches and endpoints. This eliminates unnecessary device type checks during basic access operations. Logic that assigns destid to RIO devices stays unchanged - as before, switches use an associated destid because they do not have their own.

Re: [PATCH -mm 0/2] RapidIO: Changes to handling of RIO switches

2010-10-21 Thread Micha Nelissen
Alexandre Bounine wrote: 1. Using one storage location common for switches and endpoints eliminates unnecessary device type checks during maintenance access operations. While destination IDs and hop counts have different meaning for endpoints and switches, this does not prevent us from storing

AUTO: Michael Barry is out of the office (returning 01/11/2010)

2010-10-21 Thread Michael Barry
I am out of the office until 01/11/2010. Note: This is an automated response to your message Linuxppc-dev Digest, Vol 74, Issue 107 sent on 21/10/10 20:18:24. This is the only notification you will receive while this person is away. ___

Re: AUTO: Michael Barry is out of the office (returning 01/11/2010)

2010-10-21 Thread Sean MacLennan
On Thu, 21 Oct 2010 22:30:16 +0100 Michael Barry michael_ba...@ie.ibm.com wrote: I am out of the office until 01/11/2010. Woo hoo! Time to loot his office for the good stuff! Cheers, Sean ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org

[git pull] Please pull powerpc.git next branch

2010-10-21 Thread Benjamin Herrenschmidt
Hi Linus ! Here's powerpc's batch for this merge window. Mostly bits and pieces, such as Anton doing some performance tuning left and right, and the usual churn. One hilight is the support for the new Freescale e5500 core (64-bit BookE). Another one is that we now wire up the whole lot of socket

Re: [git pull] Please pull powerpc.git next branch

2010-10-21 Thread Linus Torvalds
On Thu, Oct 21, 2010 at 8:51 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: Here's powerpc's batch for this merge window. Ok. Please double-check that I fixed up the merge conflict (due to the irq_work changes) correctly. Linus

[PATCH 3/9] drivers/net: typo fix of faild to failed

2010-10-21 Thread Joe Perches
Signed-off-by: Joe Perches j...@perches.com --- drivers/net/ps3_gelic_net.c |4 ++-- drivers/net/tulip/pnic2.c |2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/net/ps3_gelic_net.c b/drivers/net/ps3_gelic_net.c index 87d6b8f..49f6700 100644 ---

[PATCH 0/9] Typo fixes of faild to failed

2010-10-21 Thread Joe Perches
Joe Perches (9): drivers/ata: typo fix of faild to failed drivers/gpu: typo fix of faild to failed drivers/net: typo fix of faild to failed drivers/rtc: typo fix of faild to failed drivers/video: typo fix of faild to failed fs/exofs: typo fix of faild to failed fs/jfs: typo fix of