RE: [RFC PATCH 1/2] RapidIO: Add DMA Engine support for RIO data transfers

2011-10-06 Thread Vinod Koul
On Mon, 2011-10-03 at 09:52 -0700, Bounine, Alexandre wrote: > Vinod Koul wrote: > > > > On Fri, 2011-09-30 at 17:38 -0400, Alexandre Bounine wrote: > > Please CC *maintainers* on your patches, get_maintainers.pl will tell > > you who. Adding Dan here > > Based on https://lkml.org/lkml/2011/2/14/

[PATCH v14 01/10] USB/ppc4xx: Add Synopsys DesignWare HS USB OTG Register definitions

2011-10-06 Thread tmarri
From: Tirumala Marri Control and Status Register (CSR) are classified as follows: - Core Global Registers - Device Mode Registers - Device Global Registers - Device Endpoint Specific Registers - Host Mode Registers - Host Global Registers - Host Port CSRs - Host Channel Specific Registers Signed

[PATCH v14 07/10] USB/ppc4xx: Add Synopsys DWC OTG PCD function

2011-10-06 Thread tmarri
From: Tirumala Marri The PCD is responsible for translating requests from the gadget driver to appropriate actions on the DWC OTG controller. Signed-off-by: Tirumala R Marri Signed-off-by: Fushen Chen Signed-off-by: Mark Miesfeld --- drivers/usb/dwc/pcd.c | 1791 +

[PATCH v14 05/10] USB/ppc4xx: Add Synopsys DWC OTG HCD interrupt function

2011-10-06 Thread tmarri
From: Tirumala Marri Implements DWC OTG USB HCD interrupt service routine. Signed-off-by: Tirumala R Marri Signed-off-by: Fushen Chen Signed-off-by: Mark Miesfeld --- drivers/usb/dwc/hcd_intr.c | 1477 1 files changed, 1477 insertions(+), 0 deleti

[PATCH v14 02/10] USB/ppc4xx: Add Synopsys DesignWare HS USB OTG driver framework

2011-10-06 Thread tmarri
From: Tirumala Marri Platform probing is in apmppc.c. Driver parameter and parameter checking are in param.c. Signed-off-by: Tirumala R Marri Signed-off-by: Fushen Chen Signed-off-by: Mark Miesfeld --- drivers/usb/dwc/apmppc.c | 353 ++ drivers/usb

[PATCH v14 06/10] USB/ppc4xx: Add Synopsys DWC OTG HCD queue function

2011-10-06 Thread tmarri
From: Tirumala Marri Implements functions to manage Queue Heads and Queue Transfer Descriptors of DWC USB OTG Controller. Signed-off-by: Tirumala R Marri Signed-off-by: Fushen Chen Signed-off-by: Mark Miesfeld --- drivers/usb/dwc/hcd_queue.c | 696 +++

[PATCH v14 09/10] Add Synopsys DWC OTG driver kernel configuration and Makefile

2011-10-06 Thread tmarri
From: Tirumala Marri Add Synopsys DesignWare HS USB OTG driver kernel configuration. Synopsys OTG driver may operate in host only, device only, or OTG mode. The driver also allows user configure the core to use its internal DMA or Slave (PIO) mode. Signed-off-by: Tirumala R Marri Signed-off-by

[PATCH v14 10/10] USB/ppc4xx:Synopsys DWC OTG driver enable gadget support

2011-10-06 Thread tmarri
From: Tirumala Marri Enable gadget support Signed-off-by: Tirumala R Marri Signed-off-by: Fushen Chen Signed-off-by: Mark Miesfeld --- drivers/usb/Makefile |1 + drivers/usb/gadget/Kconfig| 11 +++ drivers/usb/gadget/gadget_chips.h |3 +++ 3 files chang

[PATCH v14 00/10] Add-Synopsys-DesignWare-HS-USB-OTG-driver

2011-10-06 Thread tmarri
From: Tirumala Marri v14: 1. Modifying dwc_reg_read/write functions to accepts offset as arg. 2. Adding spin_lock to common interrupt function. 3. Adding start/stop, vbus_power functions to gadget_opst struct. 4. Removed some unnecessary comments and prints. 5. op_state_str() replace with co

RE: [PATCH] mlx4_en: fix transmit of packages when blue frame isenabled

2011-10-06 Thread David Laight
> static void mlx4_bf_copy(unsigned long *dst, unsigned long *src, unsigned bytecnt) { > + int i; > + __le32 *psrc = (__le32 *)src; > + > + /* > + * the buffer is already in big endian. For little endian machines that's > + * fine. For big endain machines we must swap since

Re: [PATCH] mlx4_en: fix transmit of packages when blue frame is enabled

2011-10-06 Thread Eli Cohen
On Wed, Oct 05, 2011 at 10:15:02AM +0200, Eli Cohen wrote: How about this patch - can you give it a try? >From dee60547aa9e35a02835451d9e694cd80dd3072f Mon Sep 17 00:00:00 2001 From: Eli Cohen Date: Thu, 6 Oct 2011 15:50:02 +0200 Subject: [PATCH] mlx4_en: Fix blue flame on powerpc The source b

[PATCH 4/4] powerpc/booke: Re-organize debug code

2011-10-06 Thread Kumar Gala
* set_dabr/do_dabr are no longer used when CNFIG_PPC_ADV_DEBUG_REGS is set refactor code a bit such that we only build the dabr code for !CONFIG_PPC_ADV_DEBUG_REGS and removed some CONFIG_PPC_ADV_DEBUG_REGS code in set_dabr that would never get built. * Move do_send_trap into traps.c as its

[PATCH 3/4] powerpc/book3e-64: Fix debug support for userspace

2011-10-06 Thread Kumar Gala
With the introduction of CONFIG_PPC_ADV_DEBUG_REGS user space debug is broken on Book-E 64-bit parts that support delayed debug events. When switch_booke_debug_regs() sets DBCR0 we'll start getting debug events as MSR_DE is also set and we aren't able to handle debug events from kernel space. We

[PATCH 2/4] powerpc: Remove extraneous CONFIG_PPC_ADV_DEBUG_REGS define

2011-10-06 Thread Kumar Gala
All of DebugException is already protected by CONFIG_PPC_ADV_DEBUG_REGS there is no need to have another such ifdef inside the function. Signed-off-by: Kumar Gala --- arch/powerpc/kernel/traps.c |2 -- 1 files changed, 0 insertions(+), 2 deletions(-) diff --git a/arch/powerpc/kernel/traps.c

[PATCH 1/4] powerpc: Revert show_regs() define for readability

2011-10-06 Thread Kumar Gala
We had an existing ifdef for 4xx & BOOKE processors that got changed to CONFIG_PPC_ADV_DEBUG_REGS. The define has nothing to do with CONFIG_PPC_ADV_DEBUG_REGS. The define really should be: #if defined(CONFIG_4xx) || defined(CONFIG_BOOKE) and not #ifdef CONFIG_PPC_ADV_DEBUG_REGS Signed-off-b

Re: [patch 0/4] powerpc: Mark various interrupts IRQF_NO_THREAD

2011-10-06 Thread Gabriel Paubert
On Wed, Oct 05, 2011 at 05:31:48PM +0200, Thomas Gleixner wrote: > On Wed, 5 Oct 2011, Gabriel Paubert wrote: > > > On Wed, Oct 05, 2011 at 12:30:49PM -, Thomas Gleixner wrote: > > > The following series marks the obvious interrupts IRQF_NO_THREAD to > > > prevent forced interrupt threading -

Re: [PATCH] libata: Convert LED disk trigger from IDE to libata

2011-10-06 Thread Sergei Shtylyov
Hello. On 03-10-2011 20:07, Jörg Sommer wrote: This patch converts the trigger for the LED at the front of Apple's iBooks to libata. It's merely a replacement of the string ide by disk. The patch is taken from http://dev.gentoo.org/~josejx/ata.patch. I've asked Joseph Jezak if he intends to