[PATCH 2/2 v3] powerpc/85xx: Added P1021RDB-PC Platform support

2012-01-16 Thread Xu Jiucheng
Signed-off-by: Xu Jiucheng --- arch/powerpc/platforms/85xx/mpc85xx_rdb.c | 24 1 files changed, 24 insertions(+), 0 deletions(-) diff --git a/arch/powerpc/platforms/85xx/mpc85xx_rdb.c b/arch/powerpc/platforms/85xx/mpc85xx_rdb.c index ccf520e..1273381 100644 --- a/arch

Re: [PATCH 1/2 v2] powerpc/85xx: Add dts for P1021RDB-PC board

2012-01-16 Thread Xu Jiucheng
On Mon, 2012-01-16 at 13:36 -0600, Scott Wood wrote: > On 01/16/2012 01:00 AM, Xu Jiucheng wrote: > > + mdio@24000 { > > + phy0: ethernet-phy@0 { > > + interrupt-parent = <&mpic>; > > + interrupts = <3 1>; > > + reg = <0x0>; > > +

Re: [RFC PATCH 1/2] KVM: PPC: Book3S HV: Make virtual processor area registration more robust

2012-01-16 Thread Paul Mackerras
On Mon, Jan 16, 2012 at 02:04:29PM +0100, Alexander Graf wrote: > > On 20.12.2011, at 11:22, Paul Mackerras wrote: > > @@ -152,6 +152,8 @@ static unsigned long do_h_register_vpa(struct kvm_vcpu > > *vcpu, > > flags &= 7; > > if (flags == 0 || flags == 4) > > This could probably use a ne

Re: [PATCH v3] KVM: Move gfn_to_memslot() to kvm_host.h

2012-01-16 Thread Paul Mackerras
On Mon, Jan 16, 2012 at 02:30:41PM +0100, Alexander Graf wrote: > Which tree is this against? I got this diff between your patch and the patch > when applied on my tree: It's against your tree (previously) plus my first 13-patch series, but not the second series of 5 patches, which presumably wh

AUTO: Michael Barry is out of the office (returning 18/01/2012)

2012-01-16 Thread Michael Barry
I am out of the office until 18/01/2012. Note: This is an automated response to your message "Linuxppc-dev Digest, Vol 89, Issue 49" sent on 17/1/2012 1:00:02. This is the only notification you will receive while this person is away. ___ Linuxppc-

Re: [RFC 13/14] irq_domain: Remove 'new' irq_domain in favour of the ppc one

2012-01-16 Thread Benjamin Herrenschmidt
On Mon, 2012-01-16 at 18:43 -0800, Michael Bohan wrote: > > I was planning on sending these patches out, but it seems like with > Grant's patches, they may no longer be up to date. I was curious if any > thought was given to supporting configurations like this the one I > mentioned with the adv

Re: [RFC 13/14] irq_domain: Remove 'new' irq_domain in favour of the ppc one

2012-01-16 Thread Michael Bohan
On 1/12/2012 4:31 PM, Rob Herring wrote: You have removed the irq_alloc_descs call from the GIC which is a step backwards. Several of the ARM DT enabled platforms are at the point they can fully support dynamic virq base for each irqchip. I changed the domain from legacy to linear and got things

Re: [git pull] Please pull powerpc.git merge branch

2012-01-16 Thread Benjamin Herrenschmidt
On Mon, 2012-01-16 at 13:21 -0600, Kumar Gala wrote: > This doesnt appear to have the compile fix for p1022_ds.c. I must have pulled it into the wrong branch or something... I'll do a new one after LCA. Cheers, Ben. ___ Linuxppc-dev mailing list Linux

Re: Cannot wake-up from standby with MPC8313

2012-01-16 Thread Scott Wood
On 01/13/2012 08:13 AM, Norbert van Bolhuis wrote: > I dumped SIPNR/SIMSR and uart IIR/EIR (since console triggers wake-up) > but they do not change just before entering standby (via > mpc6xx_enter_standby > which omits setting MSR_POW). uart IRQ is always enabled, unmasked and > not pending. > >

Re: [PATCH 1/2 v2] powerpc/85xx: Add dts for P1021RDB-PC board

2012-01-16 Thread Scott Wood
On 01/16/2012 01:00 AM, Xu Jiucheng wrote: > + mdio@24000 { > + phy0: ethernet-phy@0 { > + interrupt-parent = <&mpic>; > + interrupts = <3 1>; > + reg = <0x0>; > + }; > + > + phy1: ethernet-phy@1 { >

Re: [git pull] Please pull powerpc.git merge branch

2012-01-16 Thread Kumar Gala
On Jan 13, 2012, at 12:21 AM, Benjamin Herrenschmidt wrote: > Hi Linus ! > > Please pull this couple of important bug fixes (a commit > that went in breaks booting on some machines, this fixes > it properly). > > Thanks ! > > Cheers, > Ben. > > The following changes since commit 7b3480f8b7011

Re: [PATCH] drivers/video: compile fixes for fsl-diu-fb.c

2012-01-16 Thread Timur Tabi
Michael Neuling wrote: > From: Michael Neuling > > [PATCH] drivers/video: compile fixes for fsl-diu-fb.c > > Fix a compiler errors introduced in: > commit ddd3d905436b572ebadc09dcf2d12ca5b37020a0 > Author: Timur Tabi > drivers/video: fsl-diu-fb: merge all allocated data into one block >

Re: [PATCH] drivers/video: compile fixes for fsl-diu-fb.c

2012-01-16 Thread Timur Tabi
Michael Neuling wrote: > drivers/video/fsl-diu-fb.c: In function 'fsl_diu_suspend': > drivers/video/fsl-diu-fb.c:1435: error: incompatible type for argument 1 of > 'disable_lcdc' > drivers/video/fsl-diu-fb.c:592: note: expected 'struct fb_info *' but > argument is of type 'struct fb_info' > drive

Re: [PATCH v3] KVM: Move gfn_to_memslot() to kvm_host.h

2012-01-16 Thread Alexander Graf
On 13.01.2012, at 07:09, Paul Mackerras wrote: > This moves __gfn_to_memslot() and search_memslots() from kvm_main.c to > kvm_host.h to reduce the code duplication caused by the need for > non-modular code in arch/powerpc/kvm/book3s_hv_rm_mmu.c to call > gfn_to_memslot() in real mode. > > Rather

Re: [PATCH v3] KVM: Move gfn_to_memslot() to kvm_host.h

2012-01-16 Thread Avi Kivity
On 01/16/2012 03:18 PM, Alexander Graf wrote: > Avi? ACK! -- error compiling committee.c: too many arguments to function ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH v3] KVM: Move gfn_to_memslot() to kvm_host.h

2012-01-16 Thread Alexander Graf
On 13.01.2012, at 07:09, Paul Mackerras wrote: > This moves __gfn_to_memslot() and search_memslots() from kvm_main.c to > kvm_host.h to reduce the code duplication caused by the need for > non-modular code in arch/powerpc/kvm/book3s_hv_rm_mmu.c to call > gfn_to_memslot() in real mode. > > Rather

Re: [KVM PATCH 2/2] KVM: PPC: Book3S HV: Report stolen time to guest through dispatch trace log

2012-01-16 Thread Alexander Graf
On 20.12.2011, at 11:37, Paul Mackerras wrote: > This adds code to measure "stolen" time per virtual core in units of > timebase ticks, and to report the stolen time to the guest using the > dispatch trace log (DTL). The guest can register an area of memory > for the DTL for a given vcpu. The D

Re: [RFC PATCH 1/2] KVM: PPC: Book3S HV: Make virtual processor area registration more robust

2012-01-16 Thread Alexander Graf
On 20.12.2011, at 11:22, Paul Mackerras wrote: > The PAPR API allows three sorts of per-virtual-processor areas to be > registered (VPA, SLB shadow buffer, and dispatch trace log), and > furthermore, these can be registered and unregistered for another > virtual CPU. Currently we just update the

Re: [PATCH 2/2] [PowerPC Book3E] Introduce new ptrace debug feature flag

2012-01-16 Thread David Gibson
On Thu, Dec 22, 2011 at 03:04:47PM +0530, K.Prasad wrote: > On Wed, Dec 21, 2011 at 11:55:02AM +1100, David Gibson wrote: > > On Thu, Dec 08, 2011 at 04:53:30PM +0530, K.Prasad wrote: > > > While PPC_PTRACE_SETHWDEBUG ptrace flag in PowerPC accepts > > > PPC_BREAKPOINT_MODE_EXACT mode of breakpoint

Re: [PATCH 04/14] PowerPC: adapt for dma_map_ops changes

2012-01-16 Thread David Gibson
On Fri, Dec 23, 2011 at 01:27:23PM +0100, Marek Szyprowski wrote: > From: Andrzej Pietrasiewicz > > Adapt core PowerPC architecture code for dma_map_ops changes: replace > alloc/free_coherent with generic alloc/free methods. > > Signed-off-by: Andrzej Pietrasiewicz > Signed-off-by: Marek Szypro

Re: [PATCH 01/14] common: dma-mapping: introduce alloc_attrs and free_attrs methods

2012-01-16 Thread David Gibson
On Fri, Dec 23, 2011 at 01:27:20PM +0100, Marek Szyprowski wrote: > Introduce new generic alloc and free methods with attributes argument. > > Existing alloc_coherent and free_coherent can be implemented on top of the > new calls with NULL attributes argument. Later also dma_alloc_non_coherent > c