Re: [PATCH v2 3/7] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
On 17/09/12 03:07, Michael Ellerman wrote: On Fri, 2012-09-14 at 09:19 +0100, Srinivas KANDAGATLA wrote: From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in

[PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla

[PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary

[PATCH v3 0/5] Introduce of_get_child_by_name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want

[PATCH v3 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla

[v5][PATCH 1/3] powerpc/kprobe: introduce a new thread flag

2012-09-17 Thread Tiejun Chen
We need to add a new thread flag, TIF_EMULATE_STACK_STORE, for emulating stack store operation while exiting exception. Signed-off-by: Tiejun Chen tiejun.c...@windriver.com --- arch/powerpc/include/asm/thread_info.h |3 +++ 1 file changed, 3 insertions(+) diff --git

[v5][PATCH 2/3] powerpc/kprobe: complete kprobe and migrate exception frame

2012-09-17 Thread Tiejun Chen
We can't emulate stwu since that may corrupt current exception stack. So we will have to do real store operation in the exception return code. Firstly we'll allocate a trampoline exception frame below the kprobed function stack and copy the current exception frame to the trampoline. Then we can

[v5][PATCH 3/3] powerpc/kprobe: don't emulate store when kprobe stwu r1

2012-09-17 Thread Tiejun Chen
We don't do the real store operation for kprobing 'stwu Rx,(y)R1' since this may corrupt the exception frame, now we will do this operation safely in exception return code after migrate current exception frame below the kprobed function stack. So we only update gpr[1] here and trigger a thread

RE: [v5][PATCH 2/3] powerpc/kprobe: complete kprobe and migrate exception frame

2012-09-17 Thread David Laight
/* N.B. the only way to get here is from the beq following ret_from_except. */ resume_kernel: - /* check current_thread_info-preempt_count */ + /* check current_thread_info, _TIF_EMULATE_STACK_STORE */ CURRENT_THREAD_INFO(r9, r1) + lwz r8,TI_FLAGS(r9) + andis.

Re: [v5][PATCH 2/3] powerpc/kprobe: complete kprobe and migrate exception frame

2012-09-17 Thread tiejun.chen
On 09/17/2012 06:02 PM, David Laight wrote: /* N.B. the only way to get here is from the beq following ret_from_except. */ resume_kernel: - /* check current_thread_info-preempt_count */ + /* check current_thread_info, _TIF_EMULATE_STACK_STORE */ CURRENT_THREAD_INFO(r9,

RE: [PATCH] edac/85xx: fix error handle of mpc85xx_mc_err_probe

2012-09-17 Thread Xie Shaohui-B21989
-Original Message- From: Shaun Ruffell [mailto:sruff...@digium.com] Sent: Saturday, September 15, 2012 2:22 AM To: Xie Shaohui-B21989 Cc: linux-e...@vger.kernel.org; linuxppc-dev@lists.ozlabs.org; a...@linux-foundation.org; avoront...@mvista.com; linux- ker...@vger.kernel.org;

[RESEND PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla

[RESEND PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child_by_name libary

[RESEND PATCH v3 3/5] dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead. Signed-off-by: Srinivas Kandagatla

[RESEND PATCH v3 0/5] Introduce of_get_child_by_name.

2012-09-17 Thread Srinivas KANDAGATLA
From: Srinivas Kandagatla srinivas.kandaga...@st.com This patch series introduces of_get_child_by_name function to get a child node by its name in a given parent node and also removes code duplication in some of the existing driver code by using of_get_child_by_name. Normally if a driver want

Re: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Chris Ball
Hi, On Thu, Sep 13 2012, Kumar Gala wrote: Can you list out which SoCs support it and which don't. Having this list will be useful in understanding which controller versions supported it. P1020, p1021, p1022, p1024, p1015 and p4080 can't support it. Mpc8536, p2020, and the other current

Re: [RESEND PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Rob Herring
On 09/17/2012 06:58 AM, Srinivas KANDAGATLA wrote: From: Srinivas Kandagatla srinivas.kandaga...@st.com Please drop the period on the subject. This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code

Re: [RESEND PATCH v3 1/5] dt: introduce of_get_child_by_name to get child node by name.

2012-09-17 Thread Rob Herring
On 09/17/2012 06:58 AM, Srinivas KANDAGATLA wrote: From: Srinivas Kandagatla srinivas.kandaga...@st.com Please drop the period on the subject. This patch introduces of_get_child_by_name function to get a child node by its name in a given parent node. Without this patch each driver code

Re: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Kumar Gala
On Sep 17, 2012, at 7:36 AM, Chris Ball wrote: Hi, On Thu, Sep 13 2012, Kumar Gala wrote: Can you list out which SoCs support it and which don't. Having this list will be useful in understanding which controller versions supported it. P1020, p1021, p1022, p1024, p1015 and p4080 can't

Re: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Chris Ball
Hi, On Mon, Sep 17 2012, Kumar Gala wrote: P1020, p1021, p1022, p1024, p1015 and p4080 can't support it. Mpc8536, p2020, and the other current DPAA silicon (e.g. p5020, p3041) support it. Based on this, why don't we use the HOSTVER register to detect instead of device tree: I've got a

[PATCH 2/2] ppc/eeh: fix crash on converting OF node to edev

2012-09-17 Thread Gavin Shan
The kernel crash was reported by Alexy. He was testing some feature with private kernel, in which Alexy added some code in pci_pm_reset() to read the CSR after writting it. The bug could be reproduced on Fiber Channel card (Fibre Channel: Emulex Corporation Saturn-X: LightPulse Fibre Channel Host

[PATCH 1/2] ppc/eeh: lock module while handling EEH event

2012-09-17 Thread Gavin Shan
The EEH core is talking with the PCI device driver to determine the action (purely reset, or PCI device removal). During the period, the driver might be unloaded and in turn causes kernel crash as follows: EEH: Detected PCI bus error on PHB#4-PE#1 EEH: This PCI device has failed 3 times in

[PATCH][v3]: powerpc/perf: Sample only if SIAR-Valid bit is set in P7+

2012-09-17 Thread Sukadev Bhattiprolu
From 192fa874e5574d08d66d96155b6d9c536fce6e8a Mon Sep 17 00:00:00 2001 From: Sukadev Bhattiprolu suka...@linux.vnet.ibm.com Date: Mon, 2 Jul 2012 08:06:14 -0700 Subject: [PATCH] powerpc/perf: Sample only if SIAR-Valid bit is set in P7+ On POWER7+ two new bits (mmcra[35] and mmcra[36]) indicate

RE: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Huang Changming-R66093
On Sep 17, 2012, at 7:36 AM, Chris Ball wrote: Hi, On Thu, Sep 13 2012, Kumar Gala wrote: Can you list out which SoCs support it and which don't. Having this list will be useful in understanding which controller versions supported it. P1020, p1021, p1022, p1024, p1015 and p4080

Re: [RESEND PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.

2012-09-17 Thread Michael Ellerman
On Mon, 2012-09-17 at 12:58 +0100, Srinivas KANDAGATLA wrote: From: Srinivas Kandagatla srinivas.kandaga...@st.com As follow-up to dt: introduce of_get_child_by_name to get child node by name. patch, This patch removes some of the code duplication in the driver by replacing it with

[PATCH][V4] powerpc/fsl-pci: Add pci inbound/outbound PM support

2012-09-17 Thread Jia Hongtao
Power supply for PCI inbound/outbound window registers is off when system go to deep-sleep state. We save the values of registers before suspend and restore to registers after resume. Signed-off-by: Jiang Yutang b14...@freescale.com Signed-off-by: Jia Hongtao b38...@freescale.com Signed-off-by:

Re: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Kumar Gala
On Sep 17, 2012, at 8:09 PM, Huang Changming-R66093 wrote: On Sep 17, 2012, at 7:36 AM, Chris Ball wrote: Hi, On Thu, Sep 13 2012, Kumar Gala wrote: Can you list out which SoCs support it and which don't. Having this list will be useful in understanding which controller versions

Re: [PATCH][V4] powerpc/fsl-pci: Add pci inbound/outbound PM support

2012-09-17 Thread Kumar Gala
On Sep 17, 2012, at 9:10 PM, Jia Hongtao wrote: Power supply for PCI inbound/outbound window registers is off when system go to deep-sleep state. We save the values of registers before suspend and restore to registers after resume. Signed-off-by: Jiang Yutang b14...@freescale.com

Re: [v5][PATCH 2/3] powerpc/kprobe: complete kprobe and migrate exception frame

2012-09-17 Thread Benjamin Herrenschmidt
On Mon, 2012-09-17 at 17:54 +0800, Tiejun Chen wrote: -#ifdef CONFIG_PREEMPT b restore /* N.B. the only way to get here is from the beq following ret_from_except. */ resume_kernel: - /* check current_thread_info-preempt_count */ + /* check current_thread_info,

Re: [PATCH 2/3] powerpc/esdhc: add property to disable the CMD23

2012-09-17 Thread Chris Ball
Hi, On Tue, Sep 18 2012, Kumar Gala wrote: I've got a mild preference for handling quirk assignment in the DT rather than in driver code, so I'd prefer to just push the original patch to mmc-next as-is. Does that sound okay? Why? I only ask because I agree with Scott that this means you

Re: [v5][PATCH 2/3] powerpc/kprobe: complete kprobe and migrate exception frame

2012-09-17 Thread Benjamin Herrenschmidt
On Tue, 2012-09-18 at 15:05 +1000, Benjamin Herrenschmidt wrote: On Mon, 2012-09-17 at 17:54 +0800, Tiejun Chen wrote: -#ifdef CONFIG_PREEMPT b restore /* N.B. the only way to get here is from the beq following ret_from_except. */ resume_kernel: - /* check

Re: [PATCH v2] powerpc/usb: fix bug of CPU hang when missing USB PHY clock

2012-09-17 Thread Kumar Gala
On Aug 22, 2012, at 5:17 AM, Shengzhou Liu wrote: when missing USB PHY clock, kernel booting up will hang during USB initialization. We should check USBGP[PHY_CLK_VALID] bit to avoid CPU hanging in this case. Signed-off-by: Shengzhou Liu shengzhou@freescale.com --- v2 changes: use