Re: [PATCH 3/6] arch/powerpc/kvm/e500_tlb.c: fix error return code

2012-10-02 Thread Alexander Graf
On 05.08.2012, at 11:52, Julia Lawall wrote: From: Julia Lawall ju...@diku.dk Convert a 0 error return code to a negative one, as returned elsewhere in the function. A new label is also added to avoid freeing things that are known to not yet be allocated. A simplified version of the

Re: [RFC v9 PATCH 13/21] memory-hotplug: check page type in get_page_bootmem

2012-10-02 Thread Ni zhan Chen
On 10/01/2012 11:03 AM, Yasuaki Ishimatsu wrote: Hi Chen, 2012/09/29 11:15, Ni zhan Chen wrote: On 09/05/2012 05:25 PM, we...@cn.fujitsu.com wrote: From: Yasuaki Ishimatsu isimatu.yasu...@jp.fujitsu.com The function get_page_bootmem() may be called more than one time to the same page. There

Re: [RFC v9 PATCH 06/21] memory-hotplug: export the function acpi_bus_remove()

2012-10-02 Thread KOSAKI Motohiro
On Mon, Oct 1, 2012 at 8:34 PM, Ni zhan Chen nizhan.c...@gmail.com wrote: On 09/05/2012 05:25 PM, we...@cn.fujitsu.com wrote: From: Wen Congyang we...@cn.fujitsu.com The function acpi_bus_remove() can remove a acpi device from acpi device. IIUC, s/acpi device/acpi bus IIUC,

Re: [RFC v9 PATCH 01/21] memory-hotplug: rename remove_memory() to offline_memory()/offline_pages()

2012-10-02 Thread KOSAKI Motohiro
Then, you introduced bisect breakage. It is definitely unacceptable. What is bisect breakage meaning? Think what's happen when only applying path [1/21]. ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org

Re: Build regressions/improvements in v3.6

2012-10-02 Thread Geert Uytterhoeven
On Tue, Oct 2, 2012 at 8:32 PM, Geert Uytterhoeven ge...@linux-m68k.org wrote: JFYI, when comparing v3.6 to v3.6-rc7[3], the summaries are: - build errors: +4/-1 + arch/powerpc/platforms/512x/mpc512x_shared.c: error: 'FSL_DIU_PORT_DVI' undeclared (first use in this function): = 189:9 +

Re: [REGRESSION] nfsd crashing with 3.6.0-rc7 on PowerPC

2012-10-02 Thread Nishanth Aravamudan
Hi Ben, On 02.10.2012 [10:58:29 +1000], Benjamin Herrenschmidt wrote: On Mon, 2012-10-01 at 16:03 +0200, Alexander Graf wrote: Phew. Here we go :). It looks to be more of a PPC specific problem than it appeared as at first: Ok, so I suspect the problem is the pushing down of the locks

Re: [REGRESSION] nfsd crashing with 3.6.0-rc7 on PowerPC

2012-10-02 Thread Alexander Graf
On 02.10.2012, at 23:43, Nishanth Aravamudan wrote: Hi Ben, On 02.10.2012 [10:58:29 +1000], Benjamin Herrenschmidt wrote: On Mon, 2012-10-01 at 16:03 +0200, Alexander Graf wrote: Phew. Here we go :). It looks to be more of a PPC specific problem than it appeared as at first: Ok, so I

Re: [REGRESSION] nfsd crashing with 3.6.0-rc7 on PowerPC

2012-10-02 Thread Nishanth Aravamudan
On 02.10.2012 [23:47:39 +0200], Alexander Graf wrote: On 02.10.2012, at 23:43, Nishanth Aravamudan wrote: Hi Ben, On 02.10.2012 [10:58:29 +1000], Benjamin Herrenschmidt wrote: On Mon, 2012-10-01 at 16:03 +0200, Alexander Graf wrote: Phew. Here we go :). It looks to be more of a PPC

Re: [REGRESSION] nfsd crashing with 3.6.0-rc7 on PowerPC

2012-10-02 Thread Alexander Graf
On 03.10.2012, at 00:17, Nishanth Aravamudan wrote: On 02.10.2012 [23:47:39 +0200], Alexander Graf wrote: On 02.10.2012, at 23:43, Nishanth Aravamudan wrote: Hi Ben, On 02.10.2012 [10:58:29 +1000], Benjamin Herrenschmidt wrote: On Mon, 2012-10-01 at 16:03 +0200, Alexander Graf wrote:

[PATCH] powerpc/47x: Use the new ppc-opcode intrastructiure.

2012-10-02 Thread Tony Breeds
Don't use 47x only #defines for TLBIVAX or ICBT, supply and use helpers in ppc-opcode.h This fixes a compile breakage. Signed-off-by: Tony Breeds t...@bakeyournoodle.com --- arch/powerpc/include/asm/ppc-opcode.h |4 arch/powerpc/mm/tlb_nohash_low.S | 15 --- 2 files

[PATCH] powerpc: Add asm/debug.h to get powerpc_debugfs_root

2012-10-02 Thread Tony Breeds
Since the Disintegrate asm/system.h for PowerPC (ae3a197e3d0bfe3f4bf1693723e82dc018c096f3) This has been failing when DEBUG is #defined. Signed-off-by: Tony Breeds t...@bakeyournoodle.com --- arch/powerpc/kernel/prom.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git

[PATCH 0/5] Move some OF functionality from pseries to generic OF code

2012-10-02 Thread Nathan Fontenot
This set of patches moves some OF code that has been living in the pseries tree over to the generic OF code base. The functionality being migrated over is something that, I believe, should live in the generic code base. The specific functionality being migrated to generic OF code is; o Updating

RE: [LKML] Re: Build regressions/improvements in v3.6

2012-10-02 Thread Marc Gauthier
Geert Uytterhoeven ge...@linux-m68k.org wrote: xtensa-allmodconfig (hmm, this is not a new one, it felt through the cracks in -rc7 because of log line interleaving). Ugh, arch/xtensa/include/asm/regs.h defines way to generic symbols, like MISC (which causes the above breakage), and even a few

[PATCH 1/5] Add /proc device tree updating to of node add/remove

2012-10-02 Thread Nathan Fontenot
When adding or removing a device tree node we should also update the device tree in /proc/device-tree. This action is already done in the generic OF code for adding/removing properties of a node. This patch adds this functionality for nodes. Signed-off-by: Nathan Fontenot nf...@linux.vnet.ibm.com

[PATCH 2/5] Move of_drconf_cell struct definition to asm/prom.h

2012-10-02 Thread Nathan Fontenot
This patch moves the definition of the of_drconf_cell struct to asm/prom.h to make it available for all powerpc/pseries code. Signed-off-by: Nathan Fontenot nf...@linux.vnet.ibm.com --- arch/powerpc/include/asm/prom.h | 16 arch/powerpc/mm/numa.c | 12

[PATCH 3/5] Add of node/property notification chain for adds and removes

2012-10-02 Thread Nathan Fontenot
This patch moves the notification chain for updates to the device tree from the powerpc/pseries code to the base OF code. This makes this functionality available to all architectures. Additionally the notification chain is updated to allow notifications for property add/remove/update. To make

[PATCH 4/5] Rename the drivers/of prom_* functions to of_*

2012-10-02 Thread Nathan Fontenot
Rename the prom_*_property routines of the generic OF code to of_*_property. This brings them in line with the naming used by the rest of the OF code. Signed-off-by: Nathan Fontenot nf...@linux.vnet.ibm.com --- arch/powerpc/kernel/machine_kexec.c | 12 ++--

[PATCH 5/5] Remove the pSeries_reconfig.h file

2012-10-02 Thread Nathan Fontenot
Remove the pSeries_reconfig.h header file. At this point there is only one definition in the file, pSeries_coalesce_init(), which can be moved to rtas.h. Signed-off-by: Nathan Fontenot nf...@linux.vnet.ibm.com --- arch/powerpc/include/asm/pSeries_reconfig.h | 15 ---

Re: [REGRESSION] nfsd crashing with 3.6.0-rc7 on PowerPC

2012-10-02 Thread Benjamin Herrenschmidt
On Tue, 2012-10-02 at 14:43 -0700, Nishanth Aravamudan wrote: Started looking into this. If your suspicion were accurate, wouldn't the bisection have stopped at 0e4bc95d87394364f408627067238453830bdbf3 (powerpc/iommu: Reduce spinlock coverage in iommu_alloc and iommu_free)? Alex, the