Re: [PATCH 1/2] PPC: powernv: remove redundant cpuidle_idle_call()

2014-02-14 Thread Preeti U Murthy
Hi Nicolas, You will have to include the below patch with yours. You could squash the two I guess, I have added the changelog just for clarity. And you also might want to change the subject to cpuidle/powernv. It gives a better picture. Thanks Regards Preeti U Murthy cpuidle/powernv: Add

Re: [PATCH 1/2] PPC: powernv: remove redundant cpuidle_idle_call()

2014-02-14 Thread Deepthi Dharwar
On 02/14/2014 04:47 PM, Preeti U Murthy wrote: Hi Nicolas, You will have to include the below patch with yours. You could squash the two I guess, I have added the changelog just for clarity. And you also might want to change the subject to cpuidle/powernv. It gives a better picture.

Re: [PATCH 1/6] PCI, acpiphp: Use list_for_each_entry() for bus traversal

2014-02-14 Thread Rafael J. Wysocki
On Friday, February 14, 2014 10:19:41 AM Yijing Wang wrote: On 2014/2/14 7:54, Rafael J. Wysocki wrote: On Thursday, February 13, 2014 09:13:58 PM Yijing Wang wrote: Replace list_for_each() + pci_bus_b() with the simpler list_for_each_entry(). Signed-off-by: Yijing Wang

Re: [PATCH 2/2] of: search the best compatible match first in __of_match_node()

2014-02-14 Thread Rob Herring
On Thu, Feb 13, 2014 at 11:22 PM, Kevin Hao haoke...@gmail.com wrote: Currently, of_match_node compares each given match against all node's compatible strings with of_device_is_compatible. To achieve multiple compatible strings per node with ordering from specific to generic, this requires

Re: [PATCH 2/2] of: search the best compatible match first in __of_match_node()

2014-02-14 Thread Kumar Gala
On Feb 14, 2014, at 9:53 AM, Rob Herring robherri...@gmail.com wrote: On Thu, Feb 13, 2014 at 11:22 PM, Kevin Hao haoke...@gmail.com wrote: Currently, of_match_node compares each given match against all node's compatible strings with of_device_is_compatible. To achieve multiple compatible

Re: [PATCH 2/2] of: search the best compatible match first in __of_match_node()

2014-02-14 Thread Kumar Gala
On Feb 14, 2014, at 9:53 AM, Rob Herring robherri...@gmail.com wrote: On Thu, Feb 13, 2014 at 11:22 PM, Kevin Hao haoke...@gmail.com wrote: Currently, of_match_node compares each given match against all node's compatible strings with of_device_is_compatible. To achieve multiple compatible

Re: [PATCH 1/6] PCI,acpiphp: Use list_for_each_entry() for bus traversal

2014-02-14 Thread Bjorn Helgaas
On Thu, Feb 13, 2014 at 09:13:58PM +0800, Yijing Wang wrote: Replace list_for_each() + pci_bus_b() with the simpler list_for_each_entry(). Signed-off-by: Yijing Wang wangyij...@huawei.com I applied all six of these (please include a 0/6 cover letter in the future; that's a nice place to note

Re: [PATCH V2] powerpc: thp: Fix crash on mremap

2014-02-14 Thread Benjamin Herrenschmidt
On Thu, 2014-02-13 at 08:03 +1100, Benjamin Herrenschmidt wrote: It looks very different because the function that needs to be fixed changed a lot upstream in 3.13. .../... Hi Greg ! You didn't say if that explanation was to your liking :-) If it is, do you want Aneesh to re-submit the

[PATCH v2 00/11] powerpc: Add support for Power Hypervisor supplied performance counters

2014-02-14 Thread Cody P Schafer
These patches add basic pmus for 2 powerpc hypervisor interfaces to obtain performance counters: gpci (get performance counter info) and 24x7. The counters supplied by these interfaces are continually counting and never need to be (and cannot be) disabled or enabled. They additionally do not

[PATCH v2 02/11] perf core: export swevent hrtimer helpers

2014-02-14 Thread Cody P Schafer
Export the swevent hrtimer helpers currently only used in events/core.c to allow the addition of architecture specific sw-like pmus. Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- include/linux/perf_event.h | 5 - kernel/events/core.c | 8 2 files changed, 8

[PATCH v2 01/11] perf: add PMU_RANGE_ATTR() helper for use by sw-like pmus

2014-02-14 Thread Cody P Schafer
Add PMU_RANGE_ATTR() and PMU_RANGE_RESV() (for reserved areas) which generate functions to extract the relevent bits from event-attr.config{,1,2} for use by sw-like pmus where the 'config{,1,2}' values don't map directly to hardware registers. Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com

[PATCH v2 03/11] sysfs: create bin_attributes under the requested group

2014-02-14 Thread Cody P Schafer
bin_attributes created/updated in create_files() (such as those listed via (struct device).attribute_groups) were not placed under the specified group, and instead appeared in the base kobj directory. Fix this by making bin_attributes use creating code similar to normal attributes. A quick grep

[PATCH v2 04/11] powerpc: add hvcalls for 24x7 and gpci (get performance counter info)

2014-02-14 Thread Cody P Schafer
Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/include/asm/hvcall.h | 5 + 1 file changed, 5 insertions(+) diff --git a/arch/powerpc/include/asm/hvcall.h b/arch/powerpc/include/asm/hvcall.h index d8b600b..652f7e4 100644 --- a/arch/powerpc/include/asm/hvcall.h +++

[PATCH v2 05/11] powerpc: add hv_gpci interface header

2014-02-14 Thread Cody P Schafer
H_GetPerformanceCounterInfo (refered to as hv_gpci or just gpci from here on) is an interface to retrieve specific performance counters and other data from the hypervisor. All outputs have a fixed format (and are represented as structs in this patch). Signed-off-by: Cody P Schafer

[PATCH v2 06/11] powerpc: add 24x7 interface header

2014-02-14 Thread Cody P Schafer
24x7 (also called hv_24x7 or H_24X7) is an interface to obtain performance counters from the hypervisor. These counters do not have a fixed format/possition and are instead documented in a 24x7 Catalog, which is provided by the hypervisor (that interface is also documented in this header). This

[PATCH v2 07/11] powerpc: add a shared interface to get gpci version and capabilities

2014-02-14 Thread Cody P Schafer
Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/hv-common.c | 39 +++ arch/powerpc/perf/hv-common.h | 17 + 2 files changed, 56 insertions(+) create mode 100644 arch/powerpc/perf/hv-common.c create mode 100644

[PATCH v2 08/11] powerpc/perf: add support for the hv gpci (get performance counter info) interface

2014-02-14 Thread Cody P Schafer
This provides a basic link between perf and hv_gpci. Notably, it does not yet support transactions and does not list any events (they can still be manually composed). Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/hv-gpci.c | 290

[PATCH v2 09/11] powerpc/perf: add support for the hv 24x7 interface

2014-02-14 Thread Cody P Schafer
This provides a basic interface between hv_24x7 and perf. Similar to the one provided for gpci, it lacks transaction support and does not list any events. Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/hv-24x7.c | 491 1

[PATCH v2 11/11] powerpc/perf/hv_{gpci, 24x7}: add documentation of device attributes

2014-02-14 Thread Cody P Schafer
gpci and 24x7 expose some device specific attributes. Add some documentation for them. Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- .../testing/sysfs-bus-event_source-devices-hv_24x7 | 22 +++ .../testing/sysfs-bus-event_source-devices-hv_gpci | 43 ++ 2

[PATCH v2 10/11] powerpc/perf: add kconfig option for hypervisor provided counters

2014-02-14 Thread Cody P Schafer
Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/Makefile | 2 ++ arch/powerpc/platforms/Kconfig.cputype | 6 ++ 2 files changed, 8 insertions(+) diff --git a/arch/powerpc/perf/Makefile b/arch/powerpc/perf/Makefile index 60d71ee..f9c083a 100644 ---

Re: [PATCH v2 10/11] powerpc/perf: add kconfig option for hypervisor provided counters

2014-02-14 Thread Scott Wood
On Fri, 2014-02-14 at 14:02 -0800, Cody P Schafer wrote: Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/Makefile | 2 ++ arch/powerpc/platforms/Kconfig.cputype | 6 ++ 2 files changed, 8 insertions(+) diff --git a/arch/powerpc/perf/Makefile

Anyone using SysRQ key sequences on console serial port ?

2014-02-14 Thread John Donnelly
Hi, I tried using the SysRq hotkey sequence on a serial console - 3.11.0-5-powerpc-e500mc system, by issuing a break and the system immediately wedges after displaying SysRQ : HELP : using both Putty and Teraterm terminal emulators. I know the system is dead because my ssh sessions stopped

Re: [PATCH v2 10/11] powerpc/perf: add kconfig option for hypervisor provided counters

2014-02-14 Thread Cody P Schafer
On Fri, Feb 14, 2014 at 04:32:13PM -0600, Scott Wood wrote: On Fri, 2014-02-14 at 14:02 -0800, Cody P Schafer wrote: Signed-off-by: Cody P Schafer c...@linux.vnet.ibm.com --- arch/powerpc/perf/Makefile | 2 ++ arch/powerpc/platforms/Kconfig.cputype | 6 ++ 2 files

Re: [PATCH 1/6] PCI, acpiphp: Use list_for_each_entry() for bus traversal

2014-02-14 Thread Yijing Wang
Does it conflict with anything currently in linux-next (the linux-next branch of linux-pm.git in particular)? Hi Rafael, I applied this to your linux-next branch successfully . No conflicts found. Good. :-) Please feel free to add my ACK to it. Thanks very much!

Re: [PATCH 1/6] PCI, acpiphp: Use list_for_each_entry() for bus traversal

2014-02-14 Thread Yijing Wang
On 2014/2/15 2:23, Bjorn Helgaas wrote: On Thu, Feb 13, 2014 at 09:13:58PM +0800, Yijing Wang wrote: Replace list_for_each() + pci_bus_b() with the simpler list_for_each_entry(). Signed-off-by: Yijing Wang wangyij...@huawei.com I applied all six of these (please include a 0/6 cover letter

Re: [PATCH 2/2] of: search the best compatible match first in __of_match_node()

2014-02-14 Thread Stephen N Chivers
Rob Herring robherri...@gmail.com wrote on 02/15/2014 02:53:40 AM: From: Rob Herring robherri...@gmail.com To: Kevin Hao haoke...@gmail.com Cc: devicet...@vger.kernel.org devicet...@vger.kernel.org, linuxppc-dev linuxppc-dev@lists.ozlabs.org, Sebastian Hesselbarth