[PATCH] IBM Akebono: Remove obsolete config select

2014-05-02 Thread Alistair Popple
The original implementation of MMC support for Akebono introduced a new configuration symbol (MMC_SDHCI_OF_476GTR). This symbol has been dropped in favour of using the generic platform driver however the select for this symbol was mistakenly left in the platform configuration. This patch removes t

Re: [PATCH v2 1/4] KVM: PPC: e500mc: Revert "add load inst fixup"

2014-05-02 Thread Alexander Graf
On 05/01/2014 02:45 AM, Mihai Caraman wrote: The commit 1d628af7 "add load inst fixup" made an attempt to handle failures generated by reading the guest current instruction. The fixup code that was added works by chance hiding the real issue. Load external pid (lwepx) instruction, used by KVM to

Re: [PATCH v2 3/4] KVM: PPC: Alow kvmppc_get_last_inst() to fail

2014-05-02 Thread Alexander Graf
On 05/01/2014 02:45 AM, Mihai Caraman wrote: On book3e, guest last instruction was read on the exist path using load external pid (lwepx) dedicated instruction. lwepx failures have to be handled by KVM and this would require additional checks in DO_KVM hooks (beside MSR[GS] = 1). However extra ch

Re: [PATCH v2 4/4] KVM: PPC: Bookehv: Get vcpu's last instruction for emulation

2014-05-02 Thread Alexander Graf
On 05/01/2014 02:45 AM, Mihai Caraman wrote: On bookehv vcpu's last instruction is read using load external pid (lwepx) instruction. lwepx exceptions (DTLB_MISS, DSI and LRAT) need to be handled by KVM. These exceptions originate from host state (MSR[GS] = 0) which implies additional checks in DO

RE: [PATCH v2 4/4] KVM: PPC: Bookehv: Get vcpu's last instruction for emulation

2014-05-02 Thread David Laight
From: Alexander Graf ... > > + page = pfn_to_page(pfn); > > + eaddr = (unsigned long)kmap_atomic(page); > > + eaddr |= addr & ~PAGE_MASK; > > + *instr = *(u32 *)eaddr; > > + kunmap_atomic((u32 *)eaddr); > > I think I'd rather write this as > >*instr = *(u32 *)(eaddr | (addr & ~PAGE)

[PATCH] powerpc: Remove non-uapi linkage.h export

2014-05-02 Thread James Hogan
The arch/powerpc/include/asm/linkage.h is being unintentionally exported in the kernel headers since commit e1b5bb6d1236 (consolidate cond_syscall and SYSCALL_ALIAS declarations) when arch/powerpc/include/uapi/asm/linkage.h was deleted but the header-y not removed from the Kbuild file. This happens

Re: [PATCH v2 4/4] KVM: PPC: Bookehv: Get vcpu's last instruction for emulation

2014-05-02 Thread Alexander Graf
On 05/02/2014 12:12 PM, David Laight wrote: From: Alexander Graf ... + page = pfn_to_page(pfn); + eaddr = (unsigned long)kmap_atomic(page); + eaddr |= addr & ~PAGE_MASK; + *instr = *(u32 *)eaddr; + kunmap_atomic((u32 *)eaddr); I think I'd rather write this as

Re: [PATCH v2 4/4] KVM: PPC: Bookehv: Get vcpu's last instruction for emulation

2014-05-02 Thread Scott Wood
On Fri, 2014-05-02 at 13:10 +0200, Alexander Graf wrote: > On 05/02/2014 12:12 PM, David Laight wrote: > > You also probably want the page mapped uncached - no point polluting the > > data > > cache. We can't do that without creating an architecturally illegal alias between cacheable and non-cach

Re: Build regressions/improvements in v3.15-rc3

2014-05-02 Thread Geert Uytterhoeven
On Fri, May 2, 2014 at 5:41 PM, Geert Uytterhoeven wrote: > JFYI, when comparing v3.15-rc3[1] to v3.15-rc2[3], the summaries are: > - build errors: +5/-9 + /scratch/kisskb/src/arch/um/os-Linux/mem.c: error: 'TMPFS_MAGIC' undeclared (first use in this function): => 31 + /scratch/kisskb/src

Re: [PATCH v4 1/8] DMA: Freescale: remove the unnecessary FSL_DMA_LD_DEBUG

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:44PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > Some codes are calling chan_dbg with FSL_DMA_LD_DEBUG surrounded, it is really > unnecessary to use such a macro because chan_dbg is a wrapper of dev_dbg, we > do > have corresponding DEBUG macro

Re: [PATCH v4 3/8] DMA: Freescale: remove attribute DMA_INTERRUPT of dmaengine

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:46PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > Delete attribute DMA_INTERRUPT because fsldma doesn't support this function, > exception will be thrown if talitos is used to offload xor at the same time. > Applied, thanks -- ~Vinod _

Re: [PATCH v4 4/8] DMA: Freescale: add fsl_dma_free_descriptor() to reduce code duplication

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:47PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > There are several places where descriptors are freed using identical code. > This patch puts this code into a function to reduce code duplication. > Applied, thanks -- ~Vinod __

Re: [PATCH v4 2/8] DMA: Freescale: unify register access methods

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:45PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > Methods of accessing DMA controller registers are inconsistent, some registers > are accessed by DMA_IN/OUT directly, while others are accessed by functions > get/set_* which are wrappers of DMA_I

Re: [PATCH v4 6/8] DMA: Freescale: change descriptor release process for supporting async_tx

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:49PM +0800, hongbo.zh...@freescale.com wrote: This need review from Dan ... -- ~Vinod > From: Hongbo Zhang > > Fix the potential risk when enable config NET_DMA and ASYNC_TX. Async_tx is > lack of support in current release process of dma descriptor, all descripto

Re: [PATCH v4 7/8] DMA: Freescale: use spin_lock_bh instead of spin_lock_irqsave

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:50PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > The usage of spin_lock_irqsave() is a stronger locking mechanism than is > required throughout the driver. The minimum locking required should be used > instead. Interrupts will be turned off and

Re: [PATCH v4 5/8] DMA: Freescale: move functions to avoid forward declarations

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:48PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > These functions will be modified in the next patch in the series. By moving > the > function in a patch separate from the changes, it will make review easier. > Applied, thanks -- ~Vinod __

Re: [PATCH v4 8/8] DMA: Freescale: add suspend resume functions for DMA driver

2014-05-02 Thread Vinod Koul
On Fri, Apr 18, 2014 at 04:17:51PM +0800, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > This patch adds suspend resume functions for Freescale DMA driver. > .prepare callback is used to stop further descriptors from being added into > the > pending queue, and also issue pending queu

Re: [PATCH RFC v12 3/7] dma: mpc512x: add support for peripheral transfers

2014-05-02 Thread Vinod Koul
On Wed, Apr 23, 2014 at 05:53:25PM +0400, Alexander Popov wrote: > Introduce support for slave s/g transfer preparation and the associated > device control callback in the MPC512x DMA controller driver, which adds > support for data transfers between memory and peripheral I/O to the > previously su

Re: [PATCH RFC v12 5/7] dma: of: add common xlate function for matching by channel id

2014-05-02 Thread Vinod Koul
On Wed, Apr 23, 2014 at 05:53:27PM +0400, Alexander Popov wrote: > This patch adds a new common OF dma xlate callback function which will match a > channel by it's id. The binding expects one integer argument which it will > use to > lookup the channel by the id. > > Unlike of_dma_simple_xlate th

Re: [PATCH RFC v12 1/7] dma: mpc512x: reorder mpc8308 specific instructions

2014-05-02 Thread Vinod Koul
On Wed, Apr 23, 2014 at 05:53:23PM +0400, Alexander Popov wrote: > Concentrate the specific code for MPC8308 in the 'if' branch > and handle MPC512x in the 'else' branch. > This modification only reorders instructions but doesn't change behaviour. > > Signed-off-by: Alexander Popov > Acked-by: An

Re: [PATCH RFC v12 2/7] dma: mpc512x: separate 'compatible' values for MPC512x and MPC8308

2014-05-02 Thread Vinod Koul
On Wed, Apr 23, 2014 at 05:53:24PM +0400, Alexander Popov wrote: > MPC512x and MPC8308 have similar DMA controllers, but are independent SoCs. > DMA controller driver should have separate 'compatible' values for these SoCs. > > Signed-off-by: Alexander Popov Applied, thanks -- ~Vinod __

Re: [PATCH RFC v12 4/7] dma: mpc512x: fix freeing resources in mpc_dma_probe() and mpc_dma_remove()

2014-05-02 Thread Vinod Koul
On Wed, Apr 23, 2014 at 05:53:26PM +0400, Alexander Popov wrote: > Fix mpc_dma_probe() error path and mpc_dma_remove(): manually free IRQs and > dispose IRQ mappings before devm_* takes care of other resources. > Moreover replace devm_request_irq() with request_irq() since there is no need > to use

Re: [PATCH 1/1] powerpc: crtsaveres.o needed only when -Os flag is enabled

2014-05-02 Thread Ram Pai
On Fri, May 02, 2014 at 11:09:17AM +0530, Aneesh Kumar K.V wrote: > Ram Pai writes: > > > powerpc: crtsaveres.o needed only when -Os flag is enabled > > > > Currently on powerpc arch, out-of-tree module fails to build without > > crtsaveres.o, even when the module has no dependen

RE: [PATCH v2 1/4] KVM: PPC: e500mc: Revert "add load inst fixup"

2014-05-02 Thread mihai.cara...@freescale.com
> From: Alexander Graf > Sent: Friday, May 2, 2014 12:24 PM > To: Caraman Mihai Claudiu-B02008 > Cc: kvm-...@vger.kernel.org; k...@vger.kernel.org; > linuxppc-dev@lists.ozlabs.org > Subject: Re: [PATCH v2 1/4] KVM: PPC: e500mc: Revert "add load inst fixup" > > On 05/01/2014 02:45 AM, Mihai Caram

Re: powerpc/mpc85xx: Remove P1023 RDS support

2014-05-02 Thread Scott Wood
On Fri, Apr 18, 2014 at 12:18:00PM -0500, Lijun Pan wrote: > P1023RDS is no longer supported by Freescale while P1023RDB is still > supported. Please wrap changelogs at no more than 75 columns. > Signed-off-by: Lijun Pan > > --- > arch/powerpc/boot/dts/p1023rds.dts | 219 --

Re: powerpc/mpc85xx: Add BSC9132 QDS Support

2014-05-02 Thread Scott Wood
On Tue, Mar 18, 2014 at 01:05:02PM +0530, harninder rai wrote: > +&ifc { > + nor@0,0 { > + #address-cells = <1>; > + #size-cells = <1>; > + compatible = "cfi-flash"; > + reg = <0x0 0x0 0x800>; > + bank-width = <2>; > +

Re: powerpc/mpc85xx: Add BSC9132 QDS Support

2014-05-02 Thread Scott Wood
On Tue, Mar 18, 2014 at 01:05:02PM +0530, harninder rai wrote: > +&ifc { > + #address-cells = <2>; > + #size-cells = <1>; > + compatible = "fsl,ifc", "simple-bus"; > + /* FIXME: Test whether interrupts are split */ > + interrupts = <16 2 0 0 20 2 0 0>; > +}; Have you done this

Re: powerpc/mpc85xx: Remove P1023 RDS support

2014-05-02 Thread Emil Medve
Hello Scott, On 05/02/2014 07:13 PM, Scott Wood wrote: > On Fri, Apr 18, 2014 at 12:18:00PM -0500, Lijun Pan wrote: >> P1023RDS is no longer supported by Freescale while P1023RDB is still >> supported. > > Please wrap changelogs at no more than 75 columns. > >> Signed-off-by: Lijun Pan >> >>