Re: [PATCH v2 00/14] Add support for parameterized events from sysfs

2014-08-22 Thread Sukadev Bhattiprolu
Jiri Olsa [jo...@redhat.com] wrote: | > Description of the sysfs contents when events are parameterized (copied from an | > included patch): | > | > Examples: | > | > domain=0x1,offset=0x8,starting_index=phys_cpu | > | > In the case of the last example, a value replacing "

Re: [RFC PATCH powerpc] Fix warning reported by verify_cpu_node_mapping()

2014-08-22 Thread Nishanth Aravamudan
On 22.08.2014 [10:12:56 +0800], Li Zhong wrote: > On ???, 2014-08-21 at 08:45 -0700, Nishanth Aravamudan wrote: > > On 21.08.2014 [16:14:02 +0800], Li Zhong wrote: > > > With commit 2fabf084b, during boottime, cpu_numa_callback() is called > > > earlier(before their online) for each cpu, and verify

Re: [RFC PATCH v3 1/4] topology: add support for node_to_mem_node() to determine the fallback node

2014-08-22 Thread Nishanth Aravamudan
Hi Christoph, On 14.08.2014 [13:06:56 -0700], Nishanth Aravamudan wrote: > On 14.08.2014 [09:35:37 -0500], Christoph Lameter wrote: > > On Wed, 13 Aug 2014, Nishanth Aravamudan wrote: > > > > > +++ b/include/linux/topology.h > > > @@ -119,11 +119,20 @@ static inline int numa_node_id(void) > > >

Re: [RFC PATCH 0/4] Improve slab consumption with memoryless nodes

2014-08-22 Thread Andrew Morton
On Thu, 21 Aug 2014 18:10:11 -0700 Nishanth Aravamudan wrote: > I know kernel summit is going on, so I'll be patient, but was just > curious if anyone had any further comments other than Christoph's on the > naming. Nope. Please make a decision on the naming, refresh, retest and resend and I'l

Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X regression

2014-08-22 Thread Scott Wood
On Fri, 2014-08-22 at 14:00 -0500, Aaron Sierra wrote: > - Original Message - > > From: "Scott Wood" > > To: "Aaron Sierra" > > Cc: linuxppc-dev@lists.ozlabs.org, "Minghuan Lian" > > > > Sent: Friday, August 22, 2014 1:36:31 PM > > Subject: Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X re

Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X regression

2014-08-22 Thread Aaron Sierra
- Original Message - > From: "Scott Wood" > To: "Aaron Sierra" > Cc: linuxppc-dev@lists.ozlabs.org, "Minghuan Lian" > > Sent: Friday, August 22, 2014 1:36:31 PM > Subject: Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X regression > > On Fri, 2014-08-22 at 12:54 -0500, Aaron Sierra wrote:

[PATCH 3/5] kexec: Add bit definitions for kimage entry flags

2014-08-22 Thread Geoff Levand
Define new kexec preprocessor macros IND_*_BIT that define the bit position of the kimage entry flags. Change the existing IND_* flag macros to be defined as bit shifts of the corresponding IND_*_BIT macros. Also wrap all C language code in kexec.h with #if !defined(__ASSEMBLY__) so assembly file

[PATCH 4/5] kexec: Add IND_FLAGS macro

2014-08-22 Thread Geoff Levand
Add a new kexec preprocessor macro IND_FLAGS, which is the bitwise OR of all the possible kexec IND_ kimage_entry indirection flags. Having this macro allows for simplified code in the prosessing of the kexec kimage_entry items. Signed-off-by: Geoff Levand --- include/linux/kexec.h | 1 + 1 fil

[PATCH 2/5] kexec: Simplify conditional

2014-08-22 Thread Geoff Levand
Simplify the code around one of the conditionals in the kexec_load syscall routine. The original code was confusing with a redundant check on KEXEC_ON_CRASH and comments outside of the conditional block. This change switches the order of the conditional check, and cleans up the comments for the c

[PATCH 5/5] powerpc/kexec: Use global IND_FLAGS macro

2014-08-22 Thread Geoff Levand
linux/kexec.h now defines an IND_FLAGS macro. Remove the local powerpc definition and use the generic one. Signed-off-by: Geoff Levand --- arch/powerpc/kernel/machine_kexec_64.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/arch/powerpc/kernel/machine_kexec_64.c b/arch/powerpc/kernel/ma

[PATCH 0/5] kexec: minor fixups and enhancements

2014-08-22 Thread Geoff Levand
Hi, Here are a few minor fixups and enhancements for kexec support. Patch 3 and 4 that add preprocessor macros for the kimage list flags are ones that I use in the arm64 kexec support I am working on, so it would be nice for those to go in. Please consider. -Geoff The following changes si

[PATCH 1/5] kexec: Fix make headers_check

2014-08-22 Thread Geoff Levand
Remove the unneded declaration for a kexec_load() routine. Fixes errors like these when running 'make headers_check': include/uapi/linux/kexec.h: userspace cannot reference function or variable defined in the kernel Signed-off-by: Geoff Levand --- include/uapi/linux/kexec.h | 6 -- 1 file

Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X regression

2014-08-22 Thread Scott Wood
On Fri, 2014-08-22 at 12:54 -0500, Aaron Sierra wrote: > - Original Message - > > From: "Scott Wood" > > Sent: Thursday, August 21, 2014 5:01:46 PM > > > > On Thu, 2014-08-21 at 16:54 -0500, Aaron Sierra wrote: > > > - Original Message - > > > > From: "Scott Wood" > > > > Sent: T

Re: [PATCH] ibmveth: Fix endian issues with rx_no_buffer statistic

2014-08-22 Thread David Miller
From: Anton Blanchard Date: Fri, 22 Aug 2014 11:36:52 +1000 > Hidden away in the last 8 bytes of the buffer_list page is a solitary > statistic. It needs to be byte swapped or else ethtool -S will > produce numbers that terrify the user. > > Since we do this in multiple places, create a helper f

Re: [PATCH] powerpc: fsl_pci: Fix PCI/PCI-X regression

2014-08-22 Thread Aaron Sierra
- Original Message - > From: "Scott Wood" > Sent: Thursday, August 21, 2014 5:01:46 PM > > On Thu, 2014-08-21 at 16:54 -0500, Aaron Sierra wrote: > > - Original Message - > > > From: "Scott Wood" > > > Sent: Thursday, August 21, 2014 4:19:56 PM > > > > > > On Wed, 2014-08-20 at

Re: [PATCH 2/2] fsl_ifc: Support all 8 IFC chip selects

2014-08-22 Thread Scott Wood
On Fri, 2014-08-22 at 20:07 +0530, Prabhakar Kushwaha wrote: > Sorry Scott for late reply, > > Please find my reply in-lined > > > On 8/21/2014 4:51 AM, Scott Wood wrote: > > On Wed, 2014-08-20 at 09:05 +0530, Prabhakar Kushwaha wrote: > >> On 8/20/2014 5:38 AM, Scott Wood wrote: > >>> On Fri, 2

Re: [PATCH 4/4] powerpc: Move htab_remove_mapping function prototype into header file

2014-08-22 Thread Stephen Rothwell
Hi Anton, On Wed, 20 Aug 2014 08:55:21 +1000 Anton Blanchard wrote: > > A recent patch added a function prototype for htab_remove_mapping in > c code. Fix it. > > Signed-off-by: Anton Blanchard > --- > arch/powerpc/include/asm/mmu-hash64.h | 2 ++ > arch/powerpc/mm/init_64.c | 3 --

Re: [PATCH 6/6] powerpc: Separate ppc32 symbol exports into ppc_ksyms_32.c

2014-08-22 Thread Stephen Rothwell
Hi Anton, On Wed, 20 Aug 2014 08:00:05 +1000 Anton Blanchard wrote: > > diff --git a/arch/powerpc/kernel/ppc_ksyms.c b/arch/powerpc/kernel/ppc_ksyms.c > index aba41f3..c4dfff6 100644 > --- a/arch/powerpc/kernel/ppc_ksyms.c > +++ b/arch/powerpc/kernel/ppc_ksyms.c > @@ -1,135 +1,42 @@ > -#include

Re: [PATCH 2/2] fsl_ifc: Support all 8 IFC chip selects

2014-08-22 Thread Prabhakar Kushwaha
Sorry Scott for late reply, Please find my reply in-lined On 8/21/2014 4:51 AM, Scott Wood wrote: On Wed, 2014-08-20 at 09:05 +0530, Prabhakar Kushwaha wrote: On 8/20/2014 5:38 AM, Scott Wood wrote: On Fri, 2014-08-15 at 16:07 -0500, Aaron Sierra wrote: Freescale's QorIQ T Series processors

[RESEND] clk: ppc-corenet: Add Freescale ARM-based platforms CLK_OF_DECLARE support

2014-08-22 Thread Jingchang Lu
Signed-off-by: Jingchang Lu --- drivers/clk/Kconfig | 7 --- drivers/clk/clk-ppc-corenet.c | 5 + 2 files changed, 9 insertions(+), 3 deletions(-) diff --git a/drivers/clk/Kconfig b/drivers/clk/Kconfig index cfd3af7..8784704 100644 --- a/drivers/clk/Kconfig +++ b/drivers/clk/Kc

Re: [RFC PATCH 5/6] rtc: rtc-isl12022: Change vendor prefix for Intersil Corporation to isil

2014-08-22 Thread Philipp Zabel
Am Mittwoch, den 20.08.2014, 10:43 +0200 schrieb Philipp Zabel: > Currently there is a wild mixture of isl, isil, and intersil > compatibles in the kernel. At this point, changing the vendor > symbol to the most often used variant, which is equal to the > NASDAQ symbol, isil, should not hurt, since

[PATCH v2 5/5] MSI: Use __read_msi_msg() instead of read_msi_msg()

2014-08-22 Thread Yijing Wang
Read_msi_msg() only be called in rtas_setup_msi_irqs(), use __read_msi_msg() instead of read_msi_msg for simplification. And rename __read_msi_msg() to read_msi_msg(). Signed-off-by: Yijing Wang CC: Benjamin Herrenschmidt CC: linuxppc-dev@lists.ozlabs.org --- arch/powerpc/platforms/pseries/msi.