RE: [PATCH] powerpc/fsl: Add FMan best effort port compatible

2015-05-21 Thread Madalin-Cristian Bucur
-Original Message- From: Wood Scott-B07421 The compatible string should describe what programming interface is present. Other information should be in other properties. Having the same compatible for tx and rx definitely seems wrong. -Scott Hi Scott, what we tried to

[PATCH] book3s_hv_rmhandlers:Pass the correct trap argument to kvmhv_commence_exit

2015-05-21 Thread Gautham R. Shenoy
In guest_exit_cont we call kvmhv_commence_exit which expects the trap number as the argument. However r3 doesn't contain the trap number at this point and as a result we would be calling the function with a spurious trap number. Fix this by copying r12 into r3 before calling kvmhv_commence_exit

[PATCH RESEND v7 2/2] mmc: host: sdhci: Add support to disable SDR104/SDR50/DDR50 based on capability register 0.

2015-05-21 Thread Suman Tripathi
The sdhci framework disables SDR104/SDR50/DDR50 based on only quirk. This patch adds the support to disable SDR104/SDR50/DDR50 based on reading the capability register 0. Signed-off-by: Suman Tripathi stripa...@apm.com --- --- drivers/mmc/host/sdhci.c | 3 ++- 1 file changed, 2 insertions(+), 1

[PATCH RESEND v7 1/2] arm64: dts: Add the arasan mmc nodes in apm-storm.dtsi

2015-05-21 Thread Suman Tripathi
This patch adds the arasan mmc nodes to reuse the of-arasan driver for APM X-Gene SoC. Signed-off-by: Suman Tripathi stripa...@apm.com --- --- arch/arm64/boot/dts/apm/apm-mustang.dts | 4 +++ arch/arm64/boot/dts/apm/apm-storm.dtsi | 43 + 2 files changed, 47

[PATCH RESEND v7 0/2] Add SDHCI support for APM X-Gene SoC using ARASAN SDHCI controller.

2015-05-21 Thread Suman Tripathi
This patch adds the SDHCI support for APM X-Gene SoC using ARASAN SDHCI controller. v1 change: * Use the CONFIG_ARM64_DMA_HAS_IOMMU for dma-mapping. v2 change: * Drop the IOMMU support and switching to PIO mode for arasan. controller integrated inside APM X-Gene SoC. v3 change: * Change

[PATCH v5] cxl: Export AFU error buffer via sysfs

2015-05-21 Thread Vaibhav Jain
Export the AFU Error Buffer via sysfs attribute (afu_err_buf). AFU error buffer is used by the AFU to report application specific errors. The contents of this buffer are AFU specific and are intended to be interpreted by the application interacting with the afu. Testing: - Build against

Re: [PATCH] drivers/mtd: add powernv flash MTD abstraction driver

2015-05-21 Thread Cyril Bur
On Wed, 2015-05-20 at 14:17 -0700, Brian Norris wrote: You might run this through checkpatch, as it caught several small things. Hi Brian, Oops, sorry absolutely should have done checkpatch! Thanks for the review, everything you've said is great, I've addressed all that - I'll post a v2.

[PATCH V5 01/13] powerpc: Fix handling of DSCR related facility unavailable exception

2015-05-21 Thread Anshuman Khandual
Currently DSCR (Data Stream Control Register) can be accessed with mfspr or mtspr instructions inside a thread via two different SPR numbers. One being the user accessible problem state SPR number 0x03 and the other being the privilege state SPR number 0x11. All access through the privilege state

[PATCH V5 07/13] selftests, powerpc: Add test for explicitly changing DSCR value

2015-05-21 Thread Anshuman Khandual
This patch adds a test which modifies the DSCR using mtspr instruction and verifies the change using mfspr instruction. It uses both the privilege state SPR as well as the problem state SPR for the purpose. Acked-by: Shuah Khan shua...@osg.samsung.com Signed-off-by: Anshuman Khandual

[PATCH V5 12/13] selftests, powerpc: Add thread based stress test for DSCR sysfs interfaces

2015-05-21 Thread Anshuman Khandual
This patch adds a test to update the system wide DSCR value repeatedly and then verifies that any thread on any given CPU on the system must be able to see the same DSCR value whether its is being read through the problem state based SPR or the privilege state based SPR. Acked-by: Shuah Khan

[PATCH V5 08/13] selftests, powerpc: Add test for DSCR SPR numbers

2015-05-21 Thread Anshuman Khandual
This patch adds a test which verifies that the DSCR privilege and problem state SPR read write accesses while making sure that the results are always the same irrespective of which SPR number is being used. Acked-by: Shuah Khan shua...@osg.samsung.com Signed-off-by: Anshuman Khandual

[PATCH V5 10/13] selftests, powerpc: Add test for DSCR inheritence across fork exec

2015-05-21 Thread Anshuman Khandual
This patch adds a test case to verify that the changed DSCR value inside any process would be inherited to it's child across the fork and exec system call. Acked-by: Shuah Khan shua...@osg.samsung.com Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com Signed-off-by: Anton Blanchard

[PATCH V5 02/13] powerpc, process: Remove the unused extern dscr_default

2015-05-21 Thread Anshuman Khandual
The process context switch code no longer uses dscr_default variable from the sysfs.c file. The variable became unused when we started storing the CPU specific DSCR value in the PACA structure instead. This patch just removes this extern declaration. It was originally added by the following

[PATCH V5 03/13] powerpc, offset: Change PACA_DSCR to PACA_DSCR_DEFAULT

2015-05-21 Thread Anshuman Khandual
PACA_DSCR offset macro tracks dscr_default element in the paca structure. Better change the name of this macro to match that of the data element it tracks. Makes the code more readable. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- arch/powerpc/kernel/asm-offsets.c | 2

[PATCH V5 00/13] POWER DSCR fixes, improvements, docs and tests

2015-05-21 Thread Anshuman Khandual
This patch series has patches for POWER DSCR fixes, improvements, in code documentaion, kernel support user documentation and selftest based test cases. It has got five test cases which are derived from Anton's DSCR test bucket which can be listed as follows. (1)

[PATCH V5 09/13] selftests, powerpc: Add test for DSCR value inheritence across fork

2015-05-21 Thread Anshuman Khandual
This patch adds a test to verify that the changed DSCR value inside any process would be inherited to it's child process across the fork system call. Acked-by: Shuah Khan shua...@osg.samsung.com Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com Signed-off-by: Anton Blanchard

[PATCH V5 13/13] selftests, powerpc: Add gitignore file for the new DSCR tests

2015-05-21 Thread Anshuman Khandual
This patch adds .gitignore for all the newly added DSCR tests. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- tools/testing/selftests/powerpc/dscr/.gitignore | 7 +++ 1 file changed, 7 insertions(+) create mode 100644 tools/testing/selftests/powerpc/dscr/.gitignore diff

[PATCH V5 04/13] powerpc, dscr: Added some in-code documentation

2015-05-21 Thread Anshuman Khandual
This patch adds some in-code documentation to the DSCR related code to make it more readable without having any functional change to it. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- arch/powerpc/include/asm/processor.h | 9 + arch/powerpc/kernel/sysfs.c | 38

[PATCH V5 11/13] selftests, powerpc: Add test for all DSCR sysfs interfaces

2015-05-21 Thread Anshuman Khandual
This test continuously updates the system wide DSCR default value in the sysfs interface and makes sure that the same is reflected across all the sysfs interfaces for each individual CPUs present on the system. Acked-by: Shuah Khan shua...@osg.samsung.com Signed-off-by: Anshuman Khandual

[PATCH V5 06/13] selftests, powerpc: Add test for system wide DSCR default

2015-05-21 Thread Anshuman Khandual
This patch adds a test case for the system wide DSCR default value, which when changed through it's sysfs interface must be visible to all threads reading DSCR either through the privilege state SPR or the problem state SPR. The DSCR value change should be immediate as well. Acked-by: Shuah Khan

[PATCH V5 05/13] documentation, powerpc: Add documentation for DSCR support

2015-05-21 Thread Anshuman Khandual
This patch adds a new documentation file explaining the DSCR support on powerpc platforms. This explains DSCR related data structure, code paths and also available user interfaces. Any further functional changes to the DSCR support in the kernel should definitely update the documentation here.

Re: [PATCH V5 2/3] powerpc/mm: Use generic version of pmdp_clear_flush

2015-05-21 Thread Aneesh Kumar K.V
Andrew Morton a...@linux-foundation.org writes: On Fri, 15 May 2015 21:12:29 +0530 Aneesh Kumar K.V aneesh.ku...@linux.vnet.ibm.com wrote: Also move the pmd_trans_huge check to generic code. ... --- a/include/asm-generic/pgtable.h +++ b/include/asm-generic/pgtable.h @@ -196,7 +196,12

Re: [PATCH 19/19] cxl: Add AFU virtual PHB and kernel API

2015-05-21 Thread Ian Munsie
Hi Mikey, +/* wrappers around afu_* file ops which are EXPORTED */ This is fine, though alternatively you could export the original functions directly from file.c (feel free to rename them to your versions if you do change it) - I don't really mind either way :) +static void

Re: [PATCH 05/19] cxl: Document external user of existing API

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 06/19] cxl: Add shutdown hook

2015-05-21 Thread Ian Munsie
Looks like a good change to make sure the PSL AFU is not still active across a reboot :) Wondering if this should be Cc: Stable - has there been any demonstrable stability increase after a reboot with this? Acked-by: Ian Munsie imun...@au1.ibm.com Excerpts from Michael Neuling's message of

Re: [PATCH 08/19] cxl: Dump debug info on the AFU configuration record

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 10/19] cxl: Rework detach context functions

2015-05-21 Thread Ian Munsie
Hooray, one previously useless level of indirection now has a purpose :) Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 12/19] cxl: Export some symbols

2015-05-21 Thread Ian Munsie
+void assign_psn_space(struct cxl_context *ctx); Should we consider renaming this to cxl_assign_psn_space to namespace it now that it's potentially callable from elsewhere in the kernel? +int afu_check_and_enable(struct cxl_afu *afu); Likewise? Acked-by: Ian Munsie imun...@au1.ibm.com -Ian

Re: [PATCH 14/19] cxl: Split afu_register_irqs() function

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 17/19] cxl: Move include file cxl.h - cxl-base.h

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 16/19] cxl: Cleanup Makefile

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 18/19] cxl: Export file ops for use by API

2015-05-21 Thread Ian Munsie
Like I mentioned in the other patch - I would also be happy if these were renamed to suit the api and exported directly from file.c. The prototypes can all be in the new header for the api. But that's minor - if you want to keep them as they are in your patch I'm fine with that too :) Acked-by:

Re: [PATCH 01/19] powerpc/copro: Fix faulting kernel segments

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 07/19] cxl: Re-order card init to check the VSEC earlier

2015-05-21 Thread Ian Munsie
I think this is missing the From line to indicate I wrote it ;) Otherwise... Acked-by: Ian Munsie imun...@au1.ibm.com ;-) ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 09/19] cxl: Add cookie parameter to afu_release_irqs()

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 11/19] cxl: cxl_afu_reset() - __cxl_afu_reset()

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 13/19] cxl: Only check pid for userspace contexts

2015-05-21 Thread Ian Munsie
Acked-by: Ian Munsie imun...@au1.ibm.com ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 15/19] cxl: Configure PSL for kernel contexts

2015-05-21 Thread Ian Munsie
Excerpts from Michael Neuling's message of 2015-05-19 21:22:32 +1000: +if (ctx-kernel) { +sr |= CXL_PSL_SR_An_R | (mfmsr() MSR_SF) | CXL_PSL_SR_An_HV; +pid = 0; +} else { +sr |= CXL_PSL_SR_An_PR | CXL_PSL_SR_An_R; CXL_PSL_SR_An_R is common between these two

Re: [PATCH 3/4] perf: Use pmu_events_map table to create event aliases

2015-05-21 Thread Andi Kleen
On Wed, May 20, 2015 at 10:02:04PM -0700, Sukadev Bhattiprolu wrote: Andi Kleen [a...@linux.intel.com] wrote: | If you need something else in vfm to identify the CPU | can't you just add it there? I wouldn't really call it vfm, it's | really a abstract cpu identifier per architecture. So if

[PATCH trivial] ASoC: fsl_esai: Spelling s/specifially/specifically/

2015-05-21 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven geert+rene...@glider.be --- sound/soc/fsl/fsl_esai.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/fsl/fsl_esai.c b/sound/soc/fsl/fsl_esai.c index 5c7597191e3ffc68..45eee131c47d43cd 100644 --- a/sound/soc/fsl/fsl_esai.c +++

Re: [PATCH 3/3 v2] powerpc/powernv: Add opal-prd channel

2015-05-21 Thread Stewart Smith
Jeremy Kerr j...@ozlabs.org writes: This change adds a char device to access the PRD (processor runtime diagnostics) channel to OPAL firmware. Includes contributions from Vaidyanathan Srinivasan, Neelesh Gupta Vishal Kulkarni. Signed-off-by: Neelesh Gupta neele...@linux.vnet.ibm.com

Re: [v5] cxl: Export AFU error buffer via sysfs

2015-05-21 Thread Michael Ellerman
On Thu, 2015-21-05 at 08:05:30 UTC, Vaibhav Jain wrote: Export the AFU Error Buffer via sysfs attribute (afu_err_buf). AFU error buffer is used by the AFU to report application specific errors. The contents of this buffer are AFU specific and are intended to be interpreted by the application

[PATCH v2] powerpc/85xx: p1025twr: add module conditional to fix QE-uart issue

2015-05-21 Thread Pengbo Li
From: Xie Xiaobo x@freescale.com A ioport setting was needed when used the QE uart function on TWR-P1025. Added a conditional definition to avoid missing this setting when the QE-uart driver was bulit to a module. Signed-off-by: Xie Xiaobo x@freescale.com Signed-off-by: Li Pengbo

[PATCH V6 0/3] THP related code cleanup

2015-05-21 Thread Aneesh Kumar K.V
Changes from v5: * Fix build failure on x86 with thp enabled. * Tested on x86_64, ppc64. Aneesh Kumar K.V (3): mm/thp: Split out pmd collpase flush into a separate functions powerpc/mm: Use generic version of pmdp_clear_flush mm: Clarify that the function operates on hugepage pte

[PATCH V6 1/3] mm/thp: Split out pmd collpase flush into a separate functions

2015-05-21 Thread Aneesh Kumar K.V
Architectures like ppc64 [1] need to do special things while clearing pmd before a collapse. For them this operation is largely different from a normal hugepage pte clear. Hence add a separate function to clear pmd before collapse. After this patch pmdp_* functions operate only on hugepage pte,

[PATCH V6 2/3] powerpc/mm: Use generic version of pmdp_clear_flush

2015-05-21 Thread Aneesh Kumar K.V
Also move the pmd_trans_huge check to generic code. Acked-by: Kirill A. Shutemov kirill.shute...@linux.intel.com Signed-off-by: Aneesh Kumar K.V aneesh.ku...@linux.vnet.ibm.com --- arch/powerpc/include/asm/pgtable-ppc64.h | 4 arch/powerpc/mm/pgtable_64.c | 11 ---

[PATCH V6 3/3] mm: Clarify that the function operates on hugepage pte

2015-05-21 Thread Aneesh Kumar K.V
We have confusing functions to clear pmd, pmd_clear_* and pmd_clear. Add _huge_ to pmdp_clear functions so that we are clear that they operate on hugepage pte. We don't bother about other functions like pmdp_set_wrprotect, pmdp_clear_flush_young, because they operate on PTE bits and hence

Re: [PATCH 07/19] cxl: Re-order card init to check the VSEC earlier

2015-05-21 Thread Michael Neuling
On Thu, 2015-05-21 at 19:09 +1000, Ian Munsie wrote: I think this is missing the From line to indicate I wrote it ;) Oops, yeah, although you could just change your name and that would also fix the problem. Mikey Otherwise... Acked-by: Ian Munsie imun...@au1.ibm.com ;-)

[PATCH v6] cxl: Export AFU error buffer via sysfs

2015-05-21 Thread Vaibhav Jain
Export the AFU Error Buffer via sysfs attribute (afu_err_buf). AFU error buffer is used by the AFU to report application specific errors. The contents of this buffer are AFU specific and are intended to be interpreted by the application interacting with the afu. Testing: - Build against

Re: [PATCH 15/19] cxl: Configure PSL for kernel contexts

2015-05-21 Thread Michael Neuling
On Thu, 2015-05-21 at 19:32 +1000, Ian Munsie wrote: Excerpts from Michael Neuling's message of 2015-05-19 21:22:32 +1000: +if (ctx-kernel) { +sr |= CXL_PSL_SR_An_R | (mfmsr() MSR_SF) | CXL_PSL_SR_An_HV; +pid = 0; +} else { +sr |= CXL_PSL_SR_An_PR |