[PATCH V11 05/10] powerpc/perf: Change the name of HW PMU branch filter tracking variable

2015-10-05 Thread Anshuman Khandual
This patch simply changes the name of the variable from 'bhrb_filter' to 'bhrb_hw_filter' in order to add one more variable which will track SW filters in generic powerpc book3s code which will be implemented in the subsequent patch. This patch does not change any functionality. Signed-off-by: Ans

[PATCH V11 09/10] powerpc/perf: Enable privilege mode SW branch filters

2015-10-05 Thread Anshuman Khandual
This patch enables privilege mode SW branch filters. Also modifies POWER8 PMU branch filter configuration so that the privilege mode branch filter implemented as part of base PMU event configuration is reflected in bhrb filter mask. As a result, the SW will skip and not try to process the privilege

[PATCH V11 08/10] powerpc/perf: Change POWER8 PMU configuration to work with SW filters

2015-10-05 Thread Anshuman Khandual
The kernel now supports SW based branch filters for book3s systems with some specific requirements while dealing with HW supported branch filters in order to achieve overall OR semantics prevailing in perf branch stack sampling framework. This patch adapts the BHRB branch filter configuration to me

[PATCH V11 03/10] powerpc/perf: Restore privilege level filter support for BHRB

2015-10-05 Thread Anshuman Khandual
'commit 9de5cb0f6df8 ("powerpc/perf: Add per-event excludes on Power8")' broke the PMU based BHRB privilege level filter. BHRB depends on the same MMCR0 bits for privilege level filter which was used to freeze all the PMCs as a group. Once we moved to individual event based privilege filters throug

[PATCH V11 10/10] selftests/powerpc: Add test for BHRB branch filters (HW & SW)

2015-10-05 Thread Anshuman Khandual
This patch adds a test for verifying that all the branch stack sampling filters supported on powerpc work correctly. It also adds some assembly helper functions in this regard. This patch extends the generic event description to handle kernel mapped ring buffers. Signed-off-by: Anshuman Khandual

[PATCH V11 06/10] powerpc/lib: Add new branch analysis support functions

2015-10-05 Thread Anshuman Khandual
Generic powerpc branch analysis support added in the code patching library which will help the subsequent patch on SW based filtering of branch records in perf. Signed-off-by: Anshuman Khandual --- arch/powerpc/include/asm/code-patching.h | 15 arch/powerpc/lib/code-patching.c |

[PATCH V11 04/10] powerpc/perf: Re organize BHRB processing

2015-10-05 Thread Anshuman Khandual
This patch cleans up some existing indentation problem in code and re organizes the BHRB processing code with an helper function named 'update_branch_entry' making it more readable. This patch does not change any functionality. Signed-off-by: Anshuman Khandual --- arch/powerpc/perf/core-book3s.c

[PATCH V11 02/10] powerpc/perf: Re organize PMU branch filter processing on POWER8

2015-10-05 Thread Anshuman Khandual
This patch does some code re-arrangements to make it clear that kernel ignores any separate privilege level branch filter request and does not support any combinations of HW PMU branch filters. Signed-off-by: Anshuman Khandual --- arch/powerpc/perf/power8-pmu.c | 22 +++--- 1 fil

[PATCH V11 01/10] powerpc/perf: Change name & type of 'pred' in power_pmu_bhrb_read

2015-10-05 Thread Anshuman Khandual
Branch record attributes 'mispred' and 'predicted' are single bit fields as defined in the perf ABI. Hence the data type of the field 'pred' used during BHRB processing should be changed from integer to bool. This patch also changes the name of the variable from 'pred' to 'mispred' making the logic

[PATCH V11 07/10] powerpc/perf: Enable SW filtering in branch stack sampling framework

2015-10-05 Thread Anshuman Khandual
This patch enables SW based post processing of BHRB captured branches to be able to meet more user defined branch filtration criteria in perf branch stack sampling framework. These changes increase the number of branch filters and their valid combinations on any powerpc64 server platform with BHRB

[PATCH V11 00/10] powerpc/perf: Enable SW branch filters

2015-10-05 Thread Anshuman Khandual
This is the continuation (rebased and reworked) of the series posted at https://lkml.org/lkml/2014/5/5/153 (which is V6). I remember to have incremented the version count for the re-send of the first four patches of the series to Peter Z for generic review which got pulled in last year. The

Re: Time to remove platforms/cell?

2015-10-05 Thread Marc Dietrich
Hi Geoff, Am Sonntag, 4. Oktober 2015, 12:27:19 schrieb Geoff Levand: > Hi, > > On Thu, 2015-09-17 at 12:28 +0200, Marc Dietrich wrote: > > well, I like to but I couldn't get the kernel booting for some reason. > > Still trying. > > I just tested the ps3-queue branch (v4.3-rc4 based) of my ps3-l

Re: [RFC v2 4/7] powerpc: atomic: Implement xchg_* and atomic{,64}_xchg_* variants

2015-10-05 Thread Will Deacon
On Thu, Oct 01, 2015 at 07:03:01PM +0100, Paul E. McKenney wrote: > On Thu, Oct 01, 2015 at 07:13:04PM +0200, Peter Zijlstra wrote: > > On Thu, Oct 01, 2015 at 08:09:09AM -0700, Paul E. McKenney wrote: > > > On Thu, Oct 01, 2015 at 02:24:40PM +0200, Peter Zijlstra wrote: > > > > > > I must say I'm

Re: [PATCH v2] cpufreq : powernv: Report Pmax throttling if capped below nominal frequency

2015-10-05 Thread Rafael J. Wysocki
On Monday, September 14, 2015 03:58:09 PM Viresh Kumar wrote: > On 14-09-15, 14:01, Shilpasri G Bhat wrote: > > Log a 'critical' message if the max frequency is reduced below nominal > > frequency. We already log 'info' message if the max frequency is > > capped below turbo frequency. CPU should gu

Re: [PATCH v3 1/3] powerpc/512x: add LocalPlus Bus FIFO device driver

2015-10-05 Thread Alexander Popov
On 01.10.2015 20:11, Timur Tabi wrote: > On 09/30/2015 04:24 PM, Alexander Popov wrote: >>> Driver code that has to parse #address-cells or #size-cells >>> is usually wrong. >> >> I would not call it "parsing", I just check whether the dts-file is good. >> Anyway, could you give me a clue how to do

Re: [PATCH 4/5] kernel/cpu.c: eliminate cpu_*_mask

2015-10-05 Thread Rasmus Villemoes
Hi PPC maintainers Can I get you to ack or nak this? It's a prerequisite for a minor patch series for kernel/cpu.c and include/linux/cpumask.h of mine. Thanks, Rasmus On Mon, Sep 28 2015, Rasmus Villemoes wrote: > Gah, I didn't check for struct members called cpu_online_mask :( > > PPC people:

Re: [PATCH] cxl: Fix number of allocated pages in SPA

2015-10-05 Thread Ian Munsie
Acked-by: Ian Munsie Excerpts from Christophe Lombard's message of 2015-10-03 00:01:25 +1000: > This moves the initialisation of the num_procs to before the SPA > allocation. > > Signed-off-by: Christophe Lombard > --- > drivers/misc/cxl/native.c | 2 +- > 1 file changed, 1 insertion(+), 1 del

Re: Missing operand for tlbie instruction on Power7

2015-10-05 Thread Laura Abbott
On 10/03/2015 05:00 PM, Segher Boessenkool wrote: On Fri, Oct 02, 2015 at 09:24:46PM -0500, Peter Bergner wrote: Ok, than we can just zero out r5 for example and use it in tlbie as RS, right? That won't assemble _unless_ your assembler is in POWER7 mode. It also won't do the right thing at ru

Re: [RFC v2 4/7] powerpc: atomic: Implement xchg_* and atomic{,64}_xchg_* variants

2015-10-05 Thread Paul E. McKenney
On Mon, Oct 05, 2015 at 03:44:07PM +0100, Will Deacon wrote: > On Thu, Oct 01, 2015 at 07:03:01PM +0100, Paul E. McKenney wrote: > > On Thu, Oct 01, 2015 at 07:13:04PM +0200, Peter Zijlstra wrote: > > > On Thu, Oct 01, 2015 at 08:09:09AM -0700, Paul E. McKenney wrote: > > > > On Thu, Oct 01, 2015 a

Re: [PATCH 1/2] powerpc/iommu: expose IOMMU page shift

2015-10-05 Thread David Gibson
On Fri, Oct 02, 2015 at 10:18:00AM -0700, Nishanth Aravamudan wrote: > We will leverage this macro in the NVMe driver, which needs to know the > configured IOMMU page shift to properly configure its device's page > size. > > Signed-off-by: Nishanth Aravamudan > > --- > Given this is available, i

Re: Missing operand for tlbie instruction on Power7

2015-10-05 Thread Michael Ellerman
On Fri, 2015-10-02 at 08:43 -0700, Laura Abbott wrote: > Hi, > > We received a report (https://bugzilla.redhat.com/show_bug.cgi?id=1267395) of > bad assembly > when compiling on powerpc with little endian ... > After some discussion with the binutils folks, it turns out that the tlbie > instruc

Re: [PATCH 4/5 v2] pseries/iommu: implement DDW-aware dma_get_page_shift

2015-10-05 Thread Michael Ellerman
On Sat, 2015-10-03 at 04:33 +0800, kbuild test robot wrote: > Hi Nishanth, > > [auto build test results on v4.3-rc3 -- if it's inappropriate base, please > ignore] > > config: powerpc-defconfig (attached as .config) > reproduce: > wget > https://git.kernel.org/cgit/linux/kernel/git/wfg/

Re: [PATCH 1/5 v2] dma-mapping: add generic dma_get_page_shift API

2015-10-05 Thread Michael Ellerman
On Fri, 2015-10-02 at 13:11 -0700, Nishanth Aravamudan wrote: > Drivers like NVMe need to be able to determine the page size used for > DMA transfers. Add a new API that defaults to return PAGE_SHIFT on all > architectures. > > Signed-off-by: Nishanth Aravamudan > > diff --git a/include/asm-gene

Re: [PATCH v5 33/34] cxlflash: Fix to avoid leaving dangling interrupt resources

2015-10-05 Thread Andrew Donnellan
On 02/10/15 01:58, Matthew R. Ochs wrote: When running with an unsupported AFU, the cxlflash driver fails the probe. When the driver is removed, the following Oops is encountered on a show_interrupts() thread: Call Trace: [c01fba5a7a10] [0003] 0x3 (unreliable) [c01fba5a7a60]

Who uses CROSS32_COMPILE ?

2015-10-05 Thread Michael Ellerman
Does anyone build their kernels using CROSS32_COMPILE ? cheers ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH] cxl: Fix number of allocated pages in SPA

2015-10-05 Thread Michael Ellerman
On Fri, 2015-10-02 at 16:01 +0200, Christophe Lombard wrote: > This moves the initialisation of the num_procs to before the SPA > allocation. Why? What does it fix? I can't tell from the diff or the change log. cheers ___ Linuxppc-dev mailing list Lin

Re: [PATCH 4/5] kernel/cpu.c: eliminate cpu_*_mask

2015-10-05 Thread Michael Ellerman
On Tue, 2015-10-06 at 01:10 +0200, Rasmus Villemoes wrote: > Hi PPC maintainers > > Can I get you to ack or nak this? It's a prerequisite for a minor > patch series for kernel/cpu.c and include/linux/cpumask.h of mine. Yeah fine by me. Acked-by: Michael Ellerman cheers > On Mon, Sep 28 2015,