Re: [PATCH] powerpc/powernv: document cxl dependency on special case in pnv_eeh_reset()

2016-07-24 Thread Gavin Shan
On Fri, Jul 22, 2016 at 05:16:35PM +1000, Andrew Donnellan wrote: >pnv_eeh_reset() has special handling for PEs whose primary bus is the root >bus or the bus immediately underneath the root port. > >The cxl bi-modal card support added in b0b5e5918ad1 ("cxl: Add >cxl_check_and_switch_mode() API to s

Re: [PATCH] powerpc/eeh: trivial fix to non-conventional PCI address output on EEH log

2016-07-24 Thread Gavin Shan
On Fri, Jul 22, 2016 at 02:05:29PM -0300, Guilherme G. Piccoli wrote: >This is a very minor/trivial fix for the output of PCI address on EEH logs. >The PCI address on "OF node" field currently is using ":" as a separator >for the function, but the usual separator is ".". This patch changes the >sep

Re: [PATCH V5 5/5] powerpc/kvm/stats: Implement existing and add new halt polling vcpu stats

2016-07-24 Thread Suraj Jitindar Singh
On 23/07/16 07:53, David Matlack wrote: > On Thu, Jul 21, 2016 at 8:41 PM, Suraj Jitindar Singh > wrote: >> vcpu stats are used to collect information about a vcpu which can be viewed >> in the debugfs. For example halt_attempted_poll and halt_successful_poll >> are used to keep track of the num

Re: [PATCH] powerpc/eeh: trivial fix to non-conventional PCI address output on EEH log

2016-07-24 Thread Michael Ellerman
"Guilherme G. Piccoli" writes: > This is a very minor/trivial fix for the output of PCI address on EEH logs. > The PCI address on "OF node" field currently is using ":" as a separator > for the function, but the usual separator is ".". This patch changes the > separator for dot, so the PCI addres

Re: [PATCH] powerpc/tm: do not use r13 for tabort_syscall

2016-07-24 Thread Michael Neuling
On Fri, 2016-07-22 at 17:27 +1000, Nicholas Piggin wrote: > tabort_syscall runs with RI=1, so a nested recoverable machine > check will load the paca into r13 and overwrite what we loaded > it with, because exceptions returning to privileged mode do not > restore r13. > > This has survived testing

Re: [PATCH] powerpc/eeh: trivial fix to non-conventional PCI address output on EEH log

2016-07-24 Thread Gavin Shan
On Mon, Jul 25, 2016 at 10:47:13AM +1000, Michael Ellerman wrote: >"Guilherme G. Piccoli" writes: > >> This is a very minor/trivial fix for the output of PCI address on EEH logs. >> The PCI address on "OF node" field currently is using ":" as a separator >> for the function, but the usual separato

Re: [PATCH] powerpc/eeh: trivial fix to non-conventional PCI address output on EEH log

2016-07-24 Thread Guilherme G. Piccoli
On 07/24/2016 09:47 PM, Michael Ellerman wrote: "Guilherme G. Piccoli" writes: This is a very minor/trivial fix for the output of PCI address on EEH logs. The PCI address on "OF node" field currently is using ":" as a separator for the function, but the usual separator is ".". This patch chang

Re: [PATCH] powerpc/eeh: trivial fix to non-conventional PCI address output on EEH log

2016-07-24 Thread Guilherme G. Piccoli
On 07/24/2016 10:46 PM, Gavin Shan wrote: On Mon, Jul 25, 2016 at 10:47:13AM +1000, Michael Ellerman wrote: "Guilherme G. Piccoli" writes: This is a very minor/trivial fix for the output of PCI address on EEH logs. The PCI address on "OF node" field currently is using ":" as a separator for t

Re: [PATCH] powerpc/64: implement a slice mask cache

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 18:49:06 +1000 Benjamin Herrenschmidt wrote: > On Sat, 2016-07-23 at 17:10 +1000, Nicholas Piggin wrote: > > I wanted to avoid doing more work under slice_convert_lock, but > > we should just make that a per-mm lock anyway shouldn't we? > > Aren't the readers under the mm s

Re: [PATCH] cxl: fix sparse warnings

2016-07-24 Thread Ian Munsie
Acked-by: Ian Munsie ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH 1/3] powerpc/mm: Fix build break due when PPC_NATIVE=n

2016-07-24 Thread Michael Ellerman
The recent commit to rework the hash MMU setup broke the build when CONFIG_PPC_NATIVE=n. Fix it by providing a fallback implementation of hpte_init_native(). Fixes: 166dd7d3fbf2 ("powerpc/64: Move MMU backend selection out of platform code") Reported-by: Stephen Rothwell Signed-off-by: Michael E

[PATCH 2/3] powerpc/mm: Rename hpte_init_lpar() & put fallback in a header

2016-07-24 Thread Michael Ellerman
hpte_init_lpar() is part of the pseries platform, so name it as such. Provide the fallback implementation in a header, rather than using a weak function. Signed-off-by: Michael Ellerman --- arch/powerpc/include/asm/book3s/64/mmu-hash.h | 10 +- arch/powerpc/mm/hash_utils_64.c

[PATCH 3/3] powerpc/mm: Drop unused externs for hpte_init_beat[_v3]()

2016-07-24 Thread Michael Ellerman
We removed the BEAT support in 2015 in commit bf4981a00636 ("powerpc: Remove the celleb support"). These externs are unused since then. Signed-off-by: Michael Ellerman --- arch/powerpc/include/asm/book3s/64/mmu-hash.h | 3 --- 1 file changed, 3 deletions(-) diff --git a/arch/powerpc/include/asm

[PATCH 07/14] powerpc: migrate exception table users off module.h and onto extable.h

2016-07-24 Thread Paul Gortmaker
These files were only including module.h for exception table related functions. We've now separated that content out into its own file "extable.h" so now move over to that and avoid all the extra header content in module.h that we don't really need to compile these files. Cc: Benjamin Herrenschmi

Re: [PATCH 1/3] powerpc/mm: Fix build break due when PPC_NATIVE=n

2016-07-24 Thread Stephen Rothwell
Hi Michael, On Mon, 25 Jul 2016 12:57:49 +1000 Michael Ellerman wrote: > > The recent commit to rework the hash MMU setup broke the build when > CONFIG_PPC_NATIVE=n. Fix it by providing a fallback implementation of > hpte_init_native(). Alternatively, you could make the call site dependent on IS

Re: [PATCH 2/3] powerpc/mm: Rename hpte_init_lpar() & put fallback in a header

2016-07-24 Thread Stephen Rothwell
Hi Michael, On Mon, 25 Jul 2016 12:57:50 +1000 Michael Ellerman wrote: > > hpte_init_lpar() is part of the pseries platform, so name it as such. > Provide the fallback implementation in a header, rather than using a > weak function. firmware_has_feature(FW_FEATURE_LPAR) can also be true for CONF

Re: [RFC/PATCH 00/14] split exception table content out of module.h into extable.h

2016-07-24 Thread Linus Torvalds
On Sun, Jul 24, 2016 at 8:42 PM, Paul Gortmaker wrote: > > While doing an audit looking for unnecessary instances of module.h > inclusion across arch/x86/ I found a significant number of includes > of module.h were for things like search_exception_table and friends. > > For historical reasons (i.e

[RFC/PATCH 00/14] split exception table content out of module.h into extable.h

2016-07-24 Thread Paul Gortmaker
[RFC: Not looking for detailed review given the merge window is open. As long as nobody thinks the general idea is horrible, I'll expand into more fringe arch and resend in 2wks and get it added then to linux-next.] While doing an audit looking for unnecessary instances of module.h inclusion acr

[PATCH] powerpc/tm: do not use r13 for tabort_syscall

2016-07-24 Thread Nicholas Piggin
tabort_syscall runs with RI=1, so a nested recoverable machine check will load the paca into r13 and overwrite what we loaded it with, because exceptions returning to privileged mode do not restore r13. Fixes: b4b56f9ecab4 (powerpc/tm: Abort syscalls in active transactions) Cc: sta...@vger.kernel.

Re: [PATCH] powerpc/64: implement a slice mask cache

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 20:36:42 +1000 Balbir Singh wrote: > On Sat, Jul 23, 2016 at 05:10:36PM +1000, Nicholas Piggin wrote: > > On Sat, 23 Jul 2016 12:19:37 +1000 > > Balbir Singh wrote: > > > > > On Fri, Jul 22, 2016 at 10:57:28PM +1000, Nicholas Piggin wrote: > > > > Calculating the slice m

Re: [PATCH 2/3] powerpc/mm: Rename hpte_init_lpar() & put fallback in a header

2016-07-24 Thread Benjamin Herrenschmidt
On Mon, 2016-07-25 at 14:13 +1000, Stephen Rothwell wrote: > Hi Michael, > > On Mon, 25 Jul 2016 12:57:50 +1000 Michael Ellerman > wrote: > > > > hpte_init_lpar() is part of the pseries platform, so name it as such. > > Provide the fallback implementation in a header, rather than using a > > wea

[PATCH] cxl: add device ID for Mellanox ConnectX-4

2016-07-24 Thread Andrew Donnellan
Currently the cxl driver attempts to bind to any class 1200 (processing accelerator) device, and only works out whether it's actually a CAPI card later on. This doesn't really break anything (if it's not a CAPI card, we'll abort very quickly), but ideally we'd like to remove this and be explicit ab

Re: [PATCH v2] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-24 Thread Michael Ellerman
cheng...@emindsoft.com.cn writes: > From: Chen Gang > > For pure bool function's return value, bool is a little better more or > less than int. > > Signed-off-by: Chen Gang > --- > arch/powerpc/include/asm/mman.h | 8 > include/linux/mman.h| 2 +- > 2 files changed, 5 inser

Re: [PATCH for-4.8 V2 00/10] Use jump label for cpu/mmu_has_feature

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 14:42:33 +0530 "Aneesh Kumar K.V" wrote: > Changes from V1: > * Update "powerpc/mm: Convert early cpu/mmu feature check to use the > new helpers" based on resend code changes in this area. > > We now do feature fixup early and hence we can reduce the usage of > __cpu/__mmu_h

Re: [PATCH for-4.8 V2 01/10] powerpc/mm: Add __cpu/__mmu_has_feature

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 14:42:34 +0530 "Aneesh Kumar K.V" wrote: > In later patches, we will be switching cpu and mmu feature check to > use static keys. This would require us to have a variant of feature > check that can be used in early boot before jump label is initialized. > This patch adds the s

Re: [PATCH 2/3] powerpc/mm: Rename hpte_init_lpar() & put fallback in a header

2016-07-24 Thread Michael Ellerman
Stephen Rothwell writes: > Hi Michael, > > On Mon, 25 Jul 2016 12:57:50 +1000 Michael Ellerman > wrote: >> >> hpte_init_lpar() is part of the pseries platform, so name it as such. >> Provide the fallback implementation in a header, rather than using a >> weak function. > > firmware_has_feature(

Re: [PATCH] cxl: add device ID for Mellanox ConnectX-4

2016-07-24 Thread Ian Munsie
Acked-by: Ian Munsie ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH v5 1/2] qe: modify get_qe_base function

2016-07-24 Thread Zhao Qiang
modify get_qe_base function with of_address_to_resource instead of of_get_property and of_translate_address. Signed-off-by: Zhao Qiang --- Changes for v2: - na Changes for v3: - na Changes for v4: - na Changes for v5: - na drivers/soc/fsl/qe/qe.c | 10 +-

[PATCH v5 2/2] QE: remove PPCisms for QE

2016-07-24 Thread Zhao Qiang
QE was supported on PowerPC, and dependent on PPC, Now it is supported on other platforms. so remove PPCisms. Signed-off-by: Zhao Qiang --- Changes for v2: - na Changes for v3: - add NO_IRQ Changes for v4: - modify spin_event_timeout to opencoded timeout loop - rem

Re: [PATCH 1/3] powerpc/mm: Fix build break due when PPC_NATIVE=n

2016-07-24 Thread Michael Ellerman
Stephen Rothwell writes: > Hi Michael, > > On Mon, 25 Jul 2016 12:57:49 +1000 Michael Ellerman > wrote: >> >> The recent commit to rework the hash MMU setup broke the build when >> CONFIG_PPC_NATIVE=n. Fix it by providing a fallback implementation of >> hpte_init_native(). > > Alternatively, yo

Re: [PATCH for-4.8 V2 03/10] powerpc/mm/radix: Add radix_set_pte to use in early init

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 14:42:36 +0530 "Aneesh Kumar K.V" wrote: > We want to use the static key based feature check in set_pte_at. Since > we call radix__map_kernel_page early in boot before jump label is > initialized we can't call set_pte_at there. Add radix__set_pte for the > same. > > Signed-of

Re: [PATCH for-4.8 V2 00/10] Use jump label for cpu/mmu_has_feature

2016-07-24 Thread Aneesh Kumar K.V
Nicholas Piggin writes: > On Sat, 23 Jul 2016 14:42:33 +0530 > "Aneesh Kumar K.V" wrote: > >> Changes from V1: >> * Update "powerpc/mm: Convert early cpu/mmu feature check to use the >> new helpers" based on resend code changes in this area. >> >> We now do feature fixup early and hence we can

Re: [PATCH for-4.8 V2 08/10] powerpc: use the jump label for cpu_has_feature

2016-07-24 Thread Nicholas Piggin
On Sat, 23 Jul 2016 14:42:41 +0530 "Aneesh Kumar K.V" wrote: > From: Kevin Hao > > The cpu features are fixed once the probe of cpu features are done. > And the function cpu_has_feature() does be used in some hot path. > The checking of the cpu features for each time of invoking of > cpu_has_fe

Re: [PATCH for-4.8 V2 00/10] Use jump label for cpu/mmu_has_feature

2016-07-24 Thread Nicholas Piggin
On Mon, 25 Jul 2016 11:55:50 +0530 "Aneesh Kumar K.V" wrote: > Nicholas Piggin writes: > > > On Sat, 23 Jul 2016 14:42:33 +0530 > > "Aneesh Kumar K.V" wrote: > > > >> Changes from V1: > >> * Update "powerpc/mm: Convert early cpu/mmu feature check to use > >> the new helpers" based on resend