Re: [PATCH v1 7/7] pseries/setup: Add Initialization of VF Bars

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > When enabling SR-IOV in pseries platform, > the VF bar properties for a PF are reported on > the device node in the device tree. > > This patch adds the IOV Bar resources to Linux > structures from the device tree for later use > when configuring SR-IOV by

Re: [PATCH v1 6/7] pseries/pci: Associate PEs to VFs in configure SR-IOV

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > After initial validation of SR-IOV resources, firmware will > associate PEs to the dynamic VFs created within this call. This > patch adds the association of PEs to the PF array of PE numbers > indexed by VF. > > Signed-off-by: Bryant G. Ly

Re: [PATCH] On ppc64le we HAVE_RELIABLE_STACKTRACE

2017-12-17 Thread Nicholas Piggin
On Sun, 17 Dec 2017 20:58:54 -0600 Josh Poimboeuf wrote: > On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote: > > On Tue, 12 Dec 2017 08:05:01 -0600 > > Josh Poimboeuf wrote: > > > > > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten

Re: [PATCH] cpufreq: powernv: Add support of frequency domain

2017-12-17 Thread Abhishek
On 12/14/2017 10:12 AM, Viresh Kumar wrote: + Gautham, @Gautham: Can you please help reviewing this one ? On 13-12-17, 13:49, Abhishek Goel wrote: @@ -693,6 +746,8 @@ static int powernv_cpufreq_target_index(struct cpufreq_policy *policy, { struct powernv_smp_call_data freq_data;

Re: [PATCH v1 4/7] powerpc/kernel Add EEH operations to notify resume

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > When pseries SR-IOV is enabled and after a PF driver > has resumed from EEH, platform has to be notified > of the event so the child VFs can be allowed to > resume their normal recovery path. > > This patch makes the EEH operation allow unfreeze > platform

Re: [PATCH v1 3/7] platforms/pseries: Set eeh_pe of EEH_PE_VF type

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > To correctly use EEH code one has to make > sure that the EEH_PE_VF is set for dynamic created > VFs. Therefore this patch allocates an eeh_pe of > eeh type EEH_PE_VF and associates PE with parent. > > Signed-off-by: Bryant G. Ly

Re: [PATCH v1 3/7] platforms/pseries: Set eeh_pe of EEH_PE_VF type

2017-12-17 Thread Russell Currey
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote: > To correctly use EEH code one has to make > sure that the EEH_PE_VF is set for dynamic created > VFs. Therefore this patch allocates an eeh_pe of > eeh type EEH_PE_VF and associates PE with parent. > > Signed-off-by: Bryant G. Ly

Re: [PATCH v1 4/7] powerpc/kernel Add EEH operations to notify resume

2017-12-17 Thread Russell Currey
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote: > When pseries SR-IOV is enabled and after a PF driver > has resumed from EEH, platform has to be notified > of the event so the child VFs can be allowed to > resume their normal recovery path. > > This patch makes the EEH operation allow

Re: [PATCH v1 2/7] powerpc/kernel: Add uevents in EEH error/resume

2017-12-17 Thread Russell Currey
On Wed, 2017-12-13 at 09:32 -0600, Bryant G. Ly wrote: > Devices can go offline when EEH is reported. This patch adds > a change to the kernel object and lets udev know of error. > When device resumes a change is also set reporting device as > online. Therefore, EEH events are better propagated to

Re: [PATCH] On ppc64le we HAVE_RELIABLE_STACKTRACE

2017-12-17 Thread Josh Poimboeuf
On Mon, Dec 18, 2017 at 02:39:06PM +1100, Balbir Singh wrote: > On Mon, Dec 18, 2017 at 1:58 PM, Josh Poimboeuf wrote: > > On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote: > >> On Tue, 12 Dec 2017 08:05:01 -0600 > >> Josh Poimboeuf wrote:

Re: [PATCH v1 2/7] powerpc/kernel: Add uevents in EEH error/resume

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > Devices can go offline when EEH is reported. This patch adds > a change to the kernel object and lets udev know of error. > When device resumes a change is also set reporting device as > online. Therefore, EEH events are better propagated to user > space

Re: [PATCH v1 1/7] platform/pseries: Update VF config space after EEH

2017-12-17 Thread Alexey Kardashevskiy
On 14/12/17 02:32, Bryant G. Ly wrote: > Add EEH platform operations for pseries to update VF > config space. With this change after EEH, the VF > will have updated config space for pseries platform. > > Signed-off-by: Bryant G. Ly > Signed-off-by: Juan J. Alvarez

Re: [PATCH] On ppc64le we HAVE_RELIABLE_STACKTRACE

2017-12-17 Thread Balbir Singh
On Mon, Dec 18, 2017 at 1:58 PM, Josh Poimboeuf wrote: > On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote: >> On Tue, 12 Dec 2017 08:05:01 -0600 >> Josh Poimboeuf wrote: >> >> > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten Duwe wrote:

Re: [PATCH v4 00/11] ASoC: fsl_ssi: Clean up - coding style level

2017-12-17 Thread Timur Tabi
On 12/17/17 8:51 PM, Nicolin Chen wrote: Nicolin Chen (11): ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi ASoC: fsl_ssi: Cache pdev->dev pointer ASoC: fsl_ssi: Refine all comments ASoC: fsl_ssi: Rename registers and fields macros ASoC: fsl_ssi: Refine indentations and wrappings

Re: [PATCH] On ppc64le we HAVE_RELIABLE_STACKTRACE

2017-12-17 Thread Josh Poimboeuf
On Fri, Dec 15, 2017 at 07:40:09PM +1000, Nicholas Piggin wrote: > On Tue, 12 Dec 2017 08:05:01 -0600 > Josh Poimboeuf wrote: > > > On Tue, Dec 12, 2017 at 12:39:12PM +0100, Torsten Duwe wrote: > > > Hi all, > > > > > > The "Power Architecture 64-Bit ELF V2 ABI" says in

[PATCH v4 11/11] ASoC: fsl_ssi: Define ternary macros to simplify code

2017-12-17 Thread Nicolin Chen
Some regmap code looks redudant. So simplify it. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero --- sound/soc/fsl/fsl_ssi.c | 27 +++

[PATCH v4 10/11] ASoC: fsl_ssi: Rename i2smode to i2s_net

2017-12-17 Thread Nicolin Chen
Since this i2smode also includes the setting of Network mode, it should have it in the name. This patch also adds its MASK define. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero

[PATCH v4 09/11] ASoC: fsl_ssi: Replace fsl_ssi_rxtx_reg_val with fsl_ssi_regvals

2017-12-17 Thread Nicolin Chen
The name fsl_ssi_rxtx_reg_val is too long to read comfortably. So this patch shortens it by using an array (fsl_ssi_regvals, renamed from fsl_ssi_reg_val). To do that, it also introduces two macros (TX and RX) to replace the wrapper structure. This will also help further cleanups. Meanwhile, it

[PATCH v4 08/11] ASoC: fsl_ssi: Rename scr_val to scr

2017-12-17 Thread Nicolin Chen
Simplify the variable name. This reduces one over-80-character line. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero --- sound/soc/fsl/fsl_ssi.c | 12 ++-- 1

[PATCH v4 07/11] ASoC: fsl_ssi: Rename cpu_dai parameter to dai

2017-12-17 Thread Nicolin Chen
Shortens the variable name to save space, useful for dev_err outputs. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero --- sound/soc/fsl/fsl_ssi.c | 32

[PATCH v4 06/11] ASoC: fsl_ssi: Refine printk outputs

2017-12-17 Thread Nicolin Chen
This patches unifies the error message in the "failed to " format. It also reduces the length of one line and adds spaces to an operator. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero

[PATCH v4 05/11] ASoC: fsl_ssi: Refine indentations and wrappings

2017-12-17 Thread Nicolin Chen
This patch just simply unifies the coding style. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero --- sound/soc/fsl/fsl_ssi.c | 239

[PATCH v4 04/11] ASoC: fsl_ssi: Rename registers and fields macros

2017-12-17 Thread Nicolin Chen
This patch renames CCSR_SSI_xxx to REG_SSI_xxx and SSI_xxx_yyy style. It also slightly reduces the length of them to save some space. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero

[PATCH v4 03/11] ASoC: fsl_ssi: Refine all comments

2017-12-17 Thread Nicolin Chen
This patch refines the comments by: 1) Removing all out-of-date comments 2) Removing all not-so-useful comments 3) Unifying the styles of all comments 4) Shortening comments to be more conise 5) Adding comments to improve code readablity 6) Moving all register related comments to fsl_ssi.h 7)

[PATCH v4 02/11] ASoC: fsl_ssi: Cache pdev->dev pointer

2017-12-17 Thread Nicolin Chen
There should be no trouble to understand dev = pdev->dev. This can save some space to have more print info or save some wrapped lines. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero

[PATCH v4 01/11] ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi

2017-12-17 Thread Nicolin Chen
Shorten the private data structure to save some wrapped lines. Signed-off-by: Nicolin Chen Tested-by: Maciej S. Szmigiero Reviewed-by: Maciej S. Szmigiero --- sound/soc/fsl/fsl_ssi.c | 456

[PATCH v4 00/11] ASoC: fsl_ssi: Clean up - coding style level

2017-12-17 Thread Nicolin Chen
==Changelog== v3->v4 * Revised PATCH-03 "Refine all comments" by adding Timur's inputs * Rebased all other patches v2->v3 * Added Tested-by and Reviewed-by from Maciej * Revised PATCH-03 "Refine all comments" by adding Maciej's advice * Revised PATCH-05 "Refine indentations and wrappings" *

[trivial PATCH] treewide: Align function definition open/close braces

2017-12-17 Thread Joe Perches
Some functions definitions have either the initial open brace and/or the closing brace outside of column 1. Move those braces to column 1. This allows various function analyzers like gnu complexity to work properly for these modified functions. Miscellanea: o Remove extra trailing ; and blank

Re: [PATCH 17/17] memremap: merge find_dev_pagemap into get_dev_pagemap

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > There is only one caller of the trivial function find_dev_pagemap left, > so just merge it into the caller. > > Signed-off-by: Christoph Hellwig Looks good, Reviewed-by: Dan Williams

Re: [PATCH 16/17] memremap: change devm_memremap_pages interface to use struct dev_pagemap

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > From: Logan Gunthorpe > > This new interface is similar to how struct device (and many others) > work. The caller initializes a 'struct dev_pagemap' as required > and calls 'devm_memremap_pages'. This

Re: [PATCH 15/17] memremap: drop private struct page_map

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > From: Logan Gunthorpe > > 'struct page_map' is a private structure of 'struct dev_pagemap' but the > latter replicates all the same fields as the former so there isn't much > value in it. Thus drop it

Re: [PATCH 14/17] memremap: simplify duplicate region handling in devm_memremap_pages

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > __radix_tree_insert already checks for duplicates and returns -EEXIST in > that case, so remove the duplicate (and racy) duplicates check. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Logan Gunthorpe

Re: [PATCH 13/17] memremap: remove to_vmem_altmap

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > All callers are gone now. > > Signed-off-by: Christoph Hellwig > --- Nice, Reviewed-by: Dan Williams

Re: [PATCH 12/17] mm: optimize dev_pagemap reference counting around get_dev_pagemap

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > Change the calling convention so that get_dev_pagemap always consumes the > previous reference instead of doing this using an explicit earlier call to > put_dev_pagemap in the callers. > > The callers will still need to put

Re: [PATCH 11/17] mm: move get_dev_pagemap out of line

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: > This is a pretty big function, which should be out of line in general, > and a no-op stub if CONFIG_ZONE_DEVICЕ is not set. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Logan Gunthorpe

Re: [PATCH 04/17] mm: pass the vmem_altmap to arch_add_memory and __add_pages

2017-12-17 Thread Dan Williams
On Fri, Dec 15, 2017 at 5:48 PM, Dan Williams wrote: > On Fri, Dec 15, 2017 at 6:09 AM, Christoph Hellwig wrote: >> We can just pass this on instead of having to do a radix tree lookup >> without proper locking 2 levels into the callchain. >> >>

Re: Mac Mini G4 defconfig ?

2017-12-17 Thread Mathieu Malaterre
On Fri, Dec 15, 2017 at 10:01 PM, Mathieu Malaterre wrote: > On Fri, Dec 15, 2017 at 9:52 PM, Mathieu Malaterre wrote: >> On Fri, Dec 15, 2017 at 8:50 PM, Mathieu Malaterre wrote: >>> Hi there, >>> >>> Does anyone has working defconfig for a