Re: Build regressions/improvements in v4.18-rc1

2018-06-18 Thread Geert Uytterhoeven
Hi Michael, On Tue, Jun 19, 2018 at 8:35 AM Michael Ellerman wrote: > Geert Uytterhoeven writes: > > On Mon, Jun 18, 2018 at 11:18 AM Geert Uytterhoeven > > wrote: > >> Below is the list of build error/warning regressions/improvements in > >> v4.18-rc1[1] compared to v4.17[2]. > >> + /kisskb

Re: Build regressions/improvements in v4.18-rc1

2018-06-18 Thread Michael Ellerman
Geert Uytterhoeven writes: > On Mon, Jun 18, 2018 at 11:18 AM Geert Uytterhoeven > wrote: >> Below is the list of build error/warning regressions/improvements in >> v4.18-rc1[1] compared to v4.17[2]. >> >> Summarized: >> - build errors: +11/-1 > >> [1] >> http://kisskb.ellerman.id.au/kisskb/he

Re: [PATCH 1/3] powerpc: mac: fix rtc read functions

2018-06-18 Thread Mathieu Malaterre
On Mon, Jun 18, 2018 at 10:04 PM Andreas Schwab wrote: > > On Jun 18 2018, Mathieu Malaterre wrote: > > > Sadly, trying again today does not work anymore. Adding some printk > > just before WARN_ON: > > > > +printk(KERN_ERR " rtc DBG pmu_get_time1: %lld %d %lld \n", now, > > RTC_OFFSET, now - RTC

Re: [PATCH] misc: ocxl: Change return type for fault handler

2018-06-18 Thread Souptick Joarder
On Thu, Jun 14, 2018 at 9:36 PM, Frederic Barrat wrote: > > > Le 11/06/2018 à 22:29, Souptick Joarder a écrit : >> >> Use new return type vm_fault_t for fault handler. For >> now, this is just documenting that the function returns >> a VM_FAULT value rather than an errno. Once all instances >> are

[PATCH 3/3] powernv/cpuidle: Use parsed device tree values for cpuidle_init

2018-06-18 Thread Akshay Adiga
Export pnv_idle_states and nr_pnv_idle_states so that its accessible to cpuidle driver. Use properties from pnv_idle_states structure for powernv cpuidle_init. Signed-off-by: Akshay Adiga --- arch/powerpc/include/asm/cpuidle.h | 2 ++ drivers/cpuidle/cpuidle-powernv.c | 49

[PATCH 2/3] cpuidle/powernv: Change platform init to avoid reparsing dt

2018-06-18 Thread Akshay Adiga
The required data is accessible from cpuidle_states structure and nr_cpu_idle_states. This patch makes changes to avoid reparsing and use data from these structures. Signed-off-by: Akshay Adiga --- arch/powerpc/platforms/powernv/idle.c | 37 --- 1 file changed, 8

[PATCH 1/3] powernv/cpuidle: Parse dt idle properties into global structure

2018-06-18 Thread Akshay Adiga
Device-tree parsing happens in twice, once while deciding idle state to be used for hotplug and once during cpuidle init. Hence, parsing the device tree and caching it will reduce code duplication. Parsing code has been moved to pnv_parse_cpuidle_dt() from pnv_probe_idle_states(). Setting up thing

[PATCH 0/3] powernv/cpuidle Device-tree parsing cleanup

2018-06-18 Thread Akshay Adiga
Device-tree parsed multiple time in powernv cpuidle and powernv hotplug code. First to identify supported flags, secondly, to identify deepest_state and first deep state, Thirdly , during cpudidle init to find the available idle states. Any change in device-tree format will lead to make changes i

Re: [PATCH] powerpc: xmon: use ktime_get_coarse_boottime64

2018-06-18 Thread Balbir Singh
On Mon, Jun 18, 2018 at 7:56 PM, Arnd Bergmann wrote: > get_monotonic_boottime() is deprecated, and may not be safe to call in > every context, as it has to read a hardware clocksource. > > This changes xmon to print the time using ktime_get_coarse_boottime64() > instead, which avoids the old time

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Eric Dumazet
On 06/18/2018 04:29 PM, Eric Dumazet wrote: > > > On 06/18/2018 11:45 AM, Mathieu Malaterre wrote: > >> >> Here is what I get on my side >> >> [ 53.628847] sungem: sungem wrong csum : 4e04/f97, len 64 bytes >> [ 53.667063] sungem: sungem wrong csum : eea8/6eec, len 149 bytes >> [ 58.648

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Eric Dumazet
On 06/18/2018 11:45 AM, Mathieu Malaterre wrote: > > Here is what I get on my side > > [ 53.628847] sungem: sungem wrong csum : 4e04/f97, len 64 bytes > [ 53.667063] sungem: sungem wrong csum : eea8/6eec, len 149 bytes > [ 58.648952] sungem: sungem wrong csum : 2095/3d06, len 64 bytes >

[PATCH v2 4/4] powerpc/tm: Do not recheckpoint non-tm task

2018-06-18 Thread Breno Leitao
If __switch_to() tries to context switch from task A to task B, and task A had task->thread->regs->msr[TM] enabled, then __switch_to_tm() will call tm_recheckpoint_new_task(), which will call trecheckpoint, for task B, which is clearly wrong since task B might not be an active TM user. This does

[PATCH v2 3/4] powerpc/tm: Adjust tm_reclaim_thread() parameters

2018-06-18 Thread Breno Leitao
From: Cyril Bur tm_reclaim_thread() doesn't use the parameter anymore, both callers have to bother getting it as they have no need for a struct thread_info either. It was previously used but became unused in commit dc3106690b20 ("powerpc: tm: Always use fp_state and vr_state to store live regist

[PATCH v2 2/4] powerpc/tm: Fix HTM documentation

2018-06-18 Thread Breno Leitao
This patch simply fix part of the documentation on the HTM code. This fixes reference to old fields that were renamed in commit 000ec280e3dd ("powerpc: tm: Rename transct_(*) to ck(\1)_state") It also documents better the flow after commit eb5c3f1c8647 ("powerpc: Always save/restore checkpointed

[PATCH v2 1/4] powerpc/tm: Remove msr_tm_active()

2018-06-18 Thread Breno Leitao
Currently msr_tm_active() is a wrapper around MSR_TM_ACTIVE() if CONFIG_PPC_TRANSACTIONAL_MEM is set, or it is just a function that returns false if CONFIG_PPC_TRANSACTIONAL_MEM is not set. This function is not necessary, since MSR_TM_ACTIVE() just do the same, checking for the TS bits and does no

[PATCH] powerpc/pci: Remove legacy debug code

2018-06-18 Thread Breno Leitao
Commit 59f47eff03a0 ("powerpc/pci: Use of_irq_parse_and_map_pci() helper") removed the 'oirq' variable, but kept memsetting it when the DEBUG macro is defined. When setting DEBUG macro for debugging purpose, the kernel fails to build since 'oirq' is not defined anymore. This patch simply remove t

Re: [PATCH 1/3] powerpc: mac: fix rtc read functions

2018-06-18 Thread Andreas Schwab
On Jun 18 2018, Mathieu Malaterre wrote: > Sadly, trying again today does not work anymore. Adding some printk > just before WARN_ON: > > +printk(KERN_ERR " rtc DBG pmu_get_time1: %lld %d %lld \n", now, > RTC_OFFSET, now - RTC_OFFSET ); > +printk(KERN_ERR " rtc DBG pmu_get_time2: %x %x %x %x %d \

Re: [PATCH 1/3] powerpc: mac: fix rtc read functions

2018-06-18 Thread Mathieu Malaterre
On Mon, Jun 18, 2018 at 4:07 PM Arnd Bergmann wrote: > > As Mathieu pointed out, my conversion to time64_t was incorrect and resulted > in negative times to be read from the RTC. The problem is that during the > conversion from a byte array to a time64_t, the 'unsigned char' variable > holding the

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Mathieu Malaterre
On Mon, Jun 18, 2018 at 8:18 PM Eric Dumazet wrote: > > > > On 06/18/2018 10:54 AM, Andreas Schwab wrote: > > On Jun 17 2018, Eric Dumazet wrote: > > > >> Oh this is silly, please try : > >> > >> diff --git a/net/core/skbuff.c b/net/core/skbuff.c > >> index > >> c642304f178ce0a4e1358d59e45032a39

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Mathieu Malaterre
On Mon, Jun 18, 2018 at 7:54 PM Andreas Schwab wrote: > > On Jun 17 2018, Eric Dumazet wrote: > > > Oh this is silly, please try : > > > > diff --git a/net/core/skbuff.c b/net/core/skbuff.c > > index > > c642304f178ce0a4e1358d59e45032a39f76fb3f..54dd9c18ecad817812898d6f335e1794a07dabbe > > 1006

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Eric Dumazet
On 06/18/2018 10:54 AM, Andreas Schwab wrote: > On Jun 17 2018, Eric Dumazet wrote: > >> Oh this is silly, please try : >> >> diff --git a/net/core/skbuff.c b/net/core/skbuff.c >> index >> c642304f178ce0a4e1358d59e45032a39f76fb3f..54dd9c18ecad817812898d6f335e1794a07dabbe >> 100644 >> --- a/n

Re: [PATCH] Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"

2018-06-18 Thread Andreas Schwab
On Jun 17 2018, Eric Dumazet wrote: > Oh this is silly, please try : > > diff --git a/net/core/skbuff.c b/net/core/skbuff.c > index > c642304f178ce0a4e1358d59e45032a39f76fb3f..54dd9c18ecad817812898d6f335e1794a07dabbe > 100644 > --- a/net/core/skbuff.c > +++ b/net/core/skbuff.c > @@ -1845,10 +18

[PATCH] arch: powerpc: pci-common: fix wrong return value check on phd_id

2018-06-18 Thread Daniel Walker
Cisco has a couple platforms which depend on the domain values getting set a certain way. We discovered our machines not detecting the pci devices, and traced it back to this commit, 63a7228 powerpc/pci: Assign fixed PHB number based on device-tree properties It seems that the code is expecting t

Re: [PATCH 2/3] m68k: mac: use time64_t in RTC handling

2018-06-18 Thread kbuild test robot
Hi Arnd, I love your patch! Yet something to improve: [auto build test ERROR on powerpc/next] [also build test ERROR on v4.18-rc1 next-20180618] [cannot apply to m68k/for-next] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https

Re: Constant ata messages on console with commit 28361c403683 ("libata: add extra internal command") (was Re: [GIT PULL 2/2] libata changes for v4.18-rc1)

2018-06-18 Thread Jens Axboe
On 6/18/18 1:33 AM, Michael Ellerman wrote: > Tejun Heo writes: > ... >> Jens Axboe (10): >> libata: introduce notion of separate hardware tags >> libata: convert core and drivers to ->hw_tag usage >> libata: bump ->qc_active to a 64-bit type >> libata: use ata_tag_internal

[PATCH] powerpc/numa: Handle unitialized timer reset

2018-06-18 Thread Michael Bringmann
Some of the code in 'numa.c' may be reused when updating kernel state after an LPAR migration event. One such common function is 'reset_topology_timer' which was being invoked by the '.notifier_call' function within the NUMA module by 'of_property_notify'. If this occurs after a previous call to

[PATCH 1/3] powerpc: mac: fix rtc read functions

2018-06-18 Thread Arnd Bergmann
As Mathieu pointed out, my conversion to time64_t was incorrect and resulted in negative times to be read from the RTC. The problem is that during the conversion from a byte array to a time64_t, the 'unsigned char' variable holding the top byte gets turned into a negative signed 32-bit integer befo

[PATCH 3/3] m68k: remove unused set_clock_mmss() helpers

2018-06-18 Thread Arnd Bergmann
Commit 397ac99c6cef ("m68k: remove dead timer code") removed set_rtc_mmss() because it was unused in 2012. However, this was itself the only user of the mach_set_clock_mmss() callback and the many implementations of that callback, which are equally unused. This removes all of those as well. Signe

[PATCH 2/3] m68k: mac: use time64_t in RTC handling

2018-06-18 Thread Arnd Bergmann
The real-time clock on m68k (and powerpc) mac systems uses an unsigned 32-bit value starting in 1904, which overflows in 2040, about two years later than everyone else, but this gets wrapped around in the Linux code in 2038 already because of the deprecated usage of time_t and/or long in the conver

Re: powerpc: use time64_t in read_persistent_clock

2018-06-18 Thread Arnd Bergmann
On Thu, Jun 14, 2018 at 9:03 PM, Mathieu Malaterre wrote: > On Thu, Jun 14, 2018 at 1:46 PM Arnd Bergmann wrote: >> On Wed, Jun 13, 2018 at 10:24 PM, Mathieu Malaterre wrote: > >> Can you confirm that this patch addresses your problem? > > Yes ! > > Before: > [5.986710] rtc-generic rtc-gener

Re: [PATCH 0/3] Resolve -Wattribute-alias warnings from SYSCALL_DEFINEx()

2018-06-18 Thread Arnd Bergmann
On Sat, Jun 16, 2018 at 2:53 AM, Paul Burton wrote: > This series introduces infrastructure allowing compiler diagnostics to > be disabled or their severity modified for specific pieces of code, with > suitable abstractions to prevent that code from becoming tied to a > specific compiler. > > This

[PATCH] powerpc/fsl: Sanitize the syscall table for NXP PowerPC 32 bit platforms

2018-06-18 Thread Diana Craciun
Used barrier_nospec to sanitize the syscall table. Signed-off-by: Diana Craciun --- arch/powerpc/kernel/entry_32.S | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/powerpc/kernel/entry_32.S b/arch/powerpc/kernel/entry_32.S index eb8d01b..e3ff9ace 100644 --- a/arch/powerpc/ker

[PATCH] ocxl: Fix page fault handler in case of fault on dying process

2018-06-18 Thread Frederic Barrat
If a process exits without doing proper cleanup, there's a window where an opencapi device can try to access the memory of the dying process and may trigger a page fault. That's an expected scenario and the ocxl driver holds a reference on the mm_struct of the process until the opencapi device is n

[PATCH] powerpc: xmon: use ktime_get_coarse_boottime64

2018-06-18 Thread Arnd Bergmann
get_monotonic_boottime() is deprecated, and may not be safe to call in every context, as it has to read a hardware clocksource. This changes xmon to print the time using ktime_get_coarse_boottime64() instead, which avoids the old timespec type and the HW access. Signed-off-by: Arnd Bergmann ---

Re: Build regressions/improvements in v4.18-rc1

2018-06-18 Thread Geert Uytterhoeven
On Mon, Jun 18, 2018 at 11:18 AM Geert Uytterhoeven wrote: > Below is the list of build error/warning regressions/improvements in > v4.18-rc1[1] compared to v4.17[2]. > > Summarized: > - build errors: +11/-1 > [1] > http://kisskb.ellerman.id.au/kisskb/head/ce397d215ccd07b8ae3f71db689aedb85d56a

Constant ata messages on console with commit 28361c403683 ("libata: add extra internal command") (was Re: [GIT PULL 2/2] libata changes for v4.18-rc1)

2018-06-18 Thread Michael Ellerman
Tejun Heo writes: ... > Jens Axboe (10): > libata: introduce notion of separate hardware tags > libata: convert core and drivers to ->hw_tag usage > libata: bump ->qc_active to a 64-bit type > libata: use ata_tag_internal() consistently > libata: remove assumption tha

Re: [PATCH v2] powerpc/cell: fix build failure by disabling attribute-alias warning

2018-06-18 Thread Christophe LEROY
Le 29/05/2018 à 18:06, Christophe Leroy a écrit : Latest GCC version emit the following warnings As arch/powerpc code is built with -Werror, this breaks build with GCC 8.1 This patch inhibits those warnings CC arch/powerpc/platforms/cell/spu_syscalls.o In file included from arch/pow

Re: [PATCH kernel 2/2] powerpc/powernv: Define PHB4 type and enable sketchy bypass on POWER9

2018-06-18 Thread Alexey Kardashevskiy
On Mon, 18 Jun 2018 14:44:56 +1000 Benjamin Herrenschmidt wrote: > On Mon, 2018-06-18 at 12:13 +1000, Alexey Kardashevskiy wrote: > > On Sat, 16 Jun 2018 11:05:19 +1000 > > Benjamin Herrenschmidt wrote: > > > > > On Fri, 2018-06-01 at 18:10 +1000, Alexey Kardashevskiy wrote: > > > > These a

Re: [PATCH] powerpc/eeh: Avoid misleading message "EEH: no capable adapters found"

2018-06-18 Thread Venkat Rao B
On Friday 27 April 2018 06:04 AM, Russell Currey wrote: On Thu, 2018-03-22 at 23:10 -0300, Mauro S. M. Rodrigues wrote: Due to recent refactoring in EEH in: commit b9fde58db7e5 ("powerpc/powernv: Rework EEH initialization on powernv") a misleading message was seen in the kernel message buffer

Re: [PATCH 3/3] Revert "powerpc: fix build failure by disabling attribute-alias warning in pci_32"

2018-06-18 Thread Christophe LEROY
Le 16/06/2018 à 02:53, Paul Burton a écrit : With SYSCALL_DEFINEx() disabling -Wattribute-alias generically, there's no need to duplicate that for PowerPC's pciconfig_iobase syscall. This reverts commit 415520373975 ("powerpc: fix build failure by disabling attribute-alias warning in pci_32")

Re: [PATCH 2/3] disable -Wattribute-alias warning for SYSCALL_DEFINEx()

2018-06-18 Thread Christophe LEROY
Le 16/06/2018 à 02:53, Paul Burton a écrit : From: Arnd Bergmann gcc-8 warns for every single definition of a system call entry point, e.g.: include/linux/compat.h:56:18: error: 'compat_sys_rt_sigprocmask' alias between functions of incompatible types 'long int(int, compat_sigset_t *, com

Re: [PATCH 1/3] kbuild: add macro for controlling warnings to linux/compiler.h

2018-06-18 Thread Christophe LEROY
Le 16/06/2018 à 02:53, Paul Burton a écrit : From: Arnd Bergmann I have occasionally run into a situation where it would make sense to control a compiler warning from a source file rather than doing so from a Makefile using the $(cc-disable-warning, ...) or $(cc-option, ...) helpers. The ap

Re: [PATCH 0/3] Resolve -Wattribute-alias warnings from SYSCALL_DEFINEx()

2018-06-18 Thread Christophe LEROY
Le 16/06/2018 à 02:53, Paul Burton a écrit : This series introduces infrastructure allowing compiler diagnostics to be disabled or their severity modified for specific pieces of code, with suitable abstractions to prevent that code from becoming tied to a specific compiler. This infrastructur