Re: [PATCH] powerpc/boot: Use address-of operator on section symbols

2020-06-24 Thread Geoff Levand
Hi Nathan, On 6/23/20 8:59 PM, Nathan Chancellor wrote: > These are not true arrays, they are linker defined symbols, which are > just addresses. Using the address of operator silences the warning > and does not change the resulting assembly with either clang/ld.lld > or gcc/ld (tested with diff

Re: FSL P5020/P5040: DPAA Ethernet issue with the latest Git kernel

2020-06-24 Thread Alexander Gordeev
On Sun, Jun 21, 2020 at 08:40:14AM +0200, Christian Zigotzky wrote: > Hello Alexander, > > The DPAA Ethernet doesn’t work anymore on our FSL P5020/P5040 boards [1] > since the RC1 of kernel 5.8 [2]. > We bisected last days [3] and found the problematic commit [4]. I was able to > revert it [5].

Re: [PATCH 1/2] powerpc/papr_scm: Fetch nvdimm performance stats from PHYP

2020-06-24 Thread Ira Weiny
On Wed, Jun 24, 2020 at 08:28:57PM +0530, Vaibhav Jain wrote: > Thanks for reviewing this patch Ira, > > My responses below inline. > > Ira Weiny writes: > > > On Mon, Jun 22, 2020 at 09:54:50AM +0530, Vaibhav Jain wrote: > >> Update papr_scm.c to query dimm performance statistics from PHYP

Re: [PATCH 1/2] ASoC: fsl-asoc-card: Add WM8524 support

2020-06-24 Thread Mark Brown
On Tue, 23 Jun 2020 14:52:46 +0800, Shengjiu Wang wrote: > WM8524 only supports playback mode, and only works at > slave mode. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/2] ASoC: fsl-asoc-card: Add WM8524 support commit:

Re: [PATCH v4 7/8] lockdep: Change hardirq{s_enabled,_context} to per-cpu variables

2020-06-24 Thread Peter Zijlstra
On Wed, Jun 24, 2020 at 01:32:46PM +0200, Marco Elver wrote: > From: Marco Elver > Date: Wed, 24 Jun 2020 11:23:22 +0200 > Subject: [PATCH] kcsan: Make KCSAN compatible with new IRQ state tracking > > The new IRQ state tracking code does not honor lockdep_off(), and as > such we should again

Re: [PATCH 2/2] powerpc/papr_scm: Add support for fetching nvdimm 'fuel-gauge' metric

2020-06-24 Thread Vaibhav Jain
Thanks for reviewing this patch Ira, My responses below: Ira Weiny writes: [snip] >> +static int papr_pdsm_fuel_gauge(struct papr_scm_priv *p, >> +union nd_pdsm_payload *payload) >> +{ >> +int rc, size; >> +struct papr_scm_perf_stat *stat; >> +struct

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-24 Thread Rafael J. Wysocki
On Wed, Jun 24, 2020 at 7:50 AM Viresh Kumar wrote: > > On 23-06-20, 15:21, Quentin Perret wrote: > > Currently, the only way to specify the default CPUfreq governor is via > > Kconfig options, which suits users who can build the kernel themselves > > perfectly. > > > > However, for those who use

Re: [PATCH v2 2/2] powerpc/hv-24x7: Add sysfs files inside hv-24x7 device to show cpumask

2020-06-24 Thread Madhavan Srinivasan
On 6/24/20 4:26 PM, Gautham R Shenoy wrote: Hi Kajol, On Wed, Jun 24, 2020 at 03:47:54PM +0530, Kajol Jain wrote: Patch here adds a cpumask attr to hv_24x7 pmu along with ABI documentation. command:# cat /sys/devices/hv_24x7/cpumask 0 Since this sysfs interface is read-only, and the user

Re: [PATCH V3 0/4] mm/debug_vm_pgtable: Add some more tests

2020-06-24 Thread Gerald Schaefer
On Wed, 24 Jun 2020 13:05:39 +0200 Alexander Gordeev wrote: > On Wed, Jun 24, 2020 at 08:43:10AM +0530, Anshuman Khandual wrote: > > [...] > > > Hello Gerald/Christophe/Vineet, > > > > It would be really great if you could give this series a quick test > > on s390/ppc/arc platforms

[PATCH v2 2/6] powerpc/ppc-opcode: move ppc instruction encoding from test_emulate_step

2020-06-24 Thread Balamuruhan S
Few ppc instructions are encoded in test_emulate_step.c, consolidate them and use it from ppc-opcode.h Signed-off-by: Balamuruhan S Acked-by: Naveen N. Rao Tested-by: Naveen N. Rao Acked-by: Sandipan Das --- arch/powerpc/include/asm/ppc-opcode.h | 18 +++

[PATCH v2 1/6] powerpc/ppc-opcode: introduce PPC_RAW_* macros for base instruction encoding

2020-06-24 Thread Balamuruhan S
Introduce PPC_RAW_* macros to have all the bare encoding of ppc instructions. Move `VSX_XX*()` and `TMRN()` macros up to reuse it. Signed-off-by: Balamuruhan S Acked-by: Naveen N. Rao Tested-by: Naveen N. Rao --- arch/powerpc/include/asm/ppc-opcode.h | 90 --- 1 file

[PATCH v2 0/6] consolidate PowerPC instruction encoding macros

2020-06-24 Thread Balamuruhan S
ppc-opcode.h have base instruction encoding wrapped with stringify_in_c() for raw encoding to have compatibility. But there are redundant macros for base instruction encodings in bpf, instruction emulation test infrastructure and powerpc selftests. Currently PPC_INST_* macros are used for

Re: [PATCH v2 2/2] powerpc/hv-24x7: Add sysfs files inside hv-24x7 device to show cpumask

2020-06-24 Thread Gautham R Shenoy
Hi Kajol, On Wed, Jun 24, 2020 at 03:47:54PM +0530, Kajol Jain wrote: > Patch here adds a cpumask attr to hv_24x7 pmu along with ABI documentation. > > command:# cat /sys/devices/hv_24x7/cpumask > 0 Since this sysfs interface is read-only, and the user cannot change the CPU which will be making

Re: [PATCH v2 1/2] powerpc/perf/hv-24x7: Add cpu hotplug support

2020-06-24 Thread kajoljain
On 6/24/20 4:06 PM, Gautham R Shenoy wrote: > On Wed, Jun 24, 2020 at 03:47:53PM +0530, Kajol Jain wrote: >> Patch here adds cpu hotplug functions to hv_24x7 pmu. >> A new cpuhp_state "CPUHP_AP_PERF_POWERPC_HV_24x7_ONLINE" enum >> is added. >> >> The online function update the cpumask only if

Re: [PATCH v2 1/2] powerpc/perf/hv-24x7: Add cpu hotplug support

2020-06-24 Thread Gautham R Shenoy
On Wed, Jun 24, 2020 at 03:47:53PM +0530, Kajol Jain wrote: > Patch here adds cpu hotplug functions to hv_24x7 pmu. > A new cpuhp_state "CPUHP_AP_PERF_POWERPC_HV_24x7_ONLINE" enum > is added. > > The online function update the cpumask only if its NULL. ^^

Re: [PATCH v5 2/3] powerpc/numa: Prefer node id queried from vphn

2020-06-24 Thread Gautham R Shenoy
Hello Srikar, On Wed, Jun 24, 2020 at 02:58:45PM +0530, Srikar Dronamraju wrote: > Node id queried from the static device tree may not > be correct. For example: it may always show 0 on a shared processor. > Hence prefer the node id queried from vphn and fallback on the device tree > based node

[PATCH v2 0/2] Add cpu hotplug support for powerpc/perf/hv-24x7

2020-06-24 Thread Kajol Jain
This patchset add cpu hotplug support for hv_24x7 driver by adding online/offline cpu hotplug function. It also add sysfs file "cpumask" to expose current online cpu that can be used for hv_24x7 event count. Changelog: v1 -> v2 - Changed function to pick active cpu incase of offline from

Re: [PATCH v5 1/3] powerpc/numa: Set numa_node for all possible cpus

2020-06-24 Thread Gautham R Shenoy
On Wed, Jun 24, 2020 at 02:58:44PM +0530, Srikar Dronamraju wrote: > A Powerpc system with multiple possible nodes and with CONFIG_NUMA > enabled always used to have a node 0, even if node 0 does not any cpus > or memory attached to it. As per PAPR, node affinity of a cpu is only > available once

[PATCH v5 3/3] mm/page_alloc: Keep memoryless cpuless node 0 offline

2020-06-24 Thread Srikar Dronamraju
Currently Linux kernel with CONFIG_NUMA on a system with multiple possible nodes, marks node 0 as online at boot. However in practice, there are systems which have node 0 as memoryless and cpuless. This can cause numa_balancing to be enabled on systems with only one node with memory and CPUs.

[PATCH v5 2/3] powerpc/numa: Prefer node id queried from vphn

2020-06-24 Thread Srikar Dronamraju
Node id queried from the static device tree may not be correct. For example: it may always show 0 on a shared processor. Hence prefer the node id queried from vphn and fallback on the device tree based node id if vphn query fails. Cc: linuxppc-dev@lists.ozlabs.org Cc: linux...@kvack.org Cc:

[PATCH v5 1/3] powerpc/numa: Set numa_node for all possible cpus

2020-06-24 Thread Srikar Dronamraju
A Powerpc system with multiple possible nodes and with CONFIG_NUMA enabled always used to have a node 0, even if node 0 does not any cpus or memory attached to it. As per PAPR, node affinity of a cpu is only available once its present / online. For all cpus that are possible but not present,

[PATCH v5 0/3] Offline memoryless cpuless node 0

2020-06-24 Thread Srikar Dronamraju
Changelog v4:->v5: - rebased to v5.8-rc2 link v4: http://lore.kernel.org/lkml/20200512132937.19295-1-sri...@linux.vnet.ibm.com/t/#u Changelog v3:->v4: - Resolved comments from Christopher. Link v3: http://lore.kernel.org/lkml/20200501031128.19584-1-sri...@linux.vnet.ibm.com/t/#u Changelog

Re: [PATCH v4 7/8] lockdep: Change hardirq{s_enabled,_context} to per-cpu variables

2020-06-24 Thread Peter Zijlstra
On Tue, Jun 23, 2020 at 10:24:04PM +0200, Peter Zijlstra wrote: > On Tue, Jun 23, 2020 at 08:12:32PM +0200, Peter Zijlstra wrote: > > Fair enough; I'll rip it all up and boot a KCSAN kernel, see what if > > anything happens. > > OK, so the below patch doesn't seem to have any nasty recursion

[PATCH v2 6/6] powerpc/pseries/iommu: Avoid errors when DDW starts at 0x00

2020-06-24 Thread Leonardo Bras
As of today, enable_ddw() will return a non-null DMA address if the created DDW maps the whole partition. If the address is valid, iommu_bypass_supported_pSeriesLP() will consider iommu bypass enabled. This can cause some trouble if the DDW happens to start at 0x00. Instead if checking if the

[PATCH v2 5/6] powerpc/pseries/iommu: Make use of DDW even if it does not map the partition

2020-06-24 Thread Leonardo Bras
As of today, if a DDW is created and can't map the whole partition, it's removed and the default DMA window "ibm,dma-window" is used instead. Usually this DDW is bigger than the default DMA window, so it would be better to make use of it instead. Signed-off-by: Leonardo Bras ---

[PATCH v2 4/6] powerpc/pseries/iommu: Remove default DMA window before creating DDW

2020-06-24 Thread Leonardo Bras
On LoPAR "DMA Window Manipulation Calls", it's recommended to remove the default DMA window for the device, before attempting to configure a DDW, in order to make the maximum resources available for the next DDW to be created. This is a requirement for some devices to use DDW, given they only

[PATCH v2 3/6] powerpc/pseries/iommu: Move window-removing part of remove_ddw into remove_dma_window

2020-06-24 Thread Leonardo Bras
Move the window-removing part of remove_ddw into a new function (remove_dma_window), so it can be used to remove other DMA windows. It's useful for removing DMA windows that don't create DIRECT64_PROPNAME property, like the default DMA window from the device, which uses "ibm,dma-window".

[PATCH v2 2/6] powerpc/pseries/iommu: Update call to ibm, query-pe-dma-windows

2020-06-24 Thread Leonardo Bras
>From LoPAR level 2.8, "ibm,ddw-extensions" index 3 can make the number of outputs from "ibm,query-pe-dma-windows" go from 5 to 6. This change of output size is meant to expand the address size of largest_available_block PE TCE from 32-bit to 64-bit, which ends up shifting page_size and

[PATCH v2 1/6] powerpc/pseries/iommu: Create defines for operations in ibm, ddw-applicable

2020-06-24 Thread Leonardo Bras
Create defines to help handling ibm,ddw-applicable values, avoiding confusion about the index of given operations. Signed-off-by: Leonardo Bras --- arch/powerpc/platforms/pseries/iommu.c | 40 +++--- 1 file changed, 23 insertions(+), 17 deletions(-) diff --git

[PATCH v2 0/6] Remove default DMA window before creating DDW

2020-06-24 Thread Leonardo Bras
There are some devices that only allow 1 DMA window to exist at a time, and in those cases, a DDW is never created to them, since the default DMA window keeps using this resource. LoPAR recommends this procedure: 1. Remove the default DMA window, 2. Query for which configs the DDW can be created,