Re: [PATCH 11/20] irqchip/atmel-aic: convert to of_property_for_each_u32_new()

2024-07-03 Thread Nicolas Ferre
On 03/07/2024 at 12:36, Luca Ceresoli wrote: Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli Acked-by: Nicolas Ferre --- drivers/irqchip/irq-atmel-aic-common.c | 4 +--- 1

Re: [PATCH 64/64] i2c: reword i2c_algorithm in drivers according to newest specification

2024-03-22 Thread Nicolas Ferre
rivers/i2c/busses/i2c-at91-master.c | 2 +- drivers/i2c/busses/i2c-at91-slave.c| 8 [..] Acked-by: Nicolas Ferre # for at91 Probably file names themselves will need some care, in a second time. Thanks. Regards, Nicolas [..] -- 2.43.0

Re: [PATCH] net: Use of_property_read_bool() for boolean properties

2023-03-13 Thread Nicolas Ferre
for reading properties. Convert reading boolean properties to to of_property_read_bool(). Signed-off-by: Rob Herring --- drivers/net/can/cc770/cc770_platform.c | 12 ++-- drivers/net/ethernet/cadence/macb_main.c| 2 +- Acked-by: Nicolas Ferre drivers/net/ethernet

Re: [PATCH] watchdog: add SPDX identifiers for watchdog subsystem

2018-02-20 Thread Nicolas Ferre
_wdt.c | 3 +- And this one: Acked-by: Nicolas Ferre <nicolas.fe...@microchip.com> Thanks, best regards, -- Nicolas Ferre

Re: [PATCH 2/3] ARM: dts: at91: usb_a9g20: fix rtc node

2017-09-15 Thread Nicolas Ferre
On 15/09/2017 at 04:00, Alexandre Belloni wrote: > The rv3029 compatible is missing its vendor string, add it. > Also fix the node name to be a proper generic name. > > Signed-off-by: Alexandre Belloni <alexandre.bell...@free-electrons.com> Acked-by: Nicolas Ferre <nicola

Re: [PATCH] usb: Convert pr_warning to pr_warn

2016-09-28 Thread Nicolas Ferre
| 9 - > drivers/usb/gadget/function/u_serial.c | 4 ++-- > drivers/usb/gadget/udc/at91_udc.h | 2 +- > drivers/usb/gadget/udc/atmel_usba_udc.c | 4 ++-- For AT91 and Atmel parts: Acked-by: Nicolas Ferre <nicolas.fe...@atmel.com> Thanks > drivers/usb/gadget/

Re: [PATCH 31/44] arm: Register with kernel poweroff handler

2014-10-07 Thread Nicolas Ferre
the CPU in sleep mode, select a priority of 0 to indicate that the poweroff handler is one of last resort. If the poweroff handler powers off the system, select a priority of 128. Cc: Russell King li...@arm.linux.org.uk Cc: Andrew Victor li...@maxim.org.za Cc: Nicolas Ferre nicolas.fe

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Nicolas Ferre
: Acked-by: Nicolas Ferre nicolas.fe...@atmel.com [..] diff --git a/drivers/usb/host/ehci-atmel.c b/drivers/usb/host/ehci-atmel.c index 3b645ff..5831a88 100644 --- a/drivers/usb/host/ehci-atmel.c +++ b/drivers/usb/host/ehci-atmel.c @@ -92,8 +92,9 @@ static int ehci_atmel_drv_probe(struct

Re: [PATCH 119/493] usb: remove use of __devexit_p

2012-11-20 Thread Nicolas Ferre
Cc: linux-arm-ker...@lists.infradead.org Cc: linux-samsung-...@vger.kernel.org [..] drivers/usb/host/ehci-atmel.c| 2 +- drivers/usb/host/ohci-at91.c | 2 +- For Atmel: Acked-by: Nicolas Ferre nicolas.fe...@atmel.com [..] diff --git a/drivers/usb/c67x00/c67x00-drv.c b

Re: [PATCH 161/493] tty: remove use of __devinit

2012-11-20 Thread Nicolas Ferre
: sparcli...@vger.kernel.org Cc: linux-arm-ker...@lists.infradead.org drivers/tty/serial/atmel_serial.c | 6 +++--- Acked-by: Nicolas Ferre nicolas.fe...@atmel.com diff --git a/drivers/tty/cyclades.c b/drivers/tty/cyclades.c index 0244acf..444b544 100644 --- a/drivers/tty

Re: [PATCH v2 0/9] DMA engine cookie handling cleanups

2012-03-13 Thread Nicolas Ferre
| 48 drivers/dma/at_hdmac_regs.h |2 - For at_hdmac Atmel DMA driver: Tested-by: Nicolas Ferre nicolas.fe...@atmel.com Thanks a lot Russell. Best regards, -- Nicolas Ferre ___ Linuxppc-dev mailing list

Re: [PATCH v3 24/25] irq_domain: remove hint when allocating irq numbers

2012-02-15 Thread Nicolas Ferre
On 02/07/2012 07:07 PM, Nicolas Ferre : On 01/27/2012 10:36 PM, Grant Likely : The 'hint' used to try and line up irq numbers with hw irq numbers is rather a hack and not very useful. Now that /proc/interrupts also outputs the hwirq number, it is even less useful to keep around the 'hint

Re: [PATCH v3 25/25] irq_domain: mostly eliminate slow-path revmap lookups

2012-02-15 Thread Nicolas Ferre
])) - revmap[hwirq] = irq_find_mapping(domain, hwirq); + revmap[hwirq] = irq_find_mapping_slow(domain, hwirq); return revmap[hwirq]; } Bye, -- Nicolas Ferre ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https

Re: [PATCH v3 24/25] irq_domain: remove hint when allocating irq numbers

2012-02-07 Thread Nicolas Ferre
, While trying your patch series in conjunction with Rob one, I do not find this patch in your irqdomain/next branch (and a couple of others). Can you tell me if this v3 series is available as a git tree? Thanks, best regards, -- Nicolas Ferre