RE: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread David Laight
> > On Thu, Jan 21, 2021 at 11:00:20AM +0100, Christophe Leroy wrote: > > > +bool module_loaded(const char *name); > > > > Maybe module_is_loaded() would be a better name. > > Fine with me. It does look like both callers aren't 'unsafe'. But it is a bit strange returning a stale value. It did m

Re: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread Christoph Hellwig
On Thu, Jan 21, 2021 at 11:00:20AM +0100, Christophe Leroy wrote: > > +bool module_loaded(const char *name); > > Maybe module_is_loaded() would be a better name. Fine with me.

Re: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread Christophe Leroy
Le 21/01/2021 à 11:13, David Laight a écrit : From: Christophe Leroy Sorry I hit "Reply to the list" instead of "Reply all" Cc Christoph H. who is the author. Sent: 21 January 2021 10:00 Le 21/01/2021 à 08:49, Christoph Hellwig a écrit : Add a helper that takes modules_mutex and uses find_

RE: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread David Laight
From: Christophe Leroy > Sent: 21 January 2021 10:00 > > Le 21/01/2021 à 08:49, Christoph Hellwig a écrit : > > Add a helper that takes modules_mutex and uses find_module to check if a > > given module is loaded. This provides a better abstraction for the two > > callers, and allows to unexport m

Re: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread Christophe Leroy
Le 21/01/2021 à 08:49, Christoph Hellwig a écrit : > Add a helper that takes modules_mutex and uses find_module to check if a > given module is loaded. This provides a better abstraction for the two > callers, and allows to unexport modules_mutex and find_module. > > Signed-off-by: Christoph

Re: [PATCH 02/13] module: add a module_loaded helper

2021-01-21 Thread Christophe Leroy
Le 21/01/2021 à 08:49, Christoph Hellwig a écrit : Add a helper that takes modules_mutex and uses find_module to check if a given module is loaded. This provides a better abstraction for the two callers, and allows to unexport modules_mutex and find_module. Signed-off-by: Christoph Hellwig