Re: [Lldb-commits] [PATCH] D17635: Continue after process exit

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. I can remove that comment for you, no worries. http://reviews.llvm.org/D17635 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [lldb] r263333 - Let's not convert from UINT32_MAX to the std::numeric_limits version.

2016-03-19 Thread Joerg Sonnenberger via lldb-commits
On Tue, Mar 15, 2016 at 09:20:17PM +, Zachary Turner via lldb-commits wrote: > Is the stdint version better somehow? I thought C++ numeric_limits were > actually preferred over the C macros. It's quite a bit shorter and more readable? That sounds like a good reason to me. Joerg _

Re: [Lldb-commits] [PATCH] D18287: Don't try to redefine the signal() function on Windows

2016-03-19 Thread Zachary Turner via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL263858: Delete the custom implementation of signal() on Windows. (authored by zturner). Changed prior to commit: http://reviews.llvm.org/D18287?vs=51090&id=51093#toc Repository: rL LLVM http://revie

Re: [Lldb-commits] [PATCH] D17635: Continue after process exit

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. Petr, is this one ok to go in? http://reviews.llvm.org/D17635 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [lldb] r263858 - Delete the custom implementation of signal() on Windows.

2016-03-19 Thread Zachary Turner via lldb-commits
Author: zturner Date: Fri Mar 18 18:47:48 2016 New Revision: 263858 URL: http://llvm.org/viewvc/llvm-project?rev=263858&view=rev Log: Delete the custom implementation of signal() on Windows. The Windows SDK provides a version of signal() that is much more limited compared to other platforms. It

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Cameron via lldb-commits
cameron314 added a comment. I think we're in different time zones -- I'm heading home for the day, but I'll look back in the morning to see if there's anything else that needs addressing. http://reviews.llvm.org/D17107 ___ lldb-commits mailing list

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. I can look at it today. Sorry again for the delay, rebase 1 more time and I'll check it out today http://reviews.llvm.org/D17107 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailma

Re: [Lldb-commits] [lldb] r263520 - Add some test coverage for the changes in alias help

2016-03-19 Thread Zachary Turner via lldb-commits
Hi Enrico, These tests are failing on Windows. They're new tests so not really a regression, but do you have any idea what might be wrong? Basically, when the test runs, the help po is displaying the full output of "help expression". But strangely, if I go into lldb and run "help po" there, it'

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-19 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. http://reviews.llvm.org/D17970 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/li

Re: [Lldb-commits] Improving the documentation

2016-03-19 Thread John Lindal via lldb-commits
I added a reference in the class documentation. Should I submit it via a ticket? Thanks! John On Tue, Mar 15, 2016 at 5:51 PM, Jim Ingham wrote: > The only other suggestion I have is that the first time we refer to a > module in this file > we should say "(see SBModule)" or something like that

[Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Francis Ricci via lldb-commits
fjricci created this revision. fjricci added reviewers: clayborg, granata.enrico, Eugene.Zelenko, jingham. fjricci added subscribers: sas, lldb-commits. Fixes SBCommandReturnObject::SetImmediateOutputFile() and SBCommandReturnObject::SetImmediateOutputFile() for files opened with "a" or "a+" by re

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Cameron via lldb-commits
cameron314 updated this revision to Diff 50979. http://reviews.llvm.org/D17107 Files: cmake/modules/LLDBConfig.cmake include/lldb/Host/FileSystem.h include/lldb/Host/posix/HostInfoPosix.h include/lldb/Host/windows/HostInfoWindows.h packages/Python/lldbsuite/test/dotest.py source/Comma

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. I'm getting this when linking: [826/826] Linking CXX executable bin\lldb.exe FAILED: cmd.exe /C "cd . && "C:\Program Files (x86)\CMake\bin\cmake.exe" -E vs_link_exe --intdir=tools\lldb\tools\driver\CMakeFiles\lldb.dir --manifests -- C:\PROGRA~2\MICROS~3.0\VC\bin\AM

Re: [Lldb-commits] [PATCH] D18287: Don't try to redefine the signal() function on Windows

2016-03-19 Thread Cameron via lldb-commits
cameron314 added inline comments. Comment at: tools/driver/Driver.cpp:1314 @@ -1313,1 +1313,3 @@ +signal(SIGINT, sigint_handler); +#ifndef _MSC_VER signal (SIGPIPE, SIG_IGN); zturner wrote: > I think `_MSC_VER` is the right check, because the builtin `sig

Re: [Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Francis Ricci via lldb-commits
fjricci updated this revision to Diff 51005. fjricci added a comment. Always use write flag, even in append mode http://reviews.llvm.org/D18228 Files: source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp Index: source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp ==

Re: [Lldb-commits] [PATCH] D17635: Continue after process exit

2016-03-19 Thread Petr Hons via lldb-commits
Honsik added a comment. Yes please, with that comment change jingham has mentioned. Do you want me to create new diff? http://reviews.llvm.org/D17635 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/li

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Cameron via lldb-commits
cameron314 added a comment. Since it works without my patch, you're probably right about it being related to the UNICODE define. All the other changes are completely removed from that part of the code. But I still don't see how it could affect that. Here's the script I use to run cmake: setl

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. I'm using the amd64_x86 toolchain. They're supposed to be identical so that's unlikely to be the problem, but it's the only difference i can see. Let me know what happens on your clean rebuild http://reviews.llvm.org/D17107

Re: [Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Francis Ricci via lldb-commits
fjricci updated this revision to Diff 51113. fjricci added a comment. Added unit test for python file api http://reviews.llvm.org/D18228 Files: packages/Python/lldbsuite/test/functionalities/command_script_immediate_output/TestCommandScriptImmediateOutput.py packages/Python/lldbsuite/test

Re: [Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Francis Ricci via lldb-commits
fjricci added a comment. I want to add this testing to functionalities/command_script_immediate_output/TestCommandScriptImmediateOutput.py, since that test is already very basic coverage of the same functionality. However, it appears that TestCommandScriptImmediateOutput is an expected fail on

[Lldb-commits] [lldb] r263735 - Fix deadlock due to thread list locking in 'bt all' with obj-c

2016-03-19 Thread Stephane Sezer via lldb-commits
Author: sas Date: Thu Mar 17 13:52:41 2016 New Revision: 263735 URL: http://llvm.org/viewvc/llvm-project?rev=263735&view=rev Log: Fix deadlock due to thread list locking in 'bt all' with obj-c Summary: The gdb-remote async thread cannot modify thread state while the main thread holds a lock on th

[Lldb-commits] [lldb] r263637 - Fix null pointer "dereference" in DomainSocket

2016-03-19 Thread Pavel Labath via lldb-commits
Author: labath Date: Wed Mar 16 09:03:20 2016 New Revision: 263637 URL: http://llvm.org/viewvc/llvm-project?rev=263637&view=rev Log: Fix null pointer "dereference" in DomainSocket offsetof is the official way to get the offset of a field in a structure. Modified: lldb/trunk/source/Host/posix

[Lldb-commits] [lldb] r263826 - Fixed an case fall through that wasn't meant to happen. Caught by clang's unannotated case fall through warning.

2016-03-19 Thread Greg Clayton via lldb-commits
Author: gclayton Date: Fri Mar 18 15:36:30 2016 New Revision: 263826 URL: http://llvm.org/viewvc/llvm-project?rev=263826&view=rev Log: Fixed an case fall through that wasn't meant to happen. Caught by clang's unannotated case fall through warning. Modified: lldb/trunk/source/Plugins/SymbolFi

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
I can look at it today. Sorry again for the delay, rebase 1 more time and I'll check it out today On Thu, Mar 17, 2016 at 11:34 AM Cameron wrote: > cameron314 added a comment. > > @zturner: Let me know when you're ready for this patch and I'll rebase it > again, since there's been quite a few m

Re: [Lldb-commits] [PATCH] D18059: Add IR fixups for RenderScript ABI mismatch between ARMV7 frontend and x86 backend

2016-03-19 Thread Greg Clayton via lldb-commits
clayborg resigned from this revision. clayborg edited reviewers, added: spyffe; removed: clayborg. clayborg added a comment. Sean Callanan would have more expertise in this area. 1. List Item http://reviews.llvm.org/D18059 ___ lldb-commits mailing

Re: [Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Greg Clayton via lldb-commits
clayborg added a comment. Just to be clear in the code we should set the write flag and not make any assumptions. So then the first diff isn't needed and only PythonDataObjects.cpp needs to change. http://reviews.llvm.org/D18228 ___ lldb-commits m

Re: [Lldb-commits] [PATCH] D18044: Fix a couple of cornercases in FileSpec + tests

2016-03-19 Thread Zachary Turner via lldb-commits
Yea, because of the fact that we must support both syntaxes on both platforms, LLVM library is out. The whole motivation for introducing the path syntax is so that windows paths behave as if on Windows even if on linux On Wed, Mar 16, 2016 at 6:19 AM Pavel Labath wrote: > labath added inline com

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
I'm using the amd64_x86 toolchain. They're supposed to be identical so that's unlikely to be the problem, but it's the only difference i can see. Let me know what happens on your clean rebuild On Fri, Mar 18, 2016 at 7:56 AM Cameron wrote: > cameron314 added a comment. > > Since it works without

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Cameron via lldb-commits
cameron314 added a comment. Hmm, that doesn't seem good. Locally it links for me (I get compile time warnings about the signal stuff, though). It looks like the WinSDK signal.h is being pulled in despite `_INC_SIGNAL` being defined (note that there's no include guard in that header -- it uses `

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. I'm not sure what your source tree layout looks like, but this isn't applying for me. All your paths have "trunk" in front of them, which is a little unusual in the directory structure is supposed to be something like this: llvm tools lldb source A

Re: [Lldb-commits] [PATCH] D18228: Make File option flags consistent for Python API

2016-03-19 Thread Francis Ricci via lldb-commits
fjricci added a comment. So this was definitely a decision that I was debating. But I assume that the Append flag must imply the Write flag, since you can't open a file for Append without also opening it for write ("a" and "a+" both include write privileges). So I figured that having both "Appe

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
zturner added a comment. Oh yea I think the reason I didn't look at it again is because I was waiting for the update where you removed the codepage stuff from the driver. http://reviews.llvm.org/D17107 ___ lldb-commits mailing list lldb-commits@list

[Lldb-commits] [lldb] r263844 - Fix a build issue where the python module could become stale.

2016-03-19 Thread Zachary Turner via lldb-commits
Author: zturner Date: Fri Mar 18 17:33:59 2016 New Revision: 263844 URL: http://llvm.org/viewvc/llvm-project?rev=263844&view=rev Log: Fix a build issue where the python module could become stale. We are using hardlinks instead of symlinks, and we attempted to have some logic where we don't re-cre

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-19 Thread Stephane Sezer via lldb-commits
sas updated this revision to Diff 50978. sas added a comment. Change implementation according to @clayborg's comments. http://reviews.llvm.org/D17970 Files: source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.h Index: source/Plugins/Objec

Re: [Lldb-commits] [PATCH] D18044: Fix a couple of cornercases in FileSpec + tests

2016-03-19 Thread Pavel Labath via lldb-commits
labath added inline comments. Comment at: lldb/trunk/unittests/Host/FileSpecTest.cpp:25 @@ +24,3 @@ +EXPECT_STREQ("F:\\bar", fs_windows.GetCString()); +EXPECT_STREQ("F:", fs_windows.GetDirectory().GetCString()); +EXPECT_STREQ("bar", fs_windows.GetFilename().GetCString(

[Lldb-commits] LLVM buildmaster will be restarted tonight

2016-03-19 Thread Galina Kistanova via lldb-commits
Hello everyone, LLVM buildmaster will be updated and restarted after 7 PM Pacific time today. Thanks Galina ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Zachary Turner via lldb-commits
Oh yea I think the reason I didn't look at it again is because I was waiting for the update where you removed the codepage stuff from the driver. On Thu, Mar 17, 2016 at 11:39 AM Zachary Turner wrote: > I can look at it today. Sorry again for the delay, rebase 1 more time and > I'll check it ou

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-19 Thread Stephane Sezer via lldb-commits
sas added a comment. Yep, @jingham is right, I need this for expression evaluation. I'll do the change @clayborg requested. http://reviews.llvm.org/D17970 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailm

Re: [Lldb-commits] [PATCH] D17107: [lldb] Unicode support on Win32

2016-03-19 Thread Cameron via lldb-commits
cameron314 added a comment. Ah. Sorry. I have the same source layout as you locally, but I changed the paths in the patch to match the layout of Diffusion (http://reviews.llvm.org/diffusion/L/). I'll redo the patch with relative paths from lldb... http://reviews.llvm.org/D17107 ___

Re: [Lldb-commits] [lldb] r263520 - Add some test coverage for the changes in alias help

2016-03-19 Thread Zachary Turner via lldb-commits
Huh, your hypothesis might be correct. The symlink of the python extension module pointing to liblldb is out of date, and not getting updated. Never seen this happen before, but that sounds like it's probably the culprit. On Fri, Mar 18, 2016 at 2:49 PM Enrico Granata wrote: > On Mar 18, 2016

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-19 Thread Stephane Sezer via lldb-commits
sas added a comment. FWIW, I didn't cache this value because in the current form it is just returning some data that is already cached by `ParseHeader()`. If I split it in section/offset address, it might be required. http://reviews.llvm.org/D17970 __

Re: [Lldb-commits] [PATCH] D18194: Abstract the debug info parser from the ASTContext

2016-03-19 Thread Zachary Turner via lldb-commits
zturner updated this revision to Diff 50840. zturner added a comment. Re-opening this after an update. I had to move `CanCompleteType`, `CompleteType`, and `LayoutRecordType` implementations into another class (which I've called `ClangTypeImportHelper`, because PDB needed to use the exact same

Re: [Lldb-commits] [PATCH] D18075: Fix deadlock due to thread list locking in 'bt all' with obj-c

2016-03-19 Thread Stephane Sezer via lldb-commits
sas closed this revision. sas added a comment. Committed as r263735. http://reviews.llvm.org/D18075 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits