[Lldb-commits] [PATCH] D34683: [unittests] Add a helper function for getting an input file

2017-06-27 Thread Zachary Turner via Phabricator via lldb-commits
zturner added inline comments. Comment at: unittests/Utility/Helpers/TestUtilities.cpp:17 + +std::string lldb_private::GetInputFile(llvm::Twine name) { + llvm::SmallString<128> result = llvm::sys::path::parent_path(TestMainArgv0); this should be `const Twine &na

[Lldb-commits] [lldb] r306469 - Upstream the 'eInstrumentationRuntimeTypeSwiftRuntimeReporting' value of the 'eInstrumentationRuntimeType' enum from the swift-lldb project (to avoid potential clashes)

2017-06-27 Thread Kuba Mracek via lldb-commits
Author: kuba.brecka Date: Tue Jun 27 14:39:15 2017 New Revision: 306469 URL: http://llvm.org/viewvc/llvm-project?rev=306469&view=rev Log: Upstream the 'eInstrumentationRuntimeTypeSwiftRuntimeReporting' value of the 'eInstrumentationRuntimeType' enum from the swift-lldb project (to avoid potentia

[Lldb-commits] [PATCH] D34683: [unittests] Add a helper function for getting an input file

2017-06-27 Thread Eugene Zemtsov via Phabricator via lldb-commits
eugene accepted this revision. eugene added a comment. This revision is now accepted and ready to land. Great change. The only comment I have is about location of TestUtilities.cpp. Utility\Helpers kinda implies that these are helpers for Utility tests which is not true. I would move it up one l

[Lldb-commits] [lldb] r306460 - [build system] If there's an OVERRIDE, don't guess the current SCM.

2017-06-27 Thread Sean Callanan via lldb-commits
Author: spyffe Date: Tue Jun 27 13:35:53 2017 New Revision: 306460 URL: http://llvm.org/viewvc/llvm-project?rev=306460&view=rev Log: [build system] If there's an OVERRIDE, don't guess the current SCM. This makes automatic checkout work even in situations where the current repository can't be dete

[Lldb-commits] [PATCH] D34681: [DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections

2017-06-27 Thread Tatyana Krasnukha via Phabricator via lldb-commits
tatyana-krasnukha added a comment. Saying about clear intent, it would be even much more better if class name doesn't start with DWARF ;) https://reviews.llvm.org/D34681 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.or

[Lldb-commits] [lldb] r306445 - Fix up the Xcode project:

2017-06-27 Thread Jim Ingham via lldb-commits
Author: jingham Date: Tue Jun 27 11:48:32 2017 New Revision: 306445 URL: http://llvm.org/viewvc/llvm-project?rev=306445&view=rev Log: Fix up the Xcode project: 1) Renaming the InstrumentationRuntime directory & file names 2) Bunch of stuff moved from Core to Utility 3) Deleted a bunch of files re

[Lldb-commits] [PATCH] D34681: [DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections

2017-06-27 Thread Greg Clayton via Phabricator via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. https://reviews.llvm.org/D34681 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/l

[Lldb-commits] [PATCH] D33674: Implementation of Intel(R) Processor Trace support for Linux

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. I still see some room for improvement, but some of those require some infrastructure improvements, like being able to construct llvm::StringError (or equivalent easily), which I guess will hav

[Lldb-commits] [PATCH] D33674: Implementation of Intel(R) Processor Trace support for Linux

2017-06-27 Thread Ravitheja Addepally via Phabricator via lldb-commits
ravitheja updated this revision to Diff 104160. ravitheja added a comment. Removing Destroy() function. https://reviews.llvm.org/D33674 Files: include/lldb/Host/common/NativeProcessProtocol.h include/lldb/Host/linux/Support.h source/Host/linux/Support.cpp source/Plugins/Process/Linux/CM

[Lldb-commits] [PATCH] D34683: [unittests] Add a helper function for getting an input file

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
labath created this revision. Herald added subscribers: mgorny, emaste. Fetching an input file required about five lines of code, and this was repeated in multiple unit tests, with slight variations. Add a helper function for doing that into the lldbUtilityMocks module (which I rename to lldbUtili

[Lldb-commits] [lldb] r306400 - Fix windows build for the Connection move

2017-06-27 Thread Pavel Labath via lldb-commits
Author: labath Date: Tue Jun 27 04:45:32 2017 New Revision: 306400 URL: http://llvm.org/viewvc/llvm-project?rev=306400&view=rev Log: Fix windows build for the Connection move Modified: lldb/trunk/include/lldb/Host/windows/ConnectionGenericFileWindows.h Modified: lldb/trunk/include/lldb/Host/

[Lldb-commits] [PATCH] D34681: [DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
labath created this revision. instead of using a boolean to differentiate between the two section types, use an enum to make the intent clearer. I also remove the RegisterKind argument from the constructor, as this can be deduced from the Type argument. https://reviews.llvm.org/D34681 Files:

[Lldb-commits] [PATCH] D34613: Add debug_frame section support

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL306397: Add debug_frame section support (authored by labath). Changed prior to commit: https://reviews.llvm.org/D34613?vs=103922&id=104134#toc Repository: rL LLVM https://reviews.llvm.org/D34613 Fil

[Lldb-commits] [lldb] r306397 - Add debug_frame section support

2017-06-27 Thread Pavel Labath via lldb-commits
Author: labath Date: Tue Jun 27 04:16:26 2017 New Revision: 306397 URL: http://llvm.org/viewvc/llvm-project?rev=306397&view=rev Log: Add debug_frame section support Summary: This is a beefed-up version of D33504, which adds support for dwarf 4 debug_frame section format. The main difference here

[Lldb-commits] [PATCH] D34613: Add debug_frame section support

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: include/lldb/Symbol/DWARFCallFrameInfo.h:38 DWARFCallFrameInfo(ObjectFile &objfile, lldb::SectionSP §ion, lldb::RegisterKind reg_kind, bool is_eh_frame); clayborg wrote: > labath wrote: > > clay

[Lldb-commits] [PATCH] D34625: Move StructuredData from Core to Utility

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL306394: Move StructuredData from Core to Utility (authored by labath). Changed prior to commit: https://reviews.llvm.org/D34625?vs=103976&id=104127#toc Repository: rL LLVM https://reviews.llvm.org/D

[Lldb-commits] [lldb] r306394 - Move StructuredData from Core to Utility

2017-06-27 Thread Pavel Labath via lldb-commits
Author: labath Date: Tue Jun 27 03:45:31 2017 New Revision: 306394 URL: http://llvm.org/viewvc/llvm-project?rev=306394&view=rev Log: Move StructuredData from Core to Utility Summary: It had a dependency on StringConvert and file reading code, which is not in Utility. I've replaced that code by eq

[Lldb-commits] [PATCH] D34400: Move Connection from Core to Host

2017-06-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL306391: Move Connection and IOObject interfaces to Utility module (authored by labath). Changed prior to commit: https://reviews.llvm.org/D34400?vs=103971&id=104125#toc Repository: rL LLVM https://r

[Lldb-commits] [lldb] r306391 - Move Connection and IOObject interfaces to Utility module

2017-06-27 Thread Pavel Labath via lldb-commits
Author: labath Date: Tue Jun 27 03:33:14 2017 New Revision: 306391 URL: http://llvm.org/viewvc/llvm-project?rev=306391&view=rev Log: Move Connection and IOObject interfaces to Utility module Summary: These interfaces have no dependencies, so it makes sense for them to be in the lowest level modul