[Lldb-commits] [lldb] r346294 - Add a break to avoid an unannotated fall-through.

2018-11-06 Thread Eric Christopher via lldb-commits
Author: echristo Date: Tue Nov 6 21:17:31 2018 New Revision: 346294 URL: http://llvm.org/viewvc/llvm-project?rev=346294&view=rev Log: Add a break to avoid an unannotated fall-through. Modified: lldb/trunk/source/Plugins/Language/CPlusPlus/MSVCUndecoratedNameParser.cpp Modified: lldb/trunk/

[Lldb-commits] [lldb] r346285 - Standardize the OTHER_LDFLAGS for the lldb-gtest-build target.

2018-11-06 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Tue Nov 6 17:19:52 2018 New Revision: 346285 URL: http://llvm.org/viewvc/llvm-project?rev=346285&view=rev Log: Standardize the OTHER_LDFLAGS for the lldb-gtest-build target. Modified: lldb/trunk/lldb.xcodeproj/project.pbxproj Modified: lldb/trunk/lldb.xcodeproj/projec

Re: [Lldb-commits] [lldb] r346278 - Add MSVCUndecoratedNameParser.cpp.

2018-11-06 Thread Davide Italiano via lldb-commits
Thank you Jason! -- Davide On Tue, Nov 6, 2018 at 3:03 PM Jason Molenda via lldb-commits wrote: > > Author: jmolenda > Date: Tue Nov 6 15:01:42 2018 > New Revision: 346278 > > URL: http://llvm.org/viewvc/llvm-project?rev=346278&view=rev > Log: > Add MSVCUndecoratedNameParser.cpp. > > Modified: >

[Lldb-commits] [lldb] r346283 - Compiler warning pointed out a mistake - fix it.

2018-11-06 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Tue Nov 6 16:25:02 2018 New Revision: 346283 URL: http://llvm.org/viewvc/llvm-project?rev=346283&view=rev Log: Compiler warning pointed out a mistake - fix it. Modified: lldb/trunk/source/Plugins/Platform/MacOSX/PlatformMacOSX.cpp Modified: lldb/trunk/source/Plugins/

[Lldb-commits] [PATCH] D53959: Remove working directory for debugserver code signing target

2018-11-06 Thread Nathan Lanza via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rLLDB346281: Remove working directory for debugserver code signing target (authored by lanza, committed by ). Herald added a subscriber: lldb-commits. Changed prior to commit: https://reviews.llvm.org/D53

[Lldb-commits] [lldb] r346278 - Add MSVCUndecoratedNameParser.cpp.

2018-11-06 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Tue Nov 6 15:01:42 2018 New Revision: 346278 URL: http://llvm.org/viewvc/llvm-project?rev=346278&view=rev Log: Add MSVCUndecoratedNameParser.cpp. Modified: lldb/trunk/lldb.xcodeproj/project.pbxproj Modified: lldb/trunk/lldb.xcodeproj/project.pbxproj URL: http://llvm.

[Lldb-commits] [PATCH] D51566: Add a relocation to ObjectFileELF::ApplyRelocations and a test

2018-11-06 Thread Nathan Lanza via Phabricator via lldb-commits
lanza added a comment. LGTM and the test case passes. Thanks a lot, Davide! Repository: rLLDB LLDB https://reviews.llvm.org/D51566 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commi

[Lldb-commits] [PATCH] D54074: CPlusPlusLanguage: Use new demangler API to implement type substitution

2018-11-06 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added a comment. Much better, thank you! Repository: rL LLVM https://reviews.llvm.org/D54074 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [lldb] r346247 - [ObjectFile] Prefer reinterpret_cast<>

2018-11-06 Thread Davide Italiano via lldb-commits
Author: davide Date: Tue Nov 6 09:42:14 2018 New Revision: 346247 URL: http://llvm.org/viewvc/llvm-project?rev=346247&view=rev Log: [ObjectFile] Prefer reinterpret_cast<> Modified: lldb/trunk/unittests/ObjectFile/ELF/TestObjectFileELF.cpp Modified: lldb/trunk/unittests/ObjectFile/ELF/TestOb

[Lldb-commits] [PATCH] D54009: Refactor LLDB lit configuration files

2018-11-06 Thread Stella Stamenova via Phabricator via lldb-commits
stella.stamenova added a comment. In https://reviews.llvm.org/D54009#1284839, @zturner wrote: > In https://reviews.llvm.org/D54009#1284827, @stella.stamenova wrote: > > > Looks good. The formatting in lit.cfg.py is a bit messy (indentations, > > especially), but as long as the tests pass, this i

[Lldb-commits] [PATCH] D51566: Add a relocation to ObjectFileELF::ApplyRelocations and a test

2018-11-06 Thread Davide Italiano via Phabricator via lldb-commits
davide added a comment. In https://reviews.llvm.org/D51566#1288792, @davide wrote: > @lanza Hey Nathan, it looks like your test exposed an UB in > `ELFObjectFileReader`. May I ask you to take a look? > > - TEST 'lldb-Unit :: > ObjectFile/ELF/./ObjectFileELFTests/ObjectFileELFTest.TestAARCH64Rel

[Lldb-commits] [lldb] r346244 - [ObjectFileELF] Fix misaligned read/writes caught by UBSan.

2018-11-06 Thread Davide Italiano via lldb-commits
Author: davide Date: Tue Nov 6 09:11:34 2018 New Revision: 346244 URL: http://llvm.org/viewvc/llvm-project?rev=346244&view=rev Log: [ObjectFileELF] Fix misaligned read/writes caught by UBSan. Modified: lldb/trunk/source/Plugins/ObjectFile/ELF/ObjectFileELF.cpp lldb/trunk/unittests/Object

[Lldb-commits] [PATCH] D54135: Add convenience method in FileSystem to check if a path/filespec is a directory.

2018-11-06 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In https://reviews.llvm.org/D54135#1288254, @krytarowski wrote: > Why? We already put a lot of effort into reusing code from LLVM. This is still using code from LLVM, the `FileSystem` class is just an abstraction in between: 1. It uses LLVM's virtual file system.

[Lldb-commits] [PATCH] D54053: [NativePDB] Add the ability to create clang record decls from mangled names.

2018-11-06 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. In https://reviews.llvm.org/D54053#1288415, @aleksandr.urakov wrote: > In https://reviews.llvm.org/D54053#1286653, @zturner wrote: > > > Bleh, I think I found a problem with this approach. Since we assume > > everything is a namespace, it can lead to ambiguities. I thi

[Lldb-commits] [PATCH] D51566: Add a relocation to ObjectFileELF::ApplyRelocations and a test

2018-11-06 Thread Davide Italiano via Phabricator via lldb-commits
davide added a comment. @lanza Hey Nathan, it looks like your test exposed an UB in `ELFObjectFileReader`. May I ask you to take a look? - TEST 'lldb-Unit :: ObjectFile/ELF/./ObjectFileELFTests/ObjectFileELFTest.TestAARCH64Relocations' FAILED Note: Google Test filter = Ob

[Lldb-commits] [PATCH] D54074: CPlusPlusLanguage: Use new demangler API to implement type substitution

2018-11-06 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL346233: CPlusPlusLanguage: Use new demangler API to implement type substitution (authored by labath, committed by ). Herald added a subscriber: llvm-commits. Repository: rL LLVM https://reviews.llvm.or

[Lldb-commits] [lldb] r346233 - CPlusPlusLanguage: Use new demangler API to implement type substitution

2018-11-06 Thread Pavel Labath via lldb-commits
Author: labath Date: Tue Nov 6 07:41:37 2018 New Revision: 346233 URL: http://llvm.org/viewvc/llvm-project?rev=346233&view=rev Log: CPlusPlusLanguage: Use new demangler API to implement type substitution Summary: Now that llvm demangler supports more generic customization, we can implement type

[Lldb-commits] [PATCH] D54074: CPlusPlusLanguage: Use new demangler API to implement type substitution

2018-11-06 Thread Pavel Labath via Phabricator via lldb-commits
labath updated this revision to Diff 172764. labath added a comment. Thanks for the review. I have added some comments, and moved appending of the unmodified portion of the name into a separate function to aid readability. https://reviews.llvm.org/D54074 Files: source/Plugins/Language/CPlusP

[Lldb-commits] [PATCH] D53094: [pecoff] Implement ObjectFilePECOFF::GetDependedModules()

2018-11-06 Thread Aaron Smith via Phabricator via lldb-commits
asmith added a comment. The ability to dump dependent modules is in another review that is waiting on this one. https://reviews.llvm.org/D53096 https://reviews.llvm.org/D53094 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.l

[Lldb-commits] [PATCH] D54074: CPlusPlusLanguage: Use new demangler API to implement type substitution

2018-11-06 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz added inline comments. Comment at: source/Plugins/Language/CPlusPlus/CPlusPlusLanguage.cpp:337 +if (llvm::StringRef(First, Last - First).startswith(Search)) { + Result += llvm::StringRef(Written, First - Written); + Result += Replace; shaf

[Lldb-commits] [lldb] r346220 - Add parens to silence warning

2018-11-06 Thread Benjamin Kramer via lldb-commits
Author: d0k Date: Tue Nov 6 02:13:37 2018 New Revision: 346220 URL: http://llvm.org/viewvc/llvm-project?rev=346220&view=rev Log: Add parens to silence warning MSVCUndecoratedNameParser.cpp:25:36: warning: '&&' within '||' [-Wlogical-op-parentheses] Modified: lldb/trunk/source/Plugins/Langu

[Lldb-commits] [PATCH] D54053: [NativePDB] Add the ability to create clang record decls from mangled names.

2018-11-06 Thread Aleksandr Urakov via Phabricator via lldb-commits
aleksandr.urakov accepted this revision. aleksandr.urakov added a comment. In https://reviews.llvm.org/D54053#1286653, @zturner wrote: > Bleh, I think I found a problem with this approach. Since we assume > everything is a namespace, it can lead to ambiguities. I think we need to > actually c

[Lldb-commits] [PATCH] D53368: [Symbol] Search symbols with name and type in a symbol file

2018-11-06 Thread Aleksandr Urakov via Phabricator via lldb-commits
aleksandr.urakov added a comment. Yes, sure. It happens in the following functions: - `Module::ResolveSymbolContextForAddress` - `DynamicLoaderHexagonDYLD::SetRendezvousBreakpoint` through `findSymbolAddress` - `DynamicLoaderHexagonDYLD::RendezvousBreakpointHit` through `findSymbolAddress` - `J

[Lldb-commits] [lldb] r346213 - [PDB] Introduce `MSVCUndecoratedNameParser`

2018-11-06 Thread Aleksandr Urakov via lldb-commits
Author: aleksandr.urakov Date: Tue Nov 6 00:02:55 2018 New Revision: 346213 URL: http://llvm.org/viewvc/llvm-project?rev=346213&view=rev Log: [PDB] Introduce `MSVCUndecoratedNameParser` This patch introduces the simple MSVCUndecoratedNameParser. It is needed for parsing names of PDB symbols corr