[Lldb-commits] [lldb] 9a3dbc9 - [lldb] Move finish_swig logic into a function in the binding dir

2020-07-29 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-07-29T17:59:56-07:00 New Revision: 9a3dbc972322413045bb5672b0fd3ba8c216c987 URL: https://github.com/llvm/llvm-project/commit/9a3dbc972322413045bb5672b0fd3ba8c216c987 DIFF:

[Lldb-commits] [lldb] 6587ff7 - [lldb] Fix llvm-lit in standalone builds

2020-07-29 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-07-29T15:38:40-07:00 New Revision: 6587ff77ea7aea508dde4ff68bf89e301756a52c URL: https://github.com/llvm/llvm-project/commit/6587ff77ea7aea508dde4ff68bf89e301756a52c DIFF:

[Lldb-commits] [PATCH] D62732: [RISCV] Add SystemV ABI

2020-07-29 Thread Luís Marques via Phabricator via lldb-commits
luismarques added a comment. In D62732#2038309 , @jrtc27 wrote: > Yeah, I don't think we want to be merging code we can't test even in a > non-automated way. Even if this code is completely bug-free, the inability to > test it just means we risk having

[Lldb-commits] [lldb] 6700f4b - [LLDB] Add checks for ValueObjectSP in Cocoa summary providers

2020-07-29 Thread via lldb-commits
Author: shafik Date: 2020-07-29T14:47:18-07:00 New Revision: 6700f4b9fe6321ef704efa4890af5bc351a124f0 URL: https://github.com/llvm/llvm-project/commit/6700f4b9fe6321ef704efa4890af5bc351a124f0 DIFF: https://github.com/llvm/llvm-project/commit/6700f4b9fe6321ef704efa4890af5bc351a124f0.diff LOG:

[Lldb-commits] [PATCH] D84272: Add checks for ValueObjectSP in Cocoa summary providers

2020-07-29 Thread Shafik Yaghmour via Phabricator via lldb-commits
This revision was not accepted when it landed; it landed in state "Needs Revision". This revision was automatically updated to reflect the committed changes. Closed by commit rG6700f4b9fe63: [LLDB] Add checks for ValueObjectSP in Cocoa summary providers (authored by shafik). Herald added a

[Lldb-commits] [PATCH] D84555: [lldb-vscode ]Add Syntax Highlighting to Disassembly View

2020-07-29 Thread walter erquinigo via Phabricator via lldb-commits
wallace added a comment. It would be possible as well to have two media types with their corresponding syntax files, one for x86, and another for arm Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84555/new/ https://reviews.llvm.org/D84555

[Lldb-commits] [PATCH] D68909: change shortcut for 'step out' from 'o' to 'f'

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG336c7029ef3b: [lldb] change shortcut for step out from o to f (authored by llunak). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68909/new/

[Lldb-commits] [PATCH] D68908: remove somewhat dangerous 'd'(etach) and 'k'(ill) shortcuts

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG47d2c7cd5db4: [lldb] remove somewhat dangerous d(etach) and k(ill) shortcuts (authored by llunak). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68908/new/

[Lldb-commits] [PATCH] D68541: Implement 'up' and 'down' shortcuts in lldb gui

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG13978643b678: [lldb] implement up and down shortcuts in lldb gui (authored by llunak). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68541/new/

[Lldb-commits] [lldb] 1397864 - [lldb] implement 'up' and 'down' shortcuts in lldb gui

2020-07-29 Thread Luboš Luňák via lldb-commits
Author: Luboš Luňák Date: 2020-07-29T22:30:23+02:00 New Revision: 13978643b678e226500d9d1ae8a003c8ed4b05ef URL: https://github.com/llvm/llvm-project/commit/13978643b678e226500d9d1ae8a003c8ed4b05ef DIFF: https://github.com/llvm/llvm-project/commit/13978643b678e226500d9d1ae8a003c8ed4b05ef.diff

[Lldb-commits] [lldb] 47d2c7c - [lldb] remove somewhat dangerous 'd'(etach) and 'k'(ill) shortcuts

2020-07-29 Thread Luboš Luňák via lldb-commits
Author: Luboš Luňák Date: 2020-07-29T22:30:23+02:00 New Revision: 47d2c7cd5db4abe11f44fd540bceb73b8b4372d9 URL: https://github.com/llvm/llvm-project/commit/47d2c7cd5db4abe11f44fd540bceb73b8b4372d9 DIFF: https://github.com/llvm/llvm-project/commit/47d2c7cd5db4abe11f44fd540bceb73b8b4372d9.diff

[Lldb-commits] [lldb] 336c702 - [lldb] change shortcut for 'step out' from 'o' to 'f'

2020-07-29 Thread Luboš Luňák via lldb-commits
Author: Luboš Luňák Date: 2020-07-29T22:30:23+02:00 New Revision: 336c7029ef3b7eff981d6c6990a6a255a4de236e URL: https://github.com/llvm/llvm-project/commit/336c7029ef3b7eff981d6c6990a6a255a4de236e DIFF: https://github.com/llvm/llvm-project/commit/336c7029ef3b7eff981d6c6990a6a255a4de236e.diff

[Lldb-commits] [PATCH] D84555: [lldb-vscode ]Add Syntax Highlighting to Disassembly View

2020-07-29 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. This seems very x86 centric. I forwarded a few examples of ARM and ARM64 disassembly to Yifan so we can improve some of the regexes. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84555/new/

[Lldb-commits] [PATCH] D68541: Implement 'up' and 'down' shortcuts in lldb gui

2020-07-29 Thread Greg Clayton via Phabricator via lldb-commits
clayborg accepted this revision. clayborg added a comment. Thanks again for working on this. I will review any subsequent patches as they come in if you have any more contributions. Sorry for the long delay again, I had 3 months that I was out due to the head injury, hopefully this won't happen

[Lldb-commits] [PATCH] D68908: remove somewhat dangerous 'd'(etach) and 'k'(ill) shortcuts

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak added inline comments. Comment at: lldb/source/Core/IOHandler.cpp:4340-4349 -case 'k': - // 'k' == kill - { -ExecutionContext exe_ctx = -m_debugger.GetCommandInterpreter().GetExecutionContext(); -if (exe_ctx.HasProcessScope()) -

[Lldb-commits] [PATCH] D68909: change shortcut for 'step out' from 'o' to 'f'

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak updated this revision to Diff 281707. llunak added a comment. Updated for current git. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68909/new/ https://reviews.llvm.org/D68909 Files: lldb/source/Core/IOHandlerCursesGUI.cpp Index:

[Lldb-commits] [PATCH] D68908: remove somewhat dangerous 'd'(etach) and 'k'(ill) shortcuts

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak updated this revision to Diff 281706. llunak added a comment. Updated for current git, and clang-format-ed. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68908/new/ https://reviews.llvm.org/D68908 Files: lldb/source/Core/IOHandlerCursesGUI.cpp

[Lldb-commits] [PATCH] D68541: Implement 'up' and 'down' shortcuts in lldb gui

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak updated this revision to Diff 281705. llunak added a comment. Updated for current git, and clang-format-ed. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68541/new/ https://reviews.llvm.org/D68541 Files:

[Lldb-commits] [PATCH] D68908: remove somewhat dangerous 'd'(etach) and 'k'(ill) shortcuts

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak added a comment. In D68908#2174222 , @clayborg wrote: > If removing 'd' was only to make it available for "up" and "down" in > https://reviews.llvm.org/D68541, then maybe we should switch 'D' to "detach > and let run? Or is that what we did, but

[Lldb-commits] [PATCH] D68541: Implement 'up' and 'down' shortcuts in lldb gui

2020-07-29 Thread Luboš Luňák via Phabricator via lldb-commits
llunak added a comment. My usual experience with Clang submissions is that I have to be really persistent to get a reaction, let alone an approval, so I assumed it was the same here and I didn't feel like pushing this that much. I'll update the patches to match current git and have a look at

[Lldb-commits] [lldb] da0bba5 - [lldb/Breakpoint] Rename StoppointLocation to StoppointSite and drop its relationship with BreakpointLocation

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T22:07:46+03:00 New Revision: da0bba5c9abb161ff824cf450537cf2ccf50d457 URL: https://github.com/llvm/llvm-project/commit/da0bba5c9abb161ff824cf450537cf2ccf50d457 DIFF:

[Lldb-commits] [PATCH] D84527: Rename StoppointLocation to StoppointSite and drop its relationship with BreakpointLocation

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGda0bba5c9abb: [lldb/Breakpoint] Rename StoppointLocation to StoppointSite and drop its… (authored by tatyana-krasnukha). Changed prior to commit:

[Lldb-commits] [lldb] d5c1f68 - [lldb/BreakpointSite] Handle all ways of control flow

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T21:53:18+03:00 New Revision: d5c1f686e34fdd9ed8ec9b7a195799baf492e854 URL: https://github.com/llvm/llvm-project/commit/d5c1f686e34fdd9ed8ec9b7a195799baf492e854 DIFF:

[Lldb-commits] [PATCH] D81001: [lldb] Display autosuggestion part in gray if there is one possible suggestion

2020-07-29 Thread Shu Anzai via Phabricator via lldb-commits
gedatsu217 updated this revision to Diff 281686. gedatsu217 added a comment. Sorry, I mistakenly uploaded a different file. This is the correct file. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D81001/new/ https://reviews.llvm.org/D81001 Files: lldb/include/lldb/Core/Debugger.h

[Lldb-commits] [PATCH] D84257: [lldb] Don't use hardware index to determine whether a breakpoint site is hardware

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
tatyana-krasnukha added a comment. Ups... Pushed it occationaly with the other patchs. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84257/new/ https://reviews.llvm.org/D84257 ___ lldb-commits mailing

[Lldb-commits] [lldb] ebaa8b1 - [lldb] Don't use hardware index to determine whether a breakpoint site is hardware

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T21:27:24+03:00 New Revision: ebaa8b1c60749883c6449a7c16096f1c40ccf4bc URL: https://github.com/llvm/llvm-project/commit/ebaa8b1c60749883c6449a7c16096f1c40ccf4bc DIFF:

[Lldb-commits] [lldb] b352e62 - [lldb] Make process plugins check whether a hardware breakpoint is required

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T21:27:23+03:00 New Revision: b352e62feadd0aabaa7373b6fb40701f00a6aa91 URL: https://github.com/llvm/llvm-project/commit/b352e62feadd0aabaa7373b6fb40701f00a6aa91 DIFF:

[Lldb-commits] [PATCH] D84257: [lldb] Don't use hardware index to determine whether a breakpoint site is hardware

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
This revision was not accepted when it landed; it landed in state "Needs Review". This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGebaa8b1c6074: [lldb] Dont use hardware index to determine whether

[Lldb-commits] [PATCH] D84255: [lldb] Make process plugins check whether a hardware breakpoint is required

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGb352e62feadd: [lldb] Make process plugins check whether a hardware breakpoint is required (authored by tatyana-krasnukha). Repository: rG LLVM

[Lldb-commits] [PATCH] D84254: [lldb] Skip overlapping hardware and external breakpoints when writing memory

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGf7ec3e3be70d: [lldb] Skip overlapping hardware and external breakpoints when writing memory (authored by tatyana-krasnukha). Repository: rG LLVM

[Lldb-commits] [lldb] f7ec3e3 - [lldb] Skip overlapping hardware and external breakpoints when writing memory

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T21:27:23+03:00 New Revision: f7ec3e3be70d10a630ac22c64073a845b168c829 URL: https://github.com/llvm/llvm-project/commit/f7ec3e3be70d10a630ac22c64073a845b168c829 DIFF:

[Lldb-commits] [PATCH] D84311: [lldb/test] Put hardware breakpoint tests together, NFC

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGc114352edfe0: [lldb/test] Put hardware breakpoint tests together, NFC (authored by tatyana-krasnukha). Repository: rG LLVM Github Monorepo

[Lldb-commits] [lldb] c114352 - [lldb/test] Put hardware breakpoint tests together, NFC

2020-07-29 Thread Tatyana Krasnukha via lldb-commits
Author: Tatyana Krasnukha Date: 2020-07-29T21:20:04+03:00 New Revision: c114352edfe0de69050bbf1cbbc478bcfb524622 URL: https://github.com/llvm/llvm-project/commit/c114352edfe0de69050bbf1cbbc478bcfb524622 DIFF:

[Lldb-commits] [PATCH] D81001: [lldb] Display autosuggestion part in gray if there is one possible suggestion

2020-07-29 Thread Shu Anzai via Phabricator via lldb-commits
gedatsu217 updated this revision to Diff 281677. gedatsu217 added a comment. Fix the cursor position. (Editline::TypedCharacter) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D81001/new/ https://reviews.llvm.org/D81001 Files: lldb/include/lldb/Core/Debugger.h

[Lldb-commits] [PATCH] D84809: [lldb] Fix invalid error message in TargetList::CreateTargetInternal

2020-07-29 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was not accepted when it landed; it landed in state "Needs Review". This revision was automatically updated to reflect the committed changes. JDevlieghere marked 3 inline comments as done. Closed by commit rG4add853647b3: [lldb] Improve platform handling in CreateTargetInternal

[Lldb-commits] [lldb] 4add853 - [lldb] Improve platform handling in CreateTargetInternal

2020-07-29 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-07-29T10:30:20-07:00 New Revision: 4add853647b358d9bb7f162682e80672548b URL: https://github.com/llvm/llvm-project/commit/4add853647b358d9bb7f162682e80672548b DIFF:

[Lldb-commits] [PATCH] D84527: Rename StoppointLocation to StoppointSite and drop its relationship with BreakpointLocation

2020-07-29 Thread Jim Ingham via Phabricator via lldb-commits
jingham accepted this revision. jingham added a comment. Remember to do the action thingie... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84527/new/ https://reviews.llvm.org/D84527 ___ lldb-commits

[Lldb-commits] [PATCH] D84527: Rename StoppointLocation to StoppointSite and drop its relationship with BreakpointLocation

2020-07-29 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84527/new/ https://reviews.llvm.org/D84527

[Lldb-commits] [PATCH] D79147: Switch to using -debug-info-kind=constructor as default (from =limited)

2020-07-29 Thread David Blaikie via Phabricator via lldb-commits
dblaikie added a subscriber: echristo. dblaikie added a comment. In D79147#2178104 , @russell.gallop wrote: > Hi, > > It looks like is causing one of the debuginfo-tests: > llgdb-tests/nrvo-string.cpp to fail, run on Linux. Failure as below. I don't >

[Lldb-commits] [PATCH] D84038: On Windows build, making the /bigobj flag global , instead of passing it per file.

2020-07-29 Thread Michael Kruse via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG80bd6ae13ea2: On Windows build, making the /bigobj flag global , instead of passing it per… (authored by zahiraam, committed by Meinersbur). Herald added projects: clang, LLDB. Herald added subscribers:

[Lldb-commits] [PATCH] D84780: Setting the /bigobj option globally for Windows debug build. https://bugs.llvm.org/show_bug.cgi?id=46733

2020-07-29 Thread Zahira Ammarguellat via Phabricator via lldb-commits
zahiraam created this revision. Herald added subscribers: llvm-commits, lldb-commits, cfe-commits, AlexeySotkin, msifontes, jurahul, Kayjukh, grosul1, bader, Joonsoo, liufengdb, aartbik, lucyrfox, mgester, arpith-jacob, antiagainst, shauheen, jpienaar, rriddle, mehdi_amini, hiraditya, mgorny.

[Lldb-commits] [PATCH] D84527: Rename StoppointLocation to StoppointSite and drop its relationship with BreakpointLocation

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
tatyana-krasnukha updated this revision to Diff 281600. tatyana-krasnukha added reviewers: JDevlieghere, jingham. tatyana-krasnukha added a comment. Addressed comments. > It's also a little weird that we're clearing watchpoint hit counts when a > process dies, but not breakpoint hit counts. If

[Lldb-commits] [PATCH] D84255: [lldb] Make process plugins check whether a hardware breakpoint is required

2020-07-29 Thread Tatyana Krasnukha via Phabricator via lldb-commits
tatyana-krasnukha updated this revision to Diff 281598. tatyana-krasnukha added reviewers: labath, JDevlieghere. tatyana-krasnukha added a comment. Un-skip TestRequireHWBreakpoints.py on Windows, now it works as expected. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D81001: [lldb] Display autosuggestion part in gray if there is one possible suggestion

2020-07-29 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D81001#2179690 , @gedatsu217 wrote: > For example, I execute "help frame variable" and save it as command history. > Then, when I type "hel", "helhelp [me variable]" (gray characters are in []) > is displayed, probably because

[Lldb-commits] [PATCH] D84815: [LLDB] Improve PDB discovery

2020-07-29 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. The idea is fine -- the same logic is used in `Symbols::LocateExecutableSymbolFile`. In fact, one of the problems of our pdb support is that it does not use that function to locate symbol files (that way it would also respect the `target.debug-file-search-paths`

[Lldb-commits] [PATCH] D84809: [lldb] Fix invalid error message in TargetList::CreateTargetInternal

2020-07-29 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. The changes don't seem contentious to me, though I am also not very familiar with this code. What surprised me was the `OptionGroupPlatform` argument to `TargetList::CreateTargetInternal`. It seems like a slighly unusual thing to have, as that means the equivalent SB