[Lldb-commits] [PATCH] D86667: [lldb/Target] Add custom interpreter option to `platform shell`

2020-08-27 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 288531. mib marked an inline comment as done. mib edited the summary of this revision. mib added a comment. Address most comments: - Passed down the shell interpreter path down to `Host::RunShellCommand` to be "assembled" with the rest of the command. - Wrote a

[Lldb-commits] [PATCH] D86667: [lldb/Target] Add custom interpreter option to `platform shell`

2020-08-27 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib marked 9 inline comments as done. mib added a comment. In D86667#2242566 , @jingham wrote: > Do people really call command-line shells interpreters? I would have thought > --shell would be a better name. lldb already has its own command interpreter

[Lldb-commits] [lldb] cdcb9ab - Revert "Use find_library for ncurses"

2020-08-27 Thread Galina Kistanova via lldb-commits
Author: Harmen Stoppels Date: 2020-08-27T17:57:26-07:00 New Revision: cdcb9ab10e53ff08293915af3cd897c42112bcc5 URL: https://github.com/llvm/llvm-project/commit/cdcb9ab10e53ff08293915af3cd897c42112bcc5 DIFF: https://github.com/llvm/llvm-project/commit/cdcb9ab10e53ff08293915af3cd897c42112bcc5.dif

[Lldb-commits] [PATCH] D85705: Add a "Trace" plug-in to LLDB to add process trace support in stages.

2020-08-27 Thread walter erquinigo via Phabricator via lldb-commits
wallace updated this revision to Diff 288496. wallace added a comment. Addressed comments - Now using StringRef correctly whenever possible. - Revert back to using "traceFile" only inside the thread section. That's how intel-pt works at the moment and, as Greg suggested, we can change the schema

[Lldb-commits] [lldb] 7f717b6 - [lldb] Fix "no matching std::pair constructor" on Ubuntu 16.04 (NFC)

2020-08-27 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-08-27T17:23:44-07:00 New Revision: 7f717b6d1f65f8474e8633b040a16c55f0ad6b96 URL: https://github.com/llvm/llvm-project/commit/7f717b6d1f65f8474e8633b040a16c55f0ad6b96 DIFF: https://github.com/llvm/llvm-project/commit/7f717b6d1f65f8474e8633b040a16c55f0ad6b96.d

[Lldb-commits] [PATCH] D86752: [lldb/test] Use shorter test case names in TestStandardUnwind

2020-08-27 Thread Jordan Rupprecht via Phabricator via lldb-commits
rupprecht created this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. rupprecht requested review of this revision. Herald added a subscriber: JDevlieghere. TestStandardUnwind uses the full absolute path to a set of C/C++ files as the test case name, which in turn

[Lldb-commits] [PATCH] D86652: [lldb] Fix ProcessEventData::DoOnRemoval to support multiple listeners

2020-08-27 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. This still seems to me a pretty fragile way to program lldb. For instance, if the controlling thread gets the stop event first, and decides it wants to continue, it will set the process running again and by the time the memory reading thread gets the event, the process

[Lldb-commits] [PATCH] D86745: [lldb/test] Use @skipIfWindows for PExpectTest

2020-08-27 Thread Jordan Rupprecht via Phabricator via lldb-commits
rupprecht created this revision. rupprecht added a reviewer: teemperor. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. rupprecht requested review of this revision. Herald added a subscriber: JDevlieghere. Annotating `PExpectTest` with `@skipIfWindows` instead of marking it

[Lldb-commits] [PATCH] D86662: Simplify Symbol Status Message to Only Debug Info Size

2020-08-27 Thread walter erquinigo via Phabricator via lldb-commits
wallace added a comment. All module information is only displayed in our custom VSCode. Vanilla VSCode doesn't have support for displaying modules. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86662/new/ https://reviews.llvm.org/D86662 _

[Lldb-commits] [PATCH] D86662: Simplify Symbol Status Message to Only Debug Info Size

2020-08-27 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. So we are adding a custom new "debugInfoSize" field to the "module" JSON dictionary? What happens in the release VS code? Does this information not get displayed, but it will get displayed in our custom modified VS Code IDE? Repository: rG LLVM Github Monorepo CHAN

[Lldb-commits] [PATCH] D86660: Modifying ImportDeclContext(...) to ensure that we also handle the case when the FieldDecl is an ArrayType whose ElementType is a RecordDecl

2020-08-27 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik marked 2 inline comments as done. shafik added inline comments. Comment at: clang/lib/AST/ASTImporter.cpp:1755-1759 + QualType FromTy = ArrayFrom->getElementType(); + QualType ToTy = ArrayTo->getElementType(); + + FromRecordDecl = FromTy->getAsRe

[Lldb-commits] [PATCH] D86662: Simplify Symbol Status Message to Only Debug Info Size

2020-08-27 Thread Yifan Shen via Phabricator via lldb-commits
aelitashen updated this revision to Diff 288456. aelitashen added a comment. Keep symbol status till new version released, remove comments in tests. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86662/new/ https://reviews.llvm.org/D86662 Files:

[Lldb-commits] [PATCH] D85705: Add a "Trace" plug-in to LLDB to add process trace support in stages.

2020-08-27 Thread Greg Clayton via Phabricator via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. In D85705#2241249 , @labath wrote: > If the format is going to be json, why not use llvm::json from > `llvm/Support/JSON.h`? That's what

[Lldb-commits] [PATCH] D86670: [intel-pt] Add a basic implementation of the dump command

2020-08-27 Thread Greg Clayton via Phabricator via lldb-commits
clayborg requested changes to this revision. clayborg added inline comments. This revision now requires changes to proceed. Comment at: lldb/include/lldb/Target/Target.h:1105 + void SetTrace(const lldb::TraceSP &trace_sp); + wallace wrote: > wallace wrote: > >

[Lldb-commits] [PATCH] D86652: [lldb] Fix ProcessEventData::DoOnRemoval to support multiple listeners

2020-08-27 Thread Ilya Nozhkin via Phabricator via lldb-commits
ilya-nozhkin added a comment. Yeah, I understand the problem of two listeners trying to change process state simultaneously and I agree that informing other listeners once the primary one finished its job would be a great solution. But the problem is that primary listener just provides an event

[Lldb-commits] [PATCH] D86388: Fix use-after-free in ThreadPlan, and add test.

2020-08-27 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. I want to separate out two things here. One is whether lldb should internally ask questions of a thread once we've invalidated the thread list before running, the other is how we present threads to the user while the process is running. I was only suggesting restricti

[Lldb-commits] [PATCH] D86667: [lldb/Target] Add custom interpreter option to `platform shell`

2020-08-27 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. Do people really call command-line shells interpreters? I would have thought --shell would be a better name. lldb already has its own command interpreter which is orthogonal to the shells, so it seems confusing to use the same term for both. Repository: rG LLVM Gi

[Lldb-commits] [lldb] a7e4a17 - [lldb] Make lldb-argdumper a dependency of liblldb

2020-08-27 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-08-27T09:31:02-07:00 New Revision: a7e4a1773535c64dea5c1d72d6a0a3e24378eaa1 URL: https://github.com/llvm/llvm-project/commit/a7e4a1773535c64dea5c1d72d6a0a3e24378eaa1 DIFF: https://github.com/llvm/llvm-project/commit/a7e4a1773535c64dea5c1d72d6a0a3e24378eaa1.d

[Lldb-commits] [PATCH] D86722: [lldb] Make lldb-argdumper a dependency of liblldb

2020-08-27 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGa7e4a1773535: [lldb] Make lldb-argdumper a dependency of liblldb (authored by JDevlieghere). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://review

[Lldb-commits] [lldb] b981924 - [lldb] Move triple construction out of getArchCFlags in DarwinBuilder (NFC)

2020-08-27 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-08-27T09:31:01-07:00 New Revision: b981924bdda71b610c349a1d502ba83af632ae98 URL: https://github.com/llvm/llvm-project/commit/b981924bdda71b610c349a1d502ba83af632ae98 DIFF: https://github.com/llvm/llvm-project/commit/b981924bdda71b610c349a1d502ba83af632ae98.d

[Lldb-commits] [PATCH] D86521: Revert "Use find_library for ncurses"

2020-08-27 Thread Mateusz Mikuła via Phabricator via lldb-commits
mati865 added a comment. FYI this doesn't fully fix MinGW issue: $ cat tools/llvm-config/BuildVariables.inc | grep LLVM_SYSTEM_LIBS #define LLVM_SYSTEM_LIBS "-lpsapi -lshell32 -lole32 -luuid -ladvapi32 -lz.dll" It's because libraries are found by their import library which is `libz.dll.a` i

[Lldb-commits] [PATCH] D86722: [lldb] Make lldb-argdumper a dependency of liblldb

2020-08-27 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: kastiglione, davide. Herald added a subscriber: mgorny. JDevlieghere requested review of this revision. Always make `lldb-argdumper` a dependency of `liblldb`. Currently it is only a dependency of the python swig target because of

[Lldb-commits] [PATCH] D86660: Modifying ImportDeclContext(...) to ensure that we also handle the case when the FieldDecl is an ArrayType whose ElementType is a RecordDecl

2020-08-27 Thread Gabor Marton via Phabricator via lldb-commits
martong added inline comments. Comment at: clang/lib/AST/ASTImporter.cpp:1737 // If we are in the process of ImportDefinition(...) for a RecordDecl we // want to make sure that we are also completing each FieldDecl. There `ImportDefinition(...)` here

[Lldb-commits] [lldb] dd63506 - [lldb/cmake] Fix linking of lldbSymbolHelpers for 9cb222e7

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T16:40:17+02:00 New Revision: dd635062d867835cfe893698161277cc251b4456 URL: https://github.com/llvm/llvm-project/commit/dd635062d867835cfe893698161277cc251b4456 DIFF: https://github.com/llvm/llvm-project/commit/dd635062d867835cfe893698161277cc251b4456.diff

[Lldb-commits] [lldb] 5b2b754 - [lldb/cmake] Fix linking of lldbUtilityHelpers for 9cb222e74

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T16:06:59+02:00 New Revision: 5b2b754565602a8b49b68967e1810f592f175d6b URL: https://github.com/llvm/llvm-project/commit/5b2b754565602a8b49b68967e1810f592f175d6b DIFF: https://github.com/llvm/llvm-project/commit/5b2b754565602a8b49b68967e1810f592f175d6b.diff

[Lldb-commits] [lldb] 0de1463 - [lldb] Fix Type::GetByteSize for pointer types

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T15:37:49+02:00 New Revision: 0de1463373918ae424cdcfeaa5b318f45c528696 URL: https://github.com/llvm/llvm-project/commit/0de1463373918ae424cdcfeaa5b318f45c528696 DIFF: https://github.com/llvm/llvm-project/commit/0de1463373918ae424cdcfeaa5b318f45c528696.diff

[Lldb-commits] [PATCH] D86436: [lldb] Fix Type::GetByteSize for pointer types

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG0de146337391: [lldb] Fix Type::GetByteSize for pointer types (authored by labath). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D86616: [cmake] Make gtest include directories a part of the library interface

2020-08-27 Thread Louis Dionne via Phabricator via lldb-commits
ldionne added a comment. In D86616#2241936 , @labath wrote: > In D86616#2238946 , @ldionne wrote: > >> LGTM, but I'm not an owner for any of the projects touched by this change. > > I picked you because you seemed i

[Lldb-commits] [PATCH] D86616: [cmake] Make gtest include directories a part of the library interface

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG9cb222e749e8: [cmake] Make gtest include directories a part of the library interface (authored by labath). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D8661

[Lldb-commits] [lldb] 9cb222e - [cmake] Make gtest include directories a part of the library interface

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T15:35:57+02:00 New Revision: 9cb222e749e8392517a138cf6645a7c220d671c8 URL: https://github.com/llvm/llvm-project/commit/9cb222e749e8392517a138cf6645a7c220d671c8 DIFF: https://github.com/llvm/llvm-project/commit/9cb222e749e8392517a138cf6645a7c220d671c8.diff

[Lldb-commits] [PATCH] D86616: [cmake] Make gtest include directories a part of the library interface

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D86616#2238946 , @ldionne wrote: > LGTM, but I'm not an owner for any of the projects touched by this change. I picked you because you seemed interested in the overall direction that our cmake support is going :), and I believe

[Lldb-commits] [PATCH] D86615: [lldb/DWARF] Fix handling of variables with both location and const_value attributes

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG9f5927e42bf4: [lldb/DWARF] Fix handling of variables with both location and const_value… (authored by labath). Changed prior to commit: https://re

[Lldb-commits] [lldb] 9f5927e - [lldb/DWARF] Fix handling of variables with both location and const_value attributes

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T15:05:47+02:00 New Revision: 9f5927e42bf4a7448dc9dd3a1550d1126c595dad URL: https://github.com/llvm/llvm-project/commit/9f5927e42bf4a7448dc9dd3a1550d1126c595dad DIFF: https://github.com/llvm/llvm-project/commit/9f5927e42bf4a7448dc9dd3a1550d1126c595dad.diff

[Lldb-commits] [lldb] 219ccdf - [lldb/Utility] Use APSInt in the Scalar class

2020-08-27 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2020-08-27T15:05:47+02:00 New Revision: 219ccdfddecb963971ad14b5c14220b896d2c2e7 URL: https://github.com/llvm/llvm-project/commit/219ccdfddecb963971ad14b5c14220b896d2c2e7 DIFF: https://github.com/llvm/llvm-project/commit/219ccdfddecb963971ad14b5c14220b896d2c2e7.diff

[Lldb-commits] [PATCH] D86615: [lldb/DWARF] Fix handling of variables with both location and const_value attributes

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath marked 3 inline comments as done. labath added inline comments. Comment at: lldb/source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.cpp:3134 if ((tag == DW_TAG_variable) || (tag == DW_TAG_constant) || (tag == DW_TAG_formal_parameter && sc.function)) { DWARFAttr

[Lldb-commits] [PATCH] D86690: [lldb] Fix gcc 5.4.0 compile error

2020-08-27 Thread David Spickett via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGc1e6f1a7b1a8: [lldb] Fix gcc 5.4.0 compile error (authored by DavidSpickett). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION htt

[Lldb-commits] [lldb] c1e6f1a - [lldb] Fix gcc 5.4.0 compile error

2020-08-27 Thread David Spickett via lldb-commits
Author: David Spickett Date: 2020-08-27T10:23:05+01:00 New Revision: c1e6f1a7b1a8cb2bb11a76b904c6f8150bfcc3a6 URL: https://github.com/llvm/llvm-project/commit/c1e6f1a7b1a8cb2bb11a76b904c6f8150bfcc3a6 DIFF: https://github.com/llvm/llvm-project/commit/c1e6f1a7b1a8cb2bb11a76b904c6f8150bfcc3a6.diff

[Lldb-commits] [PATCH] D86690: [lldb] Fix gcc 5.4.0 compile error

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Looks good. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86690/new/ https://reviews.llvm.org/D86690 __

[Lldb-commits] [PATCH] D86690: [lldb] Fix gcc 5.4.0 compile error

2020-08-27 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added a reviewer: labath. DavidSpickett added a comment. https://www.llvm.org/docs/GettingStarted.html gives the minimum gcc as 5.1. (I found this cross compiling, the apt package for AArch64 is 5.4.0) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://revi

[Lldb-commits] [PATCH] D86690: [lldb] Fix gcc 5.4.0 compile error

2020-08-27 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. DavidSpickett requested review of this revision. Herald added a subscriber: JDevlieghere. Specify type when constructing PromotionKeys, this fixes error: "chosen constructor is explicit in c

[Lldb-commits] [PATCH] D85705: Add a "Trace" plug-in to LLDB to add process trace support in stages.

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. If the format is going to be json, why not use llvm::json from `llvm/Support/JSON.h`? That's what we been migrating most of the existing stuff to already, so going using that for new code makes perfect sense. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACT

[Lldb-commits] [PATCH] D86667: [lldb/Target] Add custom interpreter option to `platform shell`

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I am wondering what should the platform classes which do not implement this feature do (although most of them could implemented I don't think you need to implement all of them -- PlatformGdbRemote in particular can be a bit tricky). It seems to me like it would be better

[Lldb-commits] [PATCH] D85289: [DWARFYAML][debug_info] Rename some mapping keys. NFC.

2020-08-27 Thread James Henderson via Phabricator via lldb-commits
jhenderson accepted this revision. jhenderson added a comment. This revision is now accepted and ready to land. Okay, LGTM. I don't mind either way, and I suspect with the offset field becoming optional soon, it's unlikely to appear frequently, so the verbosity is a non-issue then. ==

[Lldb-commits] [PATCH] D86660: Modifying ImportDeclContext(...) to ensure that we also handle the case when the FieldDecl is an ArrayType whose ElementType is a RecordDecl

2020-08-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: clang/lib/AST/ASTImporter.cpp:1755-1759 + QualType FromTy = ArrayFrom->getElementType(); + QualType ToTy = ArrayTo->getElementType(); + + FromRecordDecl = FromTy->getAsRecordDecl(); + ToRecordDecl = ToT