[Lldb-commits] [PATCH] D97985: [lldb] Rename QueueFundamentalPlan to QueueBasePlan (NFC)

2021-03-04 Thread Dave Lee via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGe7361c8eccb7: [lldb] Rename QueueFundamentalPlan to QueueBasePlan (NFC) (authored by kastiglione). Repository: rG LLVM Github Monorepo CHANGES

[Lldb-commits] [lldb] e7361c8 - [lldb] Rename QueueFundamentalPlan to QueueBasePlan (NFC)

2021-03-04 Thread Dave Lee via lldb-commits
Author: Dave Lee Date: 2021-03-04T21:46:49-08:00 New Revision: e7361c8eccb7663146096622549dc03240414157 URL: https://github.com/llvm/llvm-project/commit/e7361c8eccb7663146096622549dc03240414157 DIFF: https://github.com/llvm/llvm-project/commit/e7361c8eccb7663146096622549dc03240414157.diff

[Lldb-commits] [PATCH] D97999: [lldb/Interpreter] Add `interpreter.repeat-previous-command` setting

2021-03-04 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97999/new/ https://reviews.llvm.org/D97999

[Lldb-commits] [PATCH] D98001: [lldb/API] Add CommandInterpreter::{Get, Set}PrintErrors to SBAPI (NFC)

2021-03-04 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. Test? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98001/new/ https://reviews.llvm.org/D98001 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D98001: [lldb/API] Add CommandInterpreter::{Get, Set}PrintErrors to SBAPI (NFC)

2021-03-04 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added reviewers: JDevlieghere, teemperor, jingham. mib added a project: LLDB. mib requested review of this revision. Herald added a subscriber: lldb-commits. This patch exposes the getter and setter methods for the command interpreter `print_errors` run option.

[Lldb-commits] [PATCH] D97999: [lldb/Interpreter] Add `interpreter.repeat-previous-command` setting

2021-03-04 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added a reviewer: JDevlieghere. mib requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This patch introduces a new interpreter setting to prevent LLDB from re-executing the previous command when passing an empty

[Lldb-commits] [PATCH] D96548: [lldb] [Process/FreeBSDRemote] Introduce aarch64 hw break/watchpoint support

2021-03-04 Thread Mitchell Horne via Phabricator via lldb-commits
mhorne added inline comments. Comment at: lldb/packages/Python/lldbsuite/test/dotest.py:807 +if lldb.SBPlatform.GetHostPlatform().GetOSMajorVersion() < 14: +return False, "Watchpoint support on arm64 requires FreeBSD 14.0" return True, "watchpoint

[Lldb-commits] [PATCH] D97985: [lldb] Rename QueueFundamentalPlan to QueueBasePlan (NFC)

2021-03-04 Thread Jim Ingham via Phabricator via lldb-commits
jingham accepted this revision. jingham added a comment. This revision is now accepted and ready to land. Herald added a subscriber: JDevlieghere. Yeah, apparently I got tired of typing Fundamental pretty quickly... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D97985: [lldb] Rename QueueFundamentalPlan to QueueBasePlan (NFC)

2021-03-04 Thread Dave Lee via Phabricator via lldb-commits
kastiglione created this revision. kastiglione added a reviewer: jingham. kastiglione requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Minor change for naming consistency. Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D97739: Add a progress class that can track and report long running operations that happen in LLDB.

2021-03-04 Thread walter erquinigo via Phabricator via lldb-commits
wallace added a comment. This looks really nice. The only thought I have is that you should accept multiple callbacks instead of only one, as the current implementation discards any existing callback if SetProgressCallback is called twice. I know that it'd be rare that two or more callbacks

[Lldb-commits] [PATCH] D97910: [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required

2021-03-04 Thread Med Ismail Bennani via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGc16fef19f6b0: [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required (authored by mib). Repository: rG LLVM Github Monorepo

[Lldb-commits] [lldb] c16fef1 - [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required

2021-03-04 Thread Med Ismail Bennani via lldb-commits
Author: Med Ismail Bennani Date: 2021-03-04T20:24:26+01:00 New Revision: c16fef19f6b002ba6ec7104d9f7dc44fef99ef57 URL: https://github.com/llvm/llvm-project/commit/c16fef19f6b002ba6ec7104d9f7dc44fef99ef57 DIFF:

[Lldb-commits] [PATCH] D97910: [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required

2021-03-04 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97910/new/ https://reviews.llvm.org/D97910

[Lldb-commits] [PATCH] D97910: [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required

2021-03-04 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 328228. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97910/new/ https://reviews.llvm.org/D97910 Files: lldb/include/lldb/Interpreter/OptionGroupPythonClassWithDict.h

[Lldb-commits] [PATCH] D97910: [lldb/Interpreter] Make OptionGroupPythonClassWithDict options non-required

2021-03-04 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 328213. mib added a comment. Replace `std::bitset` by `lldb_private::Flags` as suggested by @JDevlieghere Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97910/new/ https://reviews.llvm.org/D97910 Files:

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-03-04 Thread Caroline Tice via Phabricator via lldb-commits
cmtice updated this revision to Diff 328191. cmtice added a comment. Update to incorporate Pavel's suggested simplification. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97786/new/ https://reviews.llvm.org/D97786 Files: lldb/source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.cpp

[Lldb-commits] [PATCH] D96548: [lldb] [Process/FreeBSDRemote] Introduce aarch64 hw break/watchpoint support

2021-03-04 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 328189. mgorny added a comment. Updated version conditions since watchpoint support was backported to FreeBSD 13.0-BETA4 CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96548/new/ https://reviews.llvm.org/D96548 Files:

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-03-04 Thread Caroline Tice via Phabricator via lldb-commits
cmtice added a comment. I'm not sure about using target.debug-file-search-paths, and what the changes Pavel is suggesting would entail. But the real question I am trying to resolve here is not "what are all the places we should be searching for the .dwo files?" but "When we're given a

[Lldb-commits] [PATCH] D95601: [lldb][AArch64] Add memory tag reading to lldb-server

2021-03-04 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett marked an inline comment as done. DavidSpickett added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeProcessLinux.cpp:1357 + + if (error.Fail()) +return error; DavidSpickett wrote: > omjavaid wrote: > > ptrace request is

[Lldb-commits] [PATCH] D97769: [lldb] Apply gdb-remote timeout to platform connections as well

2021-03-04 Thread Pavel Labath via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGbf3ac994c4d5: [lldb] Apply gdb-remote timeout to platform connections as well (authored by labath). Repository: rG LLVM Github Monorepo CHANGES

[Lldb-commits] [lldb] bf3ac99 - [lldb] Apply gdb-remote timeout to platform connections as well

2021-03-04 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2021-03-04T14:46:02+01:00 New Revision: bf3ac994c4d526b74044a977176e8e07d83f2049 URL: https://github.com/llvm/llvm-project/commit/bf3ac994c4d526b74044a977176e8e07d83f2049 DIFF: https://github.com/llvm/llvm-project/commit/bf3ac994c4d526b74044a977176e8e07d83f2049.diff

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-03-04 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Having a setting for this would not be unreasonable. But what about reusing an existing setting for this purpose? I thinking of the (global) `target.debug-file-search-paths` setting and the associated logic (`Symbols::LocateExecutableSymbolFile` and friends). If we used

[Lldb-commits] [PATCH] D96548: [lldb] [Process/FreeBSDRemote] Introduce aarch64 hw break/watchpoint support

2021-03-04 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. Gentle ping. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96548/new/ https://reviews.llvm.org/D96548 ___ lldb-commits mailing list lldb-commits@lists.llvm.org