[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Dave Lee via Phabricator via lldb-commits
kastiglione added a comment. nice, I've wanted this too. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127355/new/ https://reviews.llvm.org/D127355 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGce825e46743b: [lldb] Add assertState function to the API test suite (authored by JDevlieghere). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib accepted this revision. mib added a comment. This revision is now accepted and ready to land. Awesome! Thanks! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127355/new/ https://reviews.llvm.org/D127355 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 435372. JDevlieghere added a comment. Implement Ismail's suggestion: AssertionError: stopped (5) != exited (10) : Got exit event CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127355/new/ https://reviews.llvm.org/D127355 Files:

[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib added a comment. Pretty cool but it would be nice to have the following formatting: "AssertionError: stopped (5) != exited (10) : message" ... I feel like it's easier to read this way CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127355/new/ https://reviews.llvm.org/D127355

[Lldb-commits] [PATCH] D127355: [lldb] Add assertState function

2022-06-08 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: kastiglione, mib. Herald added a project: All. JDevlieghere requested review of this revision. Add a function to make it easier to debug a test failure caused by an unexpected state. Currently, tests are using `assertEqual` which