Re: [Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

2015-10-29 Thread Ilia K via lldb-commits
ki.stfu accepted this revision. ki.stfu added a comment. This revision is now accepted and ready to land. LGTM Comment at: tools/lldb-mi/MICmdBase.h:68 @@ -67,2 +67,3 @@ virtual MIuint GetGUID(); +void AddCommonArgs(); abidh wrote: > Changed name. But

Re: [Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

2015-10-29 Thread Hafiz Abid Qadeer via lldb-commits
abidh marked an inline comment as done. Comment at: tools/lldb-mi/MICmdBase.h:68 @@ -67,2 +67,3 @@ virtual MIuint GetGUID(); +void AddCommonArgs(); Changed name. But it cant be protected as it is called from the outside. Comment at: to

Re: [Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

2015-10-29 Thread Hafiz Abid Qadeer via lldb-commits
abidh updated this revision to Diff 38741. abidh added a comment. Handled review comments. http://reviews.llvm.org/D14177 Files: packages/Python/lldbsuite/test/tools/lldb-mi/stack/TestMiStack.py tools/lldb-mi/MICmdBase.cpp tools/lldb-mi/MICmdBase.h tools/lldb-mi/MICmdCmdBreak.cpp tool

Re: [Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

2015-10-29 Thread Ilia K via lldb-commits
ki.stfu added inline comments. Comment at: tools/lldb-mi/MICmdBase.h:68 @@ -67,2 +67,3 @@ virtual MIuint GetGUID(); +void ParseCommonArgs(); How about renaming it to AddCommonArgs and making it protected? Comment at: tools/lldb-mi/MICm

[Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

2015-10-29 Thread Hafiz Abid Qadeer via lldb-commits
abidh created this revision. abidh added a reviewer: ki.stfu. abidh added a subscriber: lldb-commits. I observed that eclipse was passing --thread-group for many other commands then we are currently handling. Looking at the MI documentation, the following link states that each MI command accept th