[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-10 Thread Alex Langford via Phabricator via lldb-commits
bulbazord added a comment. In D154759#4487381 , @jasonmolenda wrote: > I guess simplest is we can have all the UnwindPlan creators have a `static > g_unwindplan_name` and save a pointer to that. Each one is unique, don't > need anything fancier than

[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-10 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda added a comment. I guess simplest is we can have all the UnwindPlan creators have a `static g_unwindplan_name` and save a pointer to that. Each one is unique, don't need anything fancier than that. There's the risk that someone will create a new UnwindPlan and forget to make it a

[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-10 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda added a comment. probably the real correct change is to have constant c-strings in as globals and have pointers to those. Then you're using the same space as a ConstString in each UnwindPlan (a pointer) but creation is cheaper. There's no dynamic aspect to the names when the

[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-10 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda added a comment. (to say it more clearly: I'm fine if you'd like to reduce the places where ConstStrings are being used, but I don't think there's any good reason to remove this use of them. It will increase our memory footprint a bit.) Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-10 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda accepted this revision. jasonmolenda added a comment. This revision is now accepted and ready to land. I'm fine with this. It does increase the size of the UnwindPlan object, and there are a couple of them for every function that we see on a stack during a program execution, but I

[Lldb-commits] [PATCH] D154759: [lldb][NFCI] Change type of UnwindPlan::m_source_name

2023-07-07 Thread Alex Langford via Phabricator via lldb-commits
bulbazord created this revision. bulbazord added reviewers: JDevlieghere, mib, jasonmolenda, jingham. Herald added a project: All. bulbazord requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. m_source_name is currently a ConstString.