[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-05-02 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL359777: Rename Minion to ASTImporterDelegate (authored by teemperor, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit: https://reviews.llvm.

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-05-02 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 197728. teemperor added a comment. - Added documentation. - Fixed more references to 'minion' pointed out in the review. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D61299/new/ https://reviews.llvm.org/D61299 Files: lldb/include/lldb/Symbol/Cl

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik accepted this revision. shafik added a comment. This is a good change! Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:259 public: - CxxModuleScope(Minion &minion, clang::ASTContext *dst_ctx) + CxxModuleScope(ASTImporterDelegate &minion, clang::AST

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Gabor Marton via Phabricator via lldb-commits
martong added inline comments. Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:259 public: - CxxModuleScope(Minion &minion, clang::ASTContext *dst_ctx) + CxxModuleScope(ASTImporterDelegate &minion, clang::ASTContext *dst_ctx) : m_minion(minion) {

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Gabor Marton via Phabricator via lldb-commits
martong added inline comments. Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:328 clang::ASTContext *m_dst_ctx; -MinionMap m_minions; +DelegateMap m_minions; OriginMap m_origins; Would it make sense to rename the variables too? E.g. `m_

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl accepted this revision. aprantl added inline comments. Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:238 - class Minion : public clang::ASTImporter { + class ASTImporterDelegate : public clang::ASTImporter { public: Is there some sort of

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Davide Italiano via Phabricator via lldb-commits
davide accepted this revision. davide added a comment. This revision is now accepted and ready to land. Herald added a subscriber: rnkovacs. yay :) Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D61299/new/ https://reviews.llvm.org/D61299 _

[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

2019-04-30 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added reviewers: aprantl, shafik. Herald added a reviewer: martong. Herald added a reviewer: a.sidorin. Herald added subscribers: lldb-commits, abidh. Herald added a project: LLDB. I think there universal agreement that Minion isn't the best name for this