[llvm-commits] [129669] Add support for this builtin: __builtin_ia32_vec_ext_v2di

2007-07-19 Thread bwendlin
Revision: 129669 Author: bwendlin Date: 2007-07-18 23:21:13 -0700 (Wed, 18 Jul 2007) Log Message: --- Add support for this builtin: __builtin_ia32_vec_ext_v2di Modified Paths: -- apple-local/branches/llvm/gcc/config/i386/llvm-i386.cpp Modified: apple-local/branches

[llvm-commits] [129250] Correct the directory that the man pages are installed into.

2007-07-06 Thread bwendlin
Revision: 129250 Author: bwendlin Date: 2007-07-06 16:56:09 -0700 (Fri, 06 Jul 2007) Log Message: --- Correct the directory that the man pages are installed into. Modified Paths: -- apple-local/branches/llvm/build_gcc Modified: apple-local/branches/llvm/build_gcc

[llvm-commits] [129120] Change the place the man pages are installed to be /usr/local/ share/man instead

2007-07-03 Thread bwendlin
Revision: 129120 Author: bwendlin Date: 2007-07-03 16:06:28 -0700 (Tue, 03 Jul 2007) Log Message: --- Change the place the man pages are installed to be /usr/local/share/man instead of /usr/local/llvm-gcc-install/share/man. Modified Paths: -- apple-local/branches

[llvm-commits] [127543] From TOT: prevent exponential recursion in isNegatibleForFree

2007-05-23 Thread bwendlin
Revision: 127543 Author: bwendlin Date: 2007-05-23 01:01:23 -0700 (Wed, 23 May 2007) Log Message: --- From TOT: prevent exponential recursion in isNegatibleForFree Modified Paths: -- apple-local/branches/llvm-leopard/llvm/lib/CodeGen/SelectionDAG/DAGCombiner.cpp

[llvm-commits] [127059] Use -- instead of - for command line options.

2007-05-08 Thread bwendlin
Revision: 127059 Author: bwendlin Date: 2007-05-08 14:48:47 -0700 (Tue, 08 May 2007) Log Message: --- Use -- instead of - for command line options. Modified Paths: -- apple-local/branches/llvm/build_gcc Modified: apple-local/branches/llvm/build_gcc

[llvm-commits] [126737] Fix the race condition where a dylib is used before it' s actually created.

2007-04-30 Thread bwendlin
Revision: 126737 Author: bwendlin Date: 2007-04-30 12:14:35 -0700 (Mon, 30 Apr 2007) Log Message: --- Fix the race condition where a dylib is used before it's actually created. Naming it a unique name for each stage will fix this. Modified Paths: -- apple-local

[llvm-commits] [126738] This function isn't used when ENABLE_LLVM is defined.

2007-04-30 Thread bwendlin
Revision: 126738 Author: bwendlin Date: 2007-04-30 14:36:53 -0700 (Mon, 30 Apr 2007) Log Message: --- This function isn't used when ENABLE_LLVM is defined. Modified Paths: -- apple-local/branches/llvm/gcc/varasm.c Modified: apple-local/branches/llvm/gcc/varasm.c

[llvm-commits] [126740] Don't strip the libstdc++.dylib thingy.

2007-04-30 Thread bwendlin
Revision: 126740 Author: bwendlin Date: 2007-04-30 15:37:52 -0700 (Mon, 30 Apr 2007) Log Message: --- Don't strip the libstdc++.dylib thingy. Modified Paths: -- apple-local/branches/llvm/build_gcc Modified: apple-local/branches/llvm/build_gcc

[llvm-commits] [125952] Add SSSSE3 support as a feature.

2007-04-10 Thread bwendlin
Revision: 125952 Author: bwendlin Date: 2007-04-10 15:10:29 -0700 (Tue, 10 Apr 2007) Log Message: --- Add E3 support as a feature. Modified Paths: -- apple-local/branches/llvm/gcc/config/i386/i386.h Modified: apple-local/branches/llvm/gcc/config/i386/i386.h

[llvm-commits] [125717] Stop random segfaults.

2007-04-04 Thread bwendlin
Revision: 125717 Author: bwendlin Date: 2007-04-04 12:02:41 -0700 (Wed, 04 Apr 2007) Log Message: --- Stop random segfaults. This explicitly sets the DYLD_LIBRARY_PATH to the stage# directories. Modified Paths: -- apple-local/branches/llvm/gcc/Makefile.in Modified

[llvm-commits] [125666] Add support for the PADDQ builtin.

2007-04-03 Thread bwendlin
Revision: 125666 Author: bwendlin Date: 2007-04-02 23:12:17 -0700 (Mon, 02 Apr 2007) Log Message: --- Add support for the PADDQ builtin. Modified Paths: -- apple-local/branches/llvm/gcc/config/i386/llvm-i386.cpp Modified: apple-local/branches/llvm/gcc/config/i386

[llvm-commits] [125255] Add support for initializing the vector.

2007-03-23 Thread bwendlin
Revision: 125255 Author: bwendlin Date: 2007-03-23 01:09:17 -0700 (Fri, 23 Mar 2007) Log Message: --- Add support for initializing the vector. One thing which can be done is to convert a vector of constants into an constant value and then move that into the destination. This is what

[llvm-commits] [125247] Add build vector shuffles for MMX instructions.

2007-03-22 Thread bwendlin
Revision: 125247 Author: bwendlin Date: 2007-03-22 11:41:21 -0700 (Thu, 22 Mar 2007) Log Message: --- Add build vector shuffles for MMX instructions. Modified Paths: -- apple-local/branches/llvm/gcc/config/i386/llvm-i386.cpp Modified: apple-local/branches/llvm/gcc

[llvm-commits] [124233] Clear out the target builtin cache before reading a PCH file.

2007-02-23 Thread bwendlin
Revision: 124233 Author: bwendlin Date: 2007-02-23 12:14:43 -0800 (Fri, 23 Feb 2007) Log Message: --- Clear out the target builtin cache before reading a PCH file. Modified Paths: -- apple-local/branches/llvm/gcc/llvm-backend.cpp apple-local/branches/llvm/gcc

[llvm-commits] [124197] Add a LLVM_MINOR_VERSION macro to Version.h.

2007-02-22 Thread bwendlin
Revision: 124197 Author: bwendlin Date: 2007-02-22 13:25:13 -0800 (Thu, 22 Feb 2007) Log Message: --- Add a LLVM_MINOR_VERSION macro to Version.h. Modified Paths: -- apple-local/branches/llvm/build_gcc Modified: apple-local/branches/llvm/build_gcc

[llvm-commits] [124123] Converts getOrInsertFunction calls to Intrinsic::getDeclaration calls for

2007-02-20 Thread bwendlin
Revision: 124123 Author: bwendlin Date: 2007-02-20 16:45:58 -0800 (Tue, 20 Feb 2007) Log Message: --- Converts getOrInsertFunction calls to Intrinsic::getDeclaration calls for PR1189. It also gets rid of the function caching mechanism, so that it's multi-module safe. Modified Paths

[llvm-commits] [124087] The buildit command on X86 was failing because the gcse. o file was being

2007-02-19 Thread bwendlin
Revision: 124087 Author: bwendlin Date: 2007-02-19 14:14:13 -0800 (Mon, 19 Feb 2007) Log Message: --- The buildit command on X86 was failing because the gcse.o file was being included in the garbage collection when LLVM was built into a dylib. (Thanks to Chris for discovering

[llvm-commits] [123990] Removed redundant EmittedGlobalVars and EmittedFunctions maps.

2007-02-16 Thread bwendlin
Revision: 123990 Author: bwendlin Date: 2007-02-16 17:18:16 -0800 (Fri, 16 Feb 2007) Log Message: --- Removed redundant EmittedGlobalVars and EmittedFunctions maps. Switched to using the get* methods in Module instead. Modified Paths: -- apple-local/branches/llvm

[llvm-commits] [123798] Pred needed to be initialized.

2007-02-13 Thread bwendlin
Revision: 123798 Author: bwendlin Date: 2007-02-13 15:58:36 -0800 (Tue, 13 Feb 2007) Log Message: --- Pred needed to be initialized. During a buildit, warnings are treated as errors. Modified Paths: -- apple-local/branches/llvm/gcc/config/i386/llvm-i386.cpp

[llvm-commits] [123565] Need to check the correct return value for the call to addPassesToEmitFile .

2007-02-07 Thread bwendlin
Revision: 123565 Author: bwendlin Date: 2007-02-07 17:42:33 -0800 (Wed, 07 Feb 2007) Log Message: --- Need to check the correct return value for the call to addPassesToEmitFile. Modified Paths: -- apple-local/branches/llvm/gcc/llvm-backend.cpp Modified: apple-local

[llvm-commits] [123567] The addPassesToEmitFile method should have the *Finish method called afterwards.

2007-02-07 Thread bwendlin
Revision: 123567 Author: bwendlin Date: 2007-02-07 18:16:06 -0800 (Wed, 07 Feb 2007) Log Message: --- The addPassesToEmitFile method should have the *Finish method called afterwards. Modified Paths: -- apple-local/branches/llvm/gcc/llvm-backend.cpp Modified: apple