[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2007-02-01 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.122 - 1.123 --- Log message: Ensure that ConvertOperandToType generates a result conversion by initializing the Res variable to 0 and asserting it is not zero after the result should have been created. --- Diffs of the

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2007-02-01 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.123 - 1.124 --- Log message: Changes to support making the shift instructions be true BinaryOperators. This feature is needed in order to support shifts of more than 255 bits on large integer types. This changes the

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2007-01-20 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.121 - 1.122 --- Log message: For PR970: http://llvm.org/PR970 : Clean up handling of isFloatingPoint() and dealing with PackedType. Patch by Gordon Henriksen! --- Diffs of the changes: (+2 -2) ExprTypeConvert.cpp |

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2007-01-14 Thread Chris Lattner
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.119 - 1.120 --- Log message: Eliminate calls to isInteger, generalizing code and tightening checks as needed. --- Diffs of the changes: (+7 -8) ExprTypeConvert.cpp | 15 +++ 1 files changed, 7

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2007-01-14 Thread Chris Lattner
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.120 - 1.121 --- Log message: rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger. rename Type::getIntegralTypeMask to Type::getIntegerTypeMask. This makes naming much more consistent. For

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp LevelRaise.cpp TransformInternals.cpp

2006-12-30 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.118 - 1.119 LevelRaise.cpp updated: 1.117 - 1.118 TransformInternals.cpp updated: 1.51 - 1.52 --- Log message: For PR950: http://llvm.org/PR950 : This patch replaces signed integer types with signless ones: 1. [US]Byte -

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp LevelRaise.cpp

2006-12-22 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.117 - 1.118 LevelRaise.cpp updated: 1.116 - 1.117 --- Log message: For PR950: http://llvm.org/PR950 : This patch removes the SetCC instructions and replaces them with the ICmp and FCmp instructions. The SetCondInst

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-12-18 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.115 - 1.116 --- Log message: Convert the last use of two-argument ConstantExpr::getCast into another form so we can remove that method from ConstantExpr. --- Diffs of the changes: (+3 -1) ExprTypeConvert.cpp |4

Re: [llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-12-18 Thread Chris Lattner
On Dec 18, 2006, at 12:16 AM, Reid Spencer wrote: Convert the last use of two-argument ConstantExpr::getCast into another form so we can remove that method from ConstantExpr. --- Diffs of the changes: (+3 -1) ExprTypeConvert.cpp |4 +++- 1 files changed, 3 insertions(+), 1

Re: [llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-12-18 Thread Reid Spencer
On Mon, 2006-12-18 at 08:56 -0800, Chris Lattner wrote: On Dec 18, 2006, at 12:16 AM, Reid Spencer wrote: Convert the last use of two-argument ConstantExpr::getCast into another form so we can remove that method from ConstantExpr. --- Diffs of the changes: (+3 -1)

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-12-06 Thread Bill Wendling
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.114 - 1.115 --- Log message: Changed llvm_ostream et all to OStream. llvm_cerr, llvm_cout, llvm_null, are now cerr, cout, and NullStream resp. --- Diffs of the changes: (+2 -2) ExprTypeConvert.cpp |4 ++-- 1

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp LevelRaise.cpp

2006-11-26 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.113 - 1.114 LevelRaise.cpp updated: 1.112 - 1.113 --- Log message: For PR950: http://llvm.org/PR950 : The long awaited CAST patch. This introduces 12 new instructions into LLVM to replace the cast instruction.

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-11-07 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.111 - 1.112 --- Log message: For PR950: http://llvm.org/PR950 : This patch converts the old SHR instruction into two instructions, AShr (Arithmetic) and LShr (Logical). The Shr instructions now are not dependent on the

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-11-02 Thread Reid Spencer
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.110 - 1.111 --- Log message: For PR786: http://llvm.org/PR786 : Turn on -Wunused and -Wno-unused-parameter. Clean up most of the resulting fall out by removing unused variables. Remaining warnings have to do with unused

[llvm-commits] CVS: llvm/lib/Transforms/ExprTypeConvert.cpp

2006-05-12 Thread Chris Lattner
Changes in directory llvm/lib/Transforms: ExprTypeConvert.cpp updated: 1.109 - 1.110 --- Log message: Remove dead stuff --- Diffs of the changes: (+0 -4) ExprTypeConvert.cpp |4 1 files changed, 4 deletions(-) Index: llvm/lib/Transforms/ExprTypeConvert.cpp diff -u