This is very nice. Only comment (and this is a nit that doesn't affect
this review) is that the "FAILs" reported when ramping up to find the upper
bounds really aren't failures since it's expected that any system will have
finite limits. But that should be perhaps just documentation.
On Thu, Mar
On Thu, Mar 26, 2015 at 8:30 AM, wrote:
> From: Balasubramanian Manoharan
>
Reviewed-and-tested-by: Bill Fischofer
>
> Fix for incorrect pmr_term_value update in odp_pmr_create_match() and
> odp_pmr_create_range() functions.
> Fixes https://bugs.linaro.org/show_bug.cgi?id=1381
>
> Signed-off
In future these should probably be posted to the new
lng-odp-...@lists.linaro.org mailing list.
Bill
On Thu, Mar 26, 2015 at 2:23 PM, Zoltan Kiss wrote:
> These patches are the leftovers from the code used for the Connect demo.
> No. 3-5
> were changed.
>
> _
On Thu, Mar 26, 2015 at 11:43 AM, Mike Holmes
wrote:
> ODP implementations should not call assert directly.
>
> Signed-off-by: Mike Holmes
>
Reviewed-by: Bill Fischofer
> ---
> platform/linux-generic/odp_timer.c | 16 +++-
> 1 file changed, 7 insertions(+), 9 deletions(-)
>
> di
On Thu, Mar 26, 2015 at 11:43 AM, Mike Holmes
wrote:
> Signed-off-by: Mike Holmes
>
Reviewed-by: Bill Fischofer
> ---
> platform/linux-generic/include/odp_debug_internal.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/platform/linux-generic/include/odp_debug_i
Sounds like we should hold v1.0.2 for this bug fix? Maxim: I think this
review is properly yours as you did the jumbo frame add for v1.0.1.
On Thu, Mar 26, 2015 at 12:52 PM, Stuart Haslam
wrote:
> A magic number, used to ensure jumbo frames are transmitted and received
> in full, is written to
On Wed, Mar 18, 2015 at 7:02 PM, Mike Holmes wrote:
> Signed-off-by: Mike Holmes
>
Reviewed-by: Bill Fischofer
> ---
> platform/linux-generic/odp_linux.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/platform/linux-generic/odp_linux.c
> b/platform/linux-generic/odp_linux.c
> inde
Refactor how odp_pktio_recv errors handled, including:
- use OVS_(UN)LIKELY
- set *c in error cases
- some code style fix at the definitions
- remove stale printf from the end
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 31 +++
1 file changed, 15 insertions(+),
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 21 +++--
1 file changed, 11 insertions(+), 10 deletions(-)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index bdea022..2ab632e 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -132,10 +132,10 @@ odp_class_init(void)
It's not used to anything, and I don't see any value of it.
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index f2fbb94..be97d0e 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -5
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index 2ab632e..f2fbb94 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -155,7 +155,7 @@ odp_class_init(void)
VLOG_ERR(
We will need this for odp_override_log
Signed-off-by: Zoltan Kiss
---
include/openvswitch/vlog.h | 2 ++
lib/vlog.c | 8
2 files changed, 10 insertions(+)
diff --git a/include/openvswitch/vlog.h b/include/openvswitch/vlog.h
index 3f71e4b..71b3453 100644
--- a/include/op
These patches make OVS compile with ODP 1.0 API. This version just
rebases to the v2 of previous patch series "Leftover from Connect"
___
lng-odp mailing list
lng-odp@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/lng-odp
These patches are the leftovers from the code used for the Connect demo. No. 3-5
were changed.
___
lng-odp mailing list
lng-odp@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/lng-odp
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index 765edee..bdea022 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -56,8 +56,8 @@ VLOG_DEFINE_THIS_MODUL
ODP logs now end up in OVS logs.
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index fa325faa..765edee 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -635,6 +635,24 @@ out_stats
Signed-off-by: Zoltan Kiss
---
lib/netdev-odp.h | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/lib/netdev-odp.h b/lib/netdev-odp.h
index 6162dd4..ba58c08 100644
--- a/lib/netdev-odp.h
+++ b/lib/netdev-odp.h
@@ -7,9 +7,8 @@
#ifdef ODP_NETDEV
#include
-#include
-#inc
Allocating it after every packet receive gives a big performance penalty. So
move it into the same buffer pool, right after the packet itself.
Signed-off-by: Zoltan Kiss
---
v2:
- fix style of for loops
- delete SHM_OFPBUF_NUM_BUFS and odp_ofpbuf
- no need to DPDK offset hack anymore, it was a DP
DPDK needs this otherwise it saturates the whole pool too fast. For some reason
it doesn't work properly if the pool size is too small. Use a 2^q - 1 number
as suggested by rte_mempool_create.
Signed-off-by: Zoltan Kiss
---
v2: decrease by one on DPDK's recommendation
lib/netdev-odp.c | 2 +-
For odp_packet_push_tail
Signed-off-by: Zoltan Kiss
---
v2: add OVS_UNLIKELY
lib/netdev-odp.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/lib/netdev-odp.c b/lib/netdev-odp.c
index b77eea0..fa325faa 100644
--- a/lib/netdev-odp.c
+++ b/lib/netdev-odp.c
@@ -326,7 +326,8 @
A magic number, used to ensure jumbo frames are transmitted and received
in full, is written to the end of a packet buffer at a fixed offset of
9170 bytes. However for non-jumbo tests this is way beyond the end of
the allocated buffer.
Signed-off-by: Stuart Haslam
---
test/validation/odp_pktio.c
OK, v3 posted to reflect these changes. Thanks.
On Thu, Mar 26, 2015 at 9:42 AM, Savolainen, Petri (Nokia - FI/Espoo) <
petri.savolai...@nokia.com> wrote:
>
>
> > -Original Message-
> > From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp-
> > boun...@lists.linaro.org] On Behalf Of ext
ping
On 18 March 2015 at 20:02, Mike Holmes wrote:
> Signed-off-by: Mike Holmes
> ---
> platform/linux-generic/odp_linux.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/platform/linux-generic/odp_linux.c
> b/platform/linux-generic/odp_linux.c
> index 67ad05c..a471dd6 100644
> --- a/
Signed-off-by: Bill Fischofer
---
v3 changes:
- Renamed odp_packet_user_metadata() to odp_packet_user_data()
- Split addr/size return, adding odp_packet_user_data_size()
- Moved udata_size to pkt structure within odp_pool_param_t
v2 changes:
- Moved udata_size to odp_pool_param_t
- Renamed odp_p
ODP implementations should not call assert directly.
Signed-off-by: Mike Holmes
---
platform/linux-generic/odp_timer.c | 16 +++-
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/platform/linux-generic/odp_timer.c
b/platform/linux-generic/odp_timer.c
index b7cb04f..500f
Signed-off-by: Mike Holmes
---
platform/linux-generic/include/odp_debug_internal.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/platform/linux-generic/include/odp_debug_internal.h
b/platform/linux-generic/include/odp_debug_internal.h
index 5e38772..24608e1 100644
--- a
Following discussions today I've posted v3 of this patch as two separate
patches as described in the update to Bug 1334:
For v3 this patch has been split into two patches to reflect the change;
Patch http://patches.opendataplane.org/patch/1215/ only changes the
packet test in a way that is fully
https://bugs.linaro.org/show_bug.cgi?id=1334
--- Comment #4 from Bill Fischofer ---
For v3 this patch has been split into two patches to reflect the change;
Patch http://patches.opendataplane.org/patch/1215/ only changes the packet test
in a way that is fully backwards-compatible with before, so
This change addresses Bug https://bugs.linaro.org/show_bug.cgi?id=1334
Signed-off-by: Bill Fischofer
---
Note that for v3 this patch is split. The test change doe not affect
the ODP API and hence can be merged as part of the next ODP maintenance
release. The API change (just doxygen) is posted t
This change addresses Bug https://bugs.linaro.org/show_bug.cgi?id=1334
Signed-off-by: Bill Fischofer
---
Note that for v3 this patch is split. The test change doe not affect
the ODP API and hence can be merged as part of the next ODP maintenance
release. The API change (just doxygen) is posted t
https://bugs.linaro.org/show_bug.cgi?id=1365
Mike Holmes changed:
What|Removed |Added
Assignee|maxim.uva...@linaro.org |stuart.has...@linaro.org
--- Comment #3 from Mik
https://bugs.linaro.org/show_bug.cgi?id=1001
--- Comment #9 from Ciprian Barbu ---
Petri started reworking the scheduler for linux-generic, but I will have to
check if the bug is still present.
--
You are receiving this mail because:
You are on the CC list for the bug.__
https://bugs.linaro.org/show_bug.cgi?id=1386
Mike Holmes changed:
What|Removed |Added
Resolution|--- |FIXED
Status|UNCONFIRMED
On 25 March 2015 at 07:58, Ciprian Barbu wrote:
> The odp_ipsec example leaks some strings allocated during parse_args.
> https://bugs.linaro.org/show_bug.cgi?id=1117
> CID 56899: Resource leak (RESOURCE_LEAK)
>
> Signed-off-by: Ciprian Barbu
>
Reviewed-by: Mike Holmes
> ---
> example/ips
On 25 March 2015 at 07:58, Ciprian Barbu wrote:
> The odp_ipsec example leaks some strings allocated during parse_args.
> https://bugs.linaro.org/show_bug.cgi?id=1117
> CID 56899: Resource leak (RESOURCE_LEAK)
>
> Signed-off-by: Ciprian Barbu
>
Reviewed-by: Mike Holmes
> ---
> example/gen
On 25 March 2015 at 07:58, Ciprian Barbu wrote:
> The odp_l2fwd example leaks some strings allocated during parse_args.
> https://bugs.linaro.org/show_bug.cgi?id=1117
> CID 56899: Resource leak (RESOURCE_LEAK)
>
> Signed-off-by: Ciprian Barbu
>
Reviewed-by: Mike Holmes
> ---
> v3:
> - reba
https://bugs.linaro.org/show_bug.cgi?id=1359
Mike Holmes changed:
What|Removed |Added
Resolution|--- |FIXED
Status|UNCONFIRMED
https://bugs.linaro.org/show_bug.cgi?id=1365
--- Comment #2 from Mike Holmes ---
Requires patch - need to return error to application, a new unit test case
could verify this behavior.
--
You are receiving this mail because:
You are on the CC list for the bug.
https://bugs.linaro.org/show_bug.cgi?id=1383
Mike Holmes changed:
What|Removed |Added
CC||mike.hol...@linaro.org
--- Comment #1 from Mike
https://bugs.linaro.org/show_bug.cgi?id=1389
Mike Holmes changed:
What|Removed |Added
Resolution|--- |FIXED
CC|
On 26 March 2015 at 15:02, Savolainen, Petri (Nokia - FI/Espoo) <
petri.savolai...@nokia.com> wrote:
> I was referring to flags in a SoC packet descriptor, which may be stored
> into one or more u64 words.
>
Code could access the most significant half (32 bits) of such 64-bit words
using 32-bit l
> -Original Message-
> From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp-
> boun...@lists.linaro.org] On Behalf Of ext Bill Fischofer
> Sent: Wednesday, March 25, 2015 8:04 PM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [RFC API-NEXT PATCHv2] api: pool/packet: proposed user
>
A self-contained throughput test using the loop interface.
A number of transmit and receive workers are run on separate cores,
the transmitters generate packets at a defined rate and the receivers
consume them. Each test iteration runs for a fixed period, at the
end of the iteration it is verified
I was referring to flags in a SoC packet descriptor, which may be stored into
one or more u64 words. I’m also suggesting to use int. Just wanted check if SoC
vendors agree that it performs OK.
-Petri
From: ext Bill Fischofer [mailto:bill.fischo...@linaro.org]
Sent: Thursday, March 26, 2015 3:
https://bugs.linaro.org/show_bug.cgi?id=1381
--- Comment #2 from Bala Manoharan ---
V2 patch submitted:
https://patches.linaro.org/46366/
--
You are receiving this mail because:
You are on the CC list for the bug.___
lng-odp mailing list
lng-odp@lists
On 25 March 2015 at 12:32, Maxim Uvarov wrote:
> Different platforms need different steps to set up pktio for testing. That
> might be veth devices for linux-generic, kernel modules and extended set up
> for dpdk and simple set pktio testing names for other platforms. This patch
> implements plat
From: Balasubramanian Manoharan
Fix for incorrect pmr_term_value update in odp_pmr_create_match() and
odp_pmr_create_range() functions.
Fixes https://bugs.linaro.org/show_bug.cgi?id=1381
Signed-off-by: Balasubramanian Manoharan
---
v2: Fixes checkpatch issue pointed by Bill
platform/linux-ge
We actually have far fewer than 32 flag bits defined (19 at present), so no
need for uint64_t to store them. Most SoCs have fairly efficient
bit-twiddling instructions anyway so I'd leave the optimal implementation
questions to them.
Sounds like we should just leave this as int (as it is today),
It’s OK to me. Although, I was thinking that an implementation defined type can
save e.g. cycle in a case like this
- flags are stored in a uint64_t
- IPv4 flag in upper 32 bits
- implementation defines the type as uint64_t
- only one mask operation is needed e.g.
return pkt_hrd.flags & HAS_IPV4_
Is there any reason not to leave this as int then?
On Thu, Mar 26, 2015 at 7:10 AM, Savolainen, Petri (Nokia - FI/Espoo) <
petri.savolai...@nokia.com> wrote:
> As discussed in one of the calls, I think 0 vs. non-zero return value is
> OK, but odp_bool_t would be misleading type for that range (bo
As discussed in one of the calls, I think 0 vs. non-zero return value is OK,
but odp_bool_t would be misleading type for that range (bool is 0 or 1). So, it
would be better to have another type for true/false integer condition.
-Petri
> -Original Message-
> From: ext Maxim Uvarov [mailt
Hi Jianhua
Egress API's are in progress currently, we expect to roll out initial
proposals into the api-next branch over the next few weeks, for
classification the existing API covers these features http://docs.
opendataplane.org/linux-generic-doxygen-html/group__odp
__classification.html
If you
ODP v1.0 has an initial set of APIs to support packet classification on
RX. See
http://docs.opendataplane.org/linux-generic-doxygen-html/group__odp__classification.html
for details.
We are currently working on corresponding TX capabilities for packet
shaping. These are currently being developed
Hi,
ODP APIs are attractive and it seems very useful for data communication
application.
But unfortunately I cannot find any API
(http://docs.opendataplane.org/html/files.html) for:
Packet classification and Packet Shaping.
Are these APIs not needed from ODP's point of view or will be defined
Petri, please review.
Maxim.
On 03/20/15 21:14, Bill Fischofer wrote:
This change addresses Bug https://bugs.linaro.org/show_bug.cgi?id=1334
Signed-off-by: Bill Fischofer
---
v2 adds doxygen fix to this patch. Petri: Please review this for API
conformance.
include/odp/api/packet_flags.h
On 03/26/15 12:21, Savolainen, Petri (Nokia - FI/Espoo) wrote:
Hi,
Api-next branch seems to be some 30 commits behind the master. Those
two should be very closely in sync, and api-next ahead of master.
Maxim, could you merge all latest commits to api-next also.
Last commit in api-next is:
commi
Hi,
Api-next branch seems to be some 30 commits behind the master. Those two should
be very closely in sync, and api-next ahead of master.
Maxim, could you merge all latest commits to api-next also.
Last commit in api-next is:
commit 66fe09dcf7bc55370781c42459ec84abfb56b195
Author: Maxim Uvaro
The test creates one queue of each schedule sync type and
destroys those.
Signed-off-by: Petri Savolainen
---
test/validation/odp_schedule.c | 64 ++
1 file changed, 64 insertions(+)
diff --git a/test/validation/odp_schedule.c b/test/validation/odp_schedu
Scheduler runs by polling scheduler priority queues for schedule
commands. There are two types of scheduler commands: queue dequeue
and packet input poll. Packet input is polled directly when a poll
command is received. From schduler point of view, the default
packet input queue is like any other q
Added clean up for pending schedule commands and queue destroys.
Added error detection of non empty queues and pre-scheduled events.
Signed-off-by: Petri Savolainen
---
platform/linux-generic/odp_schedule.c | 82 ++-
1 file changed, 61 insertions(+), 21 deletions(
v2: Addressed Mike's comments: modified TODO comments, renamed cls_enabled,
queue type check returns an error in odp_pktio_inq_setdef()
Petri Savolainen (4):
linux-generic: scheduler: restructured queue and pktio integration
linux-generic: schedule: terminate
validation: schedule: added queu
Added function to pause and exit the schedule loop
according to the API.
Signed-off-by: Petri Savolainen
---
test/validation/odp_schedule.c | 21 +
1 file changed, 21 insertions(+)
diff --git a/test/validation/odp_schedule.c b/test/validation/odp_schedule.c
index 0f659b8..b1
From: ext Mike Holmes [mailto:mike.hol...@linaro.org]
Sent: Thursday, March 26, 2015 12:00 AM
To: Savolainen, Petri (Nokia - FI/Espoo)
Cc: lng-odp
Subject: Re: [lng-odp] [PATCH 1/4] linux-generic: scheduler: restructured queue
and pktio integration
On 23 March 2015 at 10:42, Petri Savolainen
63 matches
Mail list logo