Signed-off-by: Bill Fischofer
---
include/odp/api/classification.h | 106 +++
1 file changed, 106 insertions(+)
diff --git a/include/odp/api/classification.h b/include/odp/api/classification.h
index f597b26..1829f74 100644
--- a/include/odp/api/classification.
Signed-off-by: Bill Fischofer
---
platform/linux-generic/include/odp/plat/classification_types.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/platform/linux-generic/include/odp/plat/classification_types.h
b/platform/linux-generic/include/odp/plat/classification_types.h
index 767da7d..10
Signed-off-by: Bill Fischofer
---
test/performance/odp_l2fwd.c | 2 +-
test/performance/odp_pktio_perf.c | 4 ++--
test/performance/odp_scheduling.c | 1 +
3 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/test/performance/odp_l2fwd.c b/test/performance/odp_l2fwd.c
index 9ff159b
Signed-off-by: Bill Fischofer
---
example/classifier/odp_classifier.c | 2 +-
example/generator/odp_generator.c | 2 +-
example/ipsec/odp_ipsec.c | 4 ++--
example/packet/odp_pktio.c | 2 +-
example/timer/odp_timer_test.c | 1 +
5 files changed, 6 insertions(+), 5 deleti
Signed-off-by: Bill Fischofer
---
platform/linux-generic/odp_pool.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/platform/linux-generic/odp_pool.c
b/platform/linux-generic/odp_pool.c
index 26ee06f..6fce612 100644
--- a/platform/linux-generic/odp_pool.c
+++ b/platform/linux-generic/od
Signed-off-by: Bill Fischofer
---
include/odp/api/pool.h | 9 +
1 file changed, 9 insertions(+)
diff --git a/include/odp/api/pool.h b/include/odp/api/pool.h
index 6a7291b..67eda1b 100644
--- a/include/odp/api/pool.h
+++ b/include/odp/api/pool.h
@@ -188,6 +188,15 @@ void odp_pool_print(od
Signed-off-by: Bill Fischofer
---
include/odp/api/pool.h | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/include/odp/api/pool.h b/include/odp/api/pool.h
index ed6971b..6a7291b 100644
--- a/include/odp/api/pool.h
+++ b/include/odp/api/pool.h
@@ -37,6 +37,10 @@ ext
Signed-off-by: Bill Fischofer
---
platform/linux-generic/include/odp_buffer_inlines.h | 2 +-
platform/linux-generic/include/odp_buffer_internal.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/platform/linux-generic/include/odp_buffer_inlines.h
b/platform/linux-generic/
Signed-off-by: Bill Fischofer
---
platform/linux-generic/include/odp/plat/pool_types.h | 10 ++
1 file changed, 10 insertions(+)
diff --git a/platform/linux-generic/include/odp/plat/pool_types.h
b/platform/linux-generic/include/odp/plat/pool_types.h
index 568556f..4b32c29 100644
--- a/p
Signed-off-by: Bill Fischofer
---
platform/linux-generic/odp_event.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/platform/linux-generic/odp_event.c
b/platform/linux-generic/odp_event.c
index d9e86a9..f79fcc3 100644
--- a/platform/linux-generic/odp_event.c
+++ b/platform/l
Signed-off-by: Bill Fischofer
---
include/odp/api/event.h | 23 +--
1 file changed, 5 insertions(+), 18 deletions(-)
diff --git a/include/odp/api/event.h b/include/odp/api/event.h
index 63b476f..69d23b6 100644
--- a/include/odp/api/event.h
+++ b/include/odp/api/event.h
@@ -36
Signed-off-by: Bill Fischofer
---
platform/linux-generic/include/odp/plat/event_types.h | 13 +
1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/platform/linux-generic/include/odp/plat/event_types.h
b/platform/linux-generic/include/odp/plat/event_types.h
index d91937d..0
https://bugs.linaro.org/show_bug.cgi?id=1661
--- Comment #6 from Bill Fischofer ---
Can you add your Review-and-tested-by to the patch so it can get merged?
Thanks.
--
You are receiving this mail because:
You are on the CC list for the bug.___
lng-od
On Tue, Jun 30, 2015 at 06:31:41PM +0300, Maxim Uvarov wrote:
> On 06/30/15 17:45, Stuart Haslam wrote:
> >On Tue, Jun 30, 2015 at 03:33:53PM +0200, Nicolas Morey-Chaisemartin wrote:
> >>Signed-off-by: Nicolas Morey-Chaisemartin
> >Reviewed-by: Stuart Haslam
> >
> >However this will cause test fa
scheduler_main is now ran from the platform side.
As scheduler tests do not have
any platform dependency, the call to the platform agnostic tests is
performed directly in the Makefele.am (TESTS).
Signed-off-by: Christophe Milard
---
platform/linux-generic/test/Makefile.am | 1 +
test/validation/
Module scheduler now gets its own directory and create its own lib
(currentely only containing its executable)
Signed-off-by: Christophe Milard
---
configure.ac | 1 +
test/validation/.gitignore | 1 -
test/validatio
Changes to calm down check-patch called via check-odp when the file is
moved, at next patch.
A few things remains, but not sure they'd make the code more readable...
Signed-off-by: Christophe Milard
---
test/validation/odp_scheduler.c | 27 +++
1 file changed, 19 insertio
Renaming of things which may be, one day, exported in a lib.
This renaming is important, as it creates consistency between test
symbols, which is needed if things get eventually exported in the lib.
Also, tests are often created from other tests: Fixing the first exemples
will help geting future te
Signed-off-by: Christophe Milard
---
test/validation/Makefile.am | 3 +++
test/validation/odp_scheduler.c | 15 +--
2 files changed, 16 insertions(+), 2 deletions(-)
diff --git a/test/validation/Makefile.am b/test/validation/Makefile.am
index a012ccb..872064a 100644
--- a/test/v
Scheduler tests now go through the same modification as pktio,
and gets finally called from the platform side.
To be applied on top of "validation: call to buffer_main from platform"
Christophe Milard (5):
validation: own main in odp_scheduler.c
validation: renaming in odp_scheduler.c
valida
Ping
As per the open call just now, we need to get support behind our efforts to
improve all documentation, patches like this fall on the floor.
Who cares about the docs that we can target as reviewers ?
On 12 June 2015 at 15:37, Mike Holmes wrote:
> Ping
>
> On 3 June 2015 at 13:23, Mike Holm
I got a little bit mixed up between the msg and mmsg version.
After a quick look, we should be able to fall back to recvmsg/sendmsg for a
basic socket implementation
But yes, this patch removed a lot of code and a new version would be very quick
to implement (mostly replacing mmsg by msg).
Nico
On Tue, Jun 30, 2015 at 06:28:10PM +0300, Maxim Uvarov wrote:
> Why it's needed to remove basic socket? Some people use very old
> machines mmap and mmsg might be not supported.
>
> Maxim.
It simplifies the implementation - this change removed 127 lines and
avoided having to add another bunch.
T
On 06/30/15 17:45, Stuart Haslam wrote:
On Tue, Jun 30, 2015 at 03:33:53PM +0200, Nicolas Morey-Chaisemartin wrote:
Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Stuart Haslam
However this will cause test failures due to bug #1661, so the fix for
that should be merged first.
---
Why it's needed to remove basic socket? Some people use very old
machines mmap and mmsg might be not supported.
Maxim.
On 06/30/15 17:45, Stuart Haslam wrote:
On Tue, Jun 30, 2015 at 03:33:41PM +0200, Nicolas Morey-Chaisemartin wrote:
Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: S
Merged reviewed Chistophe's patches for validation:
ea95c0b validation: call to buffer_main from platform
f023380 validation: creating own dir and lib for buffer
0ce8135 validation: renaming in odp_buffer.c
df9352e validation: own main in odp_buffer.c
491531b validation: removed odp_buffer_pool_t
https://bugs.linaro.org/show_bug.cgi?id=1661
Nicolas Morey-Chaisemartin changed:
What|Removed |Added
Blocks||1670
--
You are receiving this m
https://bugs.linaro.org/show_bug.cgi?id=1670
Nicolas Morey-Chaisemartin changed:
What|Removed |Added
Depends on||1661
--
You are receiving this m
On 25 June 2015 at 22:37, Jerin Jacob
wrote:
> On Wed, Jun 24, 2015 at 01:34:07PM +0200, Ola Liljedahl wrote:
> > On 10 June 2015 at 16:08, Jerin Jacob
> > wrote:
> >
> > > This option is to specify minimum number ticks
> > > (delta between future tick and current tick) required to successfully
On Tue, Jun 30, 2015 at 03:33:49PM +0200, Nicolas Morey-Chaisemartin wrote:
> Fixes bug #1670
>
> Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Stuart Haslam
> ---
> platform/linux-generic/odp_packet_socket.c | 74
> +++---
> 1 file changed, 58 insertions(+),
On Tue, Jun 30, 2015 at 03:33:53PM +0200, Nicolas Morey-Chaisemartin wrote:
> Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Stuart Haslam
However this will cause test failures due to bug #1661, so the fix for
that should be merged first.
> ---
> test/validation/pktio/pktio.c | 4 ++--
On Tue, Jun 30, 2015 at 03:33:41PM +0200, Nicolas Morey-Chaisemartin wrote:
> Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Stuart Haslam
> ---
> example/generator/odp_generator.c | 1 -
> example/packet/odp_pktio.c | 1 -
> .../linux-gener
On 29 June 2015 at 10:05, Nicolas Morey-Chaisemartin
wrote:
> Small patch series to:
>
> - remove the basic socket support as it doesn't seem to be used anymore
> - support segmented packets in socket MMSG mode.
>
> The first and third patches are quite straight forward.
>
> The second has more t
Signed-off-by: Nicolas Morey-Chaisemartin
---
test/validation/pktio/pktio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/test/validation/pktio/pktio.c b/test/validation/pktio/pktio.c
index 82ced5c..b87586a 100644
--- a/test/validation/pktio/pktio.c
+++ b/test/validation
Fixes bug #1670
Signed-off-by: Nicolas Morey-Chaisemartin
---
platform/linux-generic/odp_packet_socket.c | 74 +++---
1 file changed, 58 insertions(+), 16 deletions(-)
diff --git a/platform/linux-generic/odp_packet_socket.c
b/platform/linux-generic/odp_packet_socket.c
i
Signed-off-by: Nicolas Morey-Chaisemartin
---
example/generator/odp_generator.c | 1 -
example/packet/odp_pktio.c | 1 -
.../linux-generic/include/odp_packet_io_internal.h | 3 +-
platform/linux-generic/odp_packet_io.c | 18
platfor
Hi,
If there's any time maybe we can talk a bit about the status of the work for
virtualization support in ODP. I'm going to be in the ODP call today.
Cheers,
/Ciprian
___
lng-odp mailing list
lng-odp@lists.linaro.org
https://lists.linaro.org/mailman/l
On Tue, Jun 30, 2015 at 03:20:34PM +0300, Maxim Uvarov wrote:
> On 06/29/15 19:32, Nicolas Morey-Chaisemartin wrote:
> >I'm fine with this but why should it only be for this test and not all of
> >them?
>
> Nicolas, can you do required changes for your platform and test
> them? My fix needed only
On Tue, Jun 30, 2015 at 02:13:31PM +0200, Nicolas Morey-Chaisemartin wrote:
>
>
> On 06/30/2015 01:56 PM, Nicolas Morey-Chaisemartin wrote:
> >
> > On 06/30/2015 01:41 PM, Stuart Haslam wrote:
> >> On Mon, Jun 29, 2015 at 10:05:10AM +0200, Nicolas Morey-Chaisemartin wrote:
> >>> +
> >>> +static u
Added max number of worker/control threads as global init
parameter. Implementation can e.g. optimize it's per worker
thread resource reservation or configuration accordingly.
Signed-off-by: Petri Savolainen
---
include/odp/api/init.h | 13 ++---
1 file changed, 10 insertions(+), 3 delet
On 06/29/15 19:32, Nicolas Morey-Chaisemartin wrote:
I'm fine with this but why should it only be for this test and not all of them?
Nicolas, can you do required changes for your platform and test them? My
fix needed only for dpdk others tests
looks like pass.
Maxim.
On 06/29/2015 06:09 PM
On 06/30/2015 01:56 PM, Nicolas Morey-Chaisemartin wrote:
>
> On 06/30/2015 01:41 PM, Stuart Haslam wrote:
>> On Mon, Jun 29, 2015 at 10:05:10AM +0200, Nicolas Morey-Chaisemartin wrote:
>>> +
>>> +static uint32_t _rx_pkt_to_iovec(odp_packet_t pkt,
>>> +struct iovec iov
It's required to inline the odp_pool_param_init() function. But if we
don't need to inline that function then it can remain unsplit.
On Tue, Jun 30, 2015 at 6:54 AM, Savolainen, Petri (Nokia - FI/Espoo) <
petri.savolai...@nokia.com> wrote:
> I think it's better to maintain the params type in poo
> -Original Message-
> From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext
> Bill Fischofer
> Sent: Thursday, June 25, 2015 3:10 PM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [API-NEXT PATCH 4/6] linux-generic: pool: add
> odp_pool_param_init implementation
>
Applied,
with fix terminason -> termination in patch description. Interesting
that checkpatch/codespell does not capture such errors.
Maxim.
On 06/30/15 12:58, Stuart Haslam wrote:
On Mon, Jun 29, 2015 at 01:12:21PM +0200, Christophe Milard wrote:
Two new functions are introduced in odp_cu
> -Original Message-
> From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext
> Bill Fischofer
> Sent: Thursday, June 25, 2015 3:09 PM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [API-NEXT PATCH 3/6] api: pool: add odp_pool_param_init
> prototype
>
> Signed-off-
On 06/30/2015 01:41 PM, Stuart Haslam wrote:
> On Mon, Jun 29, 2015 at 10:05:10AM +0200, Nicolas Morey-Chaisemartin wrote:
>> +
>> +static uint32_t _rx_pkt_to_iovec(odp_packet_t pkt,
>> + struct iovec iovecs[ODP_BUFFER_MAX_SEG])
>> +{
>> +odp_packet_seg_t seg = odp
I think it's better to maintain the params type in pool.h, next to
odp_pool_create() which needs it. If motivation to move it comes from
implementation convenience to extend the type with hidden fields, etc ... I
think it's better to leave it for implementation to split it.
So, new file not ne
OK, thanks. I'll get a v2 out today.
On Tue, Jun 30, 2015 at 6:50 AM, Savolainen, Petri (Nokia - FI/Espoo) <
petri.savolai...@nokia.com> wrote:
>
>
> > -Original Message-
> > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext
> > Bill Fischofer
> > Sent: Thursday, Ju
> -Original Message-
> From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext
> Bill Fischofer
> Sent: Thursday, June 25, 2015 3:09 PM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [API-NEXT PATCH 1/6] linux-generic: event: convert
> event types to typedef enum
>
On Mon, Jun 29, 2015 at 10:05:10AM +0200, Nicolas Morey-Chaisemartin wrote:
> Fixes bug #1670
>
> Signed-off-by: Nicolas Morey-Chaisemartin
> ---
> platform/linux-generic/odp_packet_socket.c | 95
> +-
> 1 file changed, 79 insertions(+), 16 deletions(-)
>
> diff --g
On Thu, Jun 25, 2015 at 04:42:14PM +0200, Christophe Milard wrote:
>
> since v1: added .gitignore
>
> Pool tests now go through the same modification as pktio,
> and gets finally called from the platform side.
> To be applied on top of "validation: queue tests moved to platform side"
> Note: Pool
Yes, abort on schedule queue failures (scheduler internal errors).
-Petri
From: ext Ola Liljedahl [mailto:ola.liljed...@linaro.org]
Sent: Tuesday, June 30, 2015 1:18 PM
To: Zoltan Kiss
Cc: Savolainen, Petri (Nokia - FI/Espoo); lng-odp@lists.linaro.org
Subject: Re: [lng-odp] [API-NEXT PATCH v3 8/9
It's more generic implementation simplify reusing timer API
for other platforms.
Signed-off-by: Ivan Khoronzhuk
---
I've checked this patch with Keystone implementation.
.../linux-generic/include/odp_timer_internal.h | 9 ---
platform/linux-generic/odp_timer.c | 31 +++
On 29 June 2015 at 20:16, Zoltan Kiss wrote:
> Hi,
>
> So you say instead of returning I should use an ODP_ABORT()?
>
If an ODP function cannot succeed or fail cleanly (e.g. internal side
effects unrolled, internal state consistent), it must not return at all.
Calling ODP_ABORT is one way of achi
On Mon, Jun 29, 2015 at 02:48:16PM +0200, Christophe Milard wrote:
> since v1: use CU_ASSERT_PTR_NOT_NULL(x) to please check-patch
>
> Packet tests now go through the same modification as pktio,
> and gets finally called from the platform side.
> To be applied on top of "validation: pool tests mov
On Mon, Jun 29, 2015 at 01:12:21PM +0200, Christophe Milard wrote:
> Two new functions are introduced in odp_cunit_common.c:
> odp_cunit_register_global_init() is to be used to register test
> executable init function (overloading the default ODP init performed).
> odp_cunit_register_global_term()
I am rebasing right now. I am in the process to move all the tests modules
to the platform side (i.e. be called from the platfoem side, as you have
noticed for pktio and crypto.) I have quite a few modules ready here, but
they have not been all reviewed/merged yet. I need to rebase to get that in.
On 06/29/2015 05:39 PM, Christophe Milard wrote:
> queue_main is now ran from the platform side.
> As queue tests do not have
> any platform dependency, the call to the platform agnostic tests is
> performed directly in the Makefele.am (TESTS).
>
> Signed-off-by: Christophe Milard
> Reviewed-by:
Signed-off-by: Nicolas Morey-Chaisemartin
---
platform/linux-generic/test/pktio/pktio_run | 6 +++---
test/performance/odp_l2fwd_run | 4 ++--
test/performance/odp_scheduling_run | 2 +-
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/platform/linux-generic/tes
Signed-off-by: Nicolas Morey-Chaisemartin
---
test/Makefile.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/Makefile.inc b/test/Makefile.inc
index 6cdd0db..6ba00e0 100644
--- a/test/Makefile.inc
+++ b/test/Makefile.inc
@@ -21,4 +21,4 @@ AM_LDFLAGS += -L$(LIB)
@VALGRI
Signed-off-by: Nicolas Morey-Chaisemartin
---
helper/test/Makefile.am | 2 +-
platform/linux-generic/test/Makefile.am | 3 ++-
test/Makefile.inc | 2 ++
test/performance/Makefile.am| 2 +-
4 files changed, 6 insertions(+), 3 deletions(-)
diff --g
On 2015-06-30 08:51, Nicolas Morey-Chaisemartin wrote:
> Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Christophe Milard
> ---
> platform/linux-generic/test/Makefile.am | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/platform/linux-generic/test/Makefile.am
>
63 matches
Mail list logo