On 2015-08-28 16:18, Bill Fischofer wrote:
> Signed-off-by: Bill Fischofer
> ---
> .../include/odp/plat/schedule_types.h | 3 +
> platform/linux-generic/odp_schedule.c | 165
> -
> platform/linux-generic/odp_thread.c| 25 +++-
> 3
The API differences 1.2 to 1.3 are in the attached file
On 31 August 2015 at 12:12, Maxim Uvarov wrote:
> Subj.
>
> Please note that make check now tests all 3 pktios (under root) for
> linux-generic which can cause delay up to 3 minutes.
>
> Best regards,
> Maxim.
>
> On 08/31/15 14:10, Maxim
Subj.
Please note that make check now tests all 3 pktios (under root) for
linux-generic which can cause delay up to 3 minutes.
Best regards,
Maxim.
On 08/31/15 14:10, Maxim Uvarov wrote:
Signed-off-by: Maxim Uvarov
---
debian/changelog | 80 +++
Signed-off-by: Benoît Ganne
---
example/classifier/odp_classifier.c | 95 +
1 file changed, 76 insertions(+), 19 deletions(-)
diff --git a/example/classifier/odp_classifier.c
b/example/classifier/odp_classifier.c
index 685f335..bf8a845 100644
--- a/example/cl
Signed-off-by: Benoît Ganne
---
.../include/odp_classification_datamodel.h | 2 ++
.../include/odp_classification_inlines.h | 21 +++
platform/linux-generic/odp_classification.c| 42 --
3 files changed, 46 insertions(+), 19 deletions(-)
diff
The application can now specify a packet offset
in PMR rules. This offset is absolute from the
frame start. It is used to extract the PMR value.
This is useful to support arbitrary backplane
protocols and extensions.
Signed-off-by: Benoît Ganne
---
include/odp/api/classification.h | 39
This patch move the odp_pmr_match_t structure definition
to prepare the introduction of the new ODP_PMR_CUSTOM_FRAME
term.
Signed-off-by: Benoît Ganne
---
include/odp/api/classification.h | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/include
v4: - move definitions prior to any API modifiction to improve
readability
- change comment so that odp_pmr_match_t.offset is ignored
if not used instead of enforcing a 0 value
v3: - split the api patch in two: 1st one to modify api, 2nd one
to move declarations for rea
Petri,
On 31.08.15 15:13, Savolainen, Petri (Nokia - FI/Espoo) wrote:
I didn't see any word about global time in API, but also I didn't see
any word that
it has to be local. So I supposed that application should think that
it's worst case - local.
So, if it has to be global, it definitely sho
Merged.
Maxim.
On 08/27/15 19:32, Maxim Uvarov wrote:
v2: - move start to top level function.
- s/ret/$ret/ in first patch.
I missed branch to start pktio in burst mode. Make check reported
pass but actually 0 packets were received. Fix it.
Maxim.
Maxim Uvarov (2):
test: l2fwd: captu
On Thu, Aug 27, 2015 at 11:32 AM, Maxim Uvarov
wrote:
> l2fwd expects bunch of packets to be routed,
> test if number of packets less then 100, and report
> error to make check and mark test as failed.
>
> Signed-off-by: Maxim Uvarov
>
Reviewed-by: Bill Fischofer
> ---
> test/performance/od
On Thu, Aug 27, 2015 at 11:32 AM, Maxim Uvarov
wrote:
> Signed-off-by: Maxim Uvarov
>
Reviewed-by: Bill Fischofer
> ---
> test/performance/odp_l2fwd.c | 14 --
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/test/performance/odp_l2fwd.c b/test/performance/odp_
The direct comparing of "cur_cycles" and "end_cycles" is not valid,
as "end_cycles" can be overflowed and comparison will give wrong
result. So use odp_time_diff_cycles() for that, as it takes in
account cycles overflow.
Signed-off-by: Ivan Khoronzhuk
---
test/performance/odp_pktio_perf.c | 9 ++
The direct comparing of "cur_cycles" and "next_tx_cycles" is not
valid, as "next_tx_cycles" can be overflowed and comparison will
give wrong result. So use odp_time_diff_cycles() for that, as it
takes in account ticks overflow.
Signed-off-by: Ivan Khoronzhuk
---
test/performance/odp_pktio_perf.c
It's better to describe by example:
cur = 15;
start = 15;
diff = 2;
while (odp_time_cycles_diff(start, cur) < diff) {
cur = odp_time_cycles();
}
This example has to work. It's possible only when t2 - t1 = 0 if t2 = t1.
The validation test on it will be added later.
Signed-off-by: Ivan Kh
It's not correct to mix wall time and scheduler wait time,
used timers can have different rates. As in this example scheduler
is used only for poll purposes, using wait time for scheduling can be
avoided at all. This patch replaces callback function on function
w/o wait time, and doesn't add any fu
This series contains fixes and is required before changing time API.
It includes previous patches:
- "[lng-odp] [Patch v2 0/2] performance: odp_pktio_perf: fix potentials ticks
overflows"
https://lists.linaro.org/pipermail/lng-odp/2015-August/014129.html
with changes proposed by Stuart:
+
+/**
+ * Check if recursive spinlock is locked.
+ *
+ * @param lockPointer to a lock
+ *
+ * @retval 1 lock is locked
+ * @retval 0 lock is not locked
+ */
+int odp_spinlock_recursive_is_locked(odp_spinlock_recursive_t *lock);
+
What is the use case for this routine? The only routine that w
>
> I didn't see any word about global time in API, but also I didn't see
> any word that
> it has to be local. So I supposed that application should think that
> it's worst case - local.
> So, if it has to be global, it definitely should be described in the
> API.
> I only worry about that the s
On Mon, Aug 31, 2015 at 5:43 AM, Petri Savolainen <
petri.savolai...@nokia.com> wrote:
> Applications can use recursive spinlocks to avoid deadlock from
> single thread acquiring the same lock multiple times. Recursive
> locks are used in legacy applications. ODP version of recursive
> spinlock en
On 2015-08-27 18:47, Nicolas Morey-Chaisemartin wrote:
> log_fn is never called when --disable-debug-print was passed to
> configure which causes replacement_logging_used to stay at 0
>
> Signed-off-by: Nicolas Morey-Chaisemartin
Reviewed-by: Christophe Milard
> ---
> test/validation/init/in
Signed-off-by: Maxim Uvarov
---
debian/changelog | 80 +++
include/odp/api/version.h | 2 +-
2 files changed, 81 insertions(+), 1 deletion(-)
diff --git a/debian/changelog b/debian/changelog
index f7fdc35..741ab72 100644
--- a/debian/changelo
Reviewed-by: Petri Savolainen
> -Original Message-
> From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of
> ext Bill Fischofer
> Sent: Saturday, August 29, 2015 12:19 AM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [API-NEXT PATCHv4 00/10] Scheduler Extensions for
On 08/31/15 12:05, Alexandru Badicioiu wrote:
Hi Maxim,
I'd ask some questions related to the testing application:
https://git.linaro.org/people/maxim.uvarov/odp.git/blob/8c749b3fd6e0a3715e06c262d85244aa180dd204:/platform/linux-generic/test/pktio_ipc/pktio_ipc.c
which probably shows how an IPC p
Added recursive read-write lock. It allows threads to
read lock or write lock the rwlock multiple times without
deadlocking. Mixing read and write lock operations is
not supported.
ODP version of recursive rwlock enables porting legacy
applications, which use these kind of locks.
Signed-off-by: P
Applications can use recursive spinlocks to avoid deadlock from
single thread acquiring the same lock multiple times. Recursive
locks are used in legacy applications. ODP version of recursive
spinlock enable porting of those applications.
Signed-off-by: Petri Savolainen
---
include/odp.h
Hi Maxim,
I'd ask some questions related to the testing application:
https://git.linaro.org/people/maxim.uvarov/odp.git/blob/8c749b3fd6e0a3715e06c262d85244aa180dd204:/platform/linux-generic/test/pktio_ipc/pktio_ipc.c
which probably shows how an IPC pktio would be typically used :
- is "ipc_pktio
ping.
On 08/18/15 14:01, Maxim Uvarov wrote:
v8: - make pktio ipc internal pktio for linux-generic;
- place validation test for pktio ipc inside linux-generic;
- move odp_ring and odp_pause from helpers inside linux-generic;
- cleanup checkpatch errors in ring code.
v7: - 1.
28 matches
Mail list logo