Re: [lng-odp] [API-NEXT PATCH] linux-generic: sysinfo: update dummy function to pass validation

2015-10-29 Thread Hongbo Zhang
On 29 October 2015 at 21:25, Maxim Uvarov wrote: > On 10/29/2015 13:51, Hongbo Zhang wrote: >> >> This patch is for https://bugs.linaro.org/show_bug.cgi?id=1870, and >> has been tested on Juno. >> >> On 29 October 2015 at 18:45, wrote: >>> >>> From: Hongbo Zhang >>> >>> In the default dummy fun

[lng-odp] [API-NEXT PATCH 2/2] validation: synchronizers: add recursive lock tests

2015-10-29 Thread Bill Fischofer
Add tests for validating odp_spinlock_recursive and odp_rwlock_recursive lock types. Signed-off-by: Bill Fischofer --- test/validation/synchronizers/synchronizers.c | 386 ++ test/validation/synchronizers/synchronizers.h | 6 + 2 files changed, 392 insertions(+) diff -

[lng-odp] [API-NEXT PATCH 1/2] validation: synchronizers: add missing rwlock read lock functional test

2015-10-29 Thread Bill Fischofer
rwlock functional tests test for write locks, however they should also test for read locks. Signed-off-by: Bill Fischofer --- test/validation/synchronizers/synchronizers.c | 13 + 1 file changed, 13 insertions(+) diff --git a/test/validation/synchronizers/synchronizers.c b/test/val

[lng-odp] [PATCH] validation: pktio: fix start_stop test

2015-10-29 Thread Nicolas Morey-Chaisemartin
Test of Rx on a stopped pktio was broken due to a missing: + pkt = odp_packet_from_event(ev); pkt value was the last return for odp_packet_alloc so in the setup ODP_PACKET_INVALID which made it work. However changing the size of the pool to > 100 changed pkt value so

[lng-odp] [Bug 1365] Lock-up following sendmmsg failure

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1365 --- Comment #7 from Mike Holmes --- latest version v5 http://patches.opendataplane.org/patch/3468/ -- You are receiving this mail because: You are on the CC list for the bug.___ lng-odp mailing list lng-odp

[lng-odp] [Bug 1594] odp-ovs : back2back test shows port freezes after some time

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1594 --- Comment #1 from Mike Holmes --- This has not been reproduced, a detailed description on how to expose the issue with the current release is needed. -- You are receiving this mail because: You are the assignee for the bug. You are on the CC list f

[lng-odp] [Bug 1615] odp_timer fails in CI with Segmentation fault

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1615 --- Comment #19 from Mike Holmes --- CI is not showing this bug currently, will close next week unless there is feedback. -- You are receiving this mail because: You are on the CC list for the bug.___ lng-o

[lng-odp] [Bug 1864] Missing header file in install directory

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1864 Mike Holmes changed: What|Removed |Added Status|UNCONFIRMED |RESOLVED Resolution|---

[lng-odp] [Bug 1866] Rename validation suite synchronizer test

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1866 Mike Holmes changed: What|Removed |Added Assignee|lng-odp@lists.linaro.org|bill.fischo...@linaro.org CC|

Re: [lng-odp] [API-NEXT PATCH] validation: std_clib: added validation tests

2015-10-29 Thread Bill Fischofer
On Thu, Oct 29, 2015 at 9:52 AM, Petri Savolainen < petri.savolai...@nokia.com> wrote: > Added validation tests for ODP std C library API. > > Signed-off-by: Petri Savolainen > Reviewed-and-Tested-by: Bill Fischofer > --- > configure.ac | 1 + > platform/linux-ge

[lng-odp] [API-NEXT PATCH] validation: std_clib: added validation tests

2015-10-29 Thread Petri Savolainen
Added validation tests for ODP std C library API. Signed-off-by: Petri Savolainen --- configure.ac | 1 + platform/linux-generic/test/Makefile.am | 1 + test/validation/Makefile.am | 1 + test/validation/std_clib/.gitignore | 1 + test/validatio

[lng-odp] [PATCH 2/2] linux-generic/odp_thrmask.c: incorrect correlation THREAD to CPU

2015-10-29 Thread Anders Roxell
Its wrong to associate the maximum number of threads to the number of CPUs available. Signed-off-by: Anders Roxell --- platform/linux-generic/odp_thrmask.c | 5 - 1 file changed, 5 deletions(-) diff --git a/platform/linux-generic/odp_thrmask.c b/platform/linux-generic/odp_thrmask.c index a

[lng-odp] [PATCH 1/2] linux-generic: odp_cpumask.c: assert on ODP_CPUMASK_SIZE

2015-10-29 Thread Anders Roxell
The API definition of a CPU mask must not be incompatible with the platform it is implemented on Signed-off-by: Anders Roxell --- platform/linux-generic/odp_cpumask.c | 4 1 file changed, 4 insertions(+) diff --git a/platform/linux-generic/odp_cpumask.c b/platform/linux-generic/odp_cpumas

Re: [lng-odp] [API-NEXT PATCH] linux-generic: sysinfo: update dummy function to pass validation

2015-10-29 Thread Maxim Uvarov
On 10/29/2015 13:51, Hongbo Zhang wrote: This patch is for https://bugs.linaro.org/show_bug.cgi?id=1870, and has been tested on Juno. On 29 October 2015 at 18:45, wrote: From: Hongbo Zhang In the default dummy function systemcpu(), only cpu_hz[0] and model_str[0] are set to dummy values, th

[lng-odp] [PATCH 3/5] test: l2fwd: optimize statistics usage

2015-10-29 Thread Petri Savolainen
Allocate cacheline aligned shared memory for per thread statistics and simplify stats pointer references. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 63 1 file changed, 34 insertions(+), 29 deletions(-) diff --git a/test/perfo

[lng-odp] [PATCH 5/5] test: l2fwd: separate rx and tx drop counters

2015-10-29 Thread Petri Savolainen
Separated receive and transmit drop counters to help debugging the cause of dropped packets. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 43 +++ 1 file changed, 27 insertions(+), 16 deletions(-) diff --git a/test/performance/odp_l2f

[lng-odp] [PATCH 4/5] test: l2fwd: increase burst size

2015-10-29 Thread Petri Savolainen
Increased burst size to 32. This improves packet rate about 15% with netmap, since system call rate is halved. No harm to any implementation, since implementation decides how many packets are returned. This is comparable to DPDK l2fwd burst size. Signed-off-by: Petri Savolainen --- test/performa

[lng-odp] [PATCH 2/5] test: l2fwd: optimize queue mode

2015-10-29 Thread Petri Savolainen
Queue mode works the same way as direct mode, but uses odp_schedule_multi for packet input. This improves packet rate about 40% (with netmap). Only scheduler overhead is now added which makes it easy to compare direct vs. scheduler inputs options. Output through queues or TM can be added as a thir

[lng-odp] [PATCH 1/5] test: l2fwd: added option to disable error check

2015-10-29 Thread Petri Savolainen
Added command line option to disable packet error check. Error check requires full packet parse. Max packet rate measurements should be done with minimal feature set. This change gives +10% packet rate increase in direct recv mode with netmap. Signed-off-by: Petri Savolainen --- test/performanc

Re: [lng-odp] [PATCH 7/9] linux-generic: netmap: support segmented packets

2015-10-29 Thread Maxim Uvarov
On 10/28/2015 22:29, Stuart Haslam wrote: Replace the nm_inject() helper with our own version so that odp_packet_copydata_out() can be used as this understands segmented packets. Signed-off-by: Stuart Haslam --- platform/linux-generic/pktio/netmap.c | 59 ---

Re: [lng-odp] [PATCH 3/9] linux-generic: pktio: support using netmap: prefix

2015-10-29 Thread Maxim Uvarov
If you add prefix, then getenv() has to be removed. And previous patch looks like obsolete. Maxim. On 10/28/2015 22:29, Stuart Haslam wrote: The netmap API requires interface names to be prefixed with "netmap:", the pktio code will do that automatically, e.g. odp_pktio_open("eth0") becomes nm_

[lng-odp] [Bug 1873] odp process-mode is broken

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1873 Maxim Uvarov changed: What|Removed |Added CC||maxim.uva...@linaro.org --- Comment #1 from Max

Re: [lng-odp] [API-NEXT PATCH] validation: pktio: add test for odp_pktio_print()

2015-10-29 Thread Maxim Uvarov
Hello Matias, this test does not test anything. In many validation tests create_pktio() helper exist. I think it's reasonable to just add odp_pktio_print() just after pktio creation in all tests. So that from log it will be clear which pktio was used for testing. Thanks, Maxim. On 10/28/2015

Re: [lng-odp] [API-NEXT PATCH] mergefix: example: classifier: fix duplicate merge lines

2015-10-29 Thread Bala Manoharan
Reviewed-by: Balasubramanian Manoharan On 29 October 2015 at 16:38, Maxim Uvarov wrote: > Looks like merge to api-next, cherry-pick from api-next > and merge master to api-next produced duplicate patch lines. > Found that with inspecting branches with 'git diff master api-next' > > Signed-off-by

[lng-odp] [API-NEXT PATCH] mergefix: example: classifier: fix duplicate merge lines

2015-10-29 Thread Maxim Uvarov
Looks like merge to api-next, cherry-pick from api-next and merge master to api-next produced duplicate patch lines. Found that with inspecting branches with 'git diff master api-next' Signed-off-by: Maxim Uvarov --- example/classifier/odp_classifier.c | 5 - 1 file changed, 5 deletions(-)

Re: [lng-odp] [API-NEXT PATCH] linux-generic: sysinfo: update dummy function to pass validation

2015-10-29 Thread Hongbo Zhang
Please _DO_NOT_ merge this one; I have sent out an updated version today: https://patches.linaro.org/55776/ On 20 October 2015 at 20:38, wrote: > From: Hongbo Zhang > > In the default dummy function systemcpu(), only cpu_hz[0] and model_str[0] > are set to dummy values, then in the validation

Re: [lng-odp] [API-NEXT PATCH] linux-generic: sysinfo: update dummy function to pass validation

2015-10-29 Thread Hongbo Zhang
This patch is for https://bugs.linaro.org/show_bug.cgi?id=1870, and has been tested on Juno. On 29 October 2015 at 18:45, wrote: > From: Hongbo Zhang > > In the default dummy function systemcpu(), only cpu_hz[0] and model_str[0] > are set to dummy values, then in the validation code if iterate

[lng-odp] [API-NEXT PATCH] linux-generic: sysinfo: update dummy function to pass validation

2015-10-29 Thread hongbo.zhang
From: Hongbo Zhang In the default dummy function systemcpu(), only cpu_hz[0] and model_str[0] are set to dummy values, then in the validation code if iterate each CPU, cores other than core 0 report failure, this patchs pad all the arrays to default values to pass validation. Signed-off-by: Hong

Re: [lng-odp] [PATCH] validation: check return code from odp_queue_lock_count()

2015-10-29 Thread Bill Fischofer
Note that my Bug fix patch for Bug 1824 also touches this module. Not sure if there are merge conflicts between these two. On Thu, Oct 29, 2015 at 5:24 AM, Maxim Uvarov wrote: > odp_queue_lock_count() return int not uint32_t where -1 > is assigned for error. > Bug: https://bugs.linaro.org/show_

Re: [lng-odp] [PATCHv2] test: l2fwd: add extra counter to count packet with errors vs dropped packets

2015-10-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
OK. I'll send it shortly. -Petri > -Original Message- > From: EXT Nicolas Morey-Chaisemartin [mailto:nmo...@kalray.eu] > Sent: Thursday, October 29, 2015 12:18 PM > To: Savolainen, Petri (Nokia - FI/Espoo); lng-odp@lists.linaro.org > Subject: Re: [lng-odp] [PATCHv2] test: l2fwd: add extra

Re: [lng-odp] [API-NEXT PATCH v5 3/5] api: time: unbind CPU cycles from time API

2015-10-29 Thread Ivan Khoronzhuk
Hi Petri, Let's clarify some aspects that can be taken into account if common time type is used for global and local times. Mainly it reflected in operation/conversion functions. Mostly that is why I want to have separate functions for global and local times. Please say what do you think about

[lng-odp] [Bug 1867] CID 153388: scheduler.c: in schedule_common_()

2015-10-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1867 Maxim Uvarov changed: What|Removed |Added CC||maxim.uva...@linaro.org --- Comment #5 from Max

[lng-odp] [PATCH] validation: check return code from odp_queue_lock_count()

2015-10-29 Thread Maxim Uvarov
odp_queue_lock_count() return int not uint32_t where -1 is assigned for error. Bug: https://bugs.linaro.org/show_bug.cgi?id=1867 Signed-off-by: Maxim Uvarov --- test/validation/scheduler/scheduler.c | 22 +++--- 1 file changed, 15 insertions(+), 7 deletions(-) diff --git a/test/

Re: [lng-odp] [PATCHv2] test: l2fwd: add extra counter to count packet with errors vs dropped packets

2015-10-29 Thread Nicolas Morey-Chaisemartin
It's fine by me. Yes that's the point. Depending on the traffic source, (ie DPDPK on some HW), there tend to be a lot of Rx errors. This make it easier to know if Tx saturates, or the packet generator has issues. Nicolas On 10/29/2015 11:15 AM, Savolainen, Petri (Nokia - FI/Espoo) wrote: > I'm

Re: [lng-odp] [PATCHv2] test: l2fwd: add extra counter to count packet with errors vs dropped packets

2015-10-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
I'm just optimizing/cleaning l2fwd and this patch would conflict. I can add it to my series. So, you basically want to separate and print rx_ and tx_errors? -Petri > -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT > Nicolas Morey-Chaisemart

[lng-odp] [PATCHv2] test: l2fwd: add extra counter to count packet with errors vs dropped packets

2015-10-29 Thread Nicolas Morey-Chaisemartin
Drop packets counts both packets dropped by calls to pktio_send() and packet which were flagged with errors during parsing. Add an extra counter to differ these two types of packets. Signed-off-by: Nicolas Morey-Chaisemartin --- v2: Rebased on latest master test/performance/odp_l2fwd.c | 17

Re: [lng-odp] [PATCH v3 1/2] linux-generic: netmap: wait for the interface to become active

2015-10-29 Thread Maxim Uvarov
Merged, Maxim. On 10/23/2015 11:02, Matias Elo wrote: Netmap interface takes a few seconds to become active after calling nm_open(). This caused several test applications to fail. Check link status at the end of netmap_open() to fix this. Signed-off-by: Matias Elo --- v3: - Rebased to master

Re: [lng-odp] [PATCH 1/2] api: cpumask: don't use platform internal defines

2015-10-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
Recursive locks are per thread. CPU ids are per CPU. So, recursive lock implementation needs still max thread count. But that's implementation, not an API change. -Petri > -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT > Maxim Uvarov > Sent

Re: [lng-odp] [PATCH 1/2] api: cpumask: don't use platform internal defines

2015-10-29 Thread Maxim Uvarov
Merged to api-next. Needed to do the same for rwlock_recursive_types.h. Will merge patches to master soon. Maxim. On 10/29/2015 10:32, Savolainen, Petri (Nokia - FI/Espoo) wrote: Both patches: Reviewed-by: Petri Savolainen -Original Message- From: EXT Anders Roxell [mailto:anders

Re: [lng-odp] [PATCH 1/2] api: cpumask: don't use platform internal defines

2015-10-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
Both patches: Reviewed-by: Petri Savolainen > -Original Message- > From: EXT Anders Roxell [mailto:anders.rox...@linaro.org] > Sent: Wednesday, October 28, 2015 4:33 PM > To: Orpana, Pasi (Nokia - FI/Espoo); Wallen, Carl (Nokia - FI/Espoo) > Cc: lng-odp@lists.linaro.org; Savolainen, Pet

Re: [lng-odp] [PATCHv3 1/5] helper: add table api

2015-10-29 Thread Maxim Uvarov
On 10/29/2015 10:02, huanggaoyang wrote: Signed-off-by: huanggaoyang --- helper/include/odp/helper/table.h | 222 ++ 1 file changed, 222 insertions(+) create mode 100644 helper/include/odp/helper/table.h diff --git a/helper/include/odp/helper/table.h b/

Re: [lng-odp] [PATCHv5 0/5] handle transmit errors correctly

2015-10-29 Thread Maxim Uvarov
Stuart, That is quite big changes. I merged them to api-next to run CI tests first, if everything will be ok, I will merge it to master. Maxim. On 10/27/2015 19:42, Stuart Haslam wrote: Fixes bug: https://bugs.linaro.org/show_bug.cgi?id=1365 Changes since v4: - Fix seg fault due to unhand

[lng-odp] [PATCHv3 4/5] helper: add the new source files to Makefile

2015-10-29 Thread huanggaoyang
Signed-off-by: huanggaoyang --- helper/Makefile.am | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/helper/Makefile.am b/helper/Makefile.am index 1a74e8e..196d887 100644 --- a/helper/Makefile.am +++ b/helper/Makefile.am @@ -17,6 +17,7 @@ helperinclude_HEADERS = \

[lng-odp] [API-NEXT PATCHv3 0/5] helper: add table module

2015-10-29 Thread huanggaoyang
v1: helper: added base api of Table added two impls of Table:hash table & linear table v2: 1. fix mistakes in Copyright Info of files 2. change the name of an useless param of function odph_linear_table_create to ODP_IGNORED v3: update comments, make the description more c

[lng-odp] [PATCHv3 1/5] helper: add table api

2015-10-29 Thread huanggaoyang
Signed-off-by: huanggaoyang --- helper/include/odp/helper/table.h | 222 ++ 1 file changed, 222 insertions(+) create mode 100644 helper/include/odp/helper/table.h diff --git a/helper/include/odp/helper/table.h b/helper/include/odp/helper/table.h new file mod

[lng-odp] [PATCHv3 5/5] helper: test: add a simple test case for hashtable

2015-10-29 Thread huanggaoyang
Signed-off-by: huanggaoyang --- helper/test/Makefile.am | 5 +- helper/test/odp_table.c | 134 2 files changed, 138 insertions(+), 1 deletion(-) create mode 100644 helper/test/odp_table.c diff --git a/helper/test/Makefile.am b/helper/test/Makef

[lng-odp] [PATCHv3 3/5] helper: table: add impl of lineartable

2015-10-29 Thread huanggaoyang
Signed-off-by: huanggaoyang --- helper/lineartable.c | 211 ++ helper/odph_lineartable.h | 41 + 2 files changed, 252 insertions(+) create mode 100644 helper/lineartable.c create mode 100644 helper/odph_lineartable.h diff --git a/helper

[lng-odp] [PATCHv3 2/5] helper: table: add impl of hashtable

2015-10-29 Thread huanggaoyang
Signed-off-by: huanggaoyang --- helper/hashtable.c | 346 helper/odph_hashtable.h | 42 ++ helper/odph_list_internal.h | 85 +++ 3 files changed, 473 insertions(+) create mode 100644 helper/hashtable.c create mode 100644 he