Re: [lng-odp] [PATCH] validation: pktio check for number of interfaces

2016-02-08 Thread Christophe Milard
On 2016-02-08 09:20, Maxim Uvarov wrote: > CI got following error: > pktio.c: In function 'pktio_test_recv_queue': > pktio.c:643:11: error: 'pktio[0]' may be used uninitialized > in this function [-Werror=maybe-uninitialized] > pktio_tx = pktio[0] > > That can never happen due to

Re: [lng-odp] [PATCH] validation: pktio check for number of interfaces

2016-02-08 Thread Maxim Uvarov
Merged, Maxim. On 02/08/2016 16:28, Christophe Milard wrote: On 2016-02-08 09:20, Maxim Uvarov wrote: CI got following error: pktio.c: In function 'pktio_test_recv_queue': pktio.c:643:11: error: 'pktio[0]' may be used uninitialized in this function [-Werror=maybe-uninitialized]

Re: [lng-odp] [API-NEXT PATCHv2 0/3] Preparing for new interfaces

2016-02-08 Thread Bill Fischofer
This looks good and passes apply-and-build. However in addition to the whitespace issues in part 3 it needs a part 4 to update the Implementation Guide, which includes a diagram of the include hierarchy that this series modifies. On Mon, Feb 8, 2016 at 12:31 PM, Christophe Milard <

[lng-odp] [PATCH] Define odp_cpumask_get_bitmap to retrieve the bitmap defined by odp_cpumask_t.

2016-02-08 Thread José Pekkarinen
This patch provides a generic way to retrieve the cpu mask defined in odp_cpumask_t. Given this function definition, any platform can decide how to call the bitmap, decoupling it from the linux-generic name set. Signed-off-by: José Pekkarinen --- helper/linux.c

[lng-odp] [API-NEXT PATCHv2 3/3] doc: descr of structure for new interfaces

2016-02-08 Thread Christophe Milard
updates of the documentation to reflect the new structure allowing new interface addition. Signed-off-by: Christophe Milard --- doc/implementers-guide/implementers-guide.adoc | 72 +++--- doc/users-guide/users-guide.adoc | 11 ++--

[lng-odp] [API-NEXT PATCHv2 2/3] api: move include/odp.h to include/odp_api.h

2016-02-08 Thread Christophe Milard
odp.h actually describes the applicatiion interface of ODP and is logicaly moved to odp_api.h. Applications now includes . This simplifies the addition of other ODP interfaces (e.g. drivers may include odp_drv.h in the future.) This patch has been done by a script which is given in the cover

Re: [lng-odp] [API-NEXT PATCHv5 0/6] Packet Multicast Implementation and Documentation

2016-02-08 Thread Bill Fischofer
ping. This has been reviewed. v5 should be merged. On Thu, Jan 28, 2016 at 9:04 AM, Bill Fischofer wrote: > Changes for v5 > - Correct typos in user guide changes > > Changes for v4 > - Correct implementation of eth_bcast check > > Changes for v3 > - Changed

Re: [lng-odp] [API-NEXT PATCHv5 0/6] Packet Multicast Implementation and Documentation

2016-02-08 Thread Maxim Uvarov
On 02/08/2016 21:01, Bill Fischofer wrote: The series was reviewed by Petri. The last tweak was just a typo in the documentation patch. Ok, will merge it then. It's better to include reviews to commit message in next versions if you don't ask for one more review. Maxim. On Mon, Feb 8,

Re: [lng-odp] [API_NEXT PATCH V3 01/01] ODP API: add control/worker cpumasks to init data

2016-02-08 Thread Gary Robertson
On Tue, Feb 2, 2016 at 5:41 AM, Savolainen, Petri (Nokia - FI/Espoo) wrote: > > ... >> + This cpumask is used only to convey externally supplied >> + ODP instance during initialization. Applications code must call >> +

[lng-odp] [API-NEXT PATCHv2 0/3] Preparing for new interfaces

2016-02-08 Thread Christophe Milard
since v1: odp.h renamed to odp_api.h (and not odp/api.h as initialy proposed). This patch series implements a new structure in the ODP repo so that new interfaces can be more easily added to ODP Saddly changing the current structure seems needed as just adding to it results in a quite fuzzy file

Re: [lng-odp] [API-NEXT PATCHv5 0/6] Packet Multicast Implementation and Documentation

2016-02-08 Thread Maxim Uvarov
On 02/08/2016 20:56, Bill Fischofer wrote: ping. This has been reviewed. v5 should be merged. reviewed all patches or 5 and 6 only? Maxim. On Thu, Jan 28, 2016 at 9:04 AM, Bill Fischofer > wrote: Changes for v5 -

Re: [lng-odp] [API-NEXT PATCHv5 0/6] Packet Multicast Implementation and Documentation

2016-02-08 Thread Bill Fischofer
Good point. I'll do that in future. Thanks. On Mon, Feb 8, 2016 at 12:03 PM, Maxim Uvarov wrote: > On 02/08/2016 21:01, Bill Fischofer wrote: > >> The series was reviewed by Petri. The last tweak was just a typo in the >> documentation patch. >> >> > Ok, will merge

Re: [lng-odp] [API-NEXT PATCHv5 0/6] Packet Multicast Implementation and Documentation

2016-02-08 Thread Bill Fischofer
The series was reviewed by Petri. The last tweak was just a typo in the documentation patch. On Mon, Feb 8, 2016 at 11:58 AM, Maxim Uvarov wrote: > On 02/08/2016 20:56, Bill Fischofer wrote: > >> ping. This has been reviewed. v5 should be merged. >> > > reviewed all

[lng-odp] v1.7.0.0 is out

2016-02-08 Thread Maxim Uvarov
I'm glad to say that finally 1.7 release is happen. One of the major change in current release is new pktio API (odp_pktio_recv_queue(), odp_pktio_send_queue(), odp_pktio_pktout_queues() and etc.). Matias did great work to support netmap with new API. And idea is to replace old pktio API to

Re: [lng-odp] v1.7.0.0 is out

2016-02-08 Thread Mike Holmes
Thanks Maxim, and everyone who was able to contribute :) A rider on this, we plan v1.8 in only two weeks time and it will be the Monarch RC1 for the API, if you have an API change to push please try to get that out in time. We do expect an RC2 that will take the Traffic Manager API which is

Re: [lng-odp] [API-NEXT PATCHv2 3/3] doc: descr of structure for new interfaces

2016-02-08 Thread Bill Fischofer
Applying this part gives whitespace errors: bill@Ubuntu15:~/linaro/christophe$ git am ~/Mail/Incoming/Christophe/3 Applying: doc: descr of structure for new interfaces /home/bill/linaro/christophe/.git/rebase-apply/patch:45: indent with spaces. └── include/