Re: [lng-odp] [API-NEXT PATCH] linux-gen: pktio ipc: fix clang build

2016-12-16 Thread Bill Fischofer
On Fri, Dec 16, 2016 at 12:47 PM, Maxim Uvarov wrote: > Thanks, merged. > > I think after some time of stable pass we can remove enable/disable > option. A lot of options makes it nightmare to test all combinations. Agreed, but let's discuss that at a future ARCH call post MS-1. > > Maxim. > > O

Re: [lng-odp] [API-NEXT PATCH] linux-gen: pktio ipc: fix clang build

2016-12-16 Thread Maxim Uvarov
Thanks, merged. I think after some time of stable pass we can remove enable/disable option. A lot of options makes it nightmare to test all combinations. Maxim. On 12/16/16 21:11, Bill Fischofer wrote: > On Fri, Dec 16, 2016 at 8:27 AM, Maxim Uvarov wrote: >> clang is more clever on setting and

Re: [lng-odp] [API-NEXT PATCH] linux-gen: pktio ipc: fix clang build

2016-12-16 Thread Bill Fischofer
On Fri, Dec 16, 2016 at 8:27 AM, Maxim Uvarov wrote: > clang is more clever on setting and not using variables, > so it traps compilation. Also buffers header almost everywhere > reference by pointer so size of it should not impact on > performance. > > Signed-off-by: Maxim Uvarov Reviewed-and-t

[lng-odp] [API-NEXT PATCH] linux-gen: pktio ipc: fix clang build

2016-12-16 Thread Maxim Uvarov
clang is more clever on setting and not using variables, so it traps compilation. Also buffers header almost everywhere reference by pointer so size of it should not impact on performance. Signed-off-by: Maxim Uvarov --- platform/linux-generic/include/odp_buffer_internal.h | 7 +++ platform/

Re: [lng-odp] RFC workaround for -m32 on old gcc

2016-12-16 Thread Maxim Uvarov
Just looked one more again into that and looks like this function was rewritten in api-next. So after merge to master there should be no issue. Maxim. On 12/16/16 17:18, Mike Holmes wrote: > There is a parallel internal thread Bill, I will FWD it to you on this > topic. > The argument against is

Re: [lng-odp] RFC workaround for -m32 on old gcc

2016-12-16 Thread Mike Holmes
There is a parallel internal thread Bill, I will FWD it to you on this topic. The argument against is that it means that by definition we dont support upstream long therm supported distributions becasue that is how they ship and we can't fix them so we have to work around. On 16 December 2016 at

Re: [lng-odp] RFC workaround for -m32 on old gcc

2016-12-16 Thread Bill Fischofer
On Fri, Dec 16, 2016 at 6:44 AM, Maxim Uvarov wrote: > ping. > > Our CI still fails on 32 bit compilation. But I tested in latest Ubuntu > that 32 bits work well. So I think it's better to update CI image. I believe when I researched this a few months back I found a tirade by Linus against the "b

Re: [lng-odp] [API-NEXT PATCHv3] linux-generic: pool: defer ring allocation until pool creation

2016-12-16 Thread Bill Fischofer
On Fri, Dec 16, 2016 at 7:13 AM, Maxim Uvarov wrote: > On 12/16/16 11:06, Savolainen, Petri (Nokia - FI/Espoo) wrote: >>> >>> @@ -172,6 +172,7 @@ static pool_t *reserve_pool(void) >>> { >>> int i; >>> pool_t *pool; >>> +char ring_name[ODP_POOL_NAME_LEN]; >>> >>> for (i = 0; i <

Re: [lng-odp] [API-NEXT PATCHv3] linux-generic: pool: defer ring allocation until pool creation

2016-12-16 Thread Bill Fischofer
On Fri, Dec 16, 2016 at 6:50 AM, Maxim Uvarov wrote: > On 12/16/16 11:06, Savolainen, Petri (Nokia - FI/Espoo) wrote: >>> >>> @@ -172,6 +172,7 @@ static pool_t *reserve_pool(void) >>> { >>> int i; >>> pool_t *pool; >>> +char ring_name[ODP_POOL_NAME_LEN]; >>> >>> for (i = 0; i <

Re: [lng-odp] [API-NEXT PATCHv3] linux-generic: pool: defer ring allocation until pool creation

2016-12-16 Thread Maxim Uvarov
On 12/16/16 11:06, Savolainen, Petri (Nokia - FI/Espoo) wrote: >> >> @@ -172,6 +172,7 @@ static pool_t *reserve_pool(void) >> { >> int i; >> pool_t *pool; >> +char ring_name[ODP_POOL_NAME_LEN]; >> >> for (i = 0; i < ODP_CONFIG_POOLS; i++) { >> pool = pool_entry(i);

Re: [lng-odp] [API-NEXT PATCHv3] linux-generic: pool: defer ring allocation until pool creation

2016-12-16 Thread Maxim Uvarov
On 12/16/16 11:06, Savolainen, Petri (Nokia - FI/Espoo) wrote: >> >> @@ -172,6 +172,7 @@ static pool_t *reserve_pool(void) >> { >> int i; >> pool_t *pool; >> +char ring_name[ODP_POOL_NAME_LEN]; >> >> for (i = 0; i < ODP_CONFIG_POOLS; i++) { >> pool = pool_entry(i);

Re: [lng-odp] RFC workaround for -m32 on old gcc

2016-12-16 Thread Maxim Uvarov
ping. Our CI still fails on 32 bit compilation. But I tested in latest Ubuntu that 32 bits work well. So I think it's better to update CI image. Maxim. On 11/22/16 17:00, Maxim Uvarov wrote: > > Does somebody interested in supporting old compilers? I see for example > our CI fails. > Changing

Re: [lng-odp] [PATCH v2] example: traffic_mgmt: use PRIu32 instead of %u

2016-12-16 Thread Maxim Uvarov
On 12/15/16 22:30, Nicolas Morey-Chaisemartin wrote: > Thanks. Could you apply it to the monarch branch too? > > Nicolas Done. > > Le 12/15/2016 à 08:01 PM, Maxim Uvarov a écrit : >> Merged, >> Maxim. >> >> On 12/13/16 22:00, Bill Fischofer wrote: >>> On Tue, Dec 13, 2016 at 12:34 PM, Maxim Uv

Re: [lng-odp] [API-NEXT PATCHv3 4/5] linux-gen: pktio ipc: make it work again

2016-12-16 Thread Maxim Uvarov
Merged, Maxim. On 12/15/16 00:31, Bill Fischofer wrote: > For the v3 series: > > Reviewed-and-tested-by: Bill Fischofer > > On Wed, Dec 14, 2016 at 1:57 PM, Maxim Uvarov wrote: >> Signed-off-by: Maxim Uvarov >> --- >> .../linux-generic/include/odp_buffer_internal.h| 10 +- >> platform/l

Re: [lng-odp] [API-NEXT PATCH v3 01/10] api: crypto: rename _params_t to _param_t

2016-12-16 Thread Maxim Uvarov
On 16 December 2016 at 11:00, Savolainen, Petri (Nokia - FI/Espoo) < petri.savolai...@nokia-bell-labs.com> wrote: > > -Original Message- > > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of > Maxim > > Uvarov > > Sent: Thursday, December 15, 2016 8:22 PM > > To: lng-odp

Re: [lng-odp] [API-NEXT PATCHv3] linux-generic: pool: defer ring allocation until pool creation

2016-12-16 Thread Savolainen, Petri (Nokia - FI/Espoo)
> > @@ -172,6 +172,7 @@ static pool_t *reserve_pool(void) > { > int i; > pool_t *pool; > + char ring_name[ODP_POOL_NAME_LEN]; > > for (i = 0; i < ODP_CONFIG_POOLS; i++) { > pool = pool_entry(i); > @@ -180,6 +181,17 @@ static pool_t *reserve_pool(void) >

Re: [lng-odp] [API-NEXT PATCH v3 01/10] api: crypto: rename _params_t to _param_t

2016-12-16 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim > Uvarov > Sent: Thursday, December 15, 2016 8:22 PM > To: lng-odp@lists.linaro.org > Subject: Re: [lng-odp] [API-NEXT PATCH v3 01/10] api: crypto: rename > _params_t to _param_t > > Patch set