Re: [lng-odp] [API-NEXT PATCHv8 1/6] linux-gen: _ishm: adding buddy and slab allocation

2017-01-17 Thread Yi He
Reviewed the difference between v7 and v8, tested with make check, for this series: Reviewed-and-tested-by: Yi He On 18 January 2017 at 02:17, Christophe Milard wrote: > _ishm now provides functions to create/destroy pools for buddy/slab >

Re: [lng-odp] [PATCH] configure.ac: update version number from v12.0.0 to v13.0.0

2017-01-17 Thread Mike Holmes
subject: add "API" since more than one number is affected in the patch, also API numbering has a generation so need to add 1. One day v12.0.0 will apply to both v1.12.0.0 and v2.12.0.0 update API version number from v1.12.0.0 to v1.13.0.0 On 13 January 2017 at 08:50, Maxim Uvarov

Re: [lng-odp] [API-NEXT PATCH 0/5] power management api

2017-01-17 Thread Bill Fischofer
First off, thanks for this submission, however this series has a number of problems: 1. It does not compile due to the incorrect specification of There is no /api/ level in these includes. 2. Numerous checkpatch issues throughout. Please run ./scripts/checkpatch *.patch before submitting and

[lng-odp] [API-NEXT PATCHv8 6/6] test: drv: shm: adding buddy allocation stress tests

2017-01-17 Thread Christophe Milard
Stress tests for the random size allocator (buddy allocator in linux-generic) are added here. Signed-off-by: Christophe Milard --- .../common_plat/validation/drv/drvshmem/drvshmem.c | 177 + .../common_plat/validation/drv/drvshmem/drvshmem.h |

[lng-odp] [API-NEXT PATCHv8 5/6] test: drv: shm: adding basic fixed size allocation tests

2017-01-17 Thread Christophe Milard
Basic tests for odpdrv_shm_pool are added here, creating a fixed size pool and performing basic alloc/free on it Signed-off-by: Christophe Milard --- .../common_plat/validation/drv/drvshmem/drvshmem.c | 86 ++

[lng-odp] [API-NEXT PATCHv8 4/6] test: drv: shm: adding basic buddy allocation tests

2017-01-17 Thread Christophe Milard
Basic tests for odpdrv_shm_pool are added here, creating a buddy pool and performing basic alloc/free on it Signed-off-by: Christophe Milard --- .../common_plat/validation/drv/drvshmem/drvshmem.c | 92 ++

[lng-odp] [API-NEXT PATCHv8 2/6] drv: adding odpdrv_shm_pool functions

2017-01-17 Thread Christophe Milard
Adding functions to create and destroy memory pools (from which memory can be allocated and freed) are added. These functions enable the usage of small memory amount (compared to drvshm_reserve() whose granularity is the page size). The usage of this pool guatantees that allocated memory is

[lng-odp] [API-NEXT PATCHv8 3/6] linux-gen: drv: shm: adding pool allocator

2017-01-17 Thread Christophe Milard
Adding functions to create memory pools and allocate / free memory from the created pools. These functions calls their _ishm conterpart, of course. Signed-off-by: Christophe Milard --- platform/linux-generic/drv_shm.c | 44

[lng-odp] [API-NEXT PATCHv8 0/6] small memory amount allocator for drv shm

2017-01-17 Thread Christophe Milard
Since V7: -doxygen fix (Thanks Maxim!) Since V6: -rebased Since V5: -title fix (Yi) -rebased -flag name fix (Christophe) Since V4: -fix for clang Since V3: -copyright year changed Since V2: -comment and doxygen fixes (Petri) Since V1: -Common south pool (for all drivers) suppressed.

[lng-odp] [API-NEXT PATCHv8 1/6] linux-gen: _ishm: adding buddy and slab allocation

2017-01-17 Thread Christophe Milard
_ishm now provides functions to create/destroy pools for buddy/slab memory allocation, as well as functions to allocated/release memory from the created pools. Signed-off-by: Christophe Milard --- platform/linux-generic/Makefile.am | 2 +

[lng-odp] [API-NEXT PATCH 5/5] power: Adding a power governor implementation

2017-01-17 Thread Sergei Trofimov
Adding an API for a power governor. A governor will try to optimise power usage within an associated power domains by monitoring packet queue(s) to determine how much "performance" is necessary at a given point in time. This also implements a PoC DVFS governor that will step down the frequency

[lng-odp] [API-NEXT PATCH 4/5] queue: adding depth threshold trigger

2017-01-17 Thread Sergei Trofimov
This adds an ability to set a depth threshold for a queue. When the threshold is exceeded, an event will be enqueued on another queue as notification of the fact that the threshold has been exceeded. Signed-off-by: Sergei Trofimov --- include/odp/api/spec/queue.h

[lng-odp] [API-NEXT PATCH 3/5] queue: adding a notification queue type

2017-01-17 Thread Sergei Trofimov
This adds ODP_QUEUE_TYPE_NOTIF along side the existing plain and sched queues. Notification queues are similar to plain queues, in that they are dequeued manually. However it is also possible to wait on dequeue (via the new odp_queue_deq_wait) method, which will block on an empty queue in such a

[lng-odp] [API-NEXT PATCH 2/5] odp_queue: added support for queue depth tracking

2017-01-17 Thread Sergei Trofimov
- Added a counter to queue_entry_t to keep track of the current queue depth (number of enqueued events). - Added odp_queue_depth function to the API to query the above counter. Signed-off-by: Sergei Trofimov --- include/odp/api/spec/queue.h | 15

[lng-odp] [API-NEXT PATCH 1/5] power: added API for managing CPU DVFS

2017-01-17 Thread Sergei Trofimov
Added APIs for quiering available CPU power/frequency domains and setting their frequencies. Current implementation assumes that Linux is using userspace cpufreq governor. Signed-off-by: Sergei Trofimov --- include/odp/api/spec/power.h | 116 ++

[lng-odp] [API-NEXT PATCH 0/5] power management api

2017-01-17 Thread Sergei Trofimov
This patch series introduces a power management API and provides a sample power governor implementation. The API provides a way to query abstract performance levels supported by the platform, and to associate a power "governor" to manage power/performance levels on a set of CPUs. The sample

Re: [lng-odp] [API-NEXT PATCH 1/2] linux-gen: ipsec: add capability function

2017-01-17 Thread Maxim Uvarov
Merged, Maxim. On 01/13/17 06:10, Bill Fischofer wrote: > For this series: > > Reviewed-and-tested-by: Bill Fischofer > > On Thu, Jan 12, 2017 at 7:21 AM, Matias Elo wrote: >> Add IPsec capability function (groundwork for a proper IPsec >>

Re: [lng-odp] Platform parameters in odp_init_global

2017-01-17 Thread Maxim Uvarov
We discussed that question on yesterday meeting call. And decision was to stay with current approach. If some platform needs additional settings they can be provided with getenv() or config, or shared memory setting, or any other way which system allows. But you also can came with some rfc patch

Re: [lng-odp] [API-NEXT PATCHv7 0/6] small memory amount allocator for drv shm

2017-01-17 Thread Maxim Uvarov
please fix doxygen: /opt/Linaro/odp3.git/platform/linux-generic/include/odp/drv/plat/shm_types.h:40: warning: Member ODPDRV_SHM_POOL_INVALID (macro definition) of group odpdrv_shm is not documented. /opt/Linaro/odp3.git/platform/linux-generic/include/odp/drv/plat/shm_types.h:40: warning: Member

Re: [lng-odp] Platform parameters in odp_init_global

2017-01-17 Thread Mike Holmes
On 16 January 2017 at 05:33, Stanislaw Kardach wrote: > Hi all, > > I am working on a platform that may have mandatory parameters for a > correct initialization (and also unique to each ODP instance). If I'm > reading it right the call to odp_init_global() may take NULL for >

Re: [lng-odp] [PATCH] example: introducing multi-threaded traffic management case

2017-01-17 Thread Bala Manoharan
There is a lot of code duplication in this example rom example/traffic_mgmt/odp_traffic_mgmt.c file. Maybe the common code should be moved or we should reduce the scope of this example. Regards, Bala On 19 December 2016 at 11:31, wrote: > From: Xuelin Shi