Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-20 Thread Maxim Uvarov
On 10/20/16 15:05, Savolainen, Petri (Nokia - FI/Espoo) wrote: -Original Message- From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim Uvarov Sent: Wednesday, October 19, 2016 4:01 PM To: lng-odp@lists.linaro.org Subject: Re: [lng-odp] [PATCH 04/10] linux-gen

Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-20 Thread Savolainen, Petri (Nokia - FI/Espoo)
> >> -/** > >> - * @internal > >> - * Round up pointer 'x' to cache line size alignment > >> + * Round up 'x' to alignment 'align' > >>*/ > >> -#define ODP_CACHE_LINE_SIZE_ROUNDUP_PTR(x)\ > >> - ((void *)ODP_CACHE_LINE_SIZE_ROUNDUP((uintptr_t)(x))) > >> +#define ODP_ALIGN_ROUNDUP(x, align

Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-20 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim > Uvarov > Sent: Wednesday, October 19, 2016 4:01 PM > To: lng-odp@lists.linaro.org > Subject: Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up > power of tw

Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-19 Thread Bill Fischofer
On Wed, Oct 19, 2016 at 8:00 AM, Maxim Uvarov wrote: > On 10/19/16 15:09, Petri Savolainen wrote: > >> Added a macro to round up a value to the next power of two, >> if it's not already a power of two. Also removed duplicated >> code from the same file. >> >> Signed-off-by: Petri Savolainen >> -

Re: [lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-19 Thread Maxim Uvarov
On 10/19/16 15:09, Petri Savolainen wrote: Added a macro to round up a value to the next power of two, if it's not already a power of two. Also removed duplicated code from the same file. Signed-off-by: Petri Savolainen --- .../linux-generic/include/odp_align_internal.h | 34 +

[lng-odp] [PATCH 04/10] linux-gen: align: added round up power of two

2016-10-19 Thread Petri Savolainen
Added a macro to round up a value to the next power of two, if it's not already a power of two. Also removed duplicated code from the same file. Signed-off-by: Petri Savolainen --- .../linux-generic/include/odp_align_internal.h | 34 +- 1 file changed, 7 insertions(+), 27