I am using the Navigation toolbars mode and I wonder if  I should the 
attribute or if it can change in a future release ?

The attribute I am talking about is defined in backend_bases.py in 
NavigationToolbar2 in the __init__() method:

            self.mode = ''  # a mode string for the status bar

The strings saved on the panning and zoom mode are kinda unconventional:

            self.mode = 'pan/zoom mode'
or
            self.mode = 'Zoom to rect mode'

Having the zoom word in both strings can be confusing, moreover they 
should start either with a lower case or upper case.

                Can't they just be "zoom" or "pan" ?

Having just one word as a mode will remove confusion and make them 
easier to test when you are adding modes to the toolbar ...

                                         Just a suggestion.


                                                                         
                  Daniel.


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Reply via email to