D3728: grep: adds unmodified mode

2018-06-13 Thread mharbison72 (Matt Harbison)
mharbison72 added inline comments. INLINE COMMENTS > commands.py:2411 > _('only search files changed within revision range'), _('REV')), > +('', 'unmodified', False, > + _('include all files in the changeset while grepping')), I wonder if `--allfiles` is a better name. `--unmodifi

[Bug 5917] New: record (e.g. `hg ci -i` and `hg split`) crashes with "bad hunk #1" if diff makes a file empty

2018-06-13 Thread mercurial-bugs
https://bz.mercurial-scm.org/show_bug.cgi?id=5917 Bug ID: 5917 Summary: record (e.g. `hg ci -i` and `hg split`) crashes with "bad hunk #1" if diff makes a file empty Product: Mercurial Version: 4.6 Hardware: PC

D3731: templatefilters: rename commonprefix to commondir

2018-06-13 Thread martinvonz (Martin von Zweigbergk)
martinvonz created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Two reasons: - It makes it clearer that it's not a generic common string prefix (e.g. commonprefix(["bar", "baz"]) is not "ba", but "") - If we ever want

Re: [PATCH 7 of 7] templater: abstract truth testing to fix {if(list_of_empty_strings)}

2018-06-13 Thread Augie Fackler
> On Jun 12, 2018, at 17:24, Augie Fackler wrote: > > On Tue, Jun 12, 2018 at 11:49:09PM +0900, Yuya Nishihara wrote: >> # HG changeset patch >> # User Yuya Nishihara >> # Date 1528518887 -32400 >> # Sat Jun 09 13:34:47 2018 +0900 >> # Node ID 4eb2c19f741f50389c3de234654510deede597e2 >> #

D3730: morestatus: remove some extra spaces

2018-06-13 Thread pulkit (Pulkit Goyal)
pulkit created this revision. Herald added a reviewer: durin42. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY The information about unfinished states in `hg status -v` had a lot of spaces which are not required and feels weird. Let's limit

D3708: py3: replace `unicode` with pycompat.unicode

2018-06-13 Thread pulkit (Pulkit Goyal)
pulkit updated this revision to Diff 9053. pulkit retitled this revision from "py3: replace `unicode` with `type(u'')` in isinstance() calls" to "py3: replace `unicode` with pycompat.unicode". REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3708?vs=9007&id=

Re: [PATCH 2 of 4] debugwalk: show matcher output only if -v/--verbose

2018-06-13 Thread Martin von Zweigbergk via Mercurial-devel
On Wed, Jun 13, 2018 at 5:03 AM Yuya Nishihara wrote: > On Tue, 12 Jun 2018 13:44:17 -0700, Martin von Zweigbergk wrote: > > > --- a/mercurial/debugcommands.py > > > +++ b/mercurial/debugcommands.py > > > @@ -2542,7 +2542,8 @@ def debugwalk(ui, repo, *pats, **opts): > > > """show how files m

D3729: bitmanipulation: fix undefined behavior in bit shift in getbe32

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG1fb2510cf8c8: bitmanipulation: fix undefined behavior in bit shift in getbe32 (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/

D3718: narrow: mark the critical chunks of narrowing/widening as unsafe

2018-06-13 Thread martinvonz (Martin von Zweigbergk)
martinvonz added inline comments. INLINE COMMENTS > narrowcommands.py:248 > +repo.wvfs.unlinkpath(f) > +repo.setnarrowpats(newincludes, newexcludes) > Perhaps for another patch, but we could probably move this to before the transaction that starts on line 238 a

D3715: namespaces: allow namespaces whose symbols resolve to many nodes (API)

2018-06-13 Thread martinvonz (Martin von Zweigbergk)
martinvonz added a comment. In https://phab.mercurial-scm.org/D3715#58383, @durin42 wrote: > I'm in favor, but feel like I've got enough conflict of interest I shouldn't land the patches. > > @smf @lothiraldan this might be of interest to both of you? In https://phab.mer

D3694: shelve: use more accurate description in conflict marker

2018-06-13 Thread lothiraldan (Boris Feld)
lothiraldan added a comment. In https://phab.mercurial-scm.org/D3694#58409, @durin42 wrote: > In https://phab.mercurial-scm.org/D3694#58369, @lothiraldan wrote: > > > > How much work is this, do you have any idea? > > > > The first option (adding "reserved" phase) should be very qu

D3715: namespaces: allow namespaces whose symbols resolve to many nodes (API)

2018-06-13 Thread lothiraldan (Boris Feld)
lothiraldan added a comment. In https://phab.mercurial-scm.org/D3715#58383, @durin42 wrote: > I'm in favor, but feel like I've got enough conflict of interest I shouldn't land the patches. > > @smf @lothiraldan this might be of interest to both of you? The proposition of makin

Re: [PATCH 2 of 2] lazymanifest: don't crash when out of memory (issue5916)

2018-06-13 Thread Augie Fackler
> On Jun 13, 2018, at 10:55, Josef 'Jeff' Sipek wrote: > > # HG changeset patch > # User Josef 'Jeff' Sipek > # Date 1528900880 14400 > # Wed Jun 13 10:41:20 2018 -0400 > # Branch stable > # Node ID d591c80025ee7316b77235b2d71c4b0f01c03123 > # Parent cbb47a946bc0e0346bfc9f9ba505f9475de43

mercurial@38291: new changeset

2018-06-13 Thread Mercurial Commits
New changeset in mercurial: https://www.mercurial-scm.org/repo/hg/rev/c07424ec633c changeset: 38291:c07424ec633c bookmark:@ tag: tip user:Jun Wu date:Tue Jun 12 12:41:09 2018 -0700 summary: commandserver: close server's fds explicitly from a worker -- Repositor

[PATCH 2 of 2] lazymanifest: don't crash when out of memory (issue5916)

2018-06-13 Thread Josef 'Jeff' Sipek
# HG changeset patch # User Josef 'Jeff' Sipek # Date 1528900880 14400 # Wed Jun 13 10:41:20 2018 -0400 # Branch stable # Node ID d591c80025ee7316b77235b2d71c4b0f01c03123 # Parent cbb47a946bc0e0346bfc9f9ba505f9475de43606 lazymanifest: don't crash when out of memory (issue5916) self->lines c

[PATCH 1 of 2] cext: stop worrying and love the free(NULL)

2018-06-13 Thread Josef 'Jeff' Sipek
# HG changeset patch # User Josef 'Jeff' Sipek # Date 1528900659 14400 # Wed Jun 13 10:37:39 2018 -0400 # Branch stable # Node ID cbb47a946bc0e0346bfc9f9ba505f9475de43606 # Parent 3c84493556db3bffcff2fa2f24bb6738dde9fc58 cext: stop worrying and love the free(NULL) There is no need to check

[Bug 5916] New: lazymanifest can SIGSEGV when out of memory

2018-06-13 Thread mercurial-bugs
https://bz.mercurial-scm.org/show_bug.cgi?id=5916 Bug ID: 5916 Summary: lazymanifest can SIGSEGV when out of memory Product: Mercurial Version: 4.6 Hardware: PC OS: Other Status: UNCONFIRMED Severity: bug

Re: [PATCH 2 of 2] templatefilters: undeprecate hgdate

2018-06-13 Thread Augie Fackler
On Wed, Jun 13, 2018 at 11:00:32PM +0900, Yuya Nishihara wrote: > # HG changeset patch > # User Yuya Nishihara > # Date 1528894722 -32400 > # Wed Jun 13 21:58:42 2018 +0900 > # Node ID 74b4a54002ecb2059612d5e69ba204d05c818542 > # Parent 88e7105b5cd927ae0ecbe5dcc21c6125c4af4a6b > templatefilt

D3729: bitmanipulation: fix undefined behavior in bit shift in getbe32

2018-06-13 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY OSS-Fuzz caught this in its ubsan mode[0]. I'm not worried about a security issue here because in practice this should work out the way we naively expected, we'r

[PATCH 2 of 2] templatefilters: undeprecate hgdate

2018-06-13 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1528894722 -32400 # Wed Jun 13 21:58:42 2018 +0900 # Node ID 74b4a54002ecb2059612d5e69ba204d05c818542 # Parent 88e7105b5cd927ae0ecbe5dcc21c6125c4af4a6b templatefilters: undeprecate hgdate See the previous patch for why. Backed out changeset

[PATCH 1 of 2] templater: restore the original string format of {date}

2018-06-13 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1528894644 -32400 # Wed Jun 13 21:57:24 2018 +0900 # Node ID 88e7105b5cd927ae0ecbe5dcc21c6125c4af4a6b # Parent af0e88e64ede202ee7a058acf4f2a89ac86ec97d templater: restore the original string format of {date} Unfortunately, python-hglib relie

D3728: grep: adds unmodified mode

2018-06-13 Thread sangeet259 (Sangeet Kumar Mishra)
sangeet259 updated this revision to Diff 9050. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3728?vs=9049&id=9050 REVISION DETAIL https://phab.mercurial-scm.org/D3728 AFFECTED FILES mercurial/cmdutil.py mercurial/commands.py tests/test-grep.t CH

D3728: grep: adds unmodified mode

2018-06-13 Thread sangeet259 (Sangeet Kumar Mishra)
sangeet259 updated this revision to Diff 9049. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3728?vs=9041&id=9049 REVISION DETAIL https://phab.mercurial-scm.org/D3728 AFFECTED FILES mercurial/cmdutil.py mercurial/commands.py tests/test-grep.t CH

D3728: grep: adds unmodified mode

2018-06-13 Thread sangeet259 (Sangeet Kumar Mishra)
sangeet259 added a comment. I am updating the tests REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D3728 To: sangeet259, #hg-reviewers Cc: mercurial-devel ___ Mercurial-devel mailing list Mercurial-devel@mercurial-scm.o

D3720: commandserver: close server's fds explicitly from a worker

2018-06-13 Thread quark (Jun Wu)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGc07424ec633c: commandserver: close server's fds explicitly from a worker (authored by quark, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3720?v

D3726: hgweb: pass a sysstr to low-level _start_response method

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG9f499d28efb4: hgweb: pass a sysstr to low-level _start_response method (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3726?v

D3722: py3: buildbot informs me we have two new passing tests

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG9f56ad50924d: py3: buildbot informs me we have two new passing tests (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3722?vs=

D3727: hgweb: insist http_status value is a sysstr

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGaf0e88e64ede: hgweb: insist http_status value is a sysstr (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3727?vs=9039&id=904

D3723: cvsps: avoid comparison between None and a tuple in date sorting

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG80f6e95fac2d: cvsps: avoid comparison between None and a tuple in date sorting (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org

D3725: tests: fix printenv script on Python 3

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG42f3a277c8dc: tests: fix printenv script on Python 3 (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3725?vs=9037&id=9046 RE

D3724: cvsps: port changeset __repr__ to py3

2018-06-13 Thread durin42 (Augie Fackler)
This revision was automatically updated to reflect the committed changes. Closed by commit rHGbec815f991b0: cvsps: port changeset __repr__ to py3 (authored by durin42, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D3724?vs=9036&id=9045 REV

D3439: templatefilters: add commonprefix

2018-06-13 Thread yuja (Yuya Nishihara)
yuja added a comment. > > `commondir()` would be fine as well. `commonpath()` doesn't feel better. I'm ambivalent about either nam> > I'd vote for changing it then. Both because I think it might make it clearer that it's the common prefix of "foo/bar" and "food" is not "foo" and becaus

Re: D3439: templatefilters: add commonprefix

2018-06-13 Thread Yuya Nishihara
> > `commondir()` would be fine as well. `commonpath()` doesn't feel better. > I'm ambivalent about either nam> > I'd vote for changing it then. Both because I think it might make it > clearer that it's the common prefix of "foo/bar" and "food" is not "foo" and > because, as I said, we might

mercurial@38290: new changeset

2018-06-13 Thread Mercurial Commits
New changeset in mercurial: https://www.mercurial-scm.org/repo/hg/rev/b5651ae53127 changeset: 38290:b5651ae53127 bookmark:@ tag: tip user:Boris Feld date:Tue Jun 12 23:04:27 2018 +0200 summary: run-tests: restrict the test cases allowed characters -- Repository

D3728: grep: adds unmodified mode

2018-06-13 Thread sangeet259 (Sangeet Kumar Mishra)
sangeet259 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY adds an unmodified flag that lets you grep on all files in the revision and not just the one that were modified in that changeset REPOSITORY rHG Mercurial R

Re: [PATCH STABLE] tests: fix test-patch.t on pickier /bin/sh implementations

2018-06-13 Thread Yuya Nishihara
On Tue, 12 Jun 2018 18:20:39 -0400, Augie Fackler wrote: > # HG changeset patch > # User Augie Fackler > # Date 1526871918 14400 > # Sun May 20 23:05:18 2018 -0400 > # Branch stable > # Node ID 0c4019611293212012b598949832dcb2de6b96b2 > # Parent 3c84493556db3bffcff2fa2f24bb6738dde9fc58 > tes

Re: [PATCH 3 of 7] templater: introduce a wrapper for date tuple (BC)

2018-06-13 Thread Yuya Nishihara
On Tue, 12 Jun 2018 17:49:47 -0400, Augie Fackler wrote: > On Tue, Jun 12, 2018 at 11:49:05PM +0900, Yuya Nishihara wrote: > > # HG changeset patch > > # User Yuya Nishihara > > # Date 1521881642 -32400 > > # Sat Mar 24 17:54:02 2018 +0900 > > # Node ID 61e21a5a89d421909c45718ffc50f72cf83ee4b

Re: [PATCH 2 of 4] debugwalk: show matcher output only if -v/--verbose

2018-06-13 Thread Yuya Nishihara
On Tue, 12 Jun 2018 13:44:17 -0700, Martin von Zweigbergk wrote: > > --- a/mercurial/debugcommands.py > > +++ b/mercurial/debugcommands.py > > @@ -2542,7 +2542,8 @@ def debugwalk(ui, repo, *pats, **opts): > > """show how files match on given patterns""" > > opts = pycompat.byteskwargs(opt

D3636: py3: use pycompat.fsencode() to convert user value to bytes

2018-06-13 Thread pulkit (Pulkit Goyal)
pulkit abandoned this revision. pulkit added inline comments. INLINE COMMENTS > durin42 wrote in debugcommands.py:1403 > Should util.username() instead consistently return bytes? Yes, https://phab.mercurial-scm.org/D3706 did that. Abandoning this one. REPOSITORY rHG Mercurial REVISION DETAIL