mercurial@42747: 2 new changesets

2019-08-17 Thread Mercurial Commits
2 new changesets in mercurial: https://www.mercurial-scm.org/repo/hg/rev/b3518b0baa47 changeset: 42746:b3518b0baa47 user:Raphaël Gomès date:Mon Jul 08 18:01:39 2019 +0200 summary: rust-dirstate: create dirstate submodule in hg-cpython https://www.mercurial-scm.org/repo/hg/r

Re: D6632: rust-dirstate: rust implementation of dirstatemap

2019-08-17 Thread Yuya Nishihara
> +if let Some(ref mut file_fold_map) = self.file_fold_map { > +file_fold_map > +.remove::>(filename.to_ascii_uppercase().as_ref()); Looks incompatible with the dirstate class, which uses util.normcase(). ___ Mercurial

D6632: rust-dirstate: rust implementation of dirstatemap

2019-08-17 Thread yuja (Yuya Nishihara)
yuja added a comment. > +if let Some(ref mut file_fold_map) = self.file_fold_map { > +file_fold_map > +.remove::>(filename.to_ascii_uppercase().as_ref()); Looks incompatible with the dirstate class, which uses util.normcase(). REPOSITORY rHG Mercu

Re: D6631: rust-cpython: add macro for sharing references

2019-08-17 Thread Yuya Nishihara
> +impl PySharedState { > +pub fn borrow_mut<'a, T>( > +&'a self, > +py: Python<'a>, > +pyrefmut: RefMut<'a, T>, > +) -> PyResult> { > +if self.mutably_borrowed.get() { > +return Err(AlreadyBorrowed::new( > +py, > +

D6631: rust-cpython: add macro for sharing references

2019-08-17 Thread yuja (Yuya Nishihara)
yuja added a comment. > +impl PySharedState { > +pub fn borrow_mut<'a, T>( > +&'a self, > +py: Python<'a>, > +pyrefmut: RefMut<'a, T>, > +) -> PyResult> { > +if self.mutably_borrowed.get() { > +return Err(AlreadyBorrowed::new(

D6678: continue: added support for histedit

2019-08-17 Thread taapas1128 (Taapas Agrawal)
taapas1128 added a comment. @pulkit This one is ready too. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6678/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6678 To: taapas1128, durin42, #hg-reviewers Cc: pulkit, mercurial-devel _

[PATCH] transplant: unnest --stop case

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566024221 -32400 # Sat Aug 17 15:43:41 2019 +0900 # Node ID a3c360094c93509ee013ed7f4b7807c74b2d60a4 # Parent 88d6a6f7e83716146fc725f20166509a520bc164 transplant: unnest --stop case It should be aligned with --continue. diff --git a/hgext/

[PATCH] py3: do not convert rust module/attribute names to bytes

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566005104 -32400 # Sat Aug 17 10:25:04 2019 +0900 # Node ID 302e4706ab25b4d29d858f93ca2678a609e95570 # Parent a3c360094c93509ee013ed7f4b7807c74b2d60a4 py3: do not convert rust module/attribute names to bytes policy.import*() functions expec

[PATCH 01 of 11] rust-parsers: fix unboxing of PyInt on Python 3

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566011866 -32400 # Sat Aug 17 12:17:46 2019 +0900 # Node ID 809ab6f869baaa800f15fd6ab4003c480bd0871f # Parent 302e4706ab25b4d29d858f93ca2678a609e95570 rust-parsers: fix unboxing of PyInt on Python 3 Broken at 7cae6bc29ff9. diff --git a/rus

[PATCH 02 of 11] rust-dirstate: remove unneeded "ref"

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566009785 -32400 # Sat Aug 17 11:43:05 2019 +0900 # Node ID e04eef69a482c886117a6aaa604d8dce6e3e1d3a # Parent 809ab6f869baaa800f15fd6ab4003c480bd0871f rust-dirstate: remove unneeded "ref" At 7cae6bc29ff9, .to_owned() was rewritten as .to_ow

mercurial-devel@mercurial-scm.org

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566016950 -32400 # Sat Aug 17 13:42:30 2019 +0900 # Node ID 8f7737800ff279e6886250b8e2a21e67d7492937 # Parent e04eef69a482c886117a6aaa604d8dce6e3e1d3a rust-dirstate: remove too abstracted way of getting &[u8] diff --git a/rust/hg-core/src/d

[PATCH 04 of 11] rust-dirstate: remove repetition in array literal

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566015964 -32400 # Sat Aug 17 13:26:04 2019 +0900 # Node ID af8265f67d45cfff198c26e639b57e98c0c56287 # Parent 8f7737800ff279e6886250b8e2a21e67d7492937 rust-dirstate: remove repetition in array literal diff --git a/rust/hg-core/src/dirstate/

[PATCH 05 of 11] rust-dirstate: rename NULL_REVISION to NULL_ID which isn't a revision number

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566016031 -32400 # Sat Aug 17 13:27:11 2019 +0900 # Node ID f61ecf74968aae152d1cdbe946d3f418b0fa1381 # Parent af8265f67d45cfff198c26e639b57e98c0c56287 rust-dirstate: rename NULL_REVISION to NULL_ID which isn't a revision number diff --git a

[PATCH 06 of 11] rust-dirstate: use PARENT_SIZE constant where appropriate

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566017705 -32400 # Sat Aug 17 13:55:05 2019 +0900 # Node ID a57c56ff9cec59f12780c83f5dc2ab679d2523e6 # Parent f61ecf74968aae152d1cdbe946d3f418b0fa1381 rust-dirstate: use PARENT_SIZE constant where appropriate diff --git a/rust/hg-core/src/d

[PATCH 07 of 11] rust: simply use TryInto to convert slice to array

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566009462 -32400 # Sat Aug 17 11:37:42 2019 +0900 # Node ID d496a0a5d5f8ff45afde5a0a90b0917e507c # Parent a57c56ff9cec59f12780c83f5dc2ab679d2523e6 rust: simply use TryInto to convert slice to array Since our rust module depends on TryIn

[PATCH 08 of 11] rust-dirstate: handle invalid length of p1/p2 parameters

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566032768 -32400 # Sat Aug 17 18:06:08 2019 +0900 # Node ID 5f76ca22fb8fb29ec0a60ec0af88cb328f7a0c9e # Parent d496a0a5d5f8ff45afde5a0a90b0917e507c rust-dirstate: handle invalid length of p1/p2 parameters It uses match syntax since map_e

[PATCH 09 of 11] rust-dirstate: remove excessive clone() of parameter and return value

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566027185 -32400 # Sat Aug 17 16:33:05 2019 +0900 # Node ID d4c0130723d92bd545e7df45aceead8bd7562156 # Parent 5f76ca22fb8fb29ec0a60ec0af88cb328f7a0c9e rust-dirstate: remove excessive clone() of parameter and return value I think pass-by-ref

[PATCH 10 of 11] rust-dirstate: split DirsMultiset constructor per input type

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566033929 -32400 # Sat Aug 17 18:25:29 2019 +0900 # Node ID c0660c41e5b27173f73b8c88da1728b69425aeba # Parent d4c0130723d92bd545e7df45aceead8bd7562156 rust-dirstate: split DirsMultiset constructor per input type Since skip_state only applie

[PATCH 11 of 11] rust-dirstate: remove test case for DirsMultiset::new(Manifest, Some)

2019-08-17 Thread Yuya Nishihara
# HG changeset patch # User Yuya Nishihara # Date 1566034135 -32400 # Sat Aug 17 18:28:55 2019 +0900 # Node ID 24f0204173d07b53cdd34b75122b46cd74df3756 # Parent c0660c41e5b27173f73b8c88da1728b69425aeba rust-dirstate: remove test case for DirsMultiset::new(Manifest, Some) It's no longer poss

D6709: config: add --registered flag to show all known configs

2019-08-17 Thread av6 (Anton Shestakov)
av6 added inline comments. INLINE COMMENTS > ui.py:832 > +# Omit config items with dynamicdefault, devel, > +# experimental and generic config opts. > +continue Nit: originally I was fine with two different `if ...: continue` blocks her

D6730: config: handle default values of type list

2019-08-17 Thread av6 (Anton Shestakov)
This revision now requires changes to proceed. av6 added a comment. av6 requested changes to this revision. The changes in tests that this patch causes are actually already present in the D6709 , so let's fold this patch into it as well. REPOSITORY rHG

Re: [PATCH] transplant: unnest --stop case

2019-08-17 Thread Pulkit Goyal
On Sat, Aug 17, 2019 at 3:06 PM Yuya Nishihara wrote: > > # HG changeset patch > # User Yuya Nishihara > # Date 1566024221 -32400 > # Sat Aug 17 15:43:41 2019 +0900 > # Node ID a3c360094c93509ee013ed7f4b7807c74b2d60a4 > # Parent 88d6a6f7e83716146fc725f20166509a520bc164 > transplant: unnest

Re: [PATCH] py3: do not convert rust module/attribute names to bytes

2019-08-17 Thread Pulkit Goyal
On Sat, Aug 17, 2019 at 3:09 PM Yuya Nishihara wrote: > > # HG changeset patch > # User Yuya Nishihara > # Date 1566005104 -32400 > # Sat Aug 17 10:25:04 2019 +0900 > # Node ID 302e4706ab25b4d29d858f93ca2678a609e95570 > # Parent a3c360094c93509ee013ed7f4b7807c74b2d60a4 > py3: do not convert

D6709: config: add --registered flag to show all known configs

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh updated this revision to Diff 16247. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6709?vs=16229&id=16247 CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6709/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6709 AFFEC

D6730: config: handle default values of type list

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh added a comment. navaneeth.suresh abandoned this revision. In D6730#98852 , @av6 wrote: > The changes in tests that this patch causes are actually already present in the D6709 , so let's fol

D6709: config: add --registered flag to show all known configs

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh updated this revision to Diff 16248. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6709?vs=16247&id=16248 CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6709/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6709 AFFEC

D6735: update: added support for --abort flag(issue4404)

2019-08-17 Thread taapas1128 (Taapas Agrawal)
taapas1128 created this revision. Herald added subscribers: mercurial-devel, mjpieters. Herald added a reviewer: hg-reviewers. REVISION SUMMARY This patch adds functionality to abort a conflicted update. A new function `hg.abortupdate()` is added for the purpose which has a helper function

D6735: update: added support for --abort flag(issue4404)

2019-08-17 Thread taapas1128 (Taapas Agrawal)
taapas1128 updated this revision to Diff 16250. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6735?vs=16249&id=16250 CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6735/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6735 AFFECTED FI

D6735: update: added support for --abort flag(issue4404)

2019-08-17 Thread taapas1128 (Taapas Agrawal)
taapas1128 updated this revision to Diff 16251. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6735?vs=16250&id=16251 CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6735/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6735 AFFECTED FI

D6728: config: add experimental argument to the config registrar

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit added inline comments. INLINE COMMENTS > perf.py:244 > default=mercurial.configitems.dynamicdefault, > +experimental=True, > ) This breaks `contrib/perf.py` with older versions of mercurial. Can you send a compatibility fix as followup? REPOSITORY rHG Mercurial

D6731: exchange: abort on pushing bookmarks pointing to secret changesets (issue6159)

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit added a comment. In such cases, I like the idea of having fix as two patches, first which demonstrates the bug and the second which fixes the bug. What do you think? REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6731/new/ REVISION DETAIL htt

D6735: update: added support for --abort flag(issue4404)

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit added inline comments. INLINE COMMENTS > test-merge-tools.t:2092 > + > +Test for 'hg update --abort' > + I suggest taking `update --abort` tests in a new file as we will need to extensively test that. > test-merge-tools.t:2129 > + merging file > + warning: conflicts while merging file

D6479: shelve: first prototype of storing/restoring unresolved changes

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit added a comment. In D6479#98757 , @navaneeth.suresh wrote: > In D6479#98737 , @durin42 wrote: > >> The only thing I'm curious about really is why we have extrastorage and usualstorge. Can w

D6736: shelve: add method for storing mergestate in changeset extras

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY We store mergestate records in `.hg/merge`. This patch adds a method of storage in changeset extras. This will help in the exchange of mergestate record

D6737: shelve: add --unresolved flag to shelve mergestate with unresolved files

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Until now, `shelve` used to abort on trying to `shelve` a mergestate. This patch adds an `--unresolved` flag to `shelve` and use the changeset extras to

D6738: unshelve: add --unresolved flag to unshelve mergestate with unresolved files

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY `hg unshelve --unresolved` will get the user back to the old unresolved merge by the following steps: Step 1: If the user has committed new changese

D6739: unshelve: add abort on using --interactive and --unresolved together

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY It seems not to be a good idea to partially unshelve a mergestate. So, let us abort on using `--interactive` and `--unresolved` together.` REPOSITORY r

[Bug 6187] New: .orig files that are committed as largefiles cannot be pulled

2019-08-17 Thread mercurial-bugs
https://bz.mercurial-scm.org/show_bug.cgi?id=6187 Bug ID: 6187 Summary: .orig files that are committed as largefiles cannot be pulled Product: Mercurial Version: 5.0.2 Hardware: PC OS: Windows St

D6733: setup: fix a sorting issue I noticed in package names

2019-08-17 Thread durin42 (Augie Fackler)
Closed by commit rHGf299555785c5: setup: fix a sorting issue I noticed in package names (authored by durin42). This revision was automatically updated to reflect the committed changes. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6733?vs=16227&id=16256

D6740: tests: add test to demonstrate issue6159

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D6740 AFFECTED FILES tests/test-bookmarks-pushpull.t CHANGE DETAILS diff --git a/tests/test-b

D6731: exchange: abort on pushing bookmarks pointing to secret changesets (issue6159)

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh updated this revision to Diff 16258. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D6731?vs=16225&id=16258 CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6731/new/ REVISION DETAIL https://phab.mercurial-scm.org/D6731 AFFEC

D6731: exchange: abort on pushing bookmarks pointing to secret changesets (issue6159)

2019-08-17 Thread navaneeth.suresh (Navaneeth Suresh)
navaneeth.suresh added a comment. In D6731#98871 , @pulkit wrote: > In such cases, I like the idea of having fix as two patches, first which demonstrates the bug and the second which fixes the bug. What do you think? Yeah, sounds good to me

D6742: interfaceutil: move to interfaces/

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit created this revision. Herald added a reviewer: indygreg. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Now that we have a dedicated folder for interfaces, let's move interfaceutil there. REPOSITORY rHG Mercurial REVISION DETAIL

D6741: interfaces: create a new folder for interfaces and move repository.py in it

2019-08-17 Thread pulkit (Pulkit Goyal)
pulkit created this revision. Herald added a reviewer: indygreg. Herald added a reviewer: durin42. Herald added a reviewer: martinvonz. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY I was trying to understand current interfaces and write new

Re: [PATCH 02 of 10] rawdata: introduce a `rawdata` method on revlog

2019-08-17 Thread Yuya Nishihara
On Wed, 07 Aug 2019 23:30:31 +0200, Pierre-Yves David wrote: > # HG changeset patch > # User Pierre-Yves David > # Date 1565207669 -7200 > # Wed Aug 07 21:54:29 2019 +0200 > # Node ID fe5517914e9f519855d5f8c0ef89098e039d68c6 > # Parent 3b49bb04851ea501f005e7a58403fee3b1c52958 > # EXP-Topic r

Re: [PATCH 01 of 15] rawdata: update caller in revlog

2019-08-17 Thread Yuya Nishihara
On Thu, 15 Aug 2019 12:39:59 +0200, Pierre-Yves David wrote: > # HG changeset patch > # User Pierre-Yves David > # Date 1565201306 -7200 > # Wed Aug 07 20:08:26 2019 +0200 > # Node ID 66af150744d04f984d0300fb71ff93ceb2dc28a9 > # Parent bbe71b5afd02c764639780bfe763348d5e5d7a6b > # EXP-Topic r