D5358: rust: peek_mut optim for lazy ancestors

2018-12-03 Thread gracinet (Georges Racinet)
gracinet created this revision. Herald added subscribers: mercurial-devel, kevincox, durin42. Herald added a reviewer: hg-reviewers. REVISION SUMMARY This is one of the two optimizations that are also present in the Python code: replacing pairs of pop/push on the BinaryHeap by single updates

D5358: rust: peek_mut optim for lazy ancestors

2018-12-04 Thread yuja (Yuya Nishihara)
yuja added a comment. Queued, thanks. > +let parents = self > +.graph > +.parents(current) > +.unwrap_or((NULL_REVISION, NULL_REVISION)); > +let p0 = parents.0; I've renamed it to `p1` since that's the convention of Mercu

D5358: rust: peek_mut optim for lazy ancestors

2018-12-04 Thread gracinet (Georges Racinet)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG04ebdb33e5d0: rust: peek_mut optim for lazy ancestors (authored by gracinet, committed by ). CHANGED PRIOR TO COMMIT https://phab.mercurial-scm.org/D5358?vs=12683&id=12694#toc REPOSITORY rHG Mercuri

Re: D5358: rust: peek_mut optim for lazy ancestors

2018-12-04 Thread Yuya Nishihara
Queued, thanks. > +let parents = self > +.graph > +.parents(current) > +.unwrap_or((NULL_REVISION, NULL_REVISION)); > +let p0 = parents.0; I've renamed it to `p1` since that's the convention of Mercurial codebase. Maybe it can be rewritten as `