On Fri, 21 Oct 2011 20:45:59 -0700, Chad Versace wrote:
> For all texture targets except GL_TEXTURE_CUBE_MAP, the 'nr_images' and
> 'depth' fields of intel_mipmap_level were identical. In the exceptional
> case, nr_images == 6 and depth == 1.
>
> It is simple to determine if a texture is a cube
On 10/18/2011 12:31 PM, Eric Anholt wrote:
> v2: Avoid the C99 rounding functions, because I don't trust
> get/setting the C99 rounding mode from inside our library not having
> other side effects. Instead, open-code roundEven() behavior around
> Mesa's IROUND, which we're already testing for C99
On 10/21/2011 08:45 PM, Chad Versace wrote:
> For all texture targets except GL_TEXTURE_CUBE_MAP, the 'nr_images' and
> 'depth' fields of intel_mipmap_level were identical. In the exceptional
> case, nr_images == 6 and depth == 1.
>
> It is simple to determine if a texture is a cube or not, so th
On Sam, 2011-10-22 at 13:47 +0200, Mathias Fröhlich wrote:
> Hi,
>
> the attached patch enables opengl client side throtteling for r600g that
> recently slipped in as an infrastructure but is just enabled for vmgfx so far.
>
> The benefits of the client side throtteling are great, since a singl
Hi,
the attached patch enables opengl client side throtteling for r600g that
recently slipped in as an infrastructure but is just enabled for vmgfx so far.
The benefits of the client side throtteling are great, since a single render
intensive application is no longer able to just saturate the
Hi,
The attached patch reduces the amount of pipe flushes for r600g.
I am not exactly sure if we could skip this flush entirely because of the
internal r600g winsys flush logic.
But what we can do is the attached patch:
Replace pipe->flush() with pipe->texture_barrier() in
the texture upload pa
Hi,
Buffer objects may be shared across contexts.
Rework the array attrib push/pop implementation
to be thread safe. Make use of more library functions
for this purpose.
Please review.
Thanks
Mathias
From 27b335e04646abd40fc533a02e75bde4bbe09620 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Mathias
Hi,
Make sure we do not run into the classic ABA problem on buffer object bind,
reusing this name and may be never rebind since we get an new name
that was just deleted and never rebound in between.
The explicit rebinding to the debault object in the current context
prevents the above in the curr
Hi,
On Wednesday, October 19, 2011 16:32:57 Brian Paul wrote:
> As a first cut, I want something that works correctly and is easy to
> understand and maintain. We can optimize later if needed. I think
> most seasoned OpenGL programmers know that glPush/PopAttrib isn't
> exactly a high-performan