Re: [Mesa-dev] [PATCH 09/10] vbo: fix GL_LINE_LOOP stray line bug

2015-10-18 Thread Sinclair Yeh
On Fri, Oct 16, 2015 at 03:25:16PM -0600, Brian Paul wrote: > When long GL_LINE_LOOP primitives don't fit in one vertex buffer they > have to be split across buffers. The code to do this was basically correct > but drivers had to pay special attention to the _mesa_prim::begin,end flags > in order

[Mesa-dev] [PATCH 1/4] nv50: add a header file for nv50_query

2015-10-18 Thread Samuel Pitoiset
Like for nvc0, this will allow to split different types of queries and to prepare the way for both global performance counters and MP counters. While we are at it, make use of nv50_query struct instead of pipe_query. Signed-off-by: Samuel Pitoiset ---

[Mesa-dev] [PATCH 0/4] nv50: move HW queries to nv50_query_hw.c/h

2015-10-18 Thread Samuel Pitoiset
Hi there, As for nvc0, this series moves HW queries to improve readability of this area of the driver and to prepare the way for both MP counters and global perf counters. There are no regressions with piglit. Feel free to review, Thanks. Samuel Pitoiset (4): nv50: add a header file for

Re: [Mesa-dev] [RFC 1/2] gallium: add renderonly driver

2015-10-18 Thread Christian Gmeiner
Hi Thierry, Thanks for reviewing this patches. 2015-10-16 15:31 GMT+02:00 Thierry Reding : > Hi Christian, > > First off, thanks for reviving this effort. It's been one of the things > that I've had nagging at me for much too long and I think it needs to be > solved. So

Re: [Mesa-dev] [PATCH] gallium/swrast: fix front buffer blitting. (v2)

2015-10-18 Thread Dave Airlie
ping? On 9 October 2015 at 10:38, Dave Airlie wrote: > From: Dave Airlie > > So I've known this was broken before, cogl has a workaround > for it from what I know, but with the gallium based swrast > drivers BlitFramebuffer from back to front or vice-versa

Re: [Mesa-dev] [PATCH] i965/vs: Move URB entry_size and read_length calculations to compile_vs

2015-10-18 Thread Jason Ekstrand
On Sun, Oct 18, 2015 at 11:14 AM, Eduardo Lima Mitev wrote: > On 10/16/2015 05:18 PM, Jason Ekstrand wrote: >> Topi, >> Seeing as you're on a roll reviewing my move-the-code patches, mind one more? >> --Jason >> > > I took the liberty to review this one, and looks pretty >

Re: [Mesa-dev] [RFC 2/2] gallium: add tegra support

2015-10-18 Thread Christian Gmeiner
Hi Emil, 2015-10-16 1:33 GMT+02:00 Emil Velikov : > Hi Christian, > > Mostly minor suggestions I'm afraid. Things just look too good for > anything serious. > :) > On 11 October 2015 at 16:09, Christian Gmeiner > wrote: >> This commit adds

Re: [Mesa-dev] [PATCH 1/4] mesa: replace UsesClipDistance with ClipDistanceArraySize

2015-10-18 Thread Tobias Klausmann
On 18.10.2015 19:14, Marek Olšák wrote: From: Marek Olšák This is more practical and needed by gallium. --- src/glsl/linker.cpp| 33 +++-- src/glsl/nir/glsl_to_nir.cpp | 3 ++- src/mesa/drivers/dri/i965/brw_vs.c | 2

Re: [Mesa-dev] [PATCH 3/4] st/mesa: pass the clip distance array size to drivers

2015-10-18 Thread Tobias Klausmann
On 18.10.2015 19:52, Marek Olšák wrote: On Sun, Oct 18, 2015 at 7:25 PM, Ilia Mirkin wrote: Patches 1-3 are Reviewed-by: Ilia Mirkin . Not familiar with the tgsi scan stuff. Do you have plans on finishing cull distance support btw? Dave Airlie

[Mesa-dev] [PATCH 4/4] nv50: do not create an invalid HW query type

2015-10-18 Thread Samuel Pitoiset
While we are at it, store the rotate offset for occlusion queries to nv50_hw_query like on nvc0. Signed-off-by: Samuel Pitoiset --- src/gallium/drivers/nouveau/nv50/nv50_query_hw.c | 45 +--- src/gallium/drivers/nouveau/nv50/nv50_query_hw.h | 3 +-

[Mesa-dev] [PATCH 3/4] nv50: move HW queries to nv50_query_hw.c/h files

2015-10-18 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset --- src/gallium/drivers/nouveau/Makefile.sources | 2 + src/gallium/drivers/nouveau/nv50/nv50_query.c | 354 ++- src/gallium/drivers/nouveau/nv50/nv50_query.h | 26 +-

[Mesa-dev] [PATCH 0/3] brw surface builder / ssbo fixes

2015-10-18 Thread Kristian Høgsberg Kristensen
I've been giving the SSBO functionality a closer look and I found a few problems, each addressed by a patch in this series. The commit messages describe the issues and the fixes, but the net effect takes my vertex shader case from this: add(8) g7<1>D g2<0,1,0>D 16D

[Mesa-dev] [PATCH 2/3] i965/fs: Make emit_uniformize a no-op for immediates

2015-10-18 Thread Kristian Høgsberg Kristensen
An immdiate is already uniform so just return it up front. Without this, brw_fs_surface_builder ends up passing immediate surface indices through SHADER_OPCODE_BROADCAST. This writes to a stride 0 dst, which we can't constant propagate out of, and further, we don't constant propagate into the

[Mesa-dev] [PATCH 1/3] i965: Don't use message headers for typed/untyped reads

2015-10-18 Thread Kristian Høgsberg Kristensen
We always set the mask to 0x, which is what it defaults to when no header is present. Let's drop the header instead. Signed-off-by: Kristian Høgsberg Kristensen --- src/mesa/drivers/dri/i965/brw_eu_emit.c | 3 +-- src/mesa/drivers/dri/i965/brw_fs.cpp| 4 ++-- 2 files

[Mesa-dev] [PATCH 3/3] i965/fs: Read all components of a SSBO field with one send

2015-10-18 Thread Kristian Høgsberg Kristensen
Instead of looping through single-component reads, read all components in one go. Signed-off-by: Kristian Høgsberg Kristensen --- src/mesa/drivers/dri/i965/brw_fs_nir.cpp | 25 +++-- 1 file changed, 7 insertions(+), 18 deletions(-) diff --git

Re: [Mesa-dev] [PATCH 09/10] vbo: fix GL_LINE_LOOP stray line bug

2015-10-18 Thread Brian Paul
On 10/17/2015 07:31 PM, Charmaine Lee wrote: From: Brian Paul Sent: Friday, October 16, 2015 2:25 PM To: mesa-dev@lists.freedesktop.org Cc: Charmaine Lee; Jose Fonseca; Sinclair Yeh Subject: [PATCH 09/10] vbo: fix GL_LINE_LOOP stray line bug When long GL_LINE_LOOP

[Mesa-dev] [PATCH 2/4] nv50: move nva0_so_target_save_offset() to its correct location

2015-10-18 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset --- src/gallium/drivers/nouveau/nv50/nv50_query.c | 18 -- src/gallium/drivers/nouveau/nv50/nv50_query.h | 3 --- src/gallium/drivers/nouveau/nv50/nv50_state.c | 18 ++ 3 files changed, 18 insertions(+),

Re: [Mesa-dev] [PATCH 01/10] tnl: add some comments in render_line_loop code

2015-10-18 Thread Sinclair Yeh
Patches 1-8 look good. I'm spending a bit more time on 10. Reviewed-by: Sinclair Yeh From: Brian Paul Sent: Friday, October 16, 2015 2:25 PM To: mesa-dev@lists.freedesktop.org Cc: Charmaine Lee; Jose Fonseca; Sinclair

Re: [Mesa-dev] [PATCH 13/16] nvc0: enable compute support by default on Fermi

2015-10-18 Thread Pierre Moreau
An LLVM IR <-> SPIR-V was in the plans (see [first proposal][0] and [second proposal][1]). My guess is, it is still being worked on and we should hear some more around Siggraph Asia (2--5 November), if Khronos is to announce Vulkan and SPIR-V's final spec at that conference. Pierre PS: Just

Re: [Mesa-dev] [PATCH 37/40] targets/nine: add note about fd owndership

2015-10-18 Thread Emil Velikov
On 17 October 2015 at 23:58, Emil Velikov wrote: > Cc: Axel Davy > Signed-off-by: Emil Velikov > --- > src/gallium/targets/d3dadapter9/Makefile.am | 1 + > src/gallium/targets/d3dadapter9/drm.c | 2 ++ > 2 files

Re: [Mesa-dev] [PATCH] nvc0: do not bind input params at compute state init on Fermi

2015-10-18 Thread Samuel Pitoiset
On 10/17/2015 08:08 PM, Ilia Mirkin wrote: This seems surprising... could I convince you to trace a test that executes both a graphics and compute pipeline, which both use (different) uniforms? I'm convinced because this seems to be a bit weird for me too. Anyways, this patch is fine for

Re: [Mesa-dev] [PATCH] glsl: fix SSBO regression

2015-10-18 Thread Timothy Arceri
On Sun, 2015-10-18 at 11:34 +0100, Emil Velikov wrote: > Hi Timothy, > > On 17 October 2015 at 23:19, Timothy Arceri > wrote: > > Fixes regression cased by bb5aeb854915ba67abc56257f830d002c956439e > > > > We don't care about the swizzle when building the name so just skip

Re: [Mesa-dev] [PATCH] glsl: fix SSBO regression

2015-10-18 Thread Emil Velikov
Hi Timothy, On 17 October 2015 at 23:19, Timothy Arceri wrote: > Fixes regression cased by bb5aeb854915ba67abc56257f830d002c956439e > > We don't care about the swizzle when building the name so just skip over it. > --- > > New piglit test:

Re: [Mesa-dev] [PATCH 37/40] targets/nine: add note about fd owndership

2015-10-18 Thread Axel Davy
On 18/10/2015 12:25, Emil Velikov wrote: +/* XXX: Is the owner responsible for FD owndership or are we ? + * In the former we're screwing things hard here */ This will be updated to "Although the fd is provided from external source, mesa/nine takes ownership of it." based on input

Re: [Mesa-dev] [PATCH 13/16] nvc0: enable compute support by default on Fermi

2015-10-18 Thread Samuel Pitoiset
On 10/17/2015 09:11 PM, Jan Vesely wrote: Does this mean it should be possible to hook up clover with nouveau? As I said Ilia, this is just the ability to launch compute kernels on Fermi. Unfortunately, OpenCL is still not supported by Nouveau but I hope this is going to change. Jan On

Re: [Mesa-dev] [PATCH 15/40] pipe-loader: rework the sw backend

2015-10-18 Thread Emil Velikov
On 17 October 2015 at 23:57, Emil Velikov wrote: > Move the winsys into the pipe-target, bla bla bla > > XXX: separate pipe-drivers are likely to be busted > The XXX: is a left over and the pipe-drivers should be fine. Upon a second thought this whole "keep the sw

Re: [Mesa-dev] [RFC 1/2] gallium: add renderonly driver

2015-10-18 Thread Christian Gmeiner
Hi Emil, Thanks for the review! 2015-10-16 1:09 GMT+02:00 Emil Velikov : > Hi Christian, > > I'm glad to see Thierry's work revived. Hopefully this will soon be > the basis of many more drivers. I need to look into egl on wayland issue and hope to gain deeper knowledge

Re: [Mesa-dev] [PATCH 1/3] gallium: add PIPE_CAP_SHAREABLE_SHADERS

2015-10-18 Thread Marek Olšák
Ping On Thu, Oct 15, 2015 at 1:31 PM, Marek Olšák wrote: > Ping > > On Sun, Oct 11, 2015 at 3:09 AM, Marek Olšák wrote: >> From: Marek Olšák >> >> I'll let drivers figure out how to do it. >> --- >> src/gallium/docs/source/screen.rst

[Mesa-dev] [PATCH 4/4] tgsi/scan: use properties for clip/cull distance writemasks

2015-10-18 Thread Marek Olšák
From: Marek Olšák No changes needed for drivers already relying on tgsi_shader_info. --- src/gallium/auxiliary/tgsi/tgsi_scan.c | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git a/src/gallium/auxiliary/tgsi/tgsi_scan.c

[Mesa-dev] [PATCH 1/4] radeonsi: link ES-GS just like LS-HS

2015-10-18 Thread Marek Olšák
From: Marek Olšák This reduces the shader key for ES. Use a fixed attrib location based on (semantic name, index). The ESGS item size is determined by the physical index of the highest ES output, so it's almost always larger than before, but I think that shouldn't matter

[Mesa-dev] [PATCH 4/4] radeonsi: enable BC_OPTIMIZE if centroid isn't used

2015-10-18 Thread Marek Olšák
From: Marek Olšák This solution was recommended by a Catalyst developer. --- src/gallium/drivers/radeonsi/si_state_shaders.c | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/src/gallium/drivers/radeonsi/si_state_shaders.c

[Mesa-dev] [PATCH 3/4] radeonsi: fix the export_prim_id field size in the shader key

2015-10-18 Thread Marek Olšák
From: Marek Olšák --- src/gallium/drivers/radeonsi/si_shader.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/gallium/drivers/radeonsi/si_shader.h b/src/gallium/drivers/radeonsi/si_shader.h index 82d05e5..b72cb1a 100644 ---

[Mesa-dev] [PATCH 2/4] gallium: add new properties for clip and cull distance usage

2015-10-18 Thread Marek Olšák
From: Marek Olšák The TGSI usage mask can't be used, because these are declared as an output array of 2 elements. --- src/gallium/auxiliary/tgsi/tgsi_strings.c | 2 ++ src/gallium/docs/source/tgsi.rst | 10 ++ src/gallium/include/pipe/p_shader_tokens.h |

[Mesa-dev] [PATCH 1/4] mesa: replace UsesClipDistance with ClipDistanceArraySize

2015-10-18 Thread Marek Olšák
From: Marek Olšák This is more practical and needed by gallium. --- src/glsl/linker.cpp| 33 +++-- src/glsl/nir/glsl_to_nir.cpp | 3 ++- src/mesa/drivers/dri/i965/brw_vs.c | 2 +- src/mesa/main/mtypes.h | 5

[Mesa-dev] [PATCH 3/4] st/mesa: pass the clip distance array size to drivers

2015-10-18 Thread Marek Olšák
From: Marek Olšák --- src/mesa/state_tracker/st_program.c | 8 1 file changed, 8 insertions(+) diff --git a/src/mesa/state_tracker/st_program.c b/src/mesa/state_tracker/st_program.c index 87571a8..75ccaf2 100644 --- a/src/mesa/state_tracker/st_program.c +++

[Mesa-dev] [PATCH 2/4] radeonsi: remove dead code after ES-GS linkage change

2015-10-18 Thread Marek Olšák
From: Marek Olšák --- src/gallium/drivers/radeonsi/si_shader.c| 43 - src/gallium/drivers/radeonsi/si_shader.h| 1 - src/gallium/drivers/radeonsi/si_state_shaders.c | 13 3 files changed, 57 deletions(-) diff --git

Re: [Mesa-dev] [PATCH 3/4] st/mesa: pass the clip distance array size to drivers

2015-10-18 Thread Ilia Mirkin
Patches 1-3 are Reviewed-by: Ilia Mirkin . Not familiar with the tgsi scan stuff. Do you have plans on finishing cull distance support btw? Dave Airlie and Tobias Klaussman have both made attempts at it at one point or another. -ilia On Sun, Oct 18, 2015 at 1:14 PM,

Re: [Mesa-dev] [PATCH 13/16] nvc0: enable compute support by default on Fermi

2015-10-18 Thread Jan Vesely
On Sat, 2015-10-17 at 16:34 -0400, Ilia Mirkin wrote: > On Sat, Oct 17, 2015 at 4:31 PM, Ilia Mirkin > wrote: > > On Sat, Oct 17, 2015 at 4:24 PM, Jan Vesely > > wrote: > > > On Sat, 2015-10-17 at 15:24 -0400, Ilia Mirkin wrote: > > > > "compute" in

Re: [Mesa-dev] [PATCH 3/4] st/mesa: pass the clip distance array size to drivers

2015-10-18 Thread Marek Olšák
On Sun, Oct 18, 2015 at 7:25 PM, Ilia Mirkin wrote: > Patches 1-3 are Reviewed-by: Ilia Mirkin . Not > familiar with the tgsi scan stuff. > > Do you have plans on finishing cull distance support btw? Dave Airlie > and Tobias Klaussman have both made

Re: [Mesa-dev] [PATCH] i965/vs: Move URB entry_size and read_length calculations to compile_vs

2015-10-18 Thread Eduardo Lima Mitev
On 10/16/2015 05:18 PM, Jason Ekstrand wrote: > Topi, > Seeing as you're on a roll reviewing my move-the-code patches, mind one more? > --Jason > I took the liberty to review this one, and looks pretty straight-forward. So it is: Reviewed-By: Eduardo Lima Mitev It had a few